Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Raspberry Pi 3 B+ may be losing UDP packets over ethernet.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
crocket
Guru
Guru


Joined: 29 Apr 2017
Posts: 455

PostPosted: Thu Jul 11, 2019 1:28 pm    Post subject: Raspberry Pi 3 B+ may be losing UDP packets over ethernet. Reply with quote

When Raspberry Pi 3 B+ and my gentoo desktop exchange UDP packets via jack2's netmanager, netmanager reports a lot of packet drops.
jack_netsource doesn't report packet drops, but it reports netxrun from time to time. It's possible that jack_netsource ignores packet drops to a degree.

How can I test packet drops when Raspberry Pi 3 B+ and my gentoo desktop are exchange UDP packets at 400KB/s~800KB/s?

Perhaps, is God telling me to buy a new single board computer that doesn't have ethernet issues?
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 440

PostPosted: Thu Jul 11, 2019 2:27 pm    Post subject: Reply with quote

You have missed packets and they should not matter if TCP or UDP.
On TCP you'll get retransfer and with UDP it didn't matter.
So I don't think you get dropped packets _because_ of UDP.

What is distance and quality of the communication?
Multiple hops?
Bad cabling?
etc.
Back to top
View user's profile Send private message
crocket
Guru
Guru


Joined: 29 Apr 2017
Posts: 455

PostPosted: Thu Jul 11, 2019 2:44 pm    Post subject: Reply with quote

Maitreya wrote:
You have missed packets and they should not matter if TCP or UDP.
On TCP you'll get retransfer and with UDP it didn't matter.
So I don't think you get dropped packets _because_ of UDP.

What is distance and quality of the communication?
Multiple hops?
Bad cabling?
etc.


It seems that bandwidth mismatch was the cause.

The speed of the ethernet adaptor on Raspberry Pi 3 B+ was 100Mbps.
That on my gentoo desktop was 1Gbps. Once I set the ethernet speed on gentoo desktop to 100Mbps through ethtool, the problem seems to have disappeared.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum