Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma fails to start: We have no shell handlers installed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3237
Location: de

PostPosted: Tue Nov 29, 2016 8:11 pm    Post subject: Plasma fails to start: We have no shell handlers installed Reply with quote

Hi,

just updated the whole system including the whole KDE bunch. Installed is plasma-5.8.4.

Unfortunately the Plasma desktop refuses to start. SDDM starts. When I select Plasma (no wayland) the KDE splashscreen appears. After quite a long while I get the error message:

kde wrote:
A shell package is missing.
This is an installation problem. Please get in contact with you distribution.

(translated from German:
Quote:
Ein Shell-Paket fehlt.
Dies ist ein Installationsproblem. Bitte nehmen Sie Kontakt mit Ihrer Distribution auf.


Ok, that's nice and tells me the exact error. The journal-log (Systemd) is a little bit more communicative.

Code:
Nov 29 20:00:56 hexe ksmserver[648]: ksmserver: autostart service "/usr/bin/plasmashell" finished with exit code  255
Nov 29 20:00:56 hexe kwin_x11[666]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1983, resource id: 48234636, major code: 18 (ChangeProperty), minor code: 0
Nov 29 20:00:56 hexe plasmashell[671]: We have no shell handlers installed
Nov 29 20:00:54 hexe gpm[384]: *** debug [daemon/old_main.c(158)]: selected 1 times
Nov 29 19:59:41 hexe kwin_x11[666]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1413, resource id: 14680072, major code: 2 (ChangeWindowAttributes), minor code: 0
Nov 29 19:59:41 hexe kwin_x11[666]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1410, resource id: 14680072, major code: 20 (GetProperty), minor code: 0


Google sends me with "We have no shell handlers installed" mostly to the guys from Arch and Ubuntu. And they recommend to re-install all KDE packages.

Nevertheless KDE seems to work almost completely. When I press Alt+F2 I get the search dialog. And there every application (Systemsettings, Konsole) works fine. Even the Baloo Search gives me lot of search results.

eix plasma-desktop:
[I] kde-plasma/plasma-desktop
     Available versions:  (5) 5.7.5 (~)5.8.3 (~)5.8.4 **5.8.49.9999[1] **9999[1]
       {debug +fontconfig gtk2 gtk3 +handbook ibus +input_devices_evdev input_devices_synaptics legacy-systray packagekit pulseaudio +qt4 scim +semantic-desktop test}
     Installed versions:  5.8.4(5)(19:45:01 11/29/16)(fontconfig handbook input_devices_evdev pulseaudio qt4 semantic-desktop -debug -gtk2 -gtk3 -ibus -input_devices_synaptics -legacy-systray -packagekit -scim -test)
     Homepage:            https://www.kde.org/
     Description:         KDE Plasma desktop


Where do I get the shell handler from? And what's that thing?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum