Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] ctave: error while loading shared lib: libblas.so.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 28, 2016 2:16 pm    Post subject: [solved] ctave: error while loading shared lib: libblas.so.3 Reply with quote

Hi,
when I try to start octave I get following message:
Code:
/usr/bin/octave-cli-4.2.0: error while loading shared libraries: libblas.so.3: cannot open shared object file: No such file or directory


I got the same message with version "3.6.4", therefore I upgraded to "4.2.0" and still the same message.
I migrate the science overlay (https://wiki.gentoo.org/wiki/User_talk:Houseofsuns) which also did not help!

My emerge --info octave:
Code:
emerge --info octave
Portage 2.3.0 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_960_@_3.20GHz-with-gentoo-2.2
KiB Mem:    24680792 total,    820592 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 25 Nov 2016 07:00:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bindist bitmap-fonts bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif git glamor gpm gtk gtk3 gzip iconv ipv6 jpeg lcms ldap libnotify mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mpi mulitilib multilib ncurses nls nptl nsplugin ogg opengl openmp openmpi pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline scanner sdl seccomp session spell sse sse2 ssl startup-notification subversion svg tcpd threads tiff truetype type1 udev udisks unicode upower usb vim-syntax vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nouveau" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sci-mathematics/octave-4.2.0::gentoo was built with the following:
USE="X glpk imagemagick opengl qhull qrupdate readline sparse zlib -curl -doc -fftw -gnuplot -graphicsmagick -hdf5 -java -openssl -portaudio -postscript -qt5 -sndfile -static-libs" ABI_X86="64"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,defs"


Any ideas on how to fix this?


Last edited by chi86 on Tue Nov 29, 2016 7:29 am; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Mon Nov 28, 2016 2:46 pm    Post subject: Reply with quote

Do the emerge of Octave had install eselect-blas? Normally yes, did-you do
Code:
eselect blas list

to see which Blas implementations are available? Did you enable one?

The installation of Octave put in the eselect-lapack and the eselect-blas packages. You must eselect them in some ways I think.
_________________
Paul
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 28, 2016 2:48 pm    Post subject: Reply with quote

Logicien wrote:
Do the emerge of Octave had install eselect-blas? Normally yes, did-you do
Code:
eselect blas list


Yes I had set this:
Code:
#eselect blas list
Available providers for blas:
  [1]   reference *

(Also did the same for cblas and lapack)
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Mon Nov 28, 2016 3:12 pm    Post subject: Reply with quote

If you do
Code:
ldconfig
ldconfig -p | grep -i libblas

do you have an output?

Or
Code:
updatedb
locate -i libblas


If the librairy file exist in the arborescence is it in the path of /etc/ld.so.conf? Is it of the same number version than the one who is missing?
_________________
Paul


Last edited by Logicien on Mon Nov 28, 2016 3:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 28, 2016 3:13 pm    Post subject: Reply with quote

Logicien wrote:
If you do
Code:
ldconfig
ldconfig -p | grep -i libblas

do you have an output?

Or
Code:
updatedb
locate -i libblas


No none of these give me an output!
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Mon Nov 28, 2016 3:36 pm    Post subject: Reply with quote

You may not consider those as solutions but, if you change the fortran USE flag for -fortran in make.conf and recompile the world is this missing library disappear? You can try to use the static-libs USE flag for octave and see if this missing library disappear.

A better idea can be to only add the blas cblas-external and lapack USE flags to make.conf before upgrade world. Check the related USE flag to blas in /etc/portage/profiles/use.desc and use.local.desc.
_________________
Paul
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 28, 2016 4:17 pm    Post subject: Reply with quote

Logicien wrote:
You may not consider those as solutions but, if you change the fortran USE flag for -fortran in make.conf and recompile the world is this missing library disappear? You can try to use the static-libs USE flag for octave and see if this missing library disappear.

A better idea can be to only add the blas cblas-external and lapack USE flags to make.conf before upgrade world. Check the related USE flag to blas in /etc/portage/profiles/use.desc and use.local.desc.


I tried now to emerge with the static-libs flag bbut still the same error message! Also if I emerge:
    virtual/blas
    virtual/cblas
    virtual/lapack

The libraries still are missing.
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Tue Nov 29, 2016 7:29 am    Post subject: Reply with quote

I found a solution!
The problem was that the libraries where all in "/usr/lib/" but names librefblas/lapack, therefore I created a symllink:

Code:
ln -s librefblas.so libblas.so.3
ln -s librefblas.so libblas.so.0
ln -s libreflapack.so liblapack.so.0


which solved the problem and octave worked now!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum