Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox-50 breaking HTML5 video
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
STrRedWolf
n00b
n00b


Joined: 02 Sep 2002
Posts: 72

PostPosted: Mon Nov 28, 2016 2:49 am    Post subject: firefox-50 breaking HTML5 video Reply with quote

Okay, this one's stumping me, I must not be compiling www-client/firefox-50 right. If I open a web page with HTML 5 video on it, it only repeats the first few seconds.

For instance, if I play this clip of Mighty Magiswords, it never gets out of the first scene that starts playing:
https://www.youtube.com/watch?v=WkQJzC1mXfM

Yet Chrome and www-client/firefox-bin-50 work properly.

Code:
sandra ~ # emerge -pv firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] www-client/firefox-50.0::gentoo  USE="dbus gmp-autoupdate gtk2 hwaccel jemalloc jit pulseaudio skia startup-notification -bindist -custom-cflags -custom-optimization -debug -hardened (-neon) -pgo (-selinux) (-system-cairo) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite {-test} -wifi" L10N="-ach -af -an -ar -as -ast -az -be -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Here's my /etc/portage/make.conf:

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core-avx2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

USE="${CPU_FLAGS_X86} -fortran \
   -kde dvd alsa cdr ipv6 \
   dbus X pulseaudio lm_sensors policykit udev avahi \
   udisks bluetooth avahi samba \
   jpeg2k rtmp ffmpeg -libav"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

MAKEOPTS="-j5"
FEATURS="parallel-fetch clean-logs fail-clean"

GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/"

# SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"

GRUB_PLATFORMS="pc efi-64"

INPUT_DEVICES="evdev wacom void"
VIDEO_CARDS="nvidia fbdev intel i965"

SANE_BACKENDS="plustek"

PHP_TARGETS="php5-5"
PYTHON_SINGLE_TARGET="python3_4"

CALLIGRA_FEATURES="krita"

PORTDIR_OVERLAY="/usr/local/portage-crossdev ${PORTDIR_OVERLAY} /usr/local/portage"

XFCE_PLUGINS="clock multiload-nandhp"
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Mon Nov 28, 2016 4:41 am    Post subject: Reply with quote

Have-you make Html5 the default for Firefox on http://www.youtube.com/html5?

Does Firefox behave the same with non Youtube Html5 videos?
_________________
Paul
Back to top
View user's profile Send private message
STrRedWolf
n00b
n00b


Joined: 02 Sep 2002
Posts: 72

PostPosted: Mon Nov 28, 2016 11:19 am    Post subject: Reply with quote

Logicien wrote:
Have-you make Html5 the default for Firefox on http://www.youtube.com/html5?

Does Firefox behave the same with non Youtube Html5 videos?


Yes, HTML5 video is active in Youtube.

I do not know of any other sites that are using HTML5 video.
Back to top
View user's profile Send private message
EmaRsk
Apprentice
Apprentice


Joined: 07 Sep 2004
Posts: 158
Location: Italy

PostPosted: Mon Nov 28, 2016 11:44 am    Post subject: Reply with quote

I have the same problem, and yes I have enabled html5.
Another site where I can't hear audio in the new Firefox is Duolingo.
After some quick inconclusive checks in about:config, I just switched to chromium for the time being.
_________________
Please, avoid some common spelling errors:
http://theoatmeal.com/comics/misspelling
Back to top
View user's profile Send private message
tholin
Apprentice
Apprentice


Joined: 04 Oct 2008
Posts: 170

PostPosted: Mon Nov 28, 2016 12:21 pm    Post subject: Reply with quote

Its' a bug but there are some workarounds.
https://bugzilla.mozilla.org/show_bug.cgi?id=1318404
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1676
Location: United Kingdom

PostPosted: Mon Nov 28, 2016 1:28 pm    Post subject: Reply with quote

Or rebuild Firefox with USE="-hwaccel". Gentoo Bug No. 600344 - =www-client/firefox-50.0 html5 video broken
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
jhardin
n00b
n00b


Joined: 12 Oct 2005
Posts: 39

PostPosted: Thu Dec 08, 2016 6:29 am    Post subject: about:config workaround Reply with quote

This about:config change fixed it for me w/o changing USE settings:

Code:
layers.acceleration.force-enabled = false

per https://bugzilla.mozilla.org/show_bug.cgi?id=1318404#c12
Back to top
View user's profile Send private message
manywele
l33t
l33t


Joined: 12 Jul 2003
Posts: 726
Location: Basking in the Zen glow of Jerry

PostPosted: Wed Dec 14, 2016 4:09 am    Post subject: Re: about:config workaround Reply with quote

jhardin wrote:
This about:config change fixed it for me w/o changing USE settings:

Code:
layers.acceleration.force-enabled = false

per https://bugzilla.mozilla.org/show_bug.cgi?id=1318404#c12


Thank you so much. This affected me starting with firefox-49. After much fruitless googling and searching on mozilla forums I finally find the answer on the gentoo forums, of course.
Back to top
View user's profile Send private message
papu
l33t
l33t


Joined: 25 Jan 2008
Posts: 605
Location: Sota algun pi o alzina...

PostPosted: Wed Dec 14, 2016 6:03 pm    Post subject: Reply with quote

ahhh, i am suffering this about weeks with not explanation, event more, because in windows that isn't happens: in windows layers.acceleration.force-enabled;false it's default but in gnu/linux the default is true.

Today randomize i read this post and go...

but what is the useless of layers.acceleration.force-enabled if exists other option like layers.acceleration.disabled? i not understand this, they seems same thing but with diferent name

i am using 51.0b7 (beta channel) in both s.o
thanks, :lol:
_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum