Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QT5.5.1 - QML applications failing with wayland plugin.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MANU VIVEK
n00b
n00b


Joined: 17 Nov 2016
Posts: 1

PostPosted: Thu Nov 17, 2016 3:15 pm    Post subject: QT5.5.1 - QML applications failing with wayland plugin. Reply with quote

I was able to compile and execute a simple Hello world widget application using qt in Target :
To run the application with wayland plugin after following steps:
1)Setting the env variable: export XDG_RUNTIME_DIR=/run/user/0 -
2)weston --device=/dev/fb0 --tty=3 --backend=fbdev-backend.so &

./Helloworld -platform wayland-egl

Eventhough it was showing "failed to initialize EGL display", I was succesfully able to view the output.

Cross compiled an QT qml application in Qt 5.5.1 creator and executed in target. It was giving error "failed to initialize EGL display" and segmentation fault. I was using wayland -egl plugin here also.

At the same time QT widget applications in qt examples are also was working fine. But QT examples based on qml are giving segmentation fault.

Can any one help 8O ?. Thanks in advance.

It seems i am stuck up here.!!! Can any one provide some inputs so that i can try from there on .???
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum