Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disabling VHOSTS
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ferg
Guru
Guru


Joined: 15 Nov 2002
Posts: 457
Location: Cambridge, UK

PostPosted: Mon Nov 14, 2016 5:13 pm    Post subject: Disabling VHOSTS Reply with quote

Hello all,

Years ago I enabled Virtual hosts on my Gentoo server. It was so long ago, I cannot even remember why.

I currently use Apache to server a few different webpages in my house LAN (CCTV, MRTG, Mythtv and a few other similar things). I would like to serve a single one of these pages externally. So I need to relearn Apache.

I tried disabling VHOSTS by removing

in /etc/conf.d/apache I changed this line

Code:
APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D SSL -D SSL_DEFAULT_VHOST -D SUEXEC -D LANGUAGE -D SECURITY"


to this line

Code:
APACHE2_OPTS="-D PHP -D INFO -D SSL  -D SUEXEC -D LANGUAGE -D SECURITY"



in /etc/apache2/httpd.conf I removed this line.

Code:
 Include /etc/apache2/vhosts.d/*.conf


However, then restarting Apache gives errors:

Code:
scotgate vhosts.d # /etc/init.d/apache2 restart
 * Caching service dependencies ...                                                                                                                                     [ ok ]
 * Stopping apache2 ...                                                                                                                                                 [ ok ]
 * Starting apache2 ...
no listening sockets available, shutting down
AH00015: Unable to open logs
 * start-stop-daemon: failed to start `/usr/sbin/apache2'


What else do I need to get rid of? What have I previously messed up!

Thanks.
Ferg
_________________
Climb up it, kayak down it + make sure it runs on GNU/Linux
"cease to exist, giving my goodbye, drive my car into the ocean,
you think I'm dead, but i sail away, on a wave of mutilation!"
Back to top
View user's profile Send private message
ferg
Guru
Guru


Joined: 15 Nov 2002
Posts: 457
Location: Cambridge, UK

PostPosted: Mon Nov 14, 2016 5:27 pm    Post subject: Reply with quote

Dumb solution…. I had no Listen line in my httpd.conf file…..!
_________________
Climb up it, kayak down it + make sure it runs on GNU/Linux
"cease to exist, giving my goodbye, drive my car into the ocean,
you think I'm dead, but i sail away, on a wave of mutilation!"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum