Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black screen when logging in to Plasma with SDDM service
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
seijikun
n00b
n00b


Joined: 10 Jan 2016
Posts: 5

PostPosted: Sat Nov 05, 2016 9:33 pm    Post subject: Black screen when logging in to Plasma with SDDM service Reply with quote

Since the last wave of plasma updates (from 5.8.2 to 5.8.3) I am having the problem that logging into plasma with sddm doesn't work anymore.
When logging in, I have a 50% chance of either:

  • A short black flicker and a direct return back to sddm
  • The screen turning black and sometimes a working mouse cursor on top


I got it working once after trying to log into a Wayland session (which only flickers black and directly returns to sddm) and then again logging into the normal plasma session. This is however not reproducable.

It does not seem to be due to defective config files, since it doesn't work with a completely empty home folder either.

What is weird, is that plasma seems to start just well when starting sddm as root directly in a VT.
However, after unlocking the wallet, the desktop stops reacting, and inputs are not working anymore.
SDDM's log:
Code:
Checking for pam module
Got pam-login
kwalletd: Waiting for hash on 15-
kwalletd: waitingForEnvironment on: 17
kwalletd: client connected
kwalletd: client disconnected
kwalletd5: Checking for pam module
kwalletd5: Got pam-login param
kwalletd5: Waiting for hash on 15-
kwalletd5: waitingForEnvironment on: 18
kwalletd5: client connected
kwalletd5: client disconnected


Starting kde5 manually with:

  • Stop sddm
  • Go on a VT
  • Run startx
  • Running startkde in one of the 3 white terminals

works just fine (everytime). Everything is fully functional and unlocking the wallet is no problem.

I already looked at the logs in journald, but there is nothing indicating an error. Neither does
Code:
systemctl status sddm
reveal anything relevant.
Is there any other source of logs that might be of interrest?

Is anyone having the same problem?
Back to top
View user's profile Send private message
brendlefly62
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2009
Posts: 95

PostPosted: Sat Nov 19, 2016 2:46 am    Post subject: Reply with quote

Sounds like you have already run this checklist, but just in case, see this link:

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#Display_manager

cheers
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Nov 19, 2016 8:25 am    Post subject: Reply with quote

Do you have "pam" and "systemd" USE flags?
Back to top
View user's profile Send private message
seijikun
n00b
n00b


Joined: 10 Jan 2016
Posts: 5

PostPosted: Sat Nov 19, 2016 8:19 pm    Post subject: Reply with quote

@brendlefly62
I didnt, actually, but now I did.

@Maxxx
Yes


Additionally, I found out:
Logging in normally works at least once in 10 tries.
So what I do for now is switching to VT2:
Code:
systemctl restart sddm

and try logging in again. If it didn't work: repeat.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum