Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server 1.18 and nvidia-drivers 361 - startx freezes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
whtwtr
n00b
n00b


Joined: 12 Jun 2005
Posts: 54

PostPosted: Sun Oct 30, 2016 8:08 pm    Post subject: xorg-server 1.18 and nvidia-drivers 361 - startx freezes Reply with quote

Greetings,

I normally only post a question when I'm really stuck, and this is one of those times. I bet its something trivial, so maybe I missed something somewhere.

After installing gentoo on my ThinkPad T240s, I followed the wiki in getting the nvidia drivers working with X and it has been working flawlessly, up until I upgraded xorg-server to 1.18.4 from 1.17.4. I left the config's as-is, and when I "startx" X just hangs...

I'm hoping someone can shed some light...

Running a t420s with Optimus enabled in the BIOS and 4.4.6 Kernel

Xorg.0.log:

Code:

X.Org X Server 1.18.4
Release Date: 2016-07-19
[  6586.847] X Protocol Version 11, Revision 0
[  6586.850] Build Operating System: Linux 4.4.6-gentoo x86_64 Gentoo
[  6586.853] Current Operating System: Linux zaphod 4.4.6-gentoo #5 SMP Fri Jul 22 23:48:24 CEST 2016 x86_64
[  6586.853] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.4.6-gentoo root=/dev/mapper/vg0-root ro init=/usr/lib/systemd/systemd dolvm quiet
[  6586.859] Build Date: 29 October 2016  10:47:40PM
[  6586.862] 
[  6586.865] Current version of pixman: 0.34.0
[  6586.871]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  6586.871] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6586.881] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 29 23:03:16 2016
[  6586.884] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  6586.887] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6586.887] (==) ServerLayout "layout"
[  6586.887] (**) |-->Screen "nvidia" (0)
[  6586.887] (**) |   |-->Monitor "<default monitor>"
[  6586.887] (**) |   |-->Device "nvidia"
[  6586.887] (**) |   |-->GPUDevice "intel"
[  6586.887] (==) No monitor specified for screen "nvidia".
   Using a default monitor configuration.
[  6586.887] (**) |-->Inactive Device "intel"
[  6586.887] (==) Automatically adding devices
[  6586.887] (==) Automatically enabling devices
[  6586.887] (==) Automatically adding GPU devices
[  6586.887] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  6586.887] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  6586.887] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[  6586.887] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  6586.887] (II) Loader magic: 0x814d40
[  6586.887] (II) Module ABI versions:
[  6586.887]    X.Org ANSI C Emulation: 0.4
[  6586.887]    X.Org Video Driver: 20.0
[  6586.887]    X.Org XInput driver : 22.1
[  6586.887]    X.Org Server Extension : 9.0
[  6586.888] (++) using VT number 1

[  6586.888] (--) controlling tty is VT number 1, auto-enabling KeepTty
[  6586.892] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[  6586.893] (II) xfree86: Adding drm device (/dev/dri/card0)
[  6586.894] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 7 paused 0
[  6586.894] (II) xfree86: Adding drm device (/dev/dri/card1)
[  6586.895] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 8 paused 0
[  6587.132] (--) PCI:*(0:0:2:0) 8086:0126:17aa:21d3 rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64
[  6587.132] (--) PCI: (0:1:0:0) 10de:1056:17aa:21d3 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  6587.132] (II) LoadModule: "glx"
[  6587.132] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[  6587.143] (II) Module glx: vendor="NVIDIA Corporation"
[  6587.143]    compiled for 4.0.2, module version = 1.0.0
[  6587.143]    Module class: X.Org Server Extension
[  6587.143] (II) NVIDIA GLX Module  361.28  Wed Feb  3 15:10:57 PST 2016
[  6587.143] (II) LoadModule: "nvidia"
[  6587.143] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  6587.144] (II) Module nvidia: vendor="NVIDIA Corporation"
[  6587.144]    compiled for 4.0.2, module version = 1.0.0
[  6587.144]    Module class: X.Org Video Driver
[  6587.144] (II) LoadModule: "modesetting"
[  6587.144] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[  6587.144] (II) Module modesetting: vendor="X.Org Foundation"
[  6587.144]    compiled for 1.18.4, module version = 1.18.4
[  6587.144]    Module class: X.Org Video Driver
[  6587.145]    ABI class: X.Org Video Driver, version 20.0
[  6587.145] (II) NVIDIA dlloader X Driver  361.28  Wed Feb  3 14:48:10 PST 2016
[  6587.145] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  6587.145] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  6587.145] (II) Loading sub module "fb"
[  6587.145] (II) LoadModule: "fb"
[  6587.145] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  6587.146] (II) Module fb: vendor="X.Org Foundation"
[  6587.146]    compiled for 1.18.4, module version = 1.0.0
[  6587.146]    ABI class: X.Org ANSI C Emulation, version 0.4
[  6587.146] (II) Loading sub module "wfb"
[  6587.146] (II) LoadModule: "wfb"
[  6587.146] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  6587.146] (II) Module wfb: vendor="X.Org Foundation"
[  6587.146]    compiled for 1.18.4, module version = 1.0.0
[  6587.146]    ABI class: X.Org ANSI C Emulation, version 0.4
[  6587.146] (II) Loading sub module "ramdac"
[  6587.147] (II) LoadModule: "ramdac"
[  6587.147] (II) Module "ramdac" already built-in
[  6587.148] (II) modeset(1): using drv /dev/dri/card1
[  6587.148] (EE) Screen 1 deleted because of no matching config section.
[  6587.148] (II) UnloadModule: "modesetting"
[  6587.148] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "nvidia" for depth/fbbpp 24/32
[  6587.148] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  6587.148] (==) NVIDIA(0): RGB weight 888
[  6587.148] (==) NVIDIA(0): Default visual is TrueColor
[  6587.148] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  6587.148] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[  6587.148] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1"
[  6587.148] (**) NVIDIA(0): Enabling 2D acceleration
[  6587.615] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[  6587.615] (--) NVIDIA(0):     CRT-0
[  6587.615] (--) NVIDIA(0):     DFP-0
[  6587.615] (--) NVIDIA(0):     DFP-1
[  6587.615] (--) NVIDIA(0):     DFP-2
[  6587.615] (--) NVIDIA(0):     DFP-3 (boot)
[  6587.615] (--) NVIDIA(0):     DFP-4
[  6587.615] (--) NVIDIA(0):     DFP-5
[  6587.615] (--) NVIDIA(0):     DFP-6
[  6587.616] (--) NVIDIA(0): CRT-0: disconnected
[  6587.616] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[  6587.616] (--) NVIDIA(0):
[  6587.618] (--) NVIDIA(0): DFP-0: disconnected
[  6587.618] (--) NVIDIA(0): DFP-0: Internal LVDS
[  6587.618] (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[  6587.618] (--) NVIDIA(0):
[  6587.618] (--) NVIDIA(0): DFP-1: disconnected
[  6587.618] (--) NVIDIA(0): DFP-1: Internal TMDS
[  6587.618] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[  6587.618] (--) NVIDIA(0):
[  6587.622] (--) NVIDIA(0): DFP-2: disconnected
[  6587.622] (--) NVIDIA(0): DFP-2: Internal TMDS
[  6587.622] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[  6587.622] (--) NVIDIA(0):
[  6587.652] (--) NVIDIA(0): DELL 2408WFP (DFP-3): connected
[  6587.652] (--) NVIDIA(0): DELL 2408WFP (DFP-3): Internal TMDS
[  6587.652] (--) NVIDIA(0): DELL 2408WFP (DFP-3): 165.0 MHz maximum pixel clock
[  6587.652] (--) NVIDIA(0):
[  6587.653] (--) NVIDIA(0): DFP-4: disconnected
[  6587.653] (--) NVIDIA(0): DFP-4: Internal DisplayPort
[  6587.653] (--) NVIDIA(0): DFP-4: 480.0 MHz maximum pixel clock
[  6587.653] (--) NVIDIA(0):
[  6587.653] (--) NVIDIA(0): DFP-5: disconnected
[  6587.653] (--) NVIDIA(0): DFP-5: Internal DisplayPort
[  6587.653] (--) NVIDIA(0): DFP-5: 480.0 MHz maximum pixel clock
[  6587.653] (--) NVIDIA(0):
[  6587.653] (--) NVIDIA(0): DFP-6: disconnected
[  6587.653] (--) NVIDIA(0): DFP-6: Internal DisplayPort
[  6587.653] (--) NVIDIA(0): DFP-6: 480.0 MHz maximum pixel clock
[  6587.653] (--) NVIDIA(0):
[  6587.653] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[  6587.654] (II) NVIDIA(0): NVIDIA GPU NVS 4200M (GF119) at PCI:1:0:0 (GPU-0)
[  6587.654] (--) NVIDIA(0): Memory: 1048576 kBytes
[  6587.654] (--) NVIDIA(0): VideoBIOS: 75.19.15.00.05
[  6587.654] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  6587.654] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  6587.654] (**) NVIDIA(0):     device DELL 2408WFP (DFP-3) (Using EDID frequencies has
[  6587.654] (**) NVIDIA(0):     been enabled on all display devices.)
[  6587.656] (==) NVIDIA(0):
[  6587.656] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  6587.656] (==) NVIDIA(0):     will be used as the requested mode.
[  6587.656] (==) NVIDIA(0):
[  6587.656] (II) NVIDIA(0): Validated MetaModes:
[  6587.656] (II) NVIDIA(0):     "DFP-3:nvidia-auto-select"
[  6587.656] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[  6587.666] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[  6587.666] (--) NVIDIA(0):     option
[  6587.666] (--) Depth 24 pixmap format is 32 bpp
[  6587.667] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  6587.667] (II) NVIDIA:     access.
[  6587.702] (II) NVIDIA(0): Setting mode "DFP-3:nvidia-auto-select"
[  6587.725] (==) NVIDIA(0): Disabling shared memory pixmaps
[  6587.725] (==) NVIDIA(0): Backing store enabled
[  6587.725] (==) NVIDIA(0): Silken mouse enabled
[  6587.725] (==) NVIDIA(0): DPMS enabled
[  6587.725] (II) Loading sub module "x11glvnd"
[  6587.725] (II) LoadModule: "x11glvnd"
[  6587.725] (WW) Warning, couldn't open module x11glvnd
[  6587.725] (II) UnloadModule: "x11glvnd"
[  6587.725] (II) Unloading x11glvnd
[  6587.725] (II) x11glvnd Loading
[  6587.725] (II) Loading sub module "dri2"
[  6587.725] (II) LoadModule: "dri2"
[  6587.725] (II) Module "dri2" already built-in
[  6587.725] (II) NVIDIA(0): [DRI2] Setup complete
[  6587.725] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  6587.725] (--) RandR disabled
[  6587.725] (II) Initializing extension GLX
[  6587.725] (II) Indirect GLX disabled.
[  6587.803] (II) config/udev: Adding input device Power Button (/dev/input/event8)
[  6587.804] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  6587.804] (II) LoadModule: "evdev"
[  6587.804] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  6587.804] (II) Module evdev: vendor="X.Org Foundation"
[  6587.804]    compiled for 1.18.4, module version = 2.10.3
[  6587.804]    Module class: X.Org XInput Driver
[  6587.804]    ABI class: X.Org XInput driver, version 22.1
[  6587.805] (II) systemd-logind: got fd for /dev/input/event8 13:72 fd 30 paused 0
[  6587.805] (II) Using input driver 'evdev' for 'Power Button'
[  6587.805] (**) Power Button: always reports core events
[  6587.805] (**) evdev: Power Button: Device: "/dev/input/event8"
[  6587.805] (--) evdev: Power Button: Vendor 0 Product 0x1
[  6587.805] (--) evdev: Power Button: Found keys
[  6587.805] (II) evdev: Power Button: Configuring as keyboard
[  6587.805] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input10/event8"
[  6587.805] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  6587.805] (**) Option "xkb_rules" "evdev"
[  6587.806] (II) config/udev: Adding input device Lid Switch (/dev/input/event6)
[  6587.806] (II) No input driver specified, ignoring this device.
[  6587.806] (II) This device may have been added with another device file.
[  6587.806] (II) config/udev: Adding input device Sleep Button (/dev/input/event7)
[  6587.806] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  6587.807] (II) systemd-logind: got fd for /dev/input/event7 13:71 fd 31 paused 0
[  6587.807] (II) Using input driver 'evdev' for 'Sleep Button'
[  6587.807] (**) Sleep Button: always reports core events
[  6587.807] (**) evdev: Sleep Button: Device: "/dev/input/event7"
[  6587.807] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  6587.807] (--) evdev: Sleep Button: Found keys
[  6587.807] (II) evdev: Sleep Button: Configuring as keyboard
[  6587.807] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input9/event7"
[  6587.807] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
[  6587.807] (**) Option "xkb_rules" "evdev"
[  6587.808] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
[  6587.808] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[  6587.809] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 32 paused 0
[  6587.809] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[  6587.809] (**) Logitech USB Receiver: always reports core events
[  6587.809] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2"
[  6587.809] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[  6587.809] (--) evdev: Logitech USB Receiver: Found keys
[  6587.809] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[  6587.809] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.5/3-1.5.2/3-1.5.2:1.0/0003:046D:C52B.0001/input/input4/event2"
[  6587.809] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 8)
[  6587.809] (**) Option "xkb_rules" "evdev"
[  6587.811] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3)
[  6587.811] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[  6587.811] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[  6587.812] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 33 paused 0
[  6587.812] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[  6587.812] (**) Logitech USB Receiver: always reports core events
[  6587.812] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event3"
[  6587.812] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[  6587.812] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[  6587.812] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[  6587.812] (--) evdev: Logitech USB Receiver: Found relative axes
[  6587.812] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[  6587.812] (--) evdev: Logitech USB Receiver: Found absolute axes
[  6587.812] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[  6587.812] (--) evdev: Logitech USB Receiver: Found keys
[  6587.812] (II) evdev: Logitech USB Receiver: Configuring as mouse
[  6587.812] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[  6587.812] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[  6587.812] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[  6587.812] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  6587.812] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.5/3-1.5.2/3-1.5.2:1.1/0003:046D:C52B.0002/input/input5/event3"
[  6587.812] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9)
[  6587.812] (**) Option "xkb_rules" "evdev"
[  6587.812] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[  6587.812] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[  6587.813] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[  6587.813] (**) Logitech USB Receiver: (accel) acceleration profile 0
[  6587.813] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[  6587.813] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[  6587.814] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse1)
[  6587.814] (II) No input driver specified, ignoring this device.
[  6587.814] (II) This device may have been added with another device file.
[  6587.815] (II) config/udev: Adding input device PS2 to USB Adapter (/dev/input/event4)
[  6587.815] (**) PS2 to USB Adapter: Applying InputClass "evdev keyboard catchall"
[  6587.816] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 34 paused 0
[  6587.816] (II) Using input driver 'evdev' for 'PS2 to USB Adapter'
[  6587.816] (**) PS2 to USB Adapter: always reports core events
[  6587.816] (**) evdev: PS2 to USB Adapter: Device: "/dev/input/event4"
[  6587.816] (--) evdev: PS2 to USB Adapter: Vendor 0x10d5 Product 0x4
[  6587.816] (--) evdev: PS2 to USB Adapter: Found keys
[  6587.816] (II) evdev: PS2 to USB Adapter: Configuring as keyboard
[  6587.816] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.5/3-1.5.3/3-1.5.3.1/3-1.5.3.1.2/3-1.5.3.1.2:1.0/0003:10D5:0004.0004/input/input6/event4"
[  6587.816] (II) XINPUT: Adding extended input device "PS2 to USB Adapter" (type: KEYBOARD, id 10)
[  6587.816] (**) Option "xkb_rules" "evdev"
[  6587.818] (II) config/udev: Adding input device PS2 to USB Adapter (/dev/input/event5)
[  6587.818] (**) PS2 to USB Adapter: Applying InputClass "evdev pointer catchall"
[  6587.818] (**) PS2 to USB Adapter: Applying InputClass "evdev keyboard catchall"
[  6587.819] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 35 paused 0
[  6587.819] (II) Using input driver 'evdev' for 'PS2 to USB Adapter'
[  6587.819] (**) PS2 to USB Adapter: always reports core events
[  6587.819] (**) evdev: PS2 to USB Adapter: Device: "/dev/input/event5"
[  6587.819] (--) evdev: PS2 to USB Adapter: Vendor 0x10d5 Product 0x4
[  6587.819] (--) evdev: PS2 to USB Adapter: Found 9 mouse buttons
[  6587.819] (--) evdev: PS2 to USB Adapter: Found scroll wheel(s)
[  6587.819] (--) evdev: PS2 to USB Adapter: Found relative axes
[  6587.819] (--) evdev: PS2 to USB Adapter: Found x and y relative axes
[  6587.819] (--) evdev: PS2 to USB Adapter: Found absolute axes
[  6587.819] (II) evdev: PS2 to USB Adapter: Forcing absolute x/y axes to exist.
[  6587.819] (--) evdev: PS2 to USB Adapter: Found keys
[  6587.819] (II) evdev: PS2 to USB Adapter: Configuring as mouse
[  6587.819] (II) evdev: PS2 to USB Adapter: Configuring as keyboard
[  6587.819] (II) evdev: PS2 to USB Adapter: Adding scrollwheel support
[  6587.819] (**) evdev: PS2 to USB Adapter: YAxisMapping: buttons 4 and 5
[  6587.819] (**) evdev: PS2 to USB Adapter: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  6587.819] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.5/3-1.5.3/3-1.5.3.1/3-1.5.3.1.2/3-1.5.3.1.2:1.1/0003:10D5:0004.0005/input/input7/event5"
[  6587.819] (II) XINPUT: Adding extended input device "PS2 to USB Adapter" (type: KEYBOARD, id 11)
[  6587.819] (**) Option "xkb_rules" "evdev"
[  6587.819] (II) evdev: PS2 to USB Adapter: initialized for relative axes.
[  6587.819] (WW) evdev: PS2 to USB Adapter: ignoring absolute axes.
[  6587.820] (**) PS2 to USB Adapter: (accel) keeping acceleration scheme 1
[  6587.820] (**) PS2 to USB Adapter: (accel) acceleration profile 0
[  6587.820] (**) PS2 to USB Adapter: (accel) acceleration factor: 2.000
[  6587.820] (**) PS2 to USB Adapter: (accel) acceleration threshold: 4
[  6587.821] (II) config/udev: Adding input device PS2 to USB Adapter (/dev/input/mouse2)
[  6587.821] (II) No input driver specified, ignoring this device.
[  6587.821] (II) This device may have been added with another device file.
[  6587.821] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event11)
[  6587.821] (II) No input driver specified, ignoring this device.
[  6587.821] (II) This device may have been added with another device file.
[  6587.822] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event12)
[  6587.822] (II) No input driver specified, ignoring this device.
[  6587.822] (II) This device may have been added with another device file.
[  6587.822] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  6587.822] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  6587.822] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 36 paused 0
[  6587.822] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  6587.822] (**) AT Translated Set 2 keyboard: always reports core events
[  6587.822] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  6587.823] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  6587.823] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  6587.823] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  6587.823] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[  6587.823] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 12)
[  6587.823] (**) Option "xkb_rules" "evdev"
[  6587.824] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event1)
[  6587.824] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  6587.824] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  6587.824] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[  6587.824] (II) LoadModule: "synaptics"
[  6587.824] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[  6587.824] (II) Module synaptics: vendor="X.Org Foundation"
[  6587.824]    compiled for 1.18.4, module version = 1.8.3
[  6587.824]    Module class: X.Org XInput Driver
[  6587.824]    ABI class: X.Org XInput driver, version 22.1
[  6587.825] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 37 paused 0
[  6587.825] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  6587.825] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6587.825] (**) Option "Device" "/dev/input/event1"
[  6587.910] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5888 (res 75)
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4820 (res 105)
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[  6587.910] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  6587.910] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6587.910] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event1"
[  6587.910] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 13)
[  6587.910] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  6587.910] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[  6587.910] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.036
[  6587.911] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  6587.911] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  6587.911] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  6587.911] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  6587.911] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  6587.912] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  6587.912] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[  6587.913] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event13)
[  6587.913] (**) TPPS/2 IBM TrackPoint: Applying InputClass "evdev pointer catchall"
[  6587.915] (II) systemd-logind: got fd for /dev/input/event13 13:77 fd 38 paused 0
[  6587.915] (II) Using input driver 'evdev' for 'TPPS/2 IBM TrackPoint'
[  6587.915] (**) TPPS/2 IBM TrackPoint: always reports core events
[  6587.915] (**) evdev: TPPS/2 IBM TrackPoint: Device: "/dev/input/event13"
[  6587.915] (--) evdev: TPPS/2 IBM TrackPoint: Vendor 0x2 Product 0xa
[  6587.915] (--) evdev: TPPS/2 IBM TrackPoint: Found 3 mouse buttons
[  6587.915] (--) evdev: TPPS/2 IBM TrackPoint: Found relative axes
[  6587.915] (--) evdev: TPPS/2 IBM TrackPoint: Found x and y relative axes
[  6587.915] (II) evdev: TPPS/2 IBM TrackPoint: Configuring as mouse
[  6587.915] (**) evdev: TPPS/2 IBM TrackPoint: YAxisMapping: buttons 4 and 5
[  6587.915] (**) evdev: TPPS/2 IBM TrackPoint: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  6587.915] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/serio2/input/input3/event13"
[  6587.915] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 14)
[  6587.916] (II) evdev: TPPS/2 IBM TrackPoint: initialized for relative axes.
[  6587.916] (**) TPPS/2 IBM TrackPoint: (accel) keeping acceleration scheme 1
[  6587.916] (**) TPPS/2 IBM TrackPoint: (accel) acceleration profile 0
[  6587.916] (**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
[  6587.916] (**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
[  6587.919] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse3)
[  6587.919] (II) No input driver specified, ignoring this device.
[  6587.919] (II) This device may have been added with another device file.
[  6587.920] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
[  6587.920] (II) No input driver specified, ignoring this device.
[  6587.920] (II) This device may have been added with another device file.
[  6587.922] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event10)
[  6587.922] (**) ThinkPad Extra Buttons: Applying InputClass "evdev keyboard catchall"
[  6587.923] (II) systemd-logind: got fd for /dev/input/event10 13:74 fd 39 paused 0
[  6587.923] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'
[  6587.923] (**) ThinkPad Extra Buttons: always reports core events
[  6587.923] (**) evdev: ThinkPad Extra Buttons: Device: "/dev/input/event10"
[  6587.923] (--) evdev: ThinkPad Extra Buttons: Vendor 0x17aa Product 0x5054
[  6587.923] (--) evdev: ThinkPad Extra Buttons: Found keys
[  6587.923] (II) evdev: ThinkPad Extra Buttons: Configuring as keyboard
[  6587.923] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input11/event10"
[  6587.923] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 15)
[  6587.923] (**) Option "xkb_rules" "evdev"
[  6595.373] (II) systemd-logind: got pause for 13:77
[  6595.373] (II) systemd-logind: got pause for 226:1
[  6595.373] (II) systemd-logind: got pause for 13:68
[  6595.373] (II) systemd-logind: got pause for 226:0
[  6595.373] (II) systemd-logind: got pause for 13:71
[  6595.373] (II) systemd-logind: got pause for 13:65
[  6595.373] (II) systemd-logind: got pause for 13:69
[  6595.373] (II) systemd-logind: got pause for 13:66
[  6595.373] (II) systemd-logind: got pause for 13:67
[  6595.373] (II) systemd-logind: got pause for 13:74
[  6595.373] (II) systemd-logind: got pause for 13:72
[  6595.373] (II) systemd-logind: got pause for 13:64


and the xorg.conf:

Code:

Section "ServerLayout"
   Identifier "layout"
   Screen 0 "nvidia"
   Inactive "intel"
EndSection

Section "Device"
   Identifier "nvidia"
   Driver "nvidia"
   BusID "PCI:1:0:0"
   Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Section "Screen"
        Identifier "nvidia"
   Device "nvidia"
   Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
   Identifier "intel"
   Driver "modesetting"
   BusID "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "intel"
   Deviice "intel"
EndSection


Oh... and my .xinitrc, (using twm just to test X)

Code:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
[ -f $HOME/.Xresources ] && xrdb -merge $HOME/.Xresources
#exec i3
exec twm



Thanks in advance...
Back to top
View user's profile Send private message
Schnulli
Guru
Guru


Joined: 25 Jun 2010
Posts: 320
Location: Bremen DE

PostPosted: Sun Oct 30, 2016 10:10 pm    Post subject: Reply with quote

HI,
get the latest Nvidia Source from Nvidia DL Site, install it in Runlevel 3, follow insturctions and it runs.
This is nothing new.. this happens from time to time, if it dont works leave a note and i help

Regards
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Mon Oct 31, 2016 7:52 am    Post subject: Reply with quote

I think u might need to add something like that

Option "ConnectedMonitor" "DFP-3"

after :
Section "Device"
Identifier "nvidia"
Driver "nvidia"


There is something wrong with: Screen 1 deleted because of no matching config section
Maybe just kick out kms from nvidia-drivers, if it doesnt help.
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
hhfeuer
Apprentice
Apprentice


Joined: 28 Jul 2005
Posts: 156

PostPosted: Sun Nov 20, 2016 9:54 pm    Post subject: Reply with quote

xorg-server >1.18.1 has a bug regarding modesetting driver config. It might sound stupid but it is solved by defining the modesetting setings before nvidia settings.
Code:

Section "ServerLayout"
   Identifier "layout"
   Screen 0 "nvidia"
   Inactive "intel"
EndSection

Section "Device"
   Identifier "intel"
   Driver "modesetting"
   BusID "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "intel"
   Deviice "intel"
EndSection

Section "Device"
   Identifier "nvidia"
   Driver "nvidia"
   BusID "PCI:1:0:0"
   Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Section "Screen"
        Identifier "nvidia"
   Device "nvidia"
   Option "AllowEmptyInitialConfiguration"
EndSection


Otherwise, you get this:
Code:
 [  6587.148] (II) UnloadModule: "modesetting"

and it doesn't work
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum