Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nvidia-340.96 in conflitto con xorg-server-1.18.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
messana
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2010
Posts: 81

PostPosted: Sat Oct 29, 2016 12:30 pm    Post subject: [SOLVED] nvidia-340.96 in conflitto con xorg-server-1.18.0 Reply with quote

Buongiorno a tutti vorrei sapere come posso risolvere questo problema. La mia scheda nvida è una gt240 e necessita di drivers 340.96 e comunque non >=341.0.0.
Quando ho installato l'xorg-x11 non è stato installato il drivers nvida allora ho tentato a farlo manualmente infatto avevo già mascherato le versioni non compatibili con la mia scheda nvidia.
Malgrado ciò non sono riuscito e nel terminale ho trovato l'indicazione di dare il seguente comando:emerge --backtrack=30 -uDNv @world
Mi sono ritrovato installato perchè ho accettato il drivers 361.28 e malgrado il mascheramento l'unico drivers che mi viene proposto è questo. Sicuramente ho pasticciato ed è un peccato perchè avrei finito il lavoro. Avete da darmi un consiglio?
Grazie della vostra attenzione buo week end.


Last edited by messana on Sun Oct 30, 2016 7:01 am; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22340
Location: here

PostPosted: Sat Oct 29, 2016 12:34 pm    Post subject: Reply with quote

Come hai mascherato le versioni non compatibili? Cosa riporta il comando
Code:
# emerge -pv nvidia-drivers


EDIT: Ho chiesto di spostare il thread nel forum italiano, questo e' solo per lingua inglese :D
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
messana
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2010
Posts: 81

PostPosted: Sat Oct 29, 2016 1:23 pm    Post subject: risposta Reply with quote

Scrivo a mano perchè sono stato assediato da mio figlio ed un suo amichetto che devono giocare a minecraft in rete locale... ;-)
[ebuild R #] x11-drivers/nvidia-drivers-361.28:0/361: :gentoo USE="X acpi driver kms multilib -gtke -pax_kernel -static-libs -uvm" 0 KiB
Ho mascherato con echo ">x11-drivers/nvidia-drivers-340.96" >> /etc/portage/package,mask/nvidia.drivers
Domanda se maschero in /etc/portage/package.mask/package.mask il risultato è lo stesso vero?
Cmq il sistema è copletamente aggiornato e coerente.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22340
Location: here

PostPosted: Sat Oct 29, 2016 1:29 pm    Post subject: Reply with quote

Se ti ritorna questo vuol dire che hai sbagliato a mascherare le nuove versioni. Per mascherare le versioni maggiori di >=341.0.0 il comando e' questo
Code:
# echo ">=x11-drivers/nvidia-drivers-341.0" >> /etc/portage/package.mask

o se package.mask e' una directory
Code:
# echo ">=x11-drivers/nvidia-drivers-341.0" >> /etc/portage/package.mask/nvidia

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
messana
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2010
Posts: 81

PostPosted: Sat Oct 29, 2016 2:48 pm    Post subject: Reply with quote

Non cambia niente continua con quella versione di driver. Non mi era mai successo....
Anche mascherando quel singolo driver portage me lo ripropone come se il file /package.mask/nviida o /package.mask/package.mask venisse ignorato. Eppure ho in funzione il kernel gentoo-sources4.4.26 e mascherato i successivi.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22340
Location: here

PostPosted: Sat Oct 29, 2016 3:07 pm    Post subject: Reply with quote

messana wrote:
Non cambia niente continua con quella versione di driver. Non mi era mai successo....
Anche mascherando quel singolo driver portage me lo ripropone come se il file /package.mask/nviida o /package.mask/package.mask venisse ignorato. Eppure ho in funzione il kernel gentoo-sources4.4.26 e mascherato i successivi.

Prova a guardare se non hai da qualche altra parte, ovvero nei vari /etc/portage/package.*, qualcosa che smaschera i driver nvidia che hai mascherato
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
messana
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2010
Posts: 81

PostPosted: Sat Oct 29, 2016 3:58 pm    Post subject: Reply with quote

Trovato i pasticci nel package.unmask e da qui torno al problema originale. Conflitto fra nvidia-drivers-340.96 e >xorg-server-17.9999 e cmq se maschero il 18 non va bene ugualmente...
Più tardi fornisco maggiori informazioni.
Code:
(chroot) ubimex / # emerge -DNua @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] x11-base/xorg-drivers-1.18-r1  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick -libinput -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nvidia -amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ] x11-base/xorg-server-1.17.4  USE="glamor ipv6 nptl suid udev xorg -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb"
[ebuild  N     ] x11-drivers/nvidia-drivers-340.96  USE="X acpi multilib tools -pax_kernel -uvm"
[ebuild  N     ] x11-base/xorg-server-1.18.4  USE="glamor ipv6 suid udev xorg -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed)
    ^^                     ^^^^                                                                                                                                     
    x11-base/xorg-server:0/1.18.4= required by (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    (and 2 more with the same problems)

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, ebuild scheduled for merge) pulled in by
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^^ ^                                                                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

(chroot) ubimex / #
Back to top
View user's profile Send private message
messana
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2010
Posts: 81

PostPosted: Sun Oct 30, 2016 6:59 am    Post subject: [solved] Reply with quote

Buongiorno a tutti, per tirare fuori le gambe da questo problema ho sudato le sette camicie (visto che sono un principiante allo sbaraglio). Il drivers della scheda video gt240 nvidia disponibile (340.96) non è compatibile con xorg-server-1.18.0, per risolvere il problema basta mettere in /etc/package.keywords/package.keywords il driver =x11-drivers/nvidia-drivers-340.98 e poi inserire il solito in /etc/portage/package.unmask.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum