Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] gnome crashes due to x11-drivers/xf86-video-intel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
adimanav
n00b
n00b


Joined: 14 Jan 2011
Posts: 24

PostPosted: Thu Oct 27, 2016 7:11 am    Post subject: [Solved] gnome crashes due to x11-drivers/xf86-video-intel Reply with quote

This problem seems to have appeared a few days ago. Now when I suspend my laptop and then resume, gnome crashes losing my existing session and then when I try to log in again, gnome crashes repeatedly (presumably gnome-shell) until I issue
Code:
systemctl restart gdm
After that I am able to log in but of course I lose my existing session and need to open up all my windows again.

Has anybody else faced this issue? If someone could help me out I would be grateful as currently suspend is broken for me.

Code:
journalctl
shows the following relevant output. Have not been able to figure out what's going wrong.
Code:

Oct 27 12:29:43 vasudha gnome-settings-daemon.desktop[5194]: (gnome-settings-daemon:5194): color-plugin-WARNING **: failed to connect to device: Failed to connect to missing device /org/freedesktop/ColorManager/devices/xrandr_Sharp_Corporation_adimanav_1000
Oct 27 12:29:43 vasudha gnome-settings-daemon.desktop[5194]: (gnome-settings-daemon:5194): color-plugin-WARNING **: failed to connect to device: Failed to connect to missing device /org/freedesktop/ColorManager/devices/xrandr_Sharp_Corporation_adimanav_1000
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "21"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "28"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "24"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "32"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "27"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "26"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "23"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "25"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "20"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (**) Option "fd" "26"
Oct 27 12:29:46 vasudha /usr/libexec/gdm-x-session[5137]: (II) AIGLX: Suspending AIGLX clients for VT switch
Oct 27 12:29:46 vasudha org.gnome.Shell.desktop[5167]: (gnome-shell:5167): Clutter-CRITICAL **: clutter_input_device_get_device_id: assertion 'CLUTTER_IS_INPUT_DEVICE (device)' failed
Oct 27 12:29:46 vasudha org.gnome.Shell.desktop[5167]: (gnome-shell:5167): Clutter-CRITICAL **: clutter_input_device_get_device_id: assertion 'CLUTTER_IS_INPUT_DEVICE (device)' failed
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:69
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:67
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:74
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:73
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:65
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:75
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:71
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 226:0
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:66
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:72
Oct 27 12:29:47 vasudha /usr/libexec/gdm-x-session[5137]: (II) systemd-logind: got pause for 13:78


Last edited by adimanav on Thu Oct 27, 2016 12:40 pm; edited 2 times in total
Back to top
View user's profile Send private message
adimanav
n00b
n00b


Joined: 14 Jan 2011
Posts: 24

PostPosted: Thu Oct 27, 2016 12:36 pm    Post subject: Reply with quote

Adding the following to /etc/portage/package.mask
Code:
=x11-drivers/xf86-video-intel-2.99.917_p20161024


That fixed the issue. Opened bug https://bugs.gentoo.org/show_bug.cgi?id=598174
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum