Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDE5/Plasma Various problem, high CPU, high Mem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
venquessa
n00b
n00b


Joined: 07 Mar 2015
Posts: 17

PostPosted: Tue Oct 25, 2016 7:28 pm    Post subject: [SOLVED] KDE5/Plasma Various problem, high CPU, high Mem Reply with quote

I did a emerge update and accepted to upgrade to KDE5/Plasma profile. I am having issues.

Here is a quick grab of top. I see this constantly. dbus-daemon runs at 40% CPU constantly. krunner has currently allocated 258Gb of virtual address space. Yes, 258Gb!

Code:
3114 paul      20   0   20228   2832   1872 S  39.2  0.0  45:31.27 dbus-daemon                                                                                                                                                                                                                                       
 3139 paul      20   0 1249104  50592  40600 S  18.3  0.3  21:07.64 kded5                                                                                                                                                                                                                                             
 3205 paul      20   0 3502444 276856  84312 S  14.6  1.7  17:04.51 plasmashell                                                                                                                                                                                                                                       
 2562 root      20   0  272380   4752   3728 S  12.3  0.0  14:15.09 syslog-ng                                                                                                                                                                                                                                         
 3238 paul      20   0  719248  58516  47672 S  11.0  0.4  12:21.52 kmix                                                                                                                                                                                                                                             
 3135 paul      20   0  464472  32700  29056 S  10.3  0.2  11:42.01 klauncher                                                                                                                                                                                                                                         
23290 paul      20   0 1248708 386332  90088 R   6.6  2.4   0:45.55 firefox                                                                                                                                                                                                                                           
 3003 root      20   0  382408  78940  54256 S   2.3  0.5   8:09.66 X   


Chrome takes 30 seconds to appear, some apps don't work and so on and so forth.

Other issues are with syslog-ng running high CPU and when I open /var/log/messages it looks like this.
Code:
02fba810  65 78 64 5b 31 37 34 32  5d 3a 20 6f 62 65 78 5f  |exd[1742]: obex_|
02fba820  73 65 72 76 65 72 5f 69  6e 69 74 20 66 61 69 6c  |server_init fail|
02fba830  65 64 0a 4f 63 74 20 31  38 20 31 38 3a 30 36 3a  |ed.Oct 18 18:06:|
02fba840  34 36 20 6c 6f 63 61 6c  68 6f 73 74 20 6f 62 65  |46 localhost obe|
02fba850  78 64 5b 31 37 34 34 5d  3a 20 4f 42 45 58 20 64  |xd[1744]: OBEX d|
02fba860  61 65 6d 6f 6e 20 35 2e  33 39 0a 4f 63 74 20 31  |aemon 5.39.Oct 1|
02fba870  38 20 31 38 3a 30 36 3a  34 36 20 6c 6f 63 61 6c  |8 18:06:46 local|
02fba880  68 6f 73 74 20 6f 62 65  78 64 5b 31 37 34 34 5d  |host obexd[1744]|
02fba890  3a 20 6f 62 65 78 5f 73  65 72 76 65 72 5f 69 6e  |: obex_server_in|
02fba8a0  69 74 20 66 61 69 6c 65  64 0a 4f 63 74 20 31 38  |it failed.Oct 18|
02fba8b0  20 31 38 3a 30 36 3a 34  36 20 6c 6f 63 61 6c 68  | 18:06:46 localh|
02fba8c0  6f 73 74 20 6f 62 65 78  64 5b 31 37 34 36 5d 3a  |ost obexd[1746]:|
02fba8d0  20 4f 42 45 58 20 64 61  65 6d 6f 6e 20 35 2e 33  | OBEX daemon 5.3|
02fba8e0  39 0a 4f 63 74 20 31 38  20 31 38 3a 30 36 3a 34  |9.Oct 18 18:06:4|
02fba8f0  36 20 6c 6f 63 61 6c 68  6f 73 74 20 6f 62 65 78  |6 localhost obex|
02fba900  64 5b 31 37 34 36 5d 3a  20 6f 62 65 78 5f 73 65  |d[1746]: obex_se|
02fba910  72 76 65 72 5f 69 6e 69  74 20 66 61 69 6c 65 64  |rver_init failed|
02fba920  0a 4f 63 74 20 31 38 20  31 38 3a 30 36 3a 34 36  |.Oct 18 18:06:46|
02fba930  20 6c 6f 63 61 6c 68 6f  73 74 20 6f 62 65 78 64  | localhost obexd|
02fba940  5b 31 37 34 38 5d 3a 20  4f 42 45 58 20 64 61 65  |[1748]: OBEX dae|
02fba950  6d 6f 6e 20 35 2e 33 39  0a 4f 63 74 20 31 38 20  |mon 5.39.Oct 18 |
02fba960  31 38 3a 30 36 3a 34 36  20 6c 6f 63 61 6c 68 6f  |18:06:46 localho|
02fba970  73 74 20 6f 62 65 78 64  5b 31 37 34 38 5d 3a 20  |st obexd[1748]: |
02fba980  6f 62 65 78 5f 73 65 72  76 65 72 5f 69 6e 69 74  |obex_server_init|
02fba990  20 66 61 69 6c 65 64 0a  4f 63 74 20 31 38 20 31  | failed.Oct 18 1|
02fba9a0  38 3a 30 36 3a 34 36 20  6c 6f 63 61 6c 68 6f 73  |8:06:46 localhos|
02fba9b0  74 20 6f 62 65 78 64 5b  31 37 35 30 5d 3a 20 4f  |t obexd[1750]: O|
02fba9c0  42 45 58 20 64 61 65 6d  6f 6e 20 35 2e 33 39 0a  |BEX daemon 5.39.|
02fba9d0  4f 63 74 20 31 38 20 31  38 3a 30 36 3a 34 36 20  |Oct 18 18:06:46 |
02fba9e0  6c 6f 63 61 6c 68 6f 73  74 20 6f 62 65 78 64 5b  |localhost obexd[|
02fba9f0  31 37 35 30 5d 3a 20 6f  62 65 78 5f 73 65 72 76  |1750]: obex_serv|
02fbaa00  65 72 5f 69 6e 69 74 20  66 61 69 6c 65 64 0a 4f  |er_init failed.O|
02fbaa10  63 74 20 31 38 20 31 38  3a 30 36 3a 34 36 20 6c  |ct 18 18:06:46 l|
02fbaa20  6f 63 61 6c 68 6f 73 74  20 6f 62 65 78 64 5b 31  |ocalhost obexd[1|
02fbaa30  37 35 32 5d 3a 20 4f 42  45 58 20 64 61 65 6d 6f  |752]: OBEX daemo|
02fbaa40  6e 20 35 2e 33 39 0a 4f  63 74 20 31 38 20 31 38  |n 5.39.Oct 18 18


Why is it binary and why is OBEX daemon spamming the logs so hard. Something isn't right here. I suspect something is running in an infinite loop spaming some part of dbus or plasmashell, but I can't work out what.

Any pointers?

Thanks


Last edited by venquessa on Tue Oct 25, 2016 8:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
venquessa
n00b
n00b


Joined: 07 Mar 2015
Posts: 17

PostPosted: Tue Oct 25, 2016 8:59 pm    Post subject: Reply with quote

It's okay, figured it out.

https://forums.gentoo.org/viewtopic-t-1053150.html?sid=17a5d2fc6af9d29227248bdccbf6d0b0

and the syslog-ng bug causing the file to be detected as binary. Not so much worried about the logging bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum