Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HARDWARE] HP 2013 UltraSlim Docking Station: displayport Ko
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
256JMaN
n00b
n00b


Joined: 20 May 2006
Posts: 37

PostPosted: Tue Oct 25, 2016 6:53 am    Post subject: [HARDWARE] HP 2013 UltraSlim Docking Station: displayport Ko Reply with quote

Bonjour,

Je n'arrive pas a configurer ma gentoo pour avoir de l'affichage sur mes trois écrans quand je connecte mon zbook sur mon dock.

L’écran du zbook fonctionne, celui connecté au port vga fonctionne également mais pas celui connecté au displayport du dock

Si je connecte le cable du displayport directement sur le zbook cela fonctionne.

Quand je démarre l'ecran s'affiche sur le message du noyau, reste figé et passe en veille au démarrage d'xorg
Détail important : tout fonctionne normalement sous windows (je suis en dualboot pour le moment)


Détail de ma config :

HARDWARE

ZBook 14 (G1)
Carte hybride Intel / AMD's Fire Pro M4100
Code:
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] (rev ff)


SOFTWARE

VIDEO_CARDS="intel i965 radeon radeonsi amdgpu"
Environnement = Plasma 5/ Xorg
Gentoo amd64 / systemd

je ne maîtrise pas trop cette config de carte hybrid pour le moment, je ne serais pas dire sur quel driver elle tourne en ce moment :roll:
je ne sais pas trop par ou chercher non plus, config du noyau, config de Xorg ... quelqu'un à une piste ?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Tue Oct 25, 2016 8:31 am    Post subject: Reply with quote

J'ai eu un problème similaire mais avec un port réseau une fois, et mon idée était effectivement un driver manquant ou une blague du genre (mais vu que ce n'était pas mon dock, je n'ai pas cherché plus loin :)).
Si tu te fais tes noyaux persos, l'idée serait de booter sur un LiveCD récent (contenant un max de drivers donc), et de voir ce qui est détecté/si cela fonctionne. Ensuite, muni de la commande lshw, tu repères le driver correspondant et tu l'ajoutes à ta configuration perso.
Pour les GPUs hybrides, je n'en ai jamais eu par contre.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum