Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
switch from profile desktop/gnome to desktop
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 54

PostPosted: Sat Oct 22, 2016 9:45 am    Post subject: switch from profile desktop/gnome to desktop Reply with quote

Hi, I am new to gentoo. I come from 5 years of arch linux and I'm really enjoying gentoo (even though I cannot make my sound card working neither the GPU..)

during the installation I planned to install gnome so I set desktop/gnome profile. But finally I went for Openbox with openRC.

Now my question is:

should I move from
Code:

default/linux/amd64/13.0/desktop/gnome

to
Code:

default/linux/amd64/13.0/desktop

?

Thanks in advance
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23504
Location: here

PostPosted: Sat Oct 22, 2016 10:44 am    Post subject: Reply with quote

desktop profile is more appropriate for openbox. When you switch run an update emerge -uDNUa @world and then emerge --depclean -a for remove package not needed for new profile
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 54

PostPosted: Sat Oct 22, 2016 6:36 pm    Post subject: Reply with quote

thanks @fedeliallalinea!

when I run the update I get some conflicts. what should I do?

Code:

# emerge -uDNUa @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/webrtc-audio-processing-0.3 [0.1-r1]
[ebuild  N     ] dev-libs/npth-1.2  USE="-static-libs"
[ebuild  N     ] net-wireless/rfkill-0.5
[ebuild     U  ] sys-process/cronbase-0.3.7-r5 [0.3.7-r3]
[ebuild     U  ] dev-libs/vala-common-0.32.1 [0.30.1]
[ebuild  NS    ] virtual/jpeg-62 [0-r2] ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-libs/libvpx-1.5.0  USE="svc threads -doc -postproc -static-libs {-test}" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx sse sse2 -avx -avx2 -sse3 -sse4_1 -ssse3"
[ebuild     U  ] app-shells/bash-4.3_p48 [4.3_p46-r1]
[ebuild     U  ] app-text/iso-codes-3.70 [3.68]
[ebuild     U  ] dev-util/gdbus-codegen-2.48.2 [2.46.2]
[ebuild     U  ] dev-libs/glib-2.48.2 [2.46.2-r3]
[ebuild     U  ] x11-libs/libX11-1.6.4 [1.6.3]
[ebuild     U  ] dev-util/gtk-doc-am-1.25-r1 [1.25]
[ebuild   R    ] net-misc/curl-7.50.3  CURL_SSL="openssl* -nss*"
[ebuild  N     ] dev-libs/re2-0.2016.05.01  USE="icu" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] x11-proto/xf86dgaproto-2.1-r2  ABI_X86="32*"
[ebuild     U  ] x11-libs/libXrender-0.9.10 [0.9.9]
[ebuild     U  ] x11-libs/libXfixes-5.0.3 [5.0.2]
[ebuild   R    ] dev-python/pycurl-7.19.3.1-r2  CURL_SSL="openssl* -nss*"
[ebuild     U  ] dev-lang/orc-0.4.26-r1 [0.4.25]
[ebuild     U  ] x11-libs/libXi-1.7.7 [1.7.6]
[ebuild     U  ] x11-libs/libXrandr-1.5.1 [1.5.0]
[ebuild     U  ] x11-libs/libXv-1.0.11 [1.0.10]
[ebuild     U  ] x11-libs/libXtst-1.2.3 [1.2.2]
[ebuild     U  ] dev-libs/gobject-introspection-common-1.48.0 [1.46.0]
[ebuild     U  ] dev-libs/gobject-introspection-1.48.0 [1.46.0]
[blocks b      ] <dev-libs/gobject-introspection-1.48.0 ("<dev-libs/gobject-introspection-1.48.0" is blocking dev-libs/gobject-introspection-common-1.48.0)
[ebuild     U  ] x11-libs/gdk-pixbuf-2.34.0 [2.32.3]
[ebuild     U  ] dev-libs/atk-2.20.0 [2.18.0]
[ebuild     U  ] dev-util/gtk-update-icon-cache-3.20.9 [3.18.4]
[ebuild   R    ] media-libs/mesa-12.0.1  USE="-gles2*"
[ebuild     U  ] sys-fs/dosfstools-4.0-r1 [3.0.28] USE="udev%* -compat%"
[ebuild     U  ] media-libs/harfbuzz-1.3.1 [1.2.7]
[ebuild     U  ] x11-libs/pango-1.40.3 [1.38.1]
[ebuild     U  ] gnome-base/dconf-0.26.0 [0.24.0]
[ebuild     U  ] sys-apps/dbus-1.10.12 [1.10.8-r1]
[ebuild     U  ] gnome-base/librsvg-2.40.16 [2.40.15]
[ebuild   R    ] media-libs/libsdl-1.2.15-r9  USE="-pulseaudio*"
[ebuild     U  ] x11-themes/adwaita-icon-theme-3.20 [3.18.0]
[ebuild     U  ] app-accessibility/at-spi2-core-2.20.2 [2.18.3]
[ebuild   R    ] x11-base/xorg-server-1.18.4  USE="-kdrive*"
[ebuild   R    ] media-video/ffmpeg-2.8.6  USE="-pulseaudio*"
[ebuild     U  ] app-accessibility/at-spi2-atk-2.20.1 [2.18.1]
[ebuild     U  ] sys-apps/man-pages-4.07 [4.06]
[ebuild   R    ] sys-auth/pambase-20150213  USE="-gnome-keyring*"
[ebuild   R    ] dev-util/ninja-1.6.0  USE="emacs*"
[ebuild   R    ] sys-power/apcupsd-3.14.13  USE="-gnome*"
[ebuild     U  ] x11-libs/gtk+-3.20.9 [3.18.9] USE="-colord*"
[ebuild     U  ] x11-libs/gtk+-2.24.31 [2.24.30]
[ebuild   R    ] x11-libs/wxGTK-3.0.2.0-r2  USE="-gstreamer*"
[ebuild  NS    ] x11-libs/vte-0.44.2 [0.36.5] USE="crypt introspection -debug -glade -vala"
[ebuild   R    ] media-libs/libcanberra-0.30-r5  USE="-gnome* -gstreamer* -pulseaudio*"
[ebuild   R    ] x11-drivers/nvidia-drivers-361.28  USE="-gtk3*"
[ebuild   R    ] virtual/notification-daemon-0  USE="-gnome*"
[ebuild   R    ] dev-util/cmake-3.5.2-r1  USE="emacs*"
[ebuild   R    ] app-crypt/pinentry-0.9.5  USE="-gnome-keyring*"
[ebuild   R    ] dev-libs/libical-1.0.1  USE="-introspection*"
[ebuild     U  ] app-crypt/gnupg-2.1.15 [2.0.28] USE="gnutls%* -tofu%"
[ebuild     U  ] x11-terms/sakura-3.3.4 [3.2.0]
[ebuild     U  ] net-wireless/wpa_supplicant-2.6 [2.5-r2]
[ebuild   R    ] dev-vcs/git-2.7.3-r1  USE="-gnome-keyring*"
[ebuild     U  ] www-client/chromium-54.0.2840.59 [53.0.2785.116] USE="(gn*) suid%* -gnome* -gnome-keyring* -pulseaudio*"
[ebuild     U  ] media-sound/pulseaudio-9.0 [8.0] USE="-gnome*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/python:2.7

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-lang/python-2.7.5-r2:2.7[sqlite] required by (dev-python/nbformat-4.1.0:0/0::gentoo, installed)
                                   ^^^^^^
    >=dev-lang/python-2.7.5-r2:2.7[readline,sqlite,threads(+)] required by (dev-python/ipython-5.1.0:0/0::gentoo, installed)
                                            ^^^^^^           

dev-lang/python:3.4

  (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/python:3.4[readline,sqlite,threads(+)] required by (dev-python/ipython-5.1.0:0/0::gentoo, installed)
                                 ^^^^^^           
    dev-lang/python:3.4[sqlite] required by (dev-python/nbformat-4.1.0:0/0::gentoo, installed)
                        ^^^^^^


Could you help me in understanding what i the issue?

thanks
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 455
Location: Australia

PostPosted: Sun Oct 23, 2016 12:22 am    Post subject: Reply with quote

The issue is caused because your ../desktop/gnome profile has built both of your installed python versions with the sqlite flag set.

Your new profile ../desktop doesn't set this flag - something installed depends on it.

You can track down the dependency and see if you actually need it, or, probably easier initially; manually set the sqlite flag for python in package use:
Code:
dev-lang/python sqlite

and re-run your world update.
Back to top
View user's profile Send private message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 54

PostPosted: Mon Oct 24, 2016 8:18 am    Post subject: Reply with quote

thanks to both of you guys! everything went fine!
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Thu Dec 26, 2019 2:55 pm    Post subject: Reply with quote

Good day, I am in the same case: switched profile from /desktop/gnome to /desktop (I am on i3). After emerge -uDNUa @world I see:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-3.6.9  USE="-sqlite*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/python:2.7

  (dev-lang/python-2.7.17:2.7/2.7::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-lang/python-2.7.5-r2:2.7[ncurses,sqlite,ssl,threads] required by (dev-lang/spidermonkey-60.5.2_p0-r2:60/60::gentoo, installed)
                                           ^^^^^^


Would you like to merge these packages? [Yes/No]

Emerge asking me to reinstall Python without sqlite? Is it safe to say Yes?

This is response from equery g dev-lang/spidermonkey-60.5.2_p0-r2
Code:
 * dependency graph for dev-lang/spidermonkey-60.5.2_p0-r2
 `--  dev-lang/spidermonkey-60.5.2_p0-r2  x86
   `--  dev-libs/nspr-4.22  (>=dev-libs/nspr-4.13.1) x86
   `--  virtual/libffi-3.3_rc0  (virtual/libffi) x86
   `--  sys-libs/readline-7.0_p5-r1  (sys-libs/readline) x86
   `--  sys-libs/zlib-1.2.11-r2  (>=sys-libs/zlib-1.2.3) x86
   `--  dev-libs/icu-64.2  (>=dev-libs/icu-59.1) x86
   `--  app-portage/elt-patches-20170815  (>=app-portage/elt-patches-20170815) x86
   `--  sys-devel/automake-1.16.1-r1  (>=sys-devel/automake-1.16.1) x86
   `--  sys-devel/automake-1.15.1-r2  (>=sys-devel/automake-1.15.1) x86
   `--  sys-devel/autoconf-2.13-r1  (~sys-devel/autoconf-2.13) x86
   `--  sys-devel/libtool-2.4.6-r3  (>=sys-devel/libtool-2.4) x86
   `--  virtual/pkgconfig-1  (virtual/pkgconfig) x86
   `--  dev-lang/python-2.7.17  (>=dev-lang/python-2.7.5-r2) x86  [ncurses sqlite ssl threads]
[ dev-lang/spidermonkey-60.5.2_p0-r2 stats: packages (13), max depth (1) ]


As I understand dev-lang/spidermonkey-60.5.2_p0-r2 needs Python with sqlite, so why world rebuild trying to rebuild python to remove sqlite?
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 169

PostPosted: Thu Dec 26, 2019 4:40 pm    Post subject: Reply with quote

If you look at the output of your emerge command, you will see that it onyl wants to rebuild python-3.6 without sqlite. spidermonkey needs python-2.7, that's why portage doesn't want to rebuild python-2.7.
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Thu Dec 26, 2019 6:47 pm    Post subject: Reply with quote

I tried to find what is mean * in use, here:
Code:
[ebuild   R    ] dev-lang/python-3.6.9  USE="-sqlite*"

Please clarify.
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Thu Dec 26, 2019 6:51 pm    Post subject: Reply with quote

R mean Rebuild?
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Thu Dec 26, 2019 7:05 pm    Post subject: :?: Reply with quote

And again about dependency conflict: ok Python 3 and Python 2 is different things, I get it, I should have read more carefully.

But the same question: what exactly this mean?
Code:
  (dev-lang/python-2.7.17:2.7/2.7::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-lang/python-2.7.5-r2:2.7[ncurses,sqlite,ssl,threads] required by (dev-lang/spidermonkey-60.5.2_p0-r2:60/60::gentoo, installed)
                                           ^^^^^^


sqlite is not needed in system anymore (after changing profile from Gnome to Desktop), but Spidermonkey needs Python 2 with sqlite, so why Emerge want remove sqlite?
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 169

PostPosted: Thu Dec 26, 2019 7:17 pm    Post subject: Reply with quote

Again, spidermonkey needs python-2.7 with sqlite. What you have to do is add an entry to /etc/portage/package.use like
Code:
dev-lang/python:2.7 sqlite
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3545
Location: Illinois, USA

PostPosted: Thu Dec 26, 2019 7:22 pm    Post subject: Re: :?: Reply with quote

vitaly-zdanevich wrote:
sqlite is not needed in system anymore (after changing profile from Gnome to Desktop), but Spidermonkey needs Python 2 with sqlite, so why Emerge want remove sqlite?

Good question. IMHO, the answer is "because portage is not very smart". You can try adding --backtrack=200 to make portage search longer, but in this case, unless you are dead set against having sqlite, you could either add sqlite to the package.use flags for spidermonkey, or (what I would do) add sqlite to the USE flags in make.conf, applying them automatically to every package with that option. But then I do want sqlite and sqlitebrowser.

The portage error messages are not very clear except to experts (I am not an expert).
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Thu Dec 26, 2019 8:12 pm    Post subject: Reply with quote

Ok, thanks for help - I added
Code:
dev-lang/python:2.7 sqlite
to etc/portage/package.use/python.
and now emerge -uDNUa @world is clean.


Last edited by vitaly-zdanevich on Tue Dec 31, 2019 1:54 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14956

PostPosted: Fri Dec 27, 2019 1:15 am    Post subject: Reply with quote

Portage was trying to rebuild with USE=-sqlite on that package because that is what your system configuration requested. The dependency resolver was smart enough to flag this as an error. It is permitted to suggest configuration changes, but it can't override your requested configuration just to satisfy some other package. In some cases, you may want to change the other package and keep the existing configuration, so overriding your configuration would be incorrect.
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Fri Dec 27, 2019 5:49 pm    Post subject: Reply with quote

Quote:
It is permitted to suggest configuration changes

What it that mean? Suggest in what form? You mean USE flags?

Quote:
you may want to change the other package

What you mean here? As I understand I cannot change dependencies of other packages?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14956

PostPosted: Sat Dec 28, 2019 1:05 am    Post subject: Reply with quote

Portage can suggest changes to USE flags, accepted keywords, or even masks.

You can influence the other package by changing any of those too. For example:
foo-1.ebuild:
IUSE="a b"
DEPEND=" a? ( category/bar[b=] )"
bar-1.ebuild:
IUSE="b"
If you set USE=a b for foo and USE=-b for bar, then you have an invalid configuration. However, there are three solutions here:
  • Set USE=-a on foo, to disable the dependency entirely.
  • Set USE=-b on foo so that bar[-b] is required, which matches what you have.
  • Set USE=b on bar.
Portage cannot know which of those solutions you will want, so the best it can do is tell you that your current configuration is not allowed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum