Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with terminals after starting X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
willyd
n00b
n00b


Joined: 07 Jan 2016
Posts: 7

PostPosted: Thu Oct 20, 2016 4:49 pm    Post subject: Problem with terminals after starting X Reply with quote

Hello.
I have some problems with terminals.
Gentoo was installed with handbook. Kernel configured with genkernel with a few manual additions.
After some random time from starting X terminal is became unvailable. It is not blacklight screen. There is cursor but it doesn't blink.
Problem appears under kde and xfce. So as I think issue with X server or kernel config.

Terminals are alive.
Code:
$ ps aux | grep tty
root      3383  0.0  0.0  17884  1904 tty1     Ss+  18:03   0:00 /sbin/agetty 38400 tty1 linux
root      3384  0.0  0.0  17884  1892 tty2     Ss+  18:03   0:00 /sbin/agetty 38400 tty2 linux
root      3385  0.0  0.0  17884  1864 tty3     Ss+  18:03   0:00 /sbin/agetty 38400 tty3 linux
root      3386  0.0  0.0  17884  1888 tty4     Ss+  18:03   0:00 /sbin/agetty 38400 tty4 linux
root      3387  0.0  0.0  17884  1956 tty5     Ss+  18:03   0:00 /sbin/agetty 38400 tty5 linux
root      3388  0.0  0.0  17884  1952 tty6     Ss+  18:03   0:00 /sbin/agetty 38400 tty6 linux

messages are clear.
Code:
[   11.996053] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input22
[   11.996112] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input23
[   11.996156] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input24
[   12.861874] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[   12.865796] vboxdrv: Found 4 processor cores.
[   12.866075] vboxdrv: fAsync=0 offMin=0x109 offMax=0xfa5
[   12.866165] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[   12.866166] vboxdrv: Successfully loaded version 4.3.38 (interface 0x001a000b).
[   12.875761] vboxpci: IOMMU not found (not registered)
[   14.089630] EXT4-fs (sdb4): re-mounted. Opts: (null)
[   14.158516] Adding 8688636k swap on /dev/sdb3.  Priority:-1 extents:1 across:8688636k SS
[   14.203025] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   16.286423] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[  170.309308] snd_hda_intel 0000:00:1b.0: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
[  399.472283] kactivitymanage[3495]: segfault at 7fa2f72e0c50 ip 00007fa2e0074171 sp 00007fff69accf08 error 4 in libQt5Sql.so.5.6.1[7fa2e005f000+43000]
[  798.938217] e1000e: enp0s25 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[  798.938245] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO
[  798.938405] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
[ 1194.775000] perf interrupt took too long (2508 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 3603.667452] perf interrupt took too long (5121 > 5000), lowering kernel.perf_event_max_sample_rate to 25000


I would be grateful for the idea which way to look.
Thank you.


Last edited by willyd on Sat Oct 22, 2016 7:21 pm; edited 2 times in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6151
Location: almost Mile High in the USA

PostPosted: Fri Oct 21, 2016 4:21 pm    Post subject: Reply with quote

Not clear what you mean.

Do you mean that when you switch out of X to the virtual console terminals it's black and unresponsive, or opening an xterm or xfce4-terminal that shows a cursor but doesn't work?

The former is actually kind of common and usually a hardware difference from the reference design. You'll have to live with it most likely if upgrading your kernel video driver doesn't work. This should NOT happen with KMS drivers.

The second is weird, almost seems the pty driver died or something. But want to make sure this is the case before investigating.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
willyd
n00b
n00b


Joined: 07 Jan 2016
Posts: 7

PostPosted: Sat Oct 22, 2016 2:22 pm    Post subject: Reply with quote

Hello.
After the machine start virtual console terminals works great. But after some certain time if I switch to console terminal it becomes irresponsible. Some times there are clear screen with non blinking cursor other it can bee irresponsible login prompt.
I can't to catch the time when it becomes not working.
Did you say that it should work if I compile kernel with KMS drivers support?
Thank you.
Back to top
View user's profile Send private message
Tony0945
Veteran
Veteran


Joined: 25 Jul 2006
Posts: 1938
Location: Illinois, USA

PostPosted: Sat Oct 22, 2016 5:47 pm    Post subject: Reply with quote

willyd wrote:
Hello.
But after some certain time if I switch to console terminal it becomes irresponsible. Some times there are clear screen with non blinking cursor other it can bee irresponsible login prompt.

I assume you mean VT1 becomes unresponsive. Did you try VT2 or VT3? Are you starting X with startx or a manager like xdm,gdm,kde,slim? If so which one?

Which version Xorg are you running 1.17 or 1.18? I just upgraded to 1.18 and the mouse was unresponsive after five boots (it's a dual boot machine), the mouse suddenly stared working. Reminds me of Windows ME.
Back to top
View user's profile Send private message
willyd
n00b
n00b


Joined: 07 Jan 2016
Posts: 7

PostPosted: Sat Oct 22, 2016 6:15 pm    Post subject: Reply with quote

Tony0945 wrote:
willyd wrote:
Hello.
But after some certain time if I switch to console terminal it becomes irresponsible. Some times there are clear screen with non blinking cursor other it can bee irresponsible login prompt.

I assume you mean VT1 becomes unresponsive. Did you try VT2 or VT3? Are you starting X with startx or a manager like xdm,gdm,kde,slim? If so which one?

Which version Xorg are you running 1.17 or 1.18? I just upgraded to 1.18 and the mouse was unresponsive after five boots (it's a dual boot machine), the mouse suddenly stared working. Reminds me of Windows ME.

They all was irresponsible.
Actually, problem is solved.
There was conflicts between FB_EFI and I915, first was compiled in kernel second in module. Disabling all unnecessary drivers and enabling i915 in kernel resolve an issue.
Thanks to iamben at #gentoo.
Thank you.
Back to top
View user's profile Send private message
willyd
n00b
n00b


Joined: 07 Jan 2016
Posts: 7

PostPosted: Sat Oct 22, 2016 7:21 pm    Post subject: Reply with quote

Not solved. Problem still exists.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6151
Location: almost Mile High in the USA

PostPosted: Sat Oct 22, 2016 7:50 pm    Post subject: Reply with quote

Is this very new hardware? What hardware are we talking about?

You may have to file a bug on freedesktop.org with your exact hardware against the Intel driver.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
willyd
n00b
n00b


Joined: 07 Jan 2016
Posts: 7

PostPosted: Sat Oct 22, 2016 10:21 pm    Post subject: Reply with quote

eccerr0r wrote:
Is this very new hardware? What hardware are we talking about?

You may have to file a bug on freedesktop.org with your exact hardware against the Intel driver.

No. It is not new hw.
HP EliteBook 840 G2.
Intel(R) Core(TM) i5-4310U CPU @ 2.00GHz
HD4400

It's not new.

I'm thinking of switching from EFI to BIOS and check it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum