Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
screen can only be right of main screen (nvidia, 2 screens)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
karloff
n00b
n00b


Joined: 22 Jan 2008
Posts: 20

PostPosted: Thu Oct 20, 2016 5:20 pm    Post subject: screen can only be right of main screen (nvidia, 2 screens) Reply with quote

Hey there i have a strange problem with my new nvidia GTX 960 card.

I try to get the following (i my mind very simple) setup, my secound screen left of my main (primary) screen, but it seems impossible - yes this sounds strange ...

I think its a problem with twinview in past with my old card and xinarama it works out of the box, but im not able to find out what the problem exactly is.

i try things like this make a file in /etc/x11/xorg.conf.d/ with the adapters and the leftof and things like this but X still ignore it, i had also try to edit my xorg.conf by hand :,(
but this dont work too ... so i dont know what can i still try.

will post output of xrandr, my xorg.conf hopefully one of you have a idea to fix this problem

xrandr
Code:

Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00*+  59.94    50.00    60.00    50.04 
   1680x1050     59.95 
   1440x900      59.89 
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1280x720      60.00    59.94    50.00 
   1152x864      75.00 
   1024x768      75.03    70.07    60.00 
   800x600       75.00    72.19    60.32    56.25 
   720x576       50.00 
   720x480       59.94 
   640x480       75.00    59.94    59.93 
   480x576       50.00 
   480x480       59.94 
DP-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+
   1680x1050     59.95 
   1440x900      59.89 
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1280x800      59.81 
   1280x720      60.00 
   1152x864      75.00 
   1024x768      75.03    70.07    60.00 
   800x600       75.00    72.19    60.32    56.25 
   640x480       75.00    59.94 
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)


xrog.conf (i removed all my useless changes and start with a fresh one)
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 361.28  (portage@blackbeard)  Mi 5. Okt 22:05:04 CEST 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ASUS VS247"
    HorizSync       24.0 - 83.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DP-0: nvidia-auto-select +0+0, HDMI-0: nvidia-auto-select +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


in /etc/X11/xorg.conf.d/ there are only a config for my keyboard (german umlauts) and one for opengl, it think eselect created it for me
[/quote]
DP-0 is the secondary screen and hdmi-0 the main screen

Ah okay i forget the tell, i can set hdmi as primary but the is dp-0 right of it (in x) but in real it stand left of it on my desk ..., to change screens position physically is no option


Last edited by karloff on Thu Oct 20, 2016 5:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Oct 20, 2016 5:23 pm    Post subject: Reply with quote

When I had nVidia card I used xrandr in my ~/.xinitrc to set up the displays.
Back to top
View user's profile Send private message
karloff
n00b
n00b


Joined: 22 Jan 2008
Posts: 20

PostPosted: Thu Oct 20, 2016 5:39 pm    Post subject: Reply with quote

oh yes i forget i played it bit around with xrandr but without any change happend.
Content of my .xinitrc

Code:

xrandr --output HDMI-0 --mode 1920x1080 --primary
xrandr --output DP-0 --auto --left-of HDMI-0 --noprimary
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Oct 20, 2016 5:59 pm    Post subject: Reply with quote

Code:
xrandr --auto --output DVI-I-3 --left-of DVI-I-2


^^ This worked for me.
Back to top
View user's profile Send private message
karloff
n00b
n00b


Joined: 22 Jan 2008
Posts: 20

PostPosted: Fri Oct 21, 2016 4:41 am    Post subject: Reply with quote

but unfortunately not for me.

I remove my /etc/X11/xorg.conf, but abolut nothing happend.

Maybe this is a new "feature" from the nvidia-drivers?
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Fri Oct 21, 2016 5:02 am    Post subject: Reply with quote

Looking at xrandr output there is DP1, not DP-1, and HDMI1, not HDMI-1.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Oct 21, 2016 8:33 am    Post subject: Reply with quote

with nvidia settings I was able to move the location / change resolution / vfreq of the additional external monitor.

I use the latest available portage nvidia binary driver.

According to the nvidia faq, those location settings should also work with the binary driver. I have read that half a year ago.

As I do not always use the external monitor, i set it up on demand with the nvidia-settings tool to my current use case on every usage.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum