Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X Server does not load GLX (nvidia 361.28)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
xombael
n00b
n00b


Joined: 07 Oct 2016
Posts: 6
Location: Germany

PostPosted: Wed Oct 19, 2016 5:06 pm    Post subject: X Server does not load GLX (nvidia 361.28) Reply with quote

hello community,
my x server starts with my intel cpu graphics instead of my nvidia card, because GLX is not found.

the kernel is configured correctly, and an own /etc/X11/xorg.conf.d/nvidia.conf is placed. (no nvidia-xconfig + no xorg.conf !)
this conf is loaded with startx without problems (x server running fine).

how can i prevent the 'autoconfigured nvidia' line from being executed ? (xorg log file)
why does it unload my nvidia module (correctly loaded with glx) and then replaces it with a wrong one? (xorg log file)

laptop:
Acer Aspire 5742G, i5-480M , GeForce 540M

if any further information is necessary, please ask.

thanks upfront for advises / fix

Code:

lspci -k
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
Subsystem: Acer Incorporated [ALI] GF108M [GeForce GT 540M]
Kernel driver in use: nvidia
Kernel modules: nvidia

nvidia.conf
Section "Device"
 Identifier "NVIDIA Corporation GF108M [GeForce GT 540M]"
 Driver "nvidia"
 VendorName "NVIDIA Corporation"
 BusID "PCI:1:0:0"
EndSection


Code:

[  2103.152]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[  2103.155] X Protocol Version 11, Revision 0
[  2103.156] Build Operating System: Linux 4.4.21-gentoo x86_64 Gentoo
[  2103.157] Current Operating System: Linux x12x13 4.4.21-gentoo #6 SMP Wed Oct 19 15:31:45 CEST 2016 x86_64
[  2103.157] Kernel command line:
[  2103.158] Build Date: 08 October 2016  06:30:18PM
[  2103.159] 
[  2103.160] Current version of pixman: 0.34.0
[  2103.162]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2103.162] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2103.166] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 19 17:49:56 2016
[  2103.167] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2103.168] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2103.169] (==) No Layout section.  Using the first Screen section.
[  2103.169] (==) No screen section available. Using defaults.
[  2103.169] (**) |-->Screen "Default Screen Section" (0)
[  2103.169] (**) |   |-->Monitor "<default monitor>"
[  2103.169] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  2103.169] (**) |   |-->Device ""
[  2103.169] (**) |   |-->GPUDevice "NVIDIA Corportation GF108M [GeForce GT 540M]"
[  2103.169] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  2103.169] (==) Automatically adding devices
[  2103.169] (==) Automatically enabling devices
[  2103.169] (==) Automatically adding GPU devices
[  2103.169] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2103.169] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  2103.169]    Entry deleted from font path.
[  2103.169] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  2103.169]    Entry deleted from font path.
[  2103.169] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  2103.169]    Entry deleted from font path.
[  2103.169] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  2103.169]    Entry deleted from font path.
[  2103.169]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  2103.169] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  2103.169]    Entry deleted from font path.
[  2103.169]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  2103.169] (==) FontPath set to:
   /usr/share/fonts/misc/
[  2103.169] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[  2103.169] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2103.169] (II) Loader magic: 0x811c80
[  2103.169] (II) Module ABI versions:
[  2103.169]    X.Org ANSI C Emulation: 0.4
[  2103.169]    X.Org Video Driver: 20.0
[  2103.169]    X.Org XInput driver : 22.1
[  2103.169]    X.Org Server Extension : 9.0
[  2103.169] (II) xfree86: Adding drm device (/dev/dri/card1)
[  2103.169] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2103.171] (--) PCI:*(0:0:2:0) 8086:0046:1025:0488 rev 2, Mem @ 0xd1400000/4194304, 0xc0000000/268435456, I/O @ 0x00004050/8
[  2103.171] (--) PCI: (0:1:0:0) 10de:0df4:1025:0488 rev 161, Mem @ 0xd0000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[  2103.171] (WW) "nouveau" will not be loaded unless you've specified it to be loaded elsewhere.
[  2103.171] (II) "glx" will be loaded by default.
[  2103.171] (II) LoadModule: "glx"
[  2103.171] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[  2103.175] (II) Module glx: vendor="NVIDIA Corporation"
[  2103.175]    compiled for 4.0.2, module version = 1.0.0
[  2103.175]    Module class: X.Org Server Extension
[  2103.175] (II) NVIDIA GLX Module  361.28  Wed Feb  3 15:10:57 PST 2016
[  2103.175] (II) Applying OutputClass "nvidia" to /dev/dri/card1
[  2103.175]    loading driver: nvidia
[  2103.175] (==) Matched intel as autoconfigured driver 0
[  2103.175] (==) Matched nvidia as autoconfigured driver 1
[  2103.175] (==) Matched nouveau as autoconfigured driver 2
[  2103.175] (==) Matched nv as autoconfigured driver 3
[  2103.175] (==) Matched intel as autoconfigured driver 4
[  2103.175] (==) Matched modesetting as autoconfigured driver 5
[  2103.175] (==) Matched fbdev as autoconfigured driver 6
[  2103.175] (==) Matched vesa as autoconfigured driver 7
[  2103.176] (==) Assigned the driver to the xf86ConfigLayout
[  2103.176] (II) LoadModule: "intel"
[  2103.176] (WW) Warning, couldn't open module intel
[  2103.176] (II) UnloadModule: "intel"
[  2103.176] (II) Unloading intel
[  2103.176] (EE) Failed to load module "intel" (module does not exist, 0)
[  2103.176] (II) LoadModule: "nvidia"
[  2103.176] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  2103.176] (II) Module nvidia: vendor="NVIDIA Corporation"
[  2103.176]    compiled for 4.0.2, module version = 1.0.0
[  2103.176]    Module class: X.Org Video Driver
[  2103.176] (II) LoadModule: "nouveau"
[  2103.176] (WW) Warning, couldn't open module nouveau
[  2103.176] (II) UnloadModule: "nouveau"
[  2103.176] (II) Unloading nouveau
[  2103.176] (EE) Failed to load module "nouveau" (module does not exist, 0)
[  2103.176] (II) LoadModule: "nv"
[  2103.177] (WW) Warning, couldn't open module nv
[  2103.177] (II) UnloadModule: "nv"
[  2103.177] (II) Unloading nv
[  2103.177] (EE) Failed to load module "nv" (module does not exist, 0)
[  2103.177] (II) LoadModule: "modesetting"
[  2103.177] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[  2103.177] (II) Module modesetting: vendor="X.Org Foundation"
[  2103.177]    compiled for 1.18.4, module version = 1.18.4
[  2103.177]    Module class: X.Org Video Driver
[  2103.177]    ABI class: X.Org Video Driver, version 20.0
[  2103.177] (II) LoadModule: "fbdev"
[  2103.177] (WW) Warning, couldn't open module fbdev
[  2103.177] (II) UnloadModule: "fbdev"
[  2103.177] (II) Unloading fbdev
[  2103.177] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2103.177] (II) LoadModule: "vesa"
[  2103.177] (WW) Warning, couldn't open module vesa
[  2103.177] (II) UnloadModule: "vesa"
[  2103.177] (II) Unloading vesa
[  2103.177] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2103.177] (II) NVIDIA dlloader X Driver  361.28  Wed Feb  3 14:48:10 PST 2016
[  2103.177] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  2103.177] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2103.177] (--) using VT number 7

[  2103.180] (II) modeset(0): using drv /dev/dri/card0
[  2103.180] (II) modeset(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[  2103.180] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[  2103.180] (==) modeset(0): RGB weight 888
[  2103.180] (==) modeset(0): Default visual is TrueColor
[  2103.180] (II) Loading sub module "glamoregl"
[  2103.180] (II) LoadModule: "glamoregl"
[  2103.180] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[  2103.184] (II) Module glamoregl: vendor="X.Org Foundation"
[  2103.184]    compiled for 1.18.4, module version = 1.0.0
[  2103.184]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2103.184] (II) glamor: OpenGL accelerated X.org driver based.
[  2103.224] (EE) modeset(0): eglInitialize() failed
[  2103.224] (EE) modeset(0): glamor initialization failed
[  2103.224] (II) modeset(0): ShadowFB: preferred YES, enabled YES
[  2103.224] (II) modeset(0): Output LVDS-1 has no monitor section
[  2103.225] (II) modeset(0): Output VGA-1 has no monitor section
[  2103.313] (II) modeset(0): Output HDMI-1 has no monitor section
[  2103.313] (II) modeset(0): Output DP-1 has no monitor section
[  2103.313] (II) modeset(0): EDID for output LVDS-1
[  2103.313] (II) modeset(0): Manufacturer: AUO  Model: 26ec  Serial#: 0
[  2103.313] (II) modeset(0): Year: 2009  Week: 1
[  2103.313] (II) modeset(0): EDID Version: 1.3
[  2103.313] (II) modeset(0): Digital Display Input
[  2103.313] (II) modeset(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[  2103.313] (II) modeset(0): Gamma: 2.20
[  2103.313] (II) modeset(0): No DPMS capabilities specified
[  2103.313] (II) modeset(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[  2103.313] (II) modeset(0): First detailed timing is preferred mode
[  2103.313] (II) modeset(0): redX: 0.577 redY: 0.333   greenX: 0.333 greenY: 0.554
[  2103.313] (II) modeset(0): blueX: 0.161 blueY: 0.144   whiteX: 0.313 whiteY: 0.329
[  2103.313] (II) modeset(0): Manufacturer's mask: 0
[  2103.313] (II) modeset(0): Supported detailed timing:
[  2103.313] (II) modeset(0): clock: 71.8 MHz   Image Size:  344 x 193 mm
[  2103.313] (II) modeset(0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1526 h_border: 0
[  2103.313] (II) modeset(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 784 v_border: 0
[  2103.313] (II) modeset(0): Unknown vendor-specific block f
[  2103.313] (II) modeset(0):  AUO
[  2103.313] (II) modeset(0):  B156XW02 V6
[  2103.313] (II) modeset(0): EDID (in hex):
[  2103.313] (II) modeset(0):    00ffffffffffff0006afec2600000000
[  2103.313] (II) modeset(0):    01130103802213780ad7759355558d29
[  2103.313] (II) modeset(0):    24505400000001010101010101010101
[  2103.313] (II) modeset(0):    0101010101010c1c56a0500010303020
[  2103.313] (II) modeset(0):    360058c1100000180000000f00000000
[  2103.313] (II) modeset(0):    00000000000000000020000000fe0041
[  2103.313] (II) modeset(0):    554f0a202020202020202020000000fe
[  2103.313] (II) modeset(0):    004231353658573032205636200a0065
[  2103.314] (II) modeset(0): Printing probed modes for output LVDS-1
[  2103.314] (II) modeset(0): Modeline "1366x768"x60.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz eP)
[  2103.314] (II) modeset(0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[  2103.314] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  2103.314] (II) modeset(0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[  2103.314] (II) modeset(0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[  2103.314] (II) modeset(0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[  2103.314] (II) modeset(0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[  2103.314] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  2103.314] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[  2103.314] (II) modeset(0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[  2103.314] (II) modeset(0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[  2103.314] (II) modeset(0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[  2103.314] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[  2103.314] (II) modeset(0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[  2103.314] (II) modeset(0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[  2103.314] (II) modeset(0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[  2103.314] (II) modeset(0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[  2103.315] (II) modeset(0): EDID for output VGA-1
[  2103.403] (II) modeset(0): EDID for output HDMI-1
[  2103.403] (II) modeset(0): EDID for output DP-1
[  2103.403] (II) modeset(0): Output LVDS-1 connected
[  2103.403] (II) modeset(0): Output VGA-1 disconnected
[  2103.403] (II) modeset(0): Output HDMI-1 disconnected
[  2103.403] (II) modeset(0): Output DP-1 disconnected
[  2103.403] (II) modeset(0): Using exact sizes for initial modes
[  2103.403] (II) modeset(0): Output LVDS-1 using initial mode 1366x768 +0+0
[  2103.403] (II) modeset(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  2103.403] (==) modeset(0): DPI set to (96, 96)
[  2103.403] (II) Loading sub module "fb"
[  2103.403] (II) LoadModule: "fb"
[  2103.403] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  2103.404] (II) Module fb: vendor="X.Org Foundation"
[  2103.404]    compiled for 1.18.4, module version = 1.0.0
[  2103.404]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2103.404] (II) Loading sub module "shadow"
[  2103.404] (II) LoadModule: "shadow"
[  2103.404] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[  2103.404] (II) Module shadow: vendor="X.Org Foundation"
[  2103.404]    compiled for 1.18.4, module version = 1.1.0
[  2103.404]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2103.404] (II) UnloadModule: "nvidia"
[  2103.404] (II) Unloading nvidia
[  2103.404] (==) Depth 24 pixmap format is 32 bpp
[  2103.405] (==) modeset(0): Backing store enabled
[  2103.405] (==) modeset(0): Silken mouse enabled
[  2103.405] (II) modeset(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  2103.405] (==) modeset(0): DPMS enabled
[  2103.405] (WW) modeset(0): Option "Monitor-DVI-0" is not used
[  2103.427] (--) RandR disabled
[  2103.427] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[  2103.427] (II) modeset(0): Damage tracking initialized
[  2103.427] (II) modeset(0): Setting screen physical size to 361 x 203
[  2103.462] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[  2103.462] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2103.462] (II) LoadModule: "evdev"
[  2103.462] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  2103.463] (II) Module evdev: vendor="X.Org Foundation"
[  2103.463]    compiled for 1.18.4, module version = 2.10.3
[  2103.463]    Module class: X.Org XInput Driver
[  2103.463]    ABI class: X.Org XInput driver, version 22.1
[  2103.463] (II) Using input driver 'evdev' for 'Power Button'
[  2103.463] (**) Power Button: always reports core events
[  2103.463] (**) evdev: Power Button: Device: "/dev/input/event3"
[  2103.463] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2103.463] (--) evdev: Power Button: Found keys
[  2103.463] (II) evdev: Power Button: Configuring as keyboard
[  2103.463] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[  2103.463] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  2103.463] (**) Option "xkb_rules" "evdev"
[  2103.464] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[  2103.464] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  2103.464] (II) Using input driver 'evdev' for 'Video Bus'
[  2103.464] (**) Video Bus: always reports core events
[  2103.464] (**) evdev: Video Bus: Device: "/dev/input/event4"
[  2103.464] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  2103.464] (--) evdev: Video Bus: Found keys
[  2103.464] (II) evdev: Video Bus: Configuring as keyboard
[  2103.464] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4/event4"
[  2103.464] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  2103.464] (**) Option "xkb_rules" "evdev"
[  2103.465] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[  2103.465] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  2103.465] (II) Using input driver 'evdev' for 'Video Bus'
[  2103.465] (**) Video Bus: always reports core events
[  2103.465] (**) evdev: Video Bus: Device: "/dev/input/event5"
[  2103.465] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  2103.465] (--) evdev: Video Bus: Found keys
[  2103.465] (II) evdev: Video Bus: Configuring as keyboard
[  2103.465] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:09/LNXVIDEO:01/input/input5/event5"
[  2103.465] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[  2103.465] (**) Option "xkb_rules" "evdev"
[  2103.466] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  2103.466] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2103.466] (II) Using input driver 'evdev' for 'Power Button'
[  2103.466] (**) Power Button: always reports core events
[  2103.466] (**) evdev: Power Button: Device: "/dev/input/event0"
[  2103.466] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2103.466] (--) evdev: Power Button: Found keys
[  2103.466] (II) evdev: Power Button: Configuring as keyboard
[  2103.466] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:10/PNP0C0C:00/input/input0/event0"
[  2103.466] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 9)
[  2103.466] (**) Option "xkb_rules" "evdev"
[  2103.467] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[  2103.467] (II) No input driver specified, ignoring this device.
[  2103.467] (II) This device may have been added with another device file.
[  2103.467] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[  2103.467] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  2103.467] (II) Using input driver 'evdev' for 'Sleep Button'
[  2103.467] (**) Sleep Button: always reports core events
[  2103.467] (**) evdev: Sleep Button: Device: "/dev/input/event2"
[  2103.468] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  2103.468] (--) evdev: Sleep Button: Found keys
[  2103.468] (II) evdev: Sleep Button: Configuring as keyboard
[  2103.468] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:10/PNP0C0E:00/input/input2/event2"
[  2103.468] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 10)
[  2103.468] (**) Option "xkb_rules" "evdev"
[  2103.469] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event6)
[  2103.469] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  2103.469] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  2103.469] (**) AT Translated Set 2 keyboard: always reports core events
[  2103.469] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event6"
[  2103.469] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  2103.469] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  2103.469] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  2103.469] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input6/event6"
[  2103.469] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[  2103.469] (**) Option "xkb_rules" "evdev"
[  2103.470] (II) config/udev: Adding input device ImPS/2 Logitech Wheel Mouse (/dev/input/event7)
[  2103.470] (**) ImPS/2 Logitech Wheel Mouse: Applying InputClass "evdev pointer catchall"
[  2103.470] (II) Using input driver 'evdev' for 'ImPS/2 Logitech Wheel Mouse'
[  2103.470] (**) ImPS/2 Logitech Wheel Mouse: always reports core events
[  2103.470] (**) evdev: ImPS/2 Logitech Wheel Mouse: Device: "/dev/input/event7"
[  2103.470] (--) evdev: ImPS/2 Logitech Wheel Mouse: Vendor 0x2 Product 0x5
[  2103.470] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found 3 mouse buttons
[  2103.470] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found scroll wheel(s)
[  2103.470] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found relative axes
[  2103.470] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found x and y relative axes
[  2103.470] (II) evdev: ImPS/2 Logitech Wheel Mouse: Configuring as mouse
[  2103.470] (II) evdev: ImPS/2 Logitech Wheel Mouse: Adding scrollwheel support
[  2103.470] (**) evdev: ImPS/2 Logitech Wheel Mouse: YAxisMapping: buttons 4 and 5
[  2103.470] (**) evdev: ImPS/2 Logitech Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  2103.470] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input8/event7"
[  2103.470] (II) XINPUT: Adding extended input device "ImPS/2 Logitech Wheel Mouse" (type: MOUSE, id 12)
[  2103.470] (II) evdev: ImPS/2 Logitech Wheel Mouse: initialized for relative axes.
[  2103.470] (**) ImPS/2 Logitech Wheel Mouse: (accel) keeping acceleration scheme 1
[  2103.471] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration profile 0
[  2103.471] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration factor: 2.000
[  2103.471] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration threshold: 4
[  2103.471] (II) config/udev: Adding input device ImPS/2 Logitech Wheel Mouse (/dev/input/mouse0)
[  2103.471] (II) No input driver specified, ignoring this device.
[  2103.471] (II) This device may have been added with another device file.
[  2104.736] (II) evdev: ImPS/2 Logitech Wheel Mouse: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: AT Translated Set 2 keyboard: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: Sleep Button: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: Power Button: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: Video Bus: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: Video Bus: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2104.736] (II) evdev: Power Button: Close
[  2104.736] (II) UnloadModule: "evdev"
[  2105.496] (II) Server terminated successfully (0). Closing log file.


Last edited by xombael on Wed Oct 19, 2016 5:32 pm; edited 2 times in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Oct 19, 2016 5:09 pm    Post subject: Reply with quote

Is this muxless Optimus?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Oct 19, 2016 5:14 pm    Post subject: Reply with quote

why do you load nouveau, fbdev, vesa and all the other unneeded stuff?

Please fix your video settings in make.conf

afaik usually you only need the gpu settings for intel and one of the two nvidia implementations.

--

Maybe not related.

Why are you using such old kernel?

Do you want to use open source or binary nvidia driver?

it seems it is a laptop. Is this a dual gpu box, hybrid graphics ? YES => if so, follow the gentoo wiki regarding hybrid laptop graphics.

It is obvious the config files are not set up or not correctly set up.

---

Most of the time, personal opinion, the newest stable kernel org. release kernel + latest nvidia homepage binary driver + latest X xorg server should work together. When you want to use stable branch you need to use a stable set of packages, which existed at the point of the age of the software.

--

Whats up with those modeprobe lines? did you configure those mode settings for your display or are those auto created?

are the config files regarding X and x-components (includes make.conf regarding X) empty or did you create those with scripts / yourself?
Back to top
View user's profile Send private message
xombael
n00b
n00b


Joined: 07 Oct 2016
Posts: 6
Location: Germany

PostPosted: Wed Oct 19, 2016 5:43 pm    Post subject: Reply with quote

i never changed any xserver related config, just inserted disablenouveau.conf & nvidia.conf.
also only adjusted /etc/portage/make.conf.

nvidia driver 361.28 was listed stable, others not.
kernel & xorg was emerged only a few days ago.
nvidia today after disabling nouveau manually in kernel (at first used nouveau but it has bad powermanagement).

everything listed in the xorg.log is auto created.
adjusted information at the top of the page
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Oct 19, 2016 5:53 pm    Post subject: Reply with quote

Please share

disablenouveau.conf & nvidia.conf.

The binary driver needs other kernel settings as the open source one afaik.

What did you set for VIDEO_CARDS="" in your make.conf?

So is this a hybrid graphics box?
Back to top
View user's profile Send private message
xombael
n00b
n00b


Joined: 07 Oct 2016
Posts: 6
Location: Germany

PostPosted: Wed Oct 19, 2016 6:02 pm    Post subject: Reply with quote

Code:

nvidia.conf
Section "Device"
 Identifier "NVIDIA Corporation GF108M [GeForce GT 540M]"
 Driver "nvidia"
 VendorName "NVIDIA Corporation"
 BusID "PCI:1:0:0"
EndSection


Code:

disablenouveau.conf
Section "Module"
 Disable "nouveau"
EndSection


Code:

/etc/portage/make.conf
VIDEO_CARDS="nvidia"


no, its not muxless.
yes, its hybrid.
yes, did exactly this: https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
nouveau is not loaded anymore, recompiled after it + put in server x nvidia.conf
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Wed Oct 19, 2016 6:24 pm    Post subject: Reply with quote

You need to follow this guide instead: https://wiki.gentoo.org/wiki/NVIDIA/Optimus
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Oct 19, 2016 6:30 pm    Post subject: Reply with quote

Ant P. wrote:
You need to follow this guide instead: https://wiki.gentoo.org/wiki/NVIDIA/Optimus


xombael mentioned this is not muxless setup.
Back to top
View user's profile Send private message
xombael
n00b
n00b


Joined: 07 Oct 2016
Posts: 6
Location: Germany

PostPosted: Wed Oct 19, 2016 6:31 pm    Post subject: Reply with quote

thanks, currently on it :roll:
edit: sry it is muxless - http://www.nvidia.de/object/product-geforce-gt-540m-de.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum