Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rxvt-unicode urxvt not displaying all characters correctly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SeaHag
n00b
n00b


Joined: 10 Jul 2009
Posts: 32

PostPosted: Thu Jul 23, 2009 2:01 am    Post subject: rxvt-unicode urxvt not displaying all characters correctly Reply with quote

I just emerged rxvt-unicode, when I run it in my terminal some characters appear correctly and some look like rectangles. Anyone know why or how to fix it? My prompt also is displayed as rectangles.
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 720

PostPosted: Thu Jul 23, 2009 2:11 am    Post subject: Reply with quote

Could be the font you're using doesn't support those characters. media-fonts/terminus-font is a really good unicode console font.
Back to top
View user's profile Send private message
SeaHag
n00b
n00b


Joined: 10 Jul 2009
Posts: 32

PostPosted: Thu Jul 23, 2009 2:33 am    Post subject: Reply with quote

This is a fresh Gentoo install. Everything should be default. It seems that the things that aren't displaying correctly are bold in the default xterm. What does bold mean for files and directories?
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Thu Jul 23, 2009 3:20 am    Post subject: Reply with quote

Bold doesn't really mean anything in xterm. It's just AFAIK an arbitrary color scheme for different types of file/directories and other things, like in manpages ...

You can always modify/change them if you want in your $HOME/.Xdefaults file.

If you read
Code:
man urxvt
you'll find plenty of examples for changing fonts and colors. :wink:
Back to top
View user's profile Send private message
SeaHag
n00b
n00b


Joined: 10 Jul 2009
Posts: 32

PostPosted: Thu Jul 23, 2009 3:33 am    Post subject: Reply with quote

How come in my xterm some hidden files are blue and bold and some are not. Also, some non hidden files are green and some are bold green. What does all that mean? Why are they displayed differently? It looks like all directories are blue. In urxvt the blue directories and green bold files display as rectangles. BTW I don't have .Xdefaults.
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 720

PostPosted: Thu Jul 23, 2009 3:43 am    Post subject: Reply with quote

See /etc/DIR_COLORS.
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Thu Jul 23, 2009 3:48 am    Post subject: Reply with quote

You need a unicode fontset like media-fonts/terminus-font as Nerevar suggests, and media-fonts/dejavu is also quite nice.

If you google Xdefaults you'll find plenty of examples you can use to make your own $HOME/.Xdefaults file. 8)
Back to top
View user's profile Send private message
SeaHag
n00b
n00b


Joined: 10 Jul 2009
Posts: 32

PostPosted: Thu Jul 23, 2009 4:54 am    Post subject: Reply with quote

I emerged media-fonts/terminus-font but still not working. Any other ideas? How come xterm displays correctly?
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Fri Apr 13, 2012 5:09 pm    Post subject: Reply with quote

Any solution to this?
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Fri Apr 13, 2012 5:39 pm    Post subject: Reply with quote

3 years old NECROBUMP!

But, if we are already here - solution to what exactly?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Fri Apr 13, 2012 5:57 pm    Post subject: Reply with quote

I just emerged rxvt-unicode, when I run it in my terminal some characters appear correctly and some look like rectangles. Anyone know why or how to fix it? My prompt also is displayed as rectangles.

All boldface characters seem to be replaced by rectangles.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Fri Apr 13, 2012 6:04 pm    Post subject: Reply with quote

As it has been said above - you need to emerge font that supports your charset, and then use .Xdefaults or - more preferably - .Xresources to configure urxvt to use that font.

For a popular Terminus font it may look like:
Code:

URxvt.font:             xft:Terminus:pixelsize=14:antialias=false
URxvt.boldFont:         xft:Terminus:bold:pixelsize=14:antialias=false

_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Fri Apr 13, 2012 6:17 pm    Post subject: Reply with quote

I've read the thread and tried everything in it without any result, that's why I asked for any (other) solution.

When I try to run rxvt-unicode I get the following error:

Code:
$ urxvt
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.


Do I need to mkfontdir or something?
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Fri Apr 13, 2012 6:43 pm    Post subject: Reply with quote

How have you specified the font?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Fri Apr 13, 2012 7:04 pm    Post subject: Reply with quote

In ~/.Xdefaults? Yes.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Fri Apr 13, 2012 7:13 pm    Post subject: Reply with quote

But how? The way I posted above?

Also do you have media-fonts/terminus-font installed, and is rxvt-unicode compiled with USE=xft?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Fri Apr 13, 2012 7:41 pm    Post subject: Reply with quote

Solved! It was as easy as a missing USE flag, I probably should have taken a look at it first. :)

Thanks for your help!
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 638
Location: San Diego, CA

PostPosted: Sun Oct 13, 2013 2:43 am    Post subject: Reply with quote

hrnick wrote:
Solved! It was as easy as a missing USE flag, I probably should have taken a look at it first. :)

Which USE flag were you missing? I'm having the exactly same problem (i.e. characters are showing as rectangles). Looks like only the bold characters are rectangles.

urxvt in Gentoo
http://postimg.org/image/l2vn7ydcx/


Interestingly, if I ssh to my Gentoo from Ubuntu and run urxvt via X-Forwarding, all characters show up correctly.

urxvt in Ubuntu via X
http://postimg.org/image/fc4ovmsmd/
__
sol
Back to top
View user's profile Send private message
188562
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 186

PostPosted: Sun Oct 13, 2013 10:59 am    Post subject: Reply with quote

solamour wrote:
hrnick wrote:
Solved! It was as easy as a missing USE flag, I probably should have taken a look at it first. :)

Which USE flag were you missing? I'm having the exactly same problem (i.e. characters are showing as rectangles). Looks like only the bold characters are rectangles.

urxvt in Gentoo
http://postimg.org/image/l2vn7ydcx/


Interestingly, if I ssh to my Gentoo from Ubuntu and run urxvt via X-Forwarding, all characters show up correctly.

urxvt in Ubuntu via X
http://postimg.org/image/fc4ovmsmd/
__
sol


With:

Code:
URxvt.font: xft:Monaco:size=11:antialias=true:hinting=true,\
      xft:WenQuanYi Micro Hei Mono:size=11:antialias=true:hinting=true
URxvt.boldfont: xft:Monaco:size=11:antialias=true:hinting=true:bold,\
      xft:WenQuanYi Micro Hei Mono:bold:size=11:antialias=true:hinting=true


for my all fine

http://s7.postimg.org/ep6fbtt6z/image.png
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 334

PostPosted: Mon Oct 14, 2013 3:02 pm    Post subject: Reply with quote

This happened a long time ago so I don't remember exactly what USE flag it was. I don't have the problem now and here are the USE flags I'm using:
Code:
[ebuild   R    ] x11-terms/rxvt-unicode-9.18  USE="focused-urgency font-styles mousewheel perl vanilla xft -256-color -alt-font-width -blink -buffer-on-clear -fading-colors -iso14755 -pixbuf -secondary-wheel -startup-notification -unicode3 -wcwidth" 0 kB

Sorry I can't be of more help...
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Tue Nov 01, 2016 3:24 pm    Post subject: Reply with quote

I know this is very old, but I found the solution of a closely related problem I had, and I would like to put it on record.

Problem: mrxvt responds to font changes but characters such as apostrophe are not returned correctly (if you type ' it is displayed correctly but if you run "rm asdfdfsgsdf" funny characters are returned instead of apostrophes).

The solution was in locale: "eselect locale list" showed "en_US" and "en_US.utf8" among other items, and the selection was on "en_US.utf8". I changed it to "en_US" (eselect locale set #), and the issue disappeared (not sure why).

Note on ".mrxvtrc": if you want to use "mrxvt*font:-*-terminus-medium-*-*-*-16-*-*-*-*-*-iso8859-1" you need to comment out "Mrxvt.xft...." entries
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1545
Location: KUUSANKOSKI, Finland

PostPosted: Tue Nov 01, 2016 11:26 pm    Post subject: Reply with quote

I actually remembered that I used Terminus, but for some reason I've changed it... It may be because of some symbols not appearing correctly...
shellcmd: grep "^\s*URxvt\." ~/.Xresources:
      URxvt.background:       #0E0E0E
      URxvt.foreground:       gray90
      URxvt.cursorColor:      #00CC00
      URxvt.throughColor:     #500000
      URxvt.highlightColor:   #3000A0
      URxvt.font:      9x15bold
      URxvt.inheritPixmap:    true
      URxvt.scrollBar:   off
      URxvt.scrollBar_right:  false
      URxvt.scrollBar_left:   false
        URxvt.colorUL: #00FFAA
      URxvt.termName:      rxvt
... that's what I have and I don't remember comming across "boxex" for a long time.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum