Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx work, but not with lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Lhymna
n00b
n00b


Joined: 24 Oct 2016
Posts: 12

PostPosted: Thu Nov 03, 2016 9:21 am    Post subject: startx work, but not with lightdm Reply with quote

Hi everyone,
I have installed MATE. and it's working with startx but not when i try to log on lightdm.
My user is in the group "video"
any help pls ?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Thu Nov 03, 2016 9:38 am    Post subject: Reply with quote

I don't understand, but does Lightdm's screen appears?
And makes it login you, but after it don't enter in MATE?
or don't you even see lightdm screen?
Back to top
View user's profile Send private message
Lhymna
n00b
n00b


Joined: 24 Oct 2016
Posts: 12

PostPosted: Thu Nov 03, 2016 9:43 am    Post subject: Reply with quote

Sorry for my poor english and thanks for the reply!
When I start my system, Lightdm start and i can try to log with my user. But when I try to log, lightdm doesn't work, he stay on the Lightdm's screen without any error messages.
But when I use the command startx, i boot on MATE.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Thu Nov 03, 2016 9:54 am    Post subject: Reply with quote

Once you emerge lightdm, the steps to follow are these:

- configure file "/etc/conf.d/xdm" (DISPLAYMANAGER="lightdm")

and then (if you use OpenRC):

Code:
- # /etc/init.d/dbus start
- # /etc/init.d/xdm start


For add dbus and xdm to boot:
Code:

- # rc-update add dbus default
- # rc-update add xdm default


Moreover, ther is a conf file: /etc/lightdm/lightdm.conf
See wiki https://wiki.gentoo.org/wiki/LightDM

Do you follow every steps?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Thu Nov 03, 2016 10:03 am    Post subject: Reply with quote

In lightdm.conf file, in line "greeter-session" you have to put the name of your greeter.
That greeter's name you can find it in /usr/share/xgreeters and sound like this:

lightdm-kde-greeter

In your case it isn't kde
Back to top
View user's profile Send private message
Lhymna
n00b
n00b


Joined: 24 Oct 2016
Posts: 12

PostPosted: Thu Nov 03, 2016 10:08 am    Post subject: Reply with quote

Thanks for the reply,
My bad, I just recreate an other group and an other user with the correct groups like this :

addgroup
useradd -m -g mygroup -G users,audio,cdrom,portage,video,wheel

I think my old user was by default in his own group and maybe it create conflits, i don't know if it could be possible?

I'm sorry and thanks a lot for the fast reply ! :)
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1479
Location: KUUSANKOSKI, Finland

PostPosted: Thu Nov 03, 2016 10:41 am    Post subject: Reply with quote

It seems that X starts ok, so it's something else that's wrong. I'd guess permission issue.
Can you post contents of /var/log/lightdm/lightdm.conf?
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum