Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HVR-1800 cx23885 firmware error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 4502
Location: Illinois, USA

PostPosted: Wed Oct 21, 2020 7:06 pm    Post subject: HVR-1800 cx23885 firmware error Reply with quote

Code:
[    7.718269] cx23885: cx23885 driver version 0.0.4 loaded
[    7.718298] cx23885 0000:1d:00.0: enabling device (0000 -> 0002)
[    7.718372] cx23885: CORE cx23885[0]: subsystem: 0070:7801, board: Hauppauge WinTV-HVR1800 [card=2,autodetected]
[    8.219050] cx23885: cx23885[0]: hauppauge eeprom: model=78521
[    8.220791] cx25840 10-0044: cx23887 A/V decoder found @ 0x88 (cx23885[0])
[    8.878382] cx25840 10-0044: loaded v4l-cx23885-avcore-01.fw firmware (16382 bytes)
[   12.122855] cx23885: cx23885[0]: registered device video0 [v4l2]
[   12.122881] cx23885: cx23885[0]: registered device vbi0
[   12.122993] cx23885: cx23885[0]: alsa: registered ALSA audio device
[   12.123047] cx23885: cx23885[0]: registered device video1 [mpeg]
[   12.123066] cx23885: Firmware and/or mailbox pointer not initialized or corrupted, signature = 0x4000, cmd = PING_FW

Googling about this seems to be about the analog input that was never fully implemented in the kernel. This stuff is like ten years ago on kernel 2.6

I don't want to use the analog input anyway. I just don't want boot hanging trying to get it working then failing.
About ten years ago the forum advice was to load linuxtv-dvb-firmware, but that package doesn't exist anymore.
Code:
~ $ ls -l `locate cx23885|grep firmware`
-rw-r--r-- 1 root root   16382 Oct 21 13:38 /lib64/firmware/v4l-cx23885-avcore-01.fw
-rw-r--r-- 1 root root   16382 Feb 16  2015 /lib64/firmware/v4l-cx23885-enc-broken.fw
-r--r--r-- 1 tony wheel 376836 Mar 17  2006 /lib64/firmware/v4l-cx23885-enc.fw
-rw-r--r-- 1 root root     481 Oct 11 18:18 /usr/src/linux-5.4.66-gentoo/drivers/base/firmware_loader/builtin/v4l-cx23885-enc.fw.gen.S

I'm actually running
Code:
~ $ uname -a
Linux MSI 5.4.72-gentoo #1 SMP Tue Oct 20 21:59:57 CDT 2020 x86_64 AMD Ryzen 7 2700X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum