Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errors starting x
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sat Oct 08, 2016 5:30 pm    Post subject: Errors starting x Reply with quote

So I've installed gentoo in these days, and now I've installed X, but by starting it I got some errors. I tried to configure X with X -configure.
Here's the Xorg log and the Xorg.conf
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sat Oct 08, 2016 6:58 pm    Post subject: Reply with quote

iData,

That's a GeForce GTX 670MX. It should work with no /etc/X11/xorg.conf file at all.
That's your first test.

Pastebin the Xorg.0.log fram that test please.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sun Oct 09, 2016 8:07 am    Post subject: Reply with quote

NeddySeagoon wrote:
iData,

That's a GeForce GTX 670MX. It should work with no /etc/X11/xorg.conf file at all.
That's your first test.

Pastebin the Xorg.0.log fram that test please.

Hi, thank you for your answer, as always.
I forgot to mention the fact that without xorg.conf it failed to load some modules.
the log without xorg.conf
Back to top
View user's profile Send private message
fturco
Guru
Guru


Joined: 08 Dec 2010
Posts: 574
Location: Italy

PostPosted: Sun Oct 09, 2016 8:44 am    Post subject: Reply with quote

Some questions:
  • Did you add your user to the video group?
  • Which kernel options did you enable for your video card?
  • Did you define the VIDEO_CARDS variable?
Back to top
View user's profile Send private message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sun Oct 09, 2016 10:10 am    Post subject: Reply with quote

fturco wrote:
Some questions:
  • Did you add your user to the video group?
  • Which kernel options did you enable for your video card?
  • Did you define the VIDEO_CARDS variable?

Hi, thank you for your answer.
Anyway yes I've added my user to the video group
For the kernel I've enabled nouveau
And in the make.conf I added nouveau in the VIDEO_CARDS variable
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Oct 09, 2016 10:12 am    Post subject: Reply with quote

Code:
[    58.498] (EE) open /dev/dri/card0: No such file or directory


Back to kernel configuration, nouveau DRM is not enabled.
Back to top
View user's profile Send private message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sun Oct 09, 2016 11:18 am    Post subject: Reply with quote

Buffoon wrote:
Code:
[    58.498] (EE) open /dev/dri/card0: No such file or directory


Back to kernel configuration, nouveau DRM is not enabled.

Hi thank you for you answer.
In the kernel I have DRM, fbdev and nouveau enabled.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Oct 09, 2016 11:24 am    Post subject: Reply with quote

Good, then install this kernel and run it. Your running kernel has no DRM enabled.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sun Oct 09, 2016 11:43 am    Post subject: Reply with quote

iData,

To expand on Buffoons answer a little, its very easy to not be running the kernel you think you are.

Code:
$ uname -v
#1 SMP PREEMPT Thu May 26 20:34:43 BST 2016
tells the build date/time of the running kernel.
Hmm, I've got a newer one that that and I usually check that every kernel update. :(

If you have a newer kernel than that shown in your
Code:
uname -v
, you may well have fixed your problem, you just don't know it yet.
There is no need to repeat the kernel build. Just mound /boot and repeat the kernel install steps.
If its a new kernel version, tell grub about it too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sun Oct 09, 2016 12:02 pm    Post subject: Reply with quote

Buffoon wrote:
Good, then install this kernel and run it. Your running kernel has no DRM enabled.


Thank you again for your answer, anyway I installed the kernel 2 times, and still, it gives me the same errors
Back to top
View user's profile Send private message
iData
n00b
n00b


Joined: 06 Oct 2016
Posts: 9

PostPosted: Sun Oct 09, 2016 12:18 pm    Post subject: Reply with quote

NeddySeagoon wrote:
iData,

To expand on Buffoons answer a little, its very easy to not be running the kernel you think you are.

Code:
$ uname -v
#1 SMP PREEMPT Thu May 26 20:34:43 BST 2016
tells the build date/time of the running kernel.
Hmm, I've got a newer one that that and I usually check that every kernel update. :(

If you have a newer kernel than that shown in your
Code:
uname -v
, you may well have fixed your problem, you just don't know it yet.
There is no need to repeat the kernel build. Just mound /boot and repeat the kernel install steps.
If its a new kernel version, tell grub about it too.

Hi thank you for your answer, as you said, I'm actually running an old kernel built 3 days ago.
Now I'll try to fix that. Thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum