Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.20: Cannot switch UI language from System Settings
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 224

PostPosted: Tue Oct 04, 2016 7:02 pm    Post subject: Gnome 3.20: Cannot switch UI language from System Settings Reply with quote

I usually work with all region/language related settings set to de_AT. Now I want to start using other languages the Gnome UI to improve my language skills. The most obvious way was to go to system settings in the Gnome UI and select the region/language dialogue. The languages I want to use are listed (since I created locales for them). When I change both region and language, the expected behaviour is that I log out, log in again and find the whole GUI in a new language.

The actual outcome first was nothing at all. Everything remained German.

I then did some research and found a bug in the DConf key "org.gnome.system.locale region" that prevented locale-related settings to take effect. The default value was an empty string. Changing it to "de_at.utf-8" made settings like date/time-format take effect upon the next login. Still, the language is German and I find no way to change it.

My make.conf includes the languages I want to use in both Linguas and I10N
LINGUAS="de en tr fr"
L10N="de en tr fr"

I have no idea what else to check. Maybe there's yet another key in DConf that needs to be edited manually? I also found that Gnome System Settings seem to invoke org.freedesktop.locale1 via dbus when I change something there, but there's no visible result.

Can any of the Gnom 3.20 users try changing the UI language and see if it works for them?
Or do you guys have any ideas?
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Sat Nov 05, 2016 5:09 pm    Post subject: Reply with quote

Could it be your kernel needs configured?

Once I configure my kernel for other languages I can use Russian and Japanese for example.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Sat Nov 05, 2016 11:29 pm    Post subject: Reply with quote

If you want the whole UI to change I think you need to change the system locale - and if that is correct the easiest way to reset it is via
Code:
eselect locale {list, set x}
you can check with (assuming systemd init on Gnome) ie.
Code:
localectl list-locales &&localectl | grep "System Locale"
Back to top
View user's profile Send private message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 224

PostPosted: Sun Nov 06, 2016 7:20 pm    Post subject: Reply with quote

ian.au wrote:
If you want the whole UI to change I think you need to change the system locale - and if that is correct the easiest way to reset it is via
Code:
eselect locale {list, set x}
you can check with (assuming systemd init on Gnome) ie.
Code:
localectl list-locales &&localectl | grep "System Locale"


Well I did chenge the system locale via localectl and it actually worked. But that's not the solution as I need to make this a per-user setting.

Also, Gnome does offer this choice in the system settings. It shouln't be necessary to work around it on the command line. It seems Gnome changes the settings, requires me to logout/login again ... and then changes the settings back to where it started from.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Mon Nov 07, 2016 3:31 am    Post subject: Reply with quote

benny1967 wrote:
ian.au wrote:
If you want the whole UI to change I think you need to change the system locale - and if that is correct the easiest way to reset it is via
Code:
eselect locale {list, set x}
you can check with (assuming systemd init on Gnome) ie.
Code:
localectl list-locales &&localectl | grep "System Locale"


Well I did chenge the system locale via localectl and it actually worked. But that's not the solution as I need to make this a per-user setting.

Also, Gnome does offer this choice in the system settings. It shouln't be necessary to work around it on the command line. It seems Gnome changes the settings, requires me to logout/login again ... and then changes the settings back to where it started from.

I tried to do exactly this for my wife on a shared machine - she's fluent in several European languages and wanted to work in the alternate UI to remain current (language skills deteriorate fast around here, where English is all you pretty much ever hear).

I'm not so sure that what you want to do is possible at the user level. Gnome3 by default at that time only took the entry for the system locale for the UI as far as I could tell.

From memory I played with the idea of custom sessions, and a couple of other tips from around the web which seemed to offer some hope, but I never got any to work. I think Gnome was at about 3.14 or 3.16 back when I was trying this, it's entirely possible there have been subsequent improvements. I built her a couple of VM's in different locales the end, it was less hassle.
Back to top
View user's profile Send private message
benny1967
Apprentice
Apprentice


Joined: 25 Apr 2004
Posts: 224

PostPosted: Thu Nov 10, 2016 6:10 pm    Post subject: Reply with quote

ian.au wrote:
I'm not so sure that what you want to do is possible at the user level. Gnome3 by default at that time only took the entry for the system locale for the UI as far as I could tell.


As I said, in Gnome system settings, there's a setting for language. The choices there are restricted to the locales available on the machine, but it's there. Why would there be a setting to change your UI language at all if Gnome wouldn't support it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum