Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Failed to open DRM device
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jommes
n00b
n00b


Joined: 19 Mar 2016
Posts: 35

PostPosted: Sat Oct 01, 2016 12:07 pm    Post subject: [SOLVED] Failed to open DRM device Reply with quote

Hello together,

after fresh hardware (GeForce GTX 1070) and fresh install of Gentoo, I'm struggling with getting X running.
I choosed nouveau as video driver (does it support the new Pascal architecture?).

Actually, I get the error message:
Code:
[  4195.688] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19


Full log can be seen here:
https://paste.pound-python.org/raw/0FcGK6C90Gar6yrmk4IP/

.config:
https://paste.pound-python.org/raw/MC57nCUbuemXFnM4L7jy/

'lspci -vk' output:
https://paste.pound-python.org/raw/gcSdhRu5HvP01frcqldu/

Additional information:
  • LiveCD used Intel Management Engine Interface, which I somehow refuse to use (after I read some bad things about it on the web)
  • I use EFI stub


Did I missed something in kernel configuration?

Many thanks in advance,
best jommes


Last edited by jommes on Sun Oct 02, 2016 6:36 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43754
Location: 56N 3W

PostPosted: Sat Oct 01, 2016 6:06 pm    Post subject: Reply with quote

jommes,

The nouveau git page says
Code:
2 days   Add Pascal Titan X
2 days   Fix the name of the Maxwell Titan X card
so the Xorg driver has only known about your card for 2 days.

Try the git driver. There doesn't appear to be a xf86-video-nouveau-9999 in the tree, which would let you do that with emerge.
However ...
The xf86-video-nouveau-1.0.12.ebuild contains
Code:
if [[ ${PV} == 9999* ]]; then
        EGIT_REPO_URI="git://anongit.freedesktop.org/git/nouveau/${PN}"
        SRC_URI=""
fi

Make a copy of xf86-video-nouveau-1.0.12.ebuild, called xf86-video-nouveau-9999.ebuild
Run
Code:
ebuild /path/to/xf86-video-nouveau-9999.ebuild digest


Code:
emerge xf86-video-nouveau
should now offer version 9999, which is from the live repository.
It may not work at all. Thats the beauty of the hemorrhaging edge. It may work now and not if you build it 30 min later, or vice versa because the repository has changed.
You may also need a kernel newer that 4.4.

You should really do this in your overlay, as emerge --sync, will remove xf86-video-nouveau-9999.ebuild from /usr/portage for you
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jommes
n00b
n00b


Joined: 19 Mar 2016
Posts: 35

PostPosted: Sun Oct 02, 2016 6:36 am    Post subject: Reply with quote

Thank you and have a nive day, NeddySeagoon :D
Best jommes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum