Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disable document history in KDE5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 873
Location: Vancouver, BC

PostPosted: Thu Sep 22, 2016 3:24 pm    Post subject: Disable document history in KDE5 Reply with quote

How do you disable document history in KDE5?

This "feature" has always driven me nuts, I hate it and turn it off on all DE's I've used, even on Windows.

I found some search settings in systemsettings, under "Search" and disabled everything and still no luck. It's such a waste of time having to remember to manually clear it.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Thu Sep 22, 2016 8:31 pm    Post subject: Reply with quote

From memory of Kde4, it's a feature of the K menu. Click right on the K menu icon on the task bar and choose whatever allow you the change the settings.
_________________
Paul
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 873
Location: Vancouver, BC

PostPosted: Thu Sep 22, 2016 9:33 pm    Post subject: Reply with quote

kde4 did not provide a way in the UI to disable this, you had to remove write privileges on a directory in your home directory.

This did not work for kde5. :cry:
Back to top
View user's profile Send private message
Frustration
n00b
n00b


Joined: 17 Sep 2016
Posts: 26

PostPosted: Fri Sep 23, 2016 12:55 pm    Post subject: Reply with quote

It's under System Settings - Workspace - Desktop Behavior - Activities - Privacy. Check "Do not remember".

Pretty hidden, yeah. I found it by accident, lol.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 873
Location: Vancouver, BC

PostPosted: Fri Sep 23, 2016 4:05 pm    Post subject: Reply with quote

Wow, thanks, that actually works. I tracked it down to kactivitymanager's database and was about to go "nuclear" on it by removing it and denying and access to that directory... but clicking a box is much easier. :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum