Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nuovo utente e problemi vari
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Mon Sep 19, 2016 12:12 pm    Post subject: Nuovo utente e problemi vari Reply with quote

Ciao ragazzi, so di fare una cosa che non posso, ma sono nuovo ed ho bisogno di capire, se potete aiutarmi.
In pratica, provo ad aggiornare e mi da questo
Code:
gentooBook martoo # emerge -DNu world
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                     
    (and 5 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, installed) pulled in by
    >=dev-qt/qtcore-5.6.1:5[icu] required by (kde-frameworks/kcoreaddons-5.23.0:5/5.23::gentoo, ebuild scheduled for merge)
                            ^^^                                                                                                                               

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "media-video/ffmpeg:0=" has unmet requirements.
- media-video/ffmpeg-2.8.6::gentoo USE="X aac alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc sdl static-libs threads truetype vorbis x264 xcb xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -ladspa -libass -libcaca (-libressl) -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -opus -oss -pic -pulseaudio -quvi -samba -schroedinger -snappy -speex -ssh -test -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zvbi" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="3dnow 3dnowext avx avx2 fma3 fma4 mmx mmxext sse sse2 sse3 sse4_2 ssse3 xop -sse4_1" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"

  The following REQUIRED_USE flag constraints are unsatisfied:
    cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 )

  The above constraints are a subset of the following complete expression:
    libv4l? ( v4l ) fftools_cws2fws? ( zlib ) test? ( encode ) postproc? ( gpl ) frei0r? ( gpl ) cdio? ( gpl ) samba? ( gpl ) zvbi? ( gpl ) encode? ( x264? ( gpl ) x265? ( gpl ) xvid? ( gpl ) X? ( !xcb? ( gpl ) ) ) cpu_flags_x86_avx2? ( cpu_flags_x86_avx ) cpu_flags_x86_fma4? ( cpu_flags_x86_avx ) cpu_flags_x86_fma3? ( cpu_flags_x86_avx ) cpu_flags_x86_xop? ( cpu_flags_x86_avx ) cpu_flags_x86_avx? ( cpu_flags_x86_sse4_2 ) cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 ) cpu_flags_x86_sse4_1? ( cpu_flags_x86_ssse3 ) cpu_flags_x86_ssse3? ( cpu_flags_x86_sse3 ) cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 ) cpu_flags_x86_sse2? ( cpu_flags_x86_sse ) cpu_flags_x86_sse? ( cpu_flags_x86_mmxext ) cpu_flags_x86_mmxext? ( cpu_flags_x86_mmx ) cpu_flags_x86_3dnowext? ( cpu_flags_x86_3dnow ) cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )

(dependency required by "media-video/vlc-2.2.4::gentoo[-libav,swscale]" [ebuild])
(dependency required by "media-libs/phonon-vlc-0.9.0::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.9.0::gentoo[vlc]" [ebuild])
(dependency required by "kde-frameworks/knotifications-5.23.0::gentoo" [ebuild])
(dependency required by "kde-frameworks/kwallet-5.23.0::gentoo" [ebuild])
(dependency required by "kde-frameworks/kio-5.23.0::gentoo[kwallet]" [ebuild])
(dependency required by "kde-plasma/kactivitymanagerd-5.6.5::gentoo" [ebuild])
(dependency required by "kde-base/kactivities-4.13.3-r2::gentoo" [ebuild])
(dependency required by "kde-apps/plasma-runtime-16.04.3::gentoo" [ebuild])
(dependency required by "x11-misc/lightdm-kde-0.3.2.1-r1::gentoo" [ebuild])
(dependency required by "x11-misc/lightdm-1.16.7::gentoo[kde]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
gentooBook martoo #

Cosa significa di preciso?
Scusate in futuro proverò a non far più questi post
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Mon Sep 19, 2016 2:08 pm    Post subject: Reply with quote

Allora hai diversi messaggi di conflitto/errore, quindi analizziamoli uno per volta.

  • Problema 1
    Code:
    !!! SYNC setting found in make.conf.

    Nel tuo make.conf hai ancora la variabile SYNC che e' deprecata in favore di /etc/portage/repos.conf/gentoo.conf (qui la guida per la configurazione)

  • Problema 2
    Code:
    dev-qt/qtcore:5

      (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (dev-qt/qtcore-5.6.1:5/5.6::gentoo, installed) pulled in by
        >=dev-qt/qtcore-5.6.1:5[icu] required by (kde-frameworks/kcoreaddons-5.23.0:5/5.23::gentoo, ebuild scheduled for merge)

    al pacchetto qtcore manca la use flag icu, per risolvere il problema:
    Code:
    # echo ">=dev-qt/qtcore-5.6.1 icu" >> /etc/portage/package.use


  • Problema 3
    Code:
    sys-libs/zlib:0

      (sys-libs/zlib-1.2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
        >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)

    come il secondo problema, al pacchetto zlib manca la use flag minizip, per risolvere il problema:
    Code:
    # echo ">=sys-libs/zlib-1.2.5.1-r2 minizip" >> /etc/portage/package.use


  • Problema 4
    Code:
      The following REQUIRED_USE flag constraints are unsatisfied:
        cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 )

    Qua dice che la cpu flag sse4_2 non puo' esistere senza sse4_1, quindi per risolvere edita il make.conf e alla variabile CPU_FLAGS_X86 aggiungi anche sse4_1

  • Problema 5
    Code:
    x11-libs/libxcb:0

      (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
        >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                               ^^^^^^^^^^                                                                                                                     
        (and 5 more with the same problem)

    Per questo prima dell'update prova a lanciare emerge -1av libxcb xcb-util-image ... dove i puntini significano tutti i 5 pacchetti che fanno conflitto, per vederli tutti devi lanciare emerge -DNu @world --verbose-conflicts

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Mon Sep 19, 2016 2:17 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Allora hai diversi messaggi di conflitto/errore, quindi analizziamoli uno per volta.

  • Problema 1
    Code:
    !!! SYNC setting found in make.conf.

    Nel tuo make.conf hai ancora la variabile SYNC che e' deprecata in favore di /etc/portage/repos.conf/gentoo.conf (qui la guida per la configurazione)

  • Problema 2
    Code:
    dev-qt/qtcore:5

      (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (dev-qt/qtcore-5.6.1:5/5.6::gentoo, installed) pulled in by
        >=dev-qt/qtcore-5.6.1:5[icu] required by (kde-frameworks/kcoreaddons-5.23.0:5/5.23::gentoo, ebuild scheduled for merge)

    al pacchetto qtcore manca la use flag icu, per risolvere il problema:
    Code:
    # echo ">=dev-qt/qtcore-5.6.1 icu" >> /etc/portage/package.use


  • Problema 3
    Code:
    sys-libs/zlib:0

      (sys-libs/zlib-1.2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
        >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)

    come il secondo problema, al pacchetto zlib manca la use flag minizip, per risolvere il problema:
    Code:
    # echo ">=sys-libs/zlib-1.2.5.1-r2 minizip" >> /etc/portage/package.use


  • Problema 4
    Code:
      The following REQUIRED_USE flag constraints are unsatisfied:
        cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 )

    Qua dice che la cpu flag sse4_2 non puo' esistere senza sse4_1, quindi per risolvere edita il make.conf e alla variabile CPU_FLAGS_X86 aggiungi anche sse4_1

  • Problema 5
    Code:
    x11-libs/libxcb:0

      (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
        >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                               ^^^^^^^^^^                                                                                                                     
        (and 5 more with the same problem)

    Per questo prima dell'update prova a lanciare emerge -1av libxcb xcb-util-image ... dove i puntini significano tutti i 5 pacchetti che fanno conflitto, per vederli tutti devi lanciare emerge -DNu @world --verbose-conflicts


Grazie mille, molto esaustivo, domattina provo e leggo bene il tutto, così da non aver più questi probli
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Sep 20, 2016 3:32 pm    Post subject: Reply with quote

Allora sono riuscito a risolvere i problemi dall'uno al quattro, ma non riesco a risolvere il 5, e per tutti i pacchetti in cui c'è scritto "dependency required" come faccio?

Un'altra curiosità, io ho in i3 2,3 Ghz con 8 gb di ram e 8 di swap, se aumentassi quest'ultima riuscirei a far velocizzare la compilazione o non cambierebbe niente? Potrei anche triplicarla volendo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Tue Sep 20, 2016 4:11 pm    Post subject: Reply with quote

zar Marco wrote:
Allora sono riuscito a risolvere i problemi dall'uno al quattro, ma non riesco a risolvere il 5, e per tutti i pacchetti in cui c'è scritto "dependency required" come faccio?

Cosa ti da il comando
Code:
# emerge -1av libxcb xcb-util-image ...

mettendo tutte le dipendenze al posto dei puntini?

zar Marco wrote:
Un'altra curiosità, io ho in i3 2,3 Ghz con 8 gb di ram e 8 di swap, se aumentassi quest'ultima riuscirei a far velocizzare la compilazione o non cambierebbe niente? Potrei anche triplicarla volendo

Non cambierebbe la velocita', fin che puo' usa la ram per compilare poi passa alla swap. Aumentare la swap al massimo serve per riuscire a compilare programmi grossi (es: libreoffice), se la compilazione va in crash con l'errore internal compiler error: Killed (program cc1plus) .
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Sep 20, 2016 5:12 pm    Post subject: Reply with quote

fedeliallalinea wrote:
zar Marco wrote:
Allora sono riuscito a risolvere i problemi dall'uno al quattro, ma non riesco a risolvere il 5, e per tutti i pacchetti in cui c'è scritto "dependency required" come faccio?

Cosa ti da il comando
Code:
# emerge -1av libxcb xcb-util-image ...

mettendo tutte le dipendenze al posto dei puntini?

zar Marco wrote:
Un'altra curiosità, io ho in i3 2,3 Ghz con 8 gb di ram e 8 di swap, se aumentassi quest'ultima riuscirei a far velocizzare la compilazione o non cambierebbe niente? Potrei anche triplicarla volendo

Non cambierebbe la velocita', fin che puo' usa la ram per compilare poi passa alla swap. Aumentare la swap al massimo serve per riuscire a compilare programmi grossi (es: libreoffice), se la compilazione va in crash con l'errore internal compiler error: Killed (program cc1plus) .


Mi diceva invalid package arg, e di verificare gli ebuilds, ma ora non ricordo di preciso, domani riprovo e posto direttamente il risultato
Riguardo alla swap quindi sarebbe comunque meglio insomma
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Tue Sep 20, 2016 5:16 pm    Post subject: Reply with quote

zar Marco wrote:
Mi diceva invalid package arg, e di verificare gli ebuilds, ma ora non ricordo di preciso, domani riprovo e posto direttamente il risultato

Posta il comando che dai e il risultato.

zar Marco wrote:
Riguardo alla swap quindi sarebbe comunque meglio insomma

Direi di no anche perche' puoi creare una swap temporanea quando e se servira' (qui trovi come creare una swap temporanea).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Sep 20, 2016 6:07 pm    Post subject: Reply with quote

fedeliallalinea wrote:
zar Marco wrote:
Mi diceva invalid package arg, e di verificare gli ebuilds, ma ora non ricordo di preciso, domani riprovo e posto direttamente il risultato

Posta il comando che dai e il risultato.

zar Marco wrote:
Riguardo alla swap quindi sarebbe comunque meglio insomma

Direi di no anche perche' puoi creare una swap temporanea quando e se servira' (qui trovi come creare una swap temporanea).


OK, grazie di tutto, domani se non risolvo posto il comando
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 710

PostPosted: Tue Sep 20, 2016 6:10 pm    Post subject: Reply with quote

ciao.

prova a far decidere portage cosa vuole per completezza con l'opzione --autounmask-write

(vedi man di emerge)

Code:
# emerge --autounmask-write libxcb


lui si calcola eventuali flags e/o dipendenze da metter sul piatto e poi ti propone la modifica di eventuali file di cnfigurazione relativi a .use e/o .keywords)

e ti propone la loro modifica con il comando
Code:
# etc-update

(ripsondendo -5 confermi le modifiche dei files , con -9 le rifiuti , genericamente sono le opzioni più utilizzate tra le 3-4 proposte)

puoi riassumere il comando completo con
Code:
# emerge --autounmask-write libxcb || etc-update


se non ci sono conflitti complessi , portage si arrangia da solo a risolvere i conflitti con le dipendenze o le USE richieste per il pacchetto o i pacchetti se ce ne sono più di uno)
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Sep 20, 2016 7:58 pm    Post subject: Reply with quote

sabayonino wrote:
ciao.

prova a far decidere portage cosa vuole per completezza con l'opzione --autounmask-write

(vedi man di emerge)

Code:
# emerge --autounmask-write libxcb


lui si calcola eventuali flags e/o dipendenze da metter sul piatto e poi ti propone la modifica di eventuali file di cnfigurazione relativi a .use e/o .keywords)

e ti propone la loro modifica con il comando
Code:
# etc-update

(ripsondendo -5 confermi le modifiche dei files , con -9 le rifiuti , genericamente sono le opzioni più utilizzate tra le 3-4 proposte)

puoi riassumere il comando completo con
Code:
# emerge --autounmask-write libxcb || etc-update


se non ci sono conflitti complessi , portage si arrangia da solo a risolvere i conflitti con le dipendenze o le USE richieste per il pacchetto o i pacchetti se ce ne sono più di uno)


OK grazie mille, domani spero di risolvere
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Wed Sep 21, 2016 3:04 pm    Post subject: Reply with quote

Ok, ricapitoliamo dando un aggiornamento mi restituisce questo
Code:
gentooBook martoo # emerge -DNu @world --verbose-conflicts
Calculating dependencies... done!
[ebuild  N     ] app-arch/lz4-0_p131  USE="{-test} -valgrind" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] sys-libs/cracklib-2.9.6-r1 [2.9.6]
[ebuild  N     ] dev-libs/libbsd-0.8.2  USE="static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] app-arch/unzip-6.0_p20  USE="-natspec*"
[ebuild     U  ] x11-proto/xproto-7.0.29 [7.0.28]
[ebuild     U  ] x11-proto/inputproto-2.3.2 [2.3.1]
[ebuild     U  ] x11-libs/pixman-0.34.0 [0.32.8] CPU_FLAGS_X86="mmxext* ssse3*"
[ebuild     U  ] x11-proto/videoproto-2.3.3 [2.3.2]
[ebuild     U  ] net-misc/curl-7.50.3 [7.50.2]
[ebuild     U  ] x11-libs/libXdmcp-1.1.2-r1 [1.1.2]
[ebuild     U  ] x11-libs/libxkbcommon-0.6.0 [0.5.0]
[ebuild     U  ] x11-libs/libXfixes-5.0.2 [5.0.1]
[ebuild     U  ] x11-libs/libXi-1.7.6 [1.7.5]
[ebuild     U  ] x11-apps/xkbcomp-1.3.1 [1.3.0]
[ebuild     U  ] x11-apps/xrandr-1.5.0 [1.4.3]
[ebuild   R    ] x11-apps/xdpyinfo-1.3.2  USE="-xinerama*"
[ebuild   R    ] x11-misc/dmenu-4.6  USE="-xinerama*"
[ebuild  NS    ] dev-qt/qtgui-4.8.6-r4 [5.6.1] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtsql-4.8.6-r1  USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql -oci8 -odbc -pch -postgres" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qt3support-4.8.6-r1  USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] x11-libs/xcb-util-cursor-0.1.3-r1 [0.1.2]
[ebuild  NS    ] dev-qt/qtscript-5.6.1 [4.8.6-r2] USE="jit -debug -scripttools {-test}"
[ebuild     U  ] dev-libs/libevdev-1.5.2 [1.4.4]
[ebuild     U  ] x11-misc/xkeyboard-config-2.17 [2.16]
[ebuild   R    ] net-libs/glib-networking-2.46.1  USE="-gnome*"
[ebuild  N     ] dev-qt/qtx11extras-5.6.1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.23.0  USE="-doc {-test}"
[ebuild  N     ] kde-frameworks/kf-env-3
[ebuild  N     ] kde-frameworks/kcoreaddons-5.23.0  USE="-debug (-fam) -nls {-test}"
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.23.0  USE="-debug -nls {-test}"
[ebuild  N     ] kde-frameworks/ki18n-5.23.0  USE="-debug {-test}" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild  N     ] kde-frameworks/kwindowsystem-5.23.0  USE="X -debug -nls {-test}"
[ebuild  N     ] kde-frameworks/kconfig-5.23.0  USE="-debug -nls {-test}"
[ebuild  N     ] kde-frameworks/karchive-5.23.0-r1  USE="bzip2 lzma -debug {-test}"
[ebuild  N     ] kde-frameworks/kitemviews-5.23.0  USE="-debug -nls {-test}"
[ebuild  N     ] kde-frameworks/kguiaddons-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kcodecs-5.23.0  USE="-debug -nls {-test}"
[ebuild  N     ] kde-frameworks/kcrash-5.23.0  USE="X -debug -nls {-test}"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.5-r1 [4.1.2-r6, 4.2-r2, 4.3-r1, 4.4-r2]
[ebuild   R    ] media-gfx/feh-2.9.3  USE="-xinerama*"
[ebuild  N     ] kde-frameworks/kdoctools-5.23.0  USE="-debug {-test}"
[ebuild  N     ] sys-apps/systemd-226-r2  USE="acl kdbus kmod lz4 pam policykit seccomp ssl (-apparmor) -audit -cryptsetup -curl -elfutils -gcrypt -gnuefi -http -idn -importd -lzma -nat -qrcode (-selinux) -sysv-utils {-test} -vanilla -xkb" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-apps/dbus-1.10.8-r1  USE="systemd*"
[ebuild  N     ] sys-apps/gentoo-systemd-integration-6
[ebuild  NS    ] dev-qt/qtdbus-4.8.6-r1 [5.6.1] USE="exceptions (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-frameworks/kdbusaddons-5.23.0  USE="X -debug -nls {-test}"
[ebuild  N     ] sys-fs/udev-225-r1  USE="acl kmod static-libs (-selinux)" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] x11-libs/gtk+-3.18.9  USE="-xinerama*"
[ebuild   R    ] x11-libs/gtk+-2.24.30  USE="-xinerama*"
[ebuild   R    ] media-libs/libcanberra-0.30-r5  USE="-gnome*"
[ebuild   R    ] virtual/notification-daemon-0  USE="-gnome*"
[ebuild   R    ] x11-terms/terminator-0.97-r1  USE="-debug*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="kde*"
[ebuild  N     ] sys-auth/polkit-qt-0.112.0-r1  USE="qt4 qt5 -debug -examples"
[ebuild     U  ] sys-apps/openrc-0.21.7 [0.21.3]
[ebuild  N     ] kde-frameworks/kauth-5.23.0-r1  USE="policykit -debug -nls {-test}"
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.23.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kiconthemes-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.6.5  USE="-debug"
[ebuild   R    ] gnome-base/gvfs-1.26.3  USE="gtk*"
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-226-r2)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-225-r1)
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/gentoo-systemd-integration-6)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-225-r1)
 
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
 
  (sys-fs/udev-225-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),static-libs]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)
    >=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
 
  (sys-apps/systemd-226-r2:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-6:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.10.8-r1:0/0::gentoo, ebuild scheduled for merge)
 
 
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
 
https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
RAW Paste Data

E guardando tramite eix ai due pacchetti che bloccano
Code:
martoo@gentooBook ~ $ sudo eix systemd
Password:
* dev-python/python-systemd
     Available versions:  230 ~231 {test PYTHON_TARGETS="python2_7 python3_3 python3_4 python3_5"}
     Homepage:            https://github.com/systemd/python-systemd
     Description:         Python module for native access to the systemd facilities
 
* kde-misc/systemd-kcm
     Available versions: 
     (4)    ~0.7.0
     (5)    ~1.2.1
       {aqua debug}
     Homepage:            https://projects.kde.org/projects/playground/sysadmin/systemd-kcm
     Description:         Plasma control module for systemd
 
* sys-apps/gentoo-systemd-integration
     Available versions:  2 4 ~5 6 **9999
     Homepage:            https://wiki.gentoo.org/wiki/Project:Systemd
     Description:         systemd integration files for Gentoo
 
* sys-apps/systemd
     Available versions:  218-r5(0/2) 226-r2(0/2) ~228-r1(0/2) ~229(0/2) ~230-r2(0/2) ~231(0/2) **9999(0/2) {acl apparmor audit cryptsetup curl doc elfutils (+)gcrypt gnuefi gudev http idn importd introspection (+)kdbus +kmod +lz4 lzma nat pam policykit python qrcode +seccomp selinux ssl sysv-utils terminal test vanilla xkb ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" PYTHON_SINGLE_TARGET="python2_7 python3_3 python3_4" PYTHON_TARGETS="python2_7 python3_3 python3_4"}
     Homepage:            https://www.freedesktop.org/wiki/Software/systemd
     Description:         System and service manager for Linux
 
* sys-apps/systemd-readahead
     Available versions:  216
     Homepage:            https://dev.gentoo.org/~pacho/systemd-readahead.html
     Description:         Split of readahead systemd implementation
 
* sys-apps/systemd-sysv-utils
     Available versions:  ~208 ~212 215 ~216 ~217
     Homepage:            https://www.freedesktop.org/wiki/Software/systemd
     Description:         sysvinit compatibility symlinks and manpages
 
* sys-boot/systemd-boot
     Available versions:  ~231
     Homepage:            https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/
     Description:         UEFI boot manager from systemd (formerly gummiboot)
 
* sys-devel/systemd-m4
     Available versions:  **9999
     Homepage:            https://bitbucket.org/mgorny/systemd-m4/
     Description:         autoconf macros for packages using systemd
 
* sys-process/systemd-cron
     Available versions:  ~1.5.3 ~1.5.4 {cron-boot etc-crontab-systemd minutely setgid yearly PYTHON_SINGLE_TARGET="pypy3 python3_3 python3_4" PYTHON_TARGETS="pypy3 python3_3 python3_4"}
     Homepage:            https://github.com/systemd-cron/systemd-cron/
     Description:         systemd units to create timers for cron directories and crontab
 
Found 9 matches
martoo@gentooBook ~ $ sudo eix udev
* app-text/uudeview
     Available versions:  0.5.20-r1 ~0.5.20-r2 {tk}
     Homepage:            http://www.fpx.de/fp/Software/UUDeview/
     Description:         uu, xx, base64, binhex decoder
 
* app-vim/udev-syntax
     Available versions:  20051016-r1
     Homepage:            http://www.vim.org/scripts/script.php?script_id=1381
     Description:         vim plugin: syntax highlighting for udev rules files
 
* dev-dotnet/gudev-sharp
     Available versions:  0.1
     Homepage:            https://launchpad.net/gudev-sharp
     Description:         GUDEV API C# binding
 
[I] dev-libs/libgudev
     Available versions:  230(0/0) ~230-r1(0/0) {debug introspection static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  230(14:27:48 14/09/2016)(introspection static-libs -debug ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            https://wiki.gnome.org/Projects/libgudev
     Description:         GObject bindings for libudev
 
* dev-python/python-gudev
     Available versions:  147.2-r1 {PYTHON_TARGETS="python2_7"}
     Homepage:            https://github.com/nzjrs/python-gudev
     Description:         Python binding to the GUDev udev helper library
 
* dev-python/pyudev
     Available versions:  0.16.1-r1 ~0.19.0 ~0.20.0 {pygobject pyqt4 pyside test PYTHON_TARGETS="python2_7 python3_3 python3_4 python3_5"}
     Homepage:            http://pyudev.readthedocs.org https://github.com/pyudev/pyudev
     Description:         Python binding to libudev
 
* sys-apps/udevil
     Available versions:  0.4.4-r1
     Homepage:            https://ignorantguru.github.com/udevil/
     Description:         mount and unmount removable devices without a password
 
* sys-fs/eudev
     Available versions:  1.9-r2 1.10-r2 3.1.2 3.1.5 ~3.2 **4.9999 **9999 {+blkid doc efi gudev +hwdb introspection +keymap +kmod +modutils +openrc (+)rule-generator selinux smack static-libs test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            https://github.com/gentoo/eudev
     Description:         Linux dynamic and persistent device naming support (aka userspace devfs)
 
* sys-fs/udev
     Available versions:  216^t 225-r1^t ~228^t ~229-r2^t ~230-r1^t **9999^t {acl doc +firmware-loader gudev introspection +kmod selinux static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            https://www.freedesktop.org/wiki/Software/systemd
     Description:         Linux dynamic and persistent device naming support (aka userspace devfs)
 
[I] sys-fs/udev-init-scripts
     Available versions:  27^t [M]~29^t ~30^t ~31^t **9999^t
     Installed versions:  27^t(07:39:13 08/09/2016)
     Homepage:            https://www.gentoo.org
     Description:         udev startup scripts for openrc
 
* sys-libs/libudev-compat
     Available versions:  ~186 {ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            http://gentoo.org/
     Description:         Wrapper around libudev.so.1 for packages needing the old libudev.so.0
 
[I] virtual/libgudev
     Available versions:  215-r1(0/0) 215-r2(0/0) 215-r3(0/0) 230(0/0) {introspection static-libs systemd ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  230(14:27:59 14/09/2016)(introspection static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Description:         Virtual for libgudev providers
 
[I] virtual/libudev
     Available versions:  215-r1(0/1) {static-libs systemd ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  215-r1(14:26:39 14/09/2016)(static-libs -systemd ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Description:         Virtual for libudev providers
 
[I] virtual/udev
     Available versions:  215 ~217 {systemd}
     Installed versions:  215(16:53:45 17/09/2016)(-systemd)
     Description:         Virtual to select between different udev daemon providers
 
Found 14 matches


Io tolgo systemd, usando openrc, da USE in make.conf, ma se volessi installare kde, che ha bisogno di dbus che ha bisogno di systemd? Lo metto nelle variabili locali?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Wed Sep 21, 2016 3:27 pm    Post subject: Reply with quote

zar Marco wrote:
Io tolgo systemd, usando openrc, da USE in make.conf, ma se volessi installare kde, che ha bisogno di dbus che ha bisogno di systemd? Lo metto nelle variabili locali?

No kde a differenza di gnome non ha bisogno di systemd, infatti dbus richiede systemd solo che ha la use flag systemd attiva.
Questo, se tu usi openrc, mi porta a pensare che hai messo un profilo sbagliato, cosa ti riporta il comando
Code:
# eselect profile list

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Wed Sep 21, 2016 3:51 pm    Post subject: Reply with quote

Attualmente ho xfce perché non riuscivo ad installare kde, come profilo ho desktop, dbus l'avevo installato e messo in USE in previsione di kde. Ma quindi dbus funziona anche senza systemd? In tal caso lo eliminerei
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Wed Sep 21, 2016 6:02 pm    Post subject: Reply with quote

zar Marco wrote:
Attualmente ho xfce perché non riuscivo ad installare kde, come profilo ho desktop, dbus l'avevo installato e messo in USE in previsione di kde. Ma quindi dbus funziona anche senza systemd? In tal caso lo eliminerei

Si dbus funziona senza systemd, io ce l'ho attivato. Non capisco perche' qualcuno vorrebbe systemd, hai attivato la use flag?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Wed Sep 21, 2016 6:24 pm    Post subject: Reply with quote

Sì, ora non mi ricordo cosa, specificamente me lo ha chiesto, ma non credevo desse tutti sti problemi
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Wed Sep 21, 2016 6:30 pm    Post subject: Reply with quote

zar Marco wrote:
Sì, ora non mi ricordo cosa, specificamente me lo ha chiesto, ma non credevo desse tutti sti problemi

Cmq se hai OpenRC non puoi attivare quella use flag. Systemd e OpenRC non possono coesistere.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Wed Sep 21, 2016 6:51 pm    Post subject: Reply with quote

fedeliallalinea wrote:
zar Marco wrote:
Sì, ora non mi ricordo cosa, specificamente me lo ha chiesto, ma non credevo desse tutti sti problemi

Cmq se hai OpenRC non puoi attivare quella use flag. Systemd e OpenRC non possono coesistere.


OK perfetto allora lo tolgo
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Thu Sep 22, 2016 7:37 am    Post subject: Reply with quote

ok, ieri sera ho spento il notebook, oggi lo riaccendo ma all'arrivo del dm (sddm) non vanno ne mouse ne tastiera, quindi non riesco ne ad accedere ne ad andare in modalità tty. Posso fare qualcosa? :oops:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Thu Sep 22, 2016 7:57 am    Post subject: Reply with quote

zar Marco wrote:
ok, ieri sera ho spento il notebook, oggi lo riaccendo ma all'arrivo del dm (sddm) non vanno ne mouse ne tastiera, quindi non riesco ne ad accedere ne ad andare in modalità tty. Posso fare qualcosa? :oops:

Sì puoi usare il cd di installazione montare le varie partizioni che hai creato per gentoo (attenzione solo montare non ricreare il file system se non perdi tutto) e fare il chroot .
Una volta che sei nel chroot (quindi come se fossi sulla tua gentoo) posta un emerge --info, perche' non riesco a capire perche' non hai installato eudev (possibile causa del tuo problema)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Thu Sep 22, 2016 8:22 am    Post subject: Reply with quote

fedeliallalinea wrote:
zar Marco wrote:
ok, ieri sera ho spento il notebook, oggi lo riaccendo ma all'arrivo del dm (sddm) non vanno ne mouse ne tastiera, quindi non riesco ne ad accedere ne ad andare in modalità tty. Posso fare qualcosa? :oops:

Sì puoi usare il cd di installazione montare le varie partizioni che hai creato per gentoo (attenzione solo montare non ricreare il file system se non perdi tutto) e fare il chroot .
Una volta che sei nel chroot (quindi come se fossi sulla tua gentoo) posta un emerge --info, perche' non riesco a capire perche' non hai installato eudev (possibile causa del tuo problema)


Alla fine sono entrato in chroot, ho riabilitato lightdm e reinstallato eudev, quest'ultimo era stata l'ultima operazione fatta ieri, può essere la causa del blocco?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Thu Sep 22, 2016 8:30 am    Post subject: Reply with quote

zar Marco wrote:
Alla fine sono entrato in chroot, ho riabilitato lightdm e reinstallato eudev, quest'ultimo era stata l'ultima operazione fatta ieri, può essere la causa del blocco?

Ma l'hai eliminato te eudev?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Thu Sep 22, 2016 8:36 am    Post subject: Reply with quote

fedeliallalinea wrote:
zar Marco wrote:
Alla fine sono entrato in chroot, ho riabilitato lightdm e reinstallato eudev, quest'ultimo era stata l'ultima operazione fatta ieri, può essere la causa del blocco?

Ma l'hai eliminato te eudev?


Sì perché mi era stato consigliato visti i blocchi in aggiornamento di eudev e systemd visto che ho anche udev installato. Ora sto eliminando systemd visto che sto utilizzando openrc
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Thu Sep 22, 2016 8:51 am    Post subject: Reply with quote

zar Marco wrote:
Sì perché mi era stato consigliato visti i blocchi in aggiornamento di eudev e systemd visto che ho anche udev installato. Ora sto eliminando systemd visto che sto utilizzando openrc

No i blocchi in realta' dicevano udev non eudev. eudev (necessario per openrc) e' il fork di udev fatto da gentoo perche' systemd lo ha integrato e non era piu' disponibile.

zar Marco wrote:
può essere la causa del blocco?



Visto che usi openrc puoi mettere in /etc/portage/package.mask le seguenti linee
Code:
sys-apps/systemd
sys-fs/udev



Per finire non sarebbe male, per i post con i problemi che hai avuto, se li editi e dici come hai risolto cosi' da essere utili anche ad altre persone :D .
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Thu Sep 22, 2016 9:05 am    Post subject: Reply with quote

Dove non specificato non ho aggiunto niente perché ho risolto seguendo i consigli.

Scusa la domanda banale ma package.mask è una directory. Io ho aggiunto quei due pacchetti creandoci un file dentro chiamandolo systemd, va bene? Chiedo perché dentro alla directory esistevano già libtool openrc e perl come file
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22154
Location: here

PostPosted: Thu Sep 22, 2016 9:20 am    Post subject: Reply with quote

zar Marco wrote:
Scusa la domanda banale ma package.mask è una directory. Io ho aggiunto quei due pacchetti creandoci un file dentro chiamandolo systemd, va bene?

Si tutti i /etc/portage/package.<qualcosa> possono essere o file o directory. Visto che la tua e' una directory la tua procedura e' corretta.

zar Marco wrote:
Chiedo perché dentro alla directory esistevano già libtool openrc e perl come file

Probabilmente e' stata l'opzione --autounmask di emerge a crearli. Comunque mi piace poco vedere un file come openrc in questa directory.
Potresti postare l'output di cat /etc/portage/package.mask/*?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2, 3, 4, 5, 6  Next
Page 1 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum