Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
impossiblie aggiornare @world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 28, 2016 7:03 am    Post subject: Reply with quote

Code:
sudo emerge -1a =app-text/poppler-0.47.0 =app-text/apvlv-0.1.5-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-text/poppler-0.47.0 [0.41.0] USE="(-cairo-qt) -nss%"
[ebuild   R    ] app-text/apvlv-0.1.5-r1

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in by
    =app-text/poppler-0.47.0 (Argument)

  (app-text/poppler-0.41.0:0/58::gentoo, installed) pulled in by
    >=app-text/poppler-0.26.0:0/58=[cairo] required by (media-gfx/inkscape-0.91-r1:0/0::gentoo, installed)
                             ^^^^^^                                                                                                           
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 28, 2016 7:05 am    Post subject: Reply with quote

Code:
sudo emerge --update --newuse --deep --with-bdeps=y @world --verbose-conflicts
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^                                                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                           

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.41.0:0/58::gentoo, installed) pulled in by
    >=app-text/poppler-0.18:0/58=[cairo,xpdf-headers(+)] required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)
                           ^^^^^^                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "app-crypt/pinentry" has unmet requirements.
- app-crypt/pinentry-0.9.7-r1::gentoo USE="gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( qt4 qt5 )

  The above constraints are a subset of the following complete expression:
    any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 )

(dependency required by "app-crypt/gnupg-2.1.15::gentoo" [ebuild])
(dependency required by "kde-base/kdelibs-4.14.24::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-mobipocket-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-meta-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kde-apps-meta-16.08.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 28, 2016 7:19 am    Post subject: Reply with quote

nonostante abbia dato
Code:
  sudo emerge -1a x11-libs/libxcb =x11-libs/xcb-util-wm-0.4.1-r1 =x11-libs/xcb-util-image-0.4.0 =x11-libs/xcb-util-keysyms-0.4.0 =x11-libs/xcb-util-renderutil-0.3.9-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-libs/libxcb-1.12
[ebuild   R    ] x11-libs/xcb-util-wm-0.4.1-r1
[ebuild   R    ] x11-libs/xcb-util-image-0.4.0
[ebuild   R    ] x11-libs/xcb-util-keysyms-0.4.0
[ebuild   R    ] x11-libs/xcb-util-renderutil-0.3.9-r1

Would you like to merge these packages? [Yes/No] Yes


rilanciando ottengo ancora questo
Code:
 sudo emerge --update --newuse --deep --with-bdeps=y @world --verbose-conflicts
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^                                                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.12=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)
                           ^^^^^^^^                                                                                                                                           

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.41.0:0/58::gentoo, installed) pulled in by
    >=app-text/poppler-0.18:0/58=[cairo,xpdf-headers(+)] required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)
                           ^^^^^^                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "app-crypt/pinentry" has unmet requirements.
- app-crypt/pinentry-0.9.7-r1::gentoo USE="gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( qt4 qt5 )

  The above constraints are a subset of the following complete expression:
    any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 )

(dependency required by "app-crypt/gnupg-2.1.15::gentoo" [ebuild])
(dependency required by "kde-base/kdelibs-4.14.24::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-mobipocket-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-meta-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kde-apps-meta-16.08.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Wed Sep 28, 2016 7:31 am    Post subject: Reply with quote

Ora ti da lo stesso problema con x11-libs/xcb-util, prova anche con:
Code:
# emerge -1a --nodeps x11-libs/libxcb x11-libs/xcb-util

Con poppler prova
Code:
# emerge -1a --nodeps app-text/poppler app-text/apvlv

Inoltre il pacchetto pinentry puo' avere solo la use flag qt4 o qt5 ma non tutte due assieme, quindi in package.use
Code:
# echo "app-crypt/pinentry -qt4 qt5" >> /etc/portage/package.use

o
Code:
# echo "app-crypt/pinentry qt4 -qt5" >> /etc/portage/package.use

a dipendenza se vuoi compilarlo con qt5 o qt4
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 669

PostPosted: Wed Sep 28, 2016 11:58 am    Post subject: Reply with quote

oltre a settare le USE che contrastano tra di loro , invece di provare a forzare il calcolo delle dipendenze complete con --deep e --newuse

prova con un semplice
Code:
# emerge -ua @world


giusto per vederne il comportamento. le dipendenze strette le si possono trattare anche di seguito (e al massimo si portano dietro il pacchetto richiesto)
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 28, 2016 2:20 pm    Post subject: Reply with quote

grazie per l'aiuto .. ma i conflitti cadono dal cielo ...

Code:
sudo emerge --update --newuse --deep --with-bdeps=y @world
Password:
Calculating dependencies                                                                                           ... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-gfx/exiv2:0

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, installed) pulled in by
    >=media-gfx/exiv2-0.24:0/14=[xmp] required by (kde-apps/libkexiv2-15.08.3:4/15.08::gentoo, installed)
                                 ^^^                                                                                                         
    >=media-gfx/exiv2-0.24:=[xmp=] required by (kde-apps/libkexiv2-15.08.3:4/15.08::gentoo, installed)
                             ^^^^                                                                                                         
    >=media-gfx/exiv2-0.25:=[xmp=] required by (kde-apps/libkexiv2-16.08.1:5/5::gentoo, ebuild scheduled for merge)
                             ^^^^                                                                                                                     

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    >=dev-libs/icu-51.2-r1:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-1.3.1:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                                     
    (and 1 more with the same problem)

dev-lang/perl:0

  (dev-lang/perl-5.22.1:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 34 more with the same problem)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 2 more with the same problem)

x11-libs/vte:2.91

  (x11-libs/vte-0.44.2:2.91/2.91::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/vte-0.42.1:2.91/2.91::nightmare, installed) pulled in by
    >=x11-libs/vte-0.38.1[termite-patch] required by (x11-terms/termite-10:0/0::nightmare, installed)
                          ^^^^^^^^^^^^^                                                                                                 

sci-libs/hdf5:0

  (sci-libs/hdf5-1.8.17:0/1.8.17::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sci-libs/hdf5-1.8.15_p1:0/1.8.15::gentoo, installed) pulled in by
    sci-libs/hdf5:0/1.8.15=[-mpi,-szip,zlib] required by (sci-libs/netcdf-4.4.0-r1:0/11::gentoo, installed)
                 ^^^^^^^^^^                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.7.5::gentoo
# required by kde-plasma/plasma-desktop-5.7.5::gentoo
# required by kde-plasma/plasma-meta-5.7.5::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/mesa-12.0.3 wayland
# required by kde-apps/kanagram-16.08.1::gentoo
# required by kde-apps/kdeedu-meta-16.08.1::gentoo
# required by kde-apps/kde-apps-meta-16.08.1::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtmultimedia-5.6.1 qml
# required by kde-apps/kdebase-runtime-meta-16.04.3::gentoo
# required by kde-apps/kdecore-meta-16.08.1::gentoo[-minimal]
# required by kde-apps/kde-apps-meta-16.08.1::gentoo
# required by @selected
# required by @world (argument)
>=kde-apps/solid-runtime-16.04.3 -bluetooth
# required by kde-apps/kate-16.08.1::gentoo[addons]
# required by kde-apps/kde-apps-meta-16.08.1::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/libgit2-0.24.1 threads
# required by kde-apps/ktp-text-ui-16.08.1::gentoo
# required by kde-apps/plasma-telepathy-meta-16.08.1::gentoo
# required by kde-apps/kdenetwork-meta-16.08.1::gentoo[telepathy]
# required by kde-apps/kde-apps-meta-16.08.1::gentoo
# required by @selected
# required by @world (argument)
>=kde-apps/ktp-common-internals-16.08.1 otr

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.use/iputils' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

emerge: there are no ebuilds to satisfy ">=app-text/poppler-0.12.3-r3:0/58=".
(dependency required by "app-text/texlive-core-2015::gentoo" [installed])
(dependency required by "dev-texlive/texlive-fontsrecommended-2015::gentoo" [installed])
(dependency required by "app-text/texlive-2015::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

!!! The ebuild selected to satisfy ">=net-wireless/wpa_supplicant-2.0[dbus]" has unmet requirements.
- net-wireless/wpa_supplicant-2.5-r2::gentoo USE="dbus hs2-0 qt4 qt5 readline ssl -ap -eap-sim -fasteap -gnutls -libressl -p2p (-ps3) (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( qt4 qt5 )

  The above constraints are a subset of the following complete expression:
    fasteap? ( !gnutls !ssl ) smartcard? ( ssl ) at-most-one-of ( qt4 qt5 )

(dependency required by "net-misc/connman-1.33::gentoo[wifi]" [ebuild])
(dependency required by "net-misc/connman-gtk-1.0-r1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 28, 2016 2:22 pm    Post subject: Reply with quote

# emerge -ua @world
mi da` la il doppio se non il triplo degli errori ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Wed Sep 28, 2016 2:47 pm    Post subject: Reply with quote

Se gli altri errori sono andati a posto prova a fare lo stesso per quelli nuovi (sono piu' o meno simili).
Code:
media-gfx/exiv2:0

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, installed) pulled in by
    >=media-gfx/exiv2-0.24:0/14=[xmp] required by (kde-apps/libkexiv2-15.08.3:4/15.08::gentoo, installed)
                                 ^^^                                                                                                         
    >=media-gfx/exiv2-0.24:=[xmp=] required by (kde-apps/libkexiv2-15.08.3:4/15.08::gentoo, installed)
                             ^^^^                                                                                                         
    >=media-gfx/exiv2-0.25:=[xmp=] required by (kde-apps/libkexiv2-16.08.1:5/5::gentoo, ebuild scheduled for merge)
                             ^^^^

Code:
# echo ">=media-gfx/exiv2-0.25 xmp" >> /etc/portage/package.use           


Code:
dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    >=dev-libs/icu-51.2-r1:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-1.3.1:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                                     
    (and 1 more with the same problem)

dev-lang/perl:0

  (dev-lang/perl-5.22.1:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 34 more with the same problem)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 2 more with the same problem)

sci-libs/hdf5:0

  (sci-libs/hdf5-1.8.17:0/1.8.17::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sci-libs/hdf5-1.8.15_p1:0/1.8.15::gentoo, installed) pulled in by
    sci-libs/hdf5:0/1.8.15=[-mpi,-szip,zlib] required by (sci-libs/netcdf-4.4.0-r1:0/11::gentoo, installed)
                 ^^^^^^^^^^     


Code:
# emerge -1a dev-libs/icu media-libs/harfbuzz ...
# emerge -1a dev-lang/perl dev-perl/SGMLSpm ...
# emerge -1a sci-libs/hdf5 sci-libs/netcdf

Dove al posto dei tre punti metti i package che vedi se metti --verbose-conflicts

Code:
x11-libs/vte:2.91

  (x11-libs/vte-0.44.2:2.91/2.91::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/vte-0.42.1:2.91/2.91::nightmare, installed) pulled in by
    >=x11-libs/vte-0.38.1[termite-patch] required by (x11-terms/termite-10:0/0::nightmare, installed)
                          ^^^^^^^^^^^^^

Qua il problema e' un po' diverso visto che cerca di aggiornare un pacchetto di un'altro overlay con quello di gentoo dove la use flag termite-patch non esiste.
Se il pacchetto x11-terms/termite non ti serve, semplicemente disinstallalo se no ti tocca macherare il pacchetto ufficiale vte
Code:
# echo "x11-libs/vte::gentoo" >> /etc/portage/package.mask


Code:
- net-wireless/wpa_supplicant-2.5-r2::gentoo USE="dbus hs2-0 qt4 qt5 readline ssl -ap -eap-sim -fasteap -gnutls -libressl -p2p (-ps3) (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( qt4 qt5 )

Anche qua solito discorso wpa_supplicant non puo' avere le use flag qt4 e qt5 contemporaneamente, quindi
Code:
# echo "net-wireless/wpa_supplicant -qt4 qt5" >> /etc/portage/package.use

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 10:38 am    Post subject: Reply with quote

Code:
sudo emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore dev-qt/qtimageformats

 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-57.1 [56.1]
[ebuild     U  ] dev-qt/qtcore-5.6.1 [5.5.1-r1]
[ebuild   R    ] media-libs/harfbuzz-1.3.1
[ebuild     U  ] dev-qt/qtdbus-5.6.1 [5.5.1]
[ebuild     U  ] dev-qt/qtgui-5.6.1 [5.5.1-r1]
[ebuild     U  ] dev-qt/qtimageformats-5.6.1 [5.5.1-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 1 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    dev-qt/qtcore (Argument)
    (and 2 more with the same problems)

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 18 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.1 required by (dev-qt/qtimageformats-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           

  (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, installed) pulled in by
    >=dev-qt/qtgui-5.5.1:5/5= required by (kde-frameworks/frameworkintegration-5.19.0:5/5.19::gentoo, installed)
                        ^^^^^                                                                                                                       
    ~dev-qt/qtgui-5.5.1[xcb] required by (dev-qt/qtx11extras-5.5.1:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                                         
    (and 7 more with the same problems)

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    dev-libs/icu:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed)
                ^^^^^^                                                                                                                             
    (and 4 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-libs/vte-0.42.1::nightmare (masked by: package.mask)
- x11-libs/vte-0.36.5::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 10:41 am    Post subject: Reply with quote

per ogni pacchetto le dipendenze aumentano .. anche per icu come vedi comincia a tirar fuori qt*
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 11:43 am    Post subject: Reply with quote

drudox wrote:
per ogni pacchetto le dipendenze aumentano .. anche per icu come vedi comincia a tirar fuori qt*

Prova con
Code:
# emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore:4 dev-qt/qtimageformats

cosi' facendo gli specifichi solo qtcore versione 4
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 1:28 pm    Post subject: Reply with quote

ma non cerca la versione 5 ???
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 1:41 pm    Post subject: Reply with quote

drudox wrote:
ma non cerca la versione 5 ???

Il messaggio diceva
Code:
dev-libs/icu:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed)

quindi la 4
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 1:55 pm    Post subject: Reply with quote

Code:
 sudo emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore:4 dev-qt/qtimageformats
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-57.1 [56.1]
[ebuild     U  ] dev-qt/qtcore-4.8.7-r2 [4.8.7-r1] USE="-icu*"
[ebuild     U  ] dev-qt/qtcore-5.6.1 [5.5.1-r1]
[ebuild   R    ] media-libs/harfbuzz-1.3.1
[ebuild     U  ] dev-qt/qtdbus-5.6.1 [5.5.1]
[ebuild     U  ] dev-qt/qtgui-5.6.1 [5.5.1-r1]
[ebuild     U  ] dev-qt/qtimageformats-5.6.1 [5.5.1-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    (and 2 more with the same problem)

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 18 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.1 required by (dev-qt/qtimageformats-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           

  (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, installed) pulled in by
    >=dev-qt/qtgui-5.5.1:5/5= required by (kde-frameworks/frameworkintegration-5.19.0:5/5.19::gentoo, installed)
                        ^^^^^                                                                                                                       
    ~dev-qt/qtgui-5.5.1[xcb] required by (dev-qt/qtx11extras-5.5.1:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                                         
    (and 7 more with the same problems)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 1 more with the same problem)

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    >=dev-libs/icu-4.4:0/56= required by (dev-tex/bibtexu-3.71_p20150521:0/0::gentoo, installed)
                      ^^^^^^                                                                                                       
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-libs/vte-0.42.1::nightmare (masked by: package.mask)
- x11-libs/vte-0.36.5::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 1:56 pm    Post subject: Reply with quote

non va` :(
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 3:01 pm    Post subject: Reply with quote

Code:
sudo emerge -1a dev-libs/icu --verbose-conflict

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-57.1 [56.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    dev-libs/icu:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed)
                ^^^^^^                                                                                                                             
    dev-libs/icu:0/56= required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/56= required by (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed)
                ^^^^^^                                                                                               
    >=dev-libs/icu-4.4:0/56= required by (dev-tex/bibtexu-3.71_p20150521:0/0::gentoo, installed)
                      ^^^^^^                                                                                                       
    >=dev-libs/icu-51.2-r1:0/56=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-1.3.1:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                                     
    dev-libs/icu:0/56= required by (media-libs/libcdr-0.1.2-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-libs/vte-0.42.1::nightmare (masked by: package.mask)
- x11-libs/vte-0.36.5::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 4:05 pm    Post subject: Reply with quote

Prova a mascherare temporaneamente in un file qt 5.6 (poi una volta dato i comandi lo elimini).
In /etc/portage/package.mask/qt56
Code:
>=dev-qt/designer-5.6
>=dev-qt/linguist-tools-5.6
>=dev-qt/qdbus-5.6
>=dev-qt/qtconcurrent-5.6
>=dev-qt/qtcore-5.6
>=dev-qt/qtdbus-5.6
>=dev-qt/qtdeclarative-5.6
>=dev-qt/qtgraphicaleffects-5.6
>=dev-qt/qtgui-5.6
>=dev-qt/qtimageformats-5.6
>=dev-qt/qtmultimedia-5.6
>=dev-qt/qtnetwork-5.6
>=dev-qt/qtopengl-5.6
>=dev-qt/qtpaths-5.6
>=dev-qt/qtprintsupport-5.6
>=dev-qt/qtquickcontrols-5.6
>=dev-qt/qtscript-5.6
>=dev-qt/qtsql-5.6
>=dev-qt/qtsvg-5.6
>=dev-qt/qttest-5.6
>=dev-qt/qtwidgets-5.6
>=dev-qt/qtx11extras-5.6
>=dev-qt/qtxml-5.6
>=dev-qt/qtxmlpatterns-5.6

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 4:29 pm    Post subject: Reply with quote

subito dopo in che senso ? quando mi da : Calculating dependencies
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 4:31 pm    Post subject: Reply with quote

Code:
sudo emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore dev-qt/qtimageformats dev-qt/qtgui
Password:

 * IMPORTANT: config file '/etc/portage/package.unmask' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-57.1 [56.1]
[ebuild   R    ] dev-qt/qtcore-5.5.1-r1  USE="-icu*"
[ebuild   R    ] media-libs/harfbuzz-1.3.1
[ebuild   R    ] dev-qt/qtgui-5.5.1-r1
[ebuild   R    ] dev-qt/qtimageformats-5.5.1-r1

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore (Argument)

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed) pulled in by
    >=dev-qt/qtcore-5.4.2:5[icu] required by (kde-frameworks/kcoreaddons-5.19.0:5/5.19::gentoo, installed)
                            ^^^                                                                                                               
    ~dev-qt/qtcore-5.5.1[icu] required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, installed)
                         ^^^                                                                                                   

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    >=dev-libs/icu-4.4:0/56= required by (dev-tex/bibtexu-3.71_p20150521:0/0::gentoo, installed)
                      ^^^^^^                                                                                                       
    (and 4 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-libs/vte-0.42.1::nightmare (masked by: package.mask)
- x11-libs/vte-0.36.5::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 4:32 pm    Post subject: Reply with quote

drudox wrote:
subito dopo in che senso ? quando mi da : Calculating dependencies

Lo crei e poi dai il comando
Code:
# emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore:4 dev-qt/qtimageformats

se funziona, ovvero non ti da piu' conflitti, lascia compilare e una volta finito rimuovi il file che maschera le qt-5.6.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 4:42 pm    Post subject: Reply with quote

ci provo !!! sei un amico :)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Sep 30, 2016 5:00 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Prova a mascherare temporaneamente in un file qt 5.6 (poi una volta dato i comandi lo elimini).
In /etc/portage/package.mask/qt56

certo che è una battaglia impari...

quando noi utenti finali personalizziamo troppo le nostre installazioni o le lasciamo ristagnare troppo a lungo senza aggiornamenti, emerge fa una fatica improba a rimetterci in piedi il sistema.

io qualche volta, in questi casi, uso 'opzione --nodeps, che mi sembra più diretta.
sarebbe stato sbagliato lanciare un emerge -1 --nodeps dev-libs/icu e poi risistemare tutto con un --preserved-rebuild?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 5:03 pm    Post subject: Reply with quote

cloc3 wrote:
sarebbe stato sbagliato lanciare un emerge -1 --nodeps dev-libs/icu e poi risistemare tutto con un --preserved-rebuild?

Non penso sia sbagliato (anzi qualsiasi cosa funzioni e' la strada giusta, il bello di linux e' questo puoi sempre mettere a posto le cose in modi differenti) ma sinceramente non ho mai avuto tutti questi problemi :D, quindi mi trovo un po' spiazato senza la possibilita' a ricreare la situazione.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 30, 2016 5:18 pm    Post subject: Reply with quote

Code:
sudo emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore:4 dev-qt/qtimageformats dev-tex/bibtexu --verbose-conflicts

 * IMPORTANT: config file '/etc/portage/package.unmask' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-57.1 [56.1]
[ebuild   R    ] dev-tex/bibtexu-3.71_p20150521
[ebuild     U  ] dev-qt/qtcore-4.8.7-r2 [4.8.7-r1] USE="-icu*"
[ebuild   R    ] media-libs/harfbuzz-1.3.1
[ebuild   R    ] dev-qt/qtimageformats-5.5.1-r1

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-56.1:0/56::gentoo, installed) pulled in by
    dev-libs/icu:0/56= required by (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed)
                ^^^^^^                                                                                               
    dev-libs/icu:0/56= required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/56= required by (media-libs/libcdr-0.1.2-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-libs/vte-0.42.1::nightmare (masked by: package.mask)
- x11-libs/vte-0.36.5::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Fri Sep 30, 2016 5:24 pm    Post subject: Reply with quote

Prova con
Code:
# emerge -1a dev-libs/icu media-libs/harfbuzz dev-qt/qtcore dev-qt/qtimageformats dev-tex/bibtexu dev-qt/qtwebkit media-libs/libcdr

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 3 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum