Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
impossiblie aggiornare @world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Sep 12, 2016 5:55 pm    Post subject: Reply with quote

grazie tante per la risposta io pero` ho 2 versioni vecchie :( come fare ???
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Mon Sep 12, 2016 6:14 pm    Post subject: Reply with quote

drudox wrote:
grazie tante per la risposta io pero` ho 2 versioni vecchie :( come fare ???

Che directory hai in /usr/lib/perl5/vendor_perl/
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Sep 13, 2016 4:50 pm    Post subject: Reply with quote

Code:
ls /usr/lib/perl5/vendor_perl/
5.20.2  5.22.1


vi prego mi sta snervando non poter aggiornare ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Tue Sep 13, 2016 4:58 pm    Post subject: Reply with quote

Quindi penso che dovresti dare
Code:
# emerge -1 --nodeps $(portageq owners / /usr/lib/perl5/vendor_perl/5.20.2 |grep -v ^[[:space:]]|sed 's/^/=/')

tieni presente che e' un trucco proposto da cloc3 io non l'ho mai provato
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Sep 13, 2016 5:24 pm    Post subject: Reply with quote

Code:
 sudo emerge -1 --nodeps $(portageq owners / /usr/lib/perl5/vendor_perl/5.20.2 |grep -v ^[[:space:]]|sed 's/^/=/')
None of the installed packages claim these files:
   /usr/lib/perl5/vendor_perl/5.20.2

emerge: there are no ebuilds to satisfy "=app-text/po4a-0.45-r1".


???
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Tue Sep 13, 2016 6:02 pm    Post subject: Reply with quote

Finche' non risponde cloc3 io ti consiglieri di provare con il comando
Code:
# perl-cleaner --reallyall

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Sep 13, 2016 8:29 pm    Post subject: Reply with quote

drudox wrote:
Code:
 sudo emerge -1 --nodeps $(portageq owners / /usr/lib/perl5/vendor_perl/5.20.2 |grep -v ^[[:space:]]|sed 's/^/=/')
None of the installed packages claim these files:
   /usr/lib/perl5/vendor_perl/5.20.2

emerge: there are no ebuilds to satisfy "=app-text/po4a-0.45-r1".


???

scusa. mi sono dimenticato che a volte capitano pacchetti con versioni che sono stati scaricate da portage.
adesso non riesco a correggere la riga che ho postato sopra, perché queste cose capitano una volta ogni tot anni, le risolvo e poi le dimentico.

l'idea alla base, comunque, è forzare la compilazione di tutti i pacchetti vecchi con il --nodeps, evitando ad emerge di calcolare dipendenze che, in questi casi, possono risultare troppo pesanti.

ovvio, tuttavia, che la strada suggerita da fedeliallalinea è preferibile.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Tue Sep 13, 2016 8:47 pm    Post subject: Reply with quote

ciao. sto seguendo la discussione da un pò.

hai provato a deselezionare i pacchetti con problemi dal world file ?

Code:
# emerge --deselect <pacchetto>


in modo che i conflitti si riducano ?

magari per i pacchetti un pò "critici" prova ad emergerli singolarmente con "--oneshot" ( o -1)

poi con calma risolvi il resto
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Wed Sep 14, 2016 12:07 pm    Post subject: Reply with quote

Oggi e' arrivato l'aggiornamento di perl 5.22 in stable, non ho avuto multi problemi con l'update.
Unica cosa che non ti ho mai detto di provare e' anche il comando
Code:
# emerge --depclean --ask

per disinstallare i pacchetti non piu' necessari.
Comunque con --depclean dai sempre un occhio a cosa vuole disinstallare; per esempio se hai due kernel installati che vuoi tenere emerge cercera' cmq di togliere il piu' vecchio.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 14, 2016 3:39 pm    Post subject: Reply with quote

niente ... ricevo sempre questo :

[url] https://paste.pound-python.org/show/o8YvFBG8WDfVdsWauG58/[/url]

anche con la soluzione proposta da sabayonino continuo a ricevere messaggi di perl bloccato :(

nessuno mi puo` aiutare?
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Wed Sep 14, 2016 7:45 pm    Post subject: Reply with quote

hai un bel casotto là e poco centra con perl

qui ad esempio ibxcdb (e non solo) richiede il supporto per librerie 64 e 32 bit
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    (and 4 more with the same problem)


prova con
Code:
# ABI_X86="64 32" emerge x11-libs/libxcb:0 --ask

(oppure se vuoi generalizzare : inserisci ABI_X86="64 32" nel make.conf , ma occhio che le grane potrebbero aumentare

oppure , prova a smascherare i vari conflitti con :
Code:
# emerge -uDNa --with-bdeps=y --autounmask-write @world || etc-update

controlla con Attenzione le varie modifiche ai files proposti e rispondi di conseguenza.

rilancia il @world


oppure prova la strada dei "7 giorni in tibet" ...
una manciata di aggiornamenti alla volta .... poi c'è il kde ed i dev-qt .... io comincerei con eliminare dal world (con --deselect) tutti i pacchetti dev-qt
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Fri Sep 16, 2016 6:02 am    Post subject: Reply with quote

Per il problema riguardante a perl puoi vedere anche qui se trovi qualcosa
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Fri Sep 16, 2016 10:28 am    Post subject: Reply with quote

ho aggiornato perl proprio ieri sera :

semplicemente con
Code:
# emerge -u1 dev-lang/perl && perl-cleaner --all


ma nel tuo caso con tutti quei conflitti , è probabile che troverai altri problemi.

devi risolvere singolarmente le collissioni dei vari pacchetti cominciando da pacchetti di "poco conto".
guardati bene il log e cosa vuole.

metti da parte il @world.
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 23, 2016 4:41 pm    Post subject: Reply with quote

Code:
sudo ABI_X86="64 32" emerge x11-libs/libxcb:0 --ask
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] x11-proto/xcb-proto-1.12-r2 [1.11] PYTHON_TARGETS="-python3_5%"
[ebuild     U  ] x11-libs/libxcb-1.12 [1.11.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libxcb:0 (Argument)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             
    (and 6 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- kde-apps/kdeartwork-emoticons-15.08.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Johannes Huber <johu@gentoo.org> (1 Aug 2016)
# Masked for removal in 30 days. Dead by upstream. Last release
# with 15.08. Exported to kde-sunset overlay.

- kde-apps/kdeartwork-desktopthemes-15.08.3::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-iconthemes-15.08.3::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-meta-15.08.3-r1::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-colorschemes-15.08.3::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-wallpapers-15.08.3-r1::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- kde-apps/kdeartwork-weatherwallpapers-15.08.3-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Fri Sep 23, 2016 5:47 pm    Post subject: Reply with quote

Prova con questo o questo (punto 5). L'utente ha risolto ma non so con quale dei due metodi.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Sep 26, 2016 4:32 pm    Post subject: Reply with quote

sto provando a lavorare pacchetto per pacchetto ... ma ottengo tutto questo :

https://paste.pound-python.org/show/jAhK2c8JcDtBvIHgf67h/
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Mon Sep 26, 2016 4:58 pm    Post subject: Reply with quote

lo riscrivo :

prova a togliere tutti i pacchetti dev-qt/* dal world con l'opzione --deselect per semplificare il calcolo delle dipendenze.

Code:
# emerge --deselect $(eix -iCc dev-qt | grep dev-qt | awk '{print $2}')


e riemergili se richiesto senza aggiungerli al world con "-1" o "--one-shot" (sono la stessa cosa)

ritenta
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Sep 26, 2016 5:11 pm    Post subject: Reply with quote

Code:
sudo emerge --deselect $(eix -iCc dev-qt | grep dev-qt | awk '{print $2}')
>>> Removing dev-qt/qtcore from "world" favorites file...
>>> Removing dev-qt/qtcore:5 from "world" favorites file...
┌─[19:10] drudox@ ─[~]
└──> sudo emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    x11-libs/libxcb:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                                                     
    (and 4 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-video/vlc-2.0.1:=[dbus,ogg,vorbis]" has unmet requirements.
- media-video/vlc-2.2.4::gentoo USE="X a52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt jpeg libnotify libsamplerate mp3 mpeg ncurses ogg opengl png pulseaudio qt4 qt5 sdl svg swscale truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -bluray -cddb -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -ieee1394 -jack -kate -kde -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib -test -theora -tremor -twolame -upnp -v4l -vaapi -vcdx -vdpau -vlm -vnc -vpx -wma-fixed -x265 -zeroconf -zvbi" ABI_X86="64" CPU_FLAGS_X86="mmx sse"

  The following REQUIRED_USE flag constraints are unsatisfied:
    qt4? ( !qt5 ) qt5? ( !qt4 )

  The above constraints are a subset of the following complete expression:
    aalib? ( X ) bidi? ( truetype ) cddb? ( cdda ) dvb? ( dvbpsi ) dxva2? ( avcodec ) ffmpeg? ( avcodec avformat swscale ) fontconfig? ( truetype ) gnutls? ( gcrypt ) httpd? ( lua ) libcaca? ( X ) libtar? ( skins ) libtiger? ( kate ) qt4? ( X !qt5 ) qt5? ( X !qt4 ) sdl? ( X ) skins? ( truetype X xml exactly-one-of ( qt4 qt5 ) ) vaapi? ( avcodec X ) vdpau? ( xcb ) vlm? ( encode ) xv? ( xcb )

(dependency required by "media-libs/phonon-vlc-0.9.0::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.9.0::gentoo[vlc]" [ebuild])
(dependency required by "kde-frameworks/knotifications-5.26.0::gentoo" [ebuild])
(dependency required by "kde-apps/konsole-16.08.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Mon Sep 26, 2016 5:23 pm    Post subject: Reply with quote

Per vlc devi scegliere se usare la use flag qt4 o qt5, quindi metti in package.use
Code:
echo "media-video/vlc qt4 -qt5" >> /etc/portage/package.use

per avere l'interfaccia grafica in qt4
Code:
echo "media-video/vlc -qt4 qt5" >> /etc/portage/package.use

per avere l'interfaccia grafica in qt5
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Mon Sep 26, 2016 8:20 pm    Post subject: Reply with quote

:P qualcuno potrebbe uscirne pazzo ... ma quasi ci siamo

inoltre
x11-libs/libxcb-1.11.1 richiede il supporto per le librerie 32bit

Code:
# emerge =x11-libs/libxcb-1.11.1 --autounmask-write || etc-update


aggiorna il file di configurazione con -5
(controlla comunque cosa viene modificato)

e riemergi x11-libs/libxcb-1.11.1
Code:
# emerge =x11-libs/libxcb-1.11.1

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Sep 27, 2016 11:39 am    Post subject: Reply with quote

ora ottengo questo
Code:
 sudo emerge --update --newuse --deep --with-bdeps=y @world
Password:
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    (and 4 more with the same problem)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^                                                                                                                   

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.41.0:0/58::gentoo, installed) pulled in by
    >=app-text/poppler-0.18:0/58=[cairo,xpdf-headers(+)] required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)
                           ^^^^^^                                                                                                                       

dev-ruby/ruby-glib2:0

  (dev-ruby/ruby-glib2-3.0.8:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/ruby-glib2-3.0.8[ruby_targets_ruby21] required by (dev-ruby/ruby-gdk3-3.0.8:0/0::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^                                                                                                                                                           
    (and 4 more with the same problem)

  (dev-ruby/ruby-glib2-3.0.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-ruby/ruby-glib2[ruby_targets_ruby20] required by (dev-ruby/rcairo-1.15.2:0/0::gentoo, ebuild scheduled for merge)
                        ^^^^^^^^^^^^^^^^^^^                                                                                                                 

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "app-crypt/pinentry" has unmet requirements.
- app-crypt/pinentry-0.9.7-r1::gentoo USE="gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( qt4 qt5 )

  The above constraints are a subset of the following complete expression:
    any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 )

(dependency required by "app-crypt/gnupg-2.1.15::gentoo" [ebuild])
(dependency required by "kde-base/kdelibs-4.14.24::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-mobipocket-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kdegraphics-meta-16.08.1::gentoo" [ebuild])
(dependency required by "kde-apps/kde-apps-meta-16.08.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Tue Sep 27, 2016 12:19 pm    Post subject: Reply with quote

Code:
x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    (and 4 more with the same problem)

Questo hai fatto come detto da sabayonino? Se si e' andato a buon fine il comando?

Code:
sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)

Aggiungi al package.use questo ">=sys-libs/zlib-1.2.5.1-r2 minizip"

Code:
app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.41.0:0/58::gentoo, installed) pulled in by
    >=app-text/poppler-0.18:0/58=[cairo,xpdf-headers(+)] required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)

Prova a lanciare il comando emerge -1a =app-text/poppler-0.47.0 =app-text/apvlv-0.1.5-r1

Code:
dev-ruby/ruby-glib2:0

  (dev-ruby/ruby-glib2-3.0.8:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/ruby-glib2-3.0.8[ruby_targets_ruby21] required by (dev-ruby/ruby-gdk3-3.0.8:0/0::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^                                                                                                                                                           
    (and 4 more with the same problem)

  (dev-ruby/ruby-glib2-3.0.7:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-ruby/ruby-glib2[ruby_targets_ruby20] required by (dev-ruby/rcairo-1.15.2:0/0::gentoo, ebuild scheduled for merge)
                        ^^^^^^^^^^^^^^^^^^^   

In questo caso prova a mettere nel package.use "=dev-ruby/rcairo-1.15.2 -ruby_targets_ruby20 ruby_targets_ruby21" e ricompilare singolarmente il pacchetto emerge -1a =dev-ruby/rcairo-1.15.2
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Sep 27, 2016 6:29 pm    Post subject: Reply with quote

Code:

Codice:
x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    (and 4 more with the same problem)


si ho fatto come mi ha detto sabayonino ma il comando et-update mi ha detto che non c'era niente da fare :\
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Tue Sep 27, 2016 6:57 pm    Post subject: Reply with quote

drudox wrote:
Code:

Codice:
x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    (and 4 more with the same problem)


si ho fatto come mi ha detto sabayonino ma il comando et-update mi ha detto che non c'era niente da fare :\

Allora prova con emerge -1a x11-libs/libxcb =x11-libs/xcb-util-wm-0.4.1-r1 ..., dove i 3 puntini li sostituisci con i 4 pachetti che hanno lo stesso problema (li vedi mettendo al comando dell'update l'opzione --verbose-conflicts)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Sep 27, 2016 10:41 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Allora prova con emerge -1a x11-libs/libxcb =x11-libs/xcb-util-wm-0.4.1-r1 ..., dove i 3 puntini li sostituisci con i 4 pachetti che hanno lo stesso problema (li vedi mettendo al comando dell'update l'opzione --verbose-conflicts)

ho avuto lo stesso problema.
ho risolto con:
Code:

emerge -1 --nodeps xcb-proto libxcb x11-libs/xcb-util-keysyms x11-libs/xcb-util-wm x11-libs/xcb-util-renderutil x11-libs/xcb-util-image

_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum