Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
impossiblie aggiornare @world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 07, 2016 5:04 pm    Post subject: impossiblie aggiornare @world Reply with quote

salve a tutti .. sto tentando di aggiornare @world ... ma non riesco perche` sembra che molti pacchetti siano in masked ... ricevo questi messaggi (nel comando ho messo in ignore quelli che mi davano il blocked package) ... e` da 2 mesi che non eseguo un update e non son molto ferrato su portage (uso da poco gentoo) qualcuno sa darmi una mano ? nella guida non ci ho capito molto ... anzi niente

Code:
sudo emerge -auvND --exclude xf86-input-keyboard --exclude kate --exclude qtquick1 --exclude qtdeclarative --verbose-conflicts --exclude File-DesktopEntry  File-BaseDir File-MimeInfo --exclude linguist-tools kde-l10n --exclude kded @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-qt/linguist-tools-5.6.1:5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/linguist-tools-5.7.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (12 Aug 2016)
# Requires revdeps to build with at least C++11. Bug 589412.
# Masked for wider testing.

- dev-qt/linguist-tools-5.6.1::gentoo (masked by: exclude option)

(dependency required by "kde-frameworks/kcrash-5.25.0::gentoo[nls]" [ebuild])
(dependency required by "kde-frameworks/kinit-5.25.0::gentoo" [ebuild])
(dependency required by "kde-apps/konsole-16.04.3::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Wed Sep 07, 2016 5:10 pm    Post subject: Reply with quote

Potresti postare l'output senza i vari exclude (se troppo lungo usa il programma wgetpaste)? Usi kde4?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 07, 2016 6:14 pm    Post subject: Reply with quote

non uso kde4....
uso i3wm di solito ma ho anche plasma installato

ecco il risultato
https://paste.pound-python.org/show/wFa3HC8EJGG01Rka5Gbj/

grazie mille per l'aiuto
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Wed Sep 07, 2016 6:47 pm    Post subject: Reply with quote

drudox wrote:
https://paste.pound-python.org/show/wFa3HC8EJGG01Rka5Gbj/

Noto che ci sono "un paio" di errori :P .
Ok iniziamo a farne uscire qualcuno in meno.
Per prima cosa metti in package.use tutto quello che ti dice da linea 1146 a 1310 (ma forse l'ha fatto in automatico mettendoli in /etc/portage/package.use/iputils in questo caso devi dare un etc-update).
Da linea 1116 a 1137 ti dice che libressl e openssl non possono coesistere, probabilmente dovuto alla use flag libressl attiva su qualche pacchetto prova a disabilitarla nel make.conf.
Fatto questo prova a dare il comando
Code:
# emerge -auvND @world --backtrack=30

e riposta l'output.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed Sep 07, 2016 8:33 pm    Post subject: Reply with quote

il file package.use e` una directory che contiene inputils ho provato a fare etc-update (con opzione -3)

e l'output di
Code:
# emerge -auvND @world --backtrack=30


lo trovi qui
[url] https://paste.pound-python.org/show/scG5GTIkxzcD1U8cFEHX/ [/url]

Grazie ancora per l'aiuto :)))))
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Thu Sep 08, 2016 6:44 am    Post subject: Reply with quote

Per gli errori da linea 917 a 995 prova a seguire la guida ufficiale.
Se riesci a risolvere posta un
Code:
# emerge -auvNDt @world --backtrack=30

così da capire che pacchetto richiede libressl.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Thu Sep 08, 2016 9:53 am    Post subject: Reply with quote

Non mi e` molto chiaro ... in pratica considerando il primo pacchetto (dev-lang/perl) dovrei dare :


emerge --ask --oneshot =dev-lang/perl-5.24 (perche` e la piu` recente.... ) giusto ?
e per dev-lang/perl-5.2* e` tutto sistemato ???
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Thu Sep 08, 2016 10:07 am    Post subject: Reply with quote

che pero` mi da` questo messaggio

Code:
sudo emerge --ask --oneshot =dev-lang/perl-5.24.0-r1
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.24.0-r1 [5.22.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24.0-r1 (Argument)

  (dev-lang/perl-5.22.1:0/5.22::gentoo, installed) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-IO-Compress-2.68.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    (and 103 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- kde-apps/kdeartwork-emoticons-15.08.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Johannes Huber <johu@gentoo.org> (1 Aug 2016)
# Masked for removal in 30 days. Dead by upstream. Last release
# with 15.08. Exported to kde-sunset overlay.

- kde-apps/kdeartwork-desktopthemes-15.08.3::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-iconthemes-15.08.3::gentoo (masked by: package.mask)
- dev-perl/cdk-perl-20141106::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Kent Fredric <kentnl@gentoo.org> (3 Aug 2016)
# No reverse dependencies, was never clear why it was in tree,
# upstream stagnant, dev-libs/cdk is mostly unmaintained.
#
# Please voice concerns on bug 575036 if you still need this.
# Removal in 30 days.

- kde-apps/kdeartwork-meta-15.08.3-r1::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-colorschemes-15.08.3::gentoo (masked by: package.mask)
- kde-apps/kdeartwork-wallpapers-15.08.3-r1::gentoo (masked by: package.mask)
- kde-apps/libkdeedu-4.14.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Palimaka <kensington@gentoo.org> (24 Aug 2016)
# No longer produced by upstream and no longer used by anything.
# Masked for removal in 30 days.

- kde-apps/kdeartwork-weatherwallpapers-15.08.3-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Thu Sep 08, 2016 2:29 pm    Post subject: Reply with quote

Domanda stupida ma perl-5.24 ti serve veramente o ti e' rimasto in qualche package.accept_keywords?
Prima di iniziare l'upgrade di perl (cosa che risulta sempre incasinata) proverei a rimuovere da package.accept_keywords il pacchetto dev-lang/perl e vedere se l'update te lo richiede o meno.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Thu Sep 08, 2016 5:11 pm    Post subject: Reply with quote

ok
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Thu Sep 08, 2016 5:33 pm    Post subject: Reply with quote

Non c'e` nulla in /etc/portage/package.accept_keywords!!

come procedo per il discorso precedente ? potrei mettere perl in exclude ?

cmq non ho capito bene come fare per gli altri pacchetti da questa guida https://wiki.gentoo.org/wiki/Troubleshooting#Dependency_graph_slot_conflicts che mi hai detto di seguire ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Thu Sep 08, 2016 5:44 pm    Post subject: Reply with quote

drudox wrote:
come procedo per il discorso precedente ?

Purtroppo non ho esperienza diretta (o se l'ho fatto non mi ricordo) ma posso rimandarti a queste due risorse:
https://forums.gentoo.org/viewtopic-t-1046754-start-0.html
http://blog.heeresonline.com/2015/04/gentoo-perl-upgrade/

EDIT: si, non hai nulla in package.keywords perche' stai usando gentoo in testing. Cmq nel primo link c'e' scritto anche come impostare perl a stable (piu' precisamente qui).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Thu Sep 08, 2016 6:55 pm    Post subject: Reply with quote

drudox wrote:
cmq non ho capito bene come fare per gli altri pacchetti da questa guida https://wiki.gentoo.org/wiki/Troubleshooting#Dependency_graph_slot_conflicts che mi hai detto di seguire ...

Scusa ma mi sa che ti ho re-indirizzato male. Per gli errori
Code:
  (dev-libs/icu-57.1:0/57::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

prova a mascherare la versione (in package.mask) visto che nessuno la usa ma la vecchia si (che tra l'altro e' quello che ti dice di fare emerge).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 09, 2016 8:50 am    Post subject: Reply with quote

dunque ho provato a mettere Perl in stable come da guida

1) non avevo una directory chiamata /etc/portage/package.accept_keywords
2) la ho creata .... ma non mi fa scrivere ... (ho usato sudo ovviamente)

sudo echo "dev-lang/perl -~amd64" >> /etc/portage/package.accept_keywords/Perl
bash: /etc/portage/package.accept_keywords/Perl: Non è una directory

anche facendolo a mano mi dice che e` in sola lettura .. ho fatto male a creare la dir ?
gli altri pacchetti li maschero o li metto come ignore ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Fri Sep 09, 2016 9:02 am    Post subject: Reply with quote

drudox wrote:
sudo echo "dev-lang/perl -~amd64" >> /etc/portage/package.accept_keywords/Perl
bash: /etc/portage/package.accept_keywords/Perl: Non è una directory

Postami un
Code:
# ls -la /etc/portage/
# ls -la /etc/portage/package.accept_keywords/


drudox wrote:
anche facendolo a mano mi dice che e` in sola lettura .. ho fatto male a creare la dir ?

No package.accept_keywords puo' essere sia file che directory

drudox wrote:
gli altri pacchetti li maschero o li metto come ignore ?

No capisco cosa intendi metterli come ignore, comunque come dice il messaggio di emerge usa package.mask
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 09, 2016 9:27 am    Post subject: Reply with quote

Code:

ls -la /etc/portage/
totale 68
drwxr-xr-x  11 root root 4096  9 set 11.25 .
drwxr-xr-x 102 root root 4096  9 set 10.05 ..
drwxr-xr-x   2 root root 4096 28 feb  2016 bin
-rw-r--r--   1 root root 1311  7 set 22.21 make.conf
-rw-r--r--   1 root root  630 26 gen  2016 make.conf.catalyst
-rw-r--r--   1 root root 1137  8 feb  2016 make.conf.euse_backup
lrwxrwxrwx   1 root root   66 29 gen  2016 make.profile -> ../../usr/portage/profiles/default/linux/amd64/13.0/desktop/plasma
-rw-r--r--   1 root root    0 10 feb  2016 package.accept_keyword
drwxr-xr-x   2 root root 4096  9 set 11.25 package.accept_keywords
-rw-r--r--   1 root root  233  8 feb  2016 package.license
drwxr-xr-x   2 root root 4096 11 feb  2016 package.mask
-rw-r--r--   1 root root  859 30 ago 21.05 package.unmask
drwxr-xr-x   2 root root 4096  7 set 22.19 package.use
drwxr-xr-x   2 root root 4096  9 set 10.40 pakage.accept_keywords
drwxr-xr-x   2 root root 4096 28 feb  2016 postsync.d
drwxr-xr-x   2 root root 4096 28 feb  2016 repo.postsync.d
drwxr-xr-x   2 root root 4096  2 feb  2016 repos.conf
drwxr-xr-x   6 root root 4096 19 feb  2016 savedconfig


Code:

 ls -la /etc/portage/package.accept_keywords/
totale 8
drwxr-xr-x  2 root root 4096  9 set 11.25 .
drwxr-xr-x 11 root root 4096  9 set 11.25 ..


con ignore intendevo dire exclude .. cmq ok li metto in mask
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 09, 2016 9:40 am    Post subject: Reply with quote

Code:

cat /etc/portage/package.accept_keywords/Perl
dev-lang/perl -~amd64
dev-perl/* -~amd64
virtual/perl* -~amd64

ho cambiato il nome del file package.accept_keywords in package.accept_keyword cosi` da poter creare la directory corretta e scrivere su di essa i file per Perl ... prima di passare a mettere in mask gli altri pacchetti ho dato
Code:

sudo emerge -avuDN @world --backtrack=300


ma non cambia inquanto ...
Code:

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Compress-Raw-Zlib-2.65.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                   
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 24 more with the same problems)

  (dev-lang/perl-5.22.1:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Types-Serialiser-1.0.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 55 more with the same problem)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Fri Sep 09, 2016 9:47 am    Post subject: Reply with quote

I permessi sulla directory sono ok, pero' vedo che hai un file package.accept_keyword, una directory pakage.accept_keywords e package.accept_keywords.
Solo l'ultima directory ha il nome corretto, se gli altri sono vuoti puoi elimenarli, altrimenti sposta il contenuto sotto quella con corretta (per il file spostalo semplicemente per l'altra dir sposta il suo contenuto).
Poi prova a fare echo ma da root direttamente non usando sudo.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 09, 2016 9:52 am    Post subject: Reply with quote

il file che ho postato e` nella directory giusta ! guarda

Code:
 cat /etc/portage/package.accept_keywords/Perl
dev-lang/perl -~amd64
dev-perl/* -~amd64
virtual/perl* -~amd64


fatto con gli echo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Fri Sep 09, 2016 10:39 am    Post subject: Reply with quote

Qualcosa è cambiato ora non richiede più perl 5.24. Puoi postare un
Code:
# sudo emerge -avuDNt @world --backtrack=300

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Sep 09, 2016 1:50 pm    Post subject: Reply with quote

pero` cerca la 5.20 e la 5.22

https://paste.pound-python.org/show/fjbfkoMoIgBOo4nWh3gS/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Fri Sep 09, 2016 8:07 pm    Post subject: Reply with quote

drudox wrote:
pero` cerca la 5.20 e la 5.22

Vero questo perche' non ho pensato che on ~arch la versione installata e' la 5.22.
Allora rimuovi il file /etc/portage/package.accept_keywords/Perl e poi dai questi comandi
Code:
# equery -q list --full-regex "dev-perl/.*" >> /etc/portage/package.mask/Perl
# equery -q list --full-regex "dev-lang/perl" >> /etc/portage/package.mask/Perl
# equery -q list --full-regex "virtual/perl.*" >> /etc/portage/package.mask/Perl

poi editi il file /etc/portage/package.mask/Perl e davanti a ogni riga metto il carattere > (cosi' da mascherare tutti i pacchetti di perl con versione maggiore di quelli che hai installato).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sat Sep 10, 2016 7:17 am    Post subject: Reply with quote

no niente :(

[url]

https://paste.pound-python.org/show/99bYgfuRbi4Mc4VSTkpB/ [/url]

e questo e il file /etc/portage/package.mask/Perl

Code:
>dev-perl/AnyEvent-7.110.0
>dev-perl/AnyEvent-I3-0.160.0
>dev-perl/Archive-Zip-1.560.0
>dev-perl/Authen-SASL-2.160.0-r1
>dev-perl/Canary-Stability-2006
>dev-perl/Class-Method-Modifiers-2.30.0
>dev-perl/DBD-mysql-4.32.0-r1
>dev-perl/DBI-1.634.0
>dev-perl/Data-Perl-0.2.9
>dev-perl/Data-Random-0.80.0
>dev-perl/Devel-PatchPerl-1.400.0
>dev-perl/Digest-HMAC-1.30.0-r1
>dev-perl/Encode-Locale-1.30.0-r1
>dev-perl/Error-0.170.240
>dev-perl/Exporter-Tiny-0.42.0
>dev-perl/File-BaseDir-0.30.0-r1
>dev-perl/File-DesktopEntry-0.40.0-r1
>dev-perl/File-Listing-6.40.0-r1
>dev-perl/File-MimeInfo-0.270.0
>dev-perl/File-pushd-1.3.0-r1
>dev-perl/Font-TTF-1.20.0-r1
>dev-perl/HTML-LinkExtractor-0.130.0-r1
>dev-perl/HTML-Parser-3.720.0
>dev-perl/HTML-Tagset-3.200.0-r1
>dev-perl/HTTP-Cookies-6.10.0
>dev-perl/HTTP-Daemon-6.10.0-r1
>dev-perl/HTTP-Date-6.20.0-r1
>dev-perl/HTTP-Message-6.110.0
>dev-perl/HTTP-Negotiate-6.10.0
>dev-perl/IO-HTML-1.1.0
>dev-perl/IO-Socket-SSL-2.24.0
>dev-perl/IO-String-1.80.0-r1
>dev-perl/JSON-XS-3.10.0
>dev-perl/LWP-MediaTypes-6.20.0-r1
>dev-perl/LWP-Protocol-https-6.60.0
>dev-perl/List-MoreUtils-0.413.0
>dev-perl/Locale-gettext-1.50.0-r1
>dev-perl/Module-Build-0.421.600
>dev-perl/Module-Pluggable-5.200.0
>dev-perl/Module-Runtime-0.14.0
>dev-perl/Net-Daemon-0.480.0-r1
>dev-perl/Net-HTTP-6.60.0
>dev-perl/Net-SMTP-SSL-1.30.0
>dev-perl/Net-SSLeay-1.650.0-r2
>dev-perl/PlRPC-0.202.0-r2
>dev-perl/Role-Tiny-2.0.1
>dev-perl/SGMLSpm-1.03-r7
>dev-perl/TermReadKey-2.330.0
>dev-perl/Test-Deep-0.117.0
>dev-perl/Text-CharWidth-0.40.0-r1
>dev-perl/Text-Unidecode-1.240.0
>dev-perl/Text-WrapI18N-0.60.0-r1
>dev-perl/Time-ParseDate-2013.91.200
>dev-perl/TimeDate-2.300.0
>dev-perl/Types-Serialiser-1.0.0
>dev-perl/URI-1.690.0
>dev-perl/Unicode-EastAsianWidth-1.330.0-r1
>dev-perl/WWW-Mechanize-FormFiller-0.110.0
>dev-perl/WWW-RobotRules-6.20.0
>dev-perl/XML-DOM-1.440.0-r1
>dev-perl/XML-LibXML-2.12.100
>dev-perl/XML-NamespaceSupport-1.110.0-r1
>dev-perl/XML-Parser-2.440.0
>dev-perl/XML-RegExp-0.40.0-r1
>dev-perl/XML-SAX-0.990.0-r1
>dev-perl/XML-SAX-Base-1.80.0-r1
>dev-perl/XML-Simple-2.200.0-r1
>dev-perl/cdk-perl-20141106
>dev-perl/common-sense-3.740.0
>dev-perl/libintl-perl-1.240.0
>dev-perl/libwww-perl-6.150.0
>dev-perl/libxml-perl-0.80.0-r1
>dev-perl/strictures-2.0.1
>dev-lang/perl-5.22.1
>virtual/perl-Archive-Tar-1.960.0
>virtual/perl-CPAN-Meta-2.150.1
>virtual/perl-CPAN-Meta-YAML-0.12.0-r1
>virtual/perl-Carp-1.360.0
>virtual/perl-Compress-Raw-Bzip2-2.68.0
>virtual/perl-Compress-Raw-Zlib-2.68.0
>virtual/perl-Data-Dumper-2.158.0
>virtual/perl-Digest-MD5-2.540.0
>virtual/perl-Digest-SHA-5.950.0
>virtual/perl-Encode-2.730.0
>virtual/perl-Exporter-5.720.0
>virtual/perl-ExtUtils-CBuilder-0.280.221
>virtual/perl-ExtUtils-Install-2.40.0
>virtual/perl-ExtUtils-MakeMaker-7.40.100_rc
>virtual/perl-ExtUtils-Manifest-1.700.0-r1
>virtual/perl-ExtUtils-ParseXS-3.280.0
>virtual/perl-File-Path-2.90.0-r3
>virtual/perl-File-Spec-3.560.0
>virtual/perl-File-Temp-0.230.400-r3
>virtual/perl-Getopt-Long-2.450.0
>virtual/perl-IO-1.350.0
>virtual/perl-IO-Compress-2.68.0
>virtual/perl-IPC-Cmd-0.920.0-r1
>virtual/perl-JSON-PP-2.273.0
>virtual/perl-MIME-Base64-3.150.0
>virtual/perl-Module-Metadata-1.0.26
>virtual/perl-Parse-CPAN-Meta-1.441.400-r1
>virtual/perl-Perl-OSType-1.8.0
>virtual/perl-Scalar-List-Utils-1.410.0
>virtual/perl-Storable-2.530.100
>virtual/perl-Sys-Syslog-0.330.0-r2
>virtual/perl-Term-ANSIColor-4.30.0
>virtual/perl-Test-Harness-3.350.0
>virtual/perl-Test-Simple-1.1.14
>virtual/perl-Text-ParseWords-3.300.0
>virtual/perl-Time-HiRes-1.972.600-r2
>virtual/perl-Time-Local-1.230.0-r2
>virtual/perl-XSLoader-0.200.0
>virtual/perl-if-0.60.400
>virtual/perl-libnet-3.50.0
>virtual/perl-parent-0.232.0
>virtual/perl-version-0.990.900-r2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Sun Sep 11, 2016 10:11 am    Post subject: Reply with quote

Visto che tu hai installato la versione 5.22 ma l'update ti richiede ancora dei moduli che sono compatibili solo con la verione 5.20, prova a lanciare un
Code:
# perl-cleaner --reallyall

non so se aiutera' molto ma a questo punto non mi viene in mente molto altro. :(
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Sep 12, 2016 11:43 am    Post subject: Reply with quote

fedeliallalinea wrote:

non so se aiutera' molto ma a questo punto non mi viene in mente molto altro. :(

anche a me capita che emerge si impalli nel calcolo delle dipendenze di un aggiornamento del perl.

in questi casi, piuttosto che insistere per la via maestra, uso il seguente trucchetto sporco:

Code:

$ vecchiaVersione=x.y.z
$ emerge -1 --nodeps $(portageq owners / /usr/lib/perl5/vendor_perl/$(vecchiaVersione) |grep -v ^[[:space:]]|sed 's/^/=/')

naturalmente, l'emerge si può bloccare se incontra qualche dipendenza incoerente ma, rilanciandolo ad oltranza (o usando emerge --resume --nodeps --skipfirst), i pacchetti da compilare diventano sempre meno numerosi.

il trucco va bene a volte anche per il python.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum