Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALT-F4 switches to tty4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Mon Sep 05, 2016 6:18 am    Post subject: ALT-F4 switches to tty4 Reply with quote

Hello,

for about 5 days now, whenever I press alt-f4 (to close a window) or alt-f2 (to open KDE's krunner), the X-Server
switches back to the particular tty, as if I had pressed ctrl-alt-f2/f4.
Does anyone know what caused this? There was never before a need to add "DontVTSwitch" to ServerFlags section in xorg.conf.

Thanks!
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Sep 06, 2016 3:46 pm    Post subject: Reply with quote

You may try to verfiy this feature with a clean home directory, e.g. create a new test user.

You may check the config files / configuration of kde and the priority of those config files. There is for sure an order on which config files overwrites the configuration of the other config files...
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Wed Sep 07, 2016 6:11 am    Post subject: Reply with quote

Thanks! I now wonder why didn't I think of this first? :oops:

It looks like it's a KDE setting I haven't yet found. in SDDM login screen it behaves as exepcted,
but in my normal KDE session, it misbehaves. You woudn't have any idea which KDE setting
this might be?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Sep 07, 2016 7:47 am    Post subject: Reply with quote

I have not used kde since kde 3 days.

These days usually config files are stored in

/home/roman/.config/subfolder

roman is my user
subfolder is generic for any folder created by any application like chrome, naev and so on...

In the old days something like (i suppose ...)

/home/roman/.kde

--

e.g. k3b-9999 creates this config file

Code:
ls -alh /home/roman/.config/k3brc
-rw------- 1 roman roman 3,4K Sep  7 09:48 /home/roman/.config/k3brc
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Tue Sep 27, 2016 5:46 pm    Post subject: Reply with quote

Finally figured it out: it's sddm-0.14.
To fix this, I need to prevent it access to ~/.local/share/sddm/ directory (i.e. do chmod 0400 on it).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum