Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Make fcitx work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
YTW
n00b
n00b


Joined: 30 Aug 2016
Posts: 65
Location: Taiwan

PostPosted: Sun Sep 04, 2016 9:33 am    Post subject: [SOLVED] Make fcitx work Reply with quote

Because ffcitx can't be use in kde app, I guess problem is either
I set USE=-gtk when emerging kde plasma app or
I did't set environment variable correctly for fcitx.

I am gonna emerge all kde plasma apps with USE=-gtk and config fcitx again.
But there is no .xprofile in home dir.
How should I solve these two things:
1) Is there anyone also installing kde plasma 5 having ~/.xinitrc? If yes, what happened to mine?
2) If no, where can I write down this setting:
Code:
export XMODIFIERS="@im=fcitx"
export QT_IM_MODULE=fcitx
export GTK_IM_MODULE=fcitx


Last edited by YTW on Thu Oct 20, 2016 6:41 am; edited 3 times in total
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Mon Sep 05, 2016 1:07 pm    Post subject: Reply with quote

You have to create the file
Back to top
View user's profile Send private message
YTW
n00b
n00b


Joined: 30 Aug 2016
Posts: 65
Location: Taiwan

PostPosted: Mon Sep 05, 2016 1:32 pm    Post subject: Reply with quote

Yes. Both .xprofile and .xinitrc are ok. (I guess maybe whatever file name prepose with "." is OK.)

The rest of problem is fcitx can not be used in KDE app(e.g. Kate / Kwrite even Libreoffice), but only for Chromium and Firefox is quit good.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Mon Sep 05, 2016 1:53 pm    Post subject: Reply with quote

Quote:
Because ffcitx can't be use in kde app

I don't know fctix, but where do you see that?
Why do you set USE=-gtk ?

You can look here
Back to top
View user's profile Send private message
YTW
n00b
n00b


Joined: 30 Aug 2016
Posts: 65
Location: Taiwan

PostPosted: Mon Sep 05, 2016 4:09 pm    Post subject: Reply with quote

sebB wrote:
Why do you set USE=-gtk ?

At the beginning, I traced those steps that different from Gentoo Wiki. The only thing different is adding USE="-gtk -gnome".
(I guess fcitx probably have to do some thing with gtk app, but I am wrong.)

Now it finally works for both Konsole and Kate (and other some KDE apps).

For configuring hotkeys for language switch in kde, app-i18n/kcm-fcitx is necessary.

After source .xprofile (do this source if configuration setting is not work),
if the further hotkeys overwritten issue occurs, just check
/${HOME}/.config/khotkeysrc & kglobalshortcutsrc

Anyway, thx!
Back to top
View user's profile Send private message
YTW
n00b
n00b


Joined: 30 Aug 2016
Posts: 65
Location: Taiwan

PostPosted: Thu Oct 20, 2016 6:50 am    Post subject: Reply with quote

An interesting found that for app-i18n/fcitx only with local use='gtk3' will enable KDE 5 apps work to use it but disable google-chrome.

And combine both local use='gtk3 gtk2' can enable both in KDE 5 app and google-chrome.

This might help people who are troubled with fcitx either KDE app or browser.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum