Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nautilus 3.18 - Not displaying mounted USB on the left panel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
malcomy
n00b
n00b


Joined: 15 Oct 2013
Posts: 4

PostPosted: Fri Sep 02, 2016 4:30 pm    Post subject: Nautilus 3.18 - Not displaying mounted USB on the left panel Reply with quote

Hello,

I have recently installed Gentoo on a new Lenovo T440; I've chosen to go with the profile:
Code:
default/linux/amd64/13.0/desktop/gnome

Nautilus is not able to display the list of mounted USB device on the left panel. I have a Other places option, which shows me the mounted devices, but I would like to have the mounted devices directly on the panel.
Is this possible? Am I missing something?
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Fri Sep 02, 2016 5:11 pm    Post subject: Reply with quote

Can you post your fstab?

It seems to me that nautilus only show partition mounted in /media
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Fri Sep 02, 2016 6:06 pm    Post subject: Reply with quote

It's possible that gvfs is compiled with <gtk+-3.18.5. Try to recompile gvfs
Code:
# emerge -1 gvfs

For more info read here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
malcomy
n00b
n00b


Joined: 15 Oct 2013
Posts: 4

PostPosted: Sat Sep 03, 2016 1:34 am    Post subject: Reply with quote

@fedeliallalinea, I have tried to re-emerge gvfs, as you suggested, and it did not solve the problem.

@sebB, I wasn't aware that Nautilus was only capable of showings drives that are mounted on /media.
Here is my /etc/fstab

Code:
# cat /etc/fstab
/dev/sdb3      /      ext4      defaults,noatime      0   1


I'm booting off an external usb drive.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Sat Sep 03, 2016 10:06 am    Post subject: Reply with quote

Can you tell us where are mounted the USB devices when you plug them.
Back to top
View user's profile Send private message
malcomy
n00b
n00b


Joined: 15 Oct 2013
Posts: 4

PostPosted: Sat Sep 03, 2016 12:20 pm    Post subject: Reply with quote

They are getting mounted on:

Code:
/run/media/username
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Mon Sep 05, 2016 1:28 pm    Post subject: Reply with quote

No more ideas... I don't have this problem on my computer.

Can you post eix gtk.

What appen if you create an entry for your usb device in your fstab? Them mount it.
Code:
/dev/sdxx      /media/test      xxxx      defaults,noatime      0   1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum