Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TrueType Fonts
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jaba
n00b
n00b


Joined: 14 Apr 2002
Posts: 7
Location: Norway

PostPosted: Sun Apr 14, 2002 1:19 pm    Post subject: TrueType Fonts Reply with quote

Fonts in X looks awfull!
I want to use TrueType Fonts, but i'm not sure how to. First i have to get them available, then i've got to make X use them.
Can you guys give me some help with this?
Back to top
View user's profile Send private message
gschneider
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2002
Posts: 81
Location: Darmstadt, Germany

PostPosted: Sun Apr 14, 2002 1:44 pm    Post subject: Reply with quote

add the paths to the TTFs to /etc/X11/fs/config
run /etc/init.d/xfs start
remove all font-paths in /etc/X11/XF86Config and add FontPath "unix/:7100"
Restart X
now your X-Server should use the X Font Server and all Fonts should be available.
You should see an increased look of the unix fonts too, because the font server uses antialiasing for all fonts.

Regards,
Gerald
_________________
/(bb|[^b]{2})/
Back to top
View user's profile Send private message
niyogi
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 199
Location: Austin, TX

PostPosted: Sun Apr 14, 2002 2:36 pm    Post subject: Reply with quote

gschneider wrote:
add the paths to the TTFs to /etc/X11/fs/config
run /etc/init.d/xfs start
remove all font-paths in /etc/X11/XF86Config and add FontPath "unix/:7100"
Restart X
now your X-Server should use the X Font Server and all Fonts should be available.
You should see an increased look of the unix fonts too, because the font server uses antialiasing for all fonts.

Regards,
Gerald


does this work for Xfree86 3.x or is it just for 4.X?

I got away with adding the FontPath to the ttf files in the XF86Config file in /etc/X11. The fonts you need are already provided with the installation in /usr/share/fonts/truetype I believe


-S
Back to top
View user's profile Send private message
gschneider
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2002
Posts: 81
Location: Darmstadt, Germany

PostPosted: Sun Apr 14, 2002 3:30 pm    Post subject: Reply with quote

dont't know if it works with 3.x, never tried it.
i prefer the XFS mainly for his ability to render teh fonts with antialising.

i have multiple directories with ttfs, I found them with "locate .ttf" and "locate .TTF"

Regards,
Gerald
_________________
/(bb|[^b]{2})/
Back to top
View user's profile Send private message
PaperCrane
n00b
n00b


Joined: 11 Apr 2002
Posts: 25
Location: Nova Scotia

PostPosted: Mon Apr 15, 2002 6:16 pm    Post subject: Reply with quote

Code:

emerge ttmkfdir
cd /usr/bin/X11R6/lib/X11/fonts/truetype
ttmkfdir > fonts.scale
mkfontdir


be sure to add a FontPath entry to you XF86Config file and you'll have to have the Freetype module loaded in there also
Back to top
View user's profile Send private message
mvo
n00b
n00b


Joined: 16 Apr 2002
Posts: 49
Location: Frankfurt/Germany

PostPosted: Tue Apr 16, 2002 5:16 pm    Post subject: Reply with quote

Hi all!
/etc/init.d/xfs start the font server with option "-port -1" as default. So it doesn't listen to port 7100. No problem to edit this but why this default settings?
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Apr 16, 2002 8:48 pm    Post subject: Reply with quote

niyogi wrote:
gschneider wrote:
add the paths to the TTFs to /etc/X11/fs/config
run /etc/init.d/xfs start
remove all font-paths in /etc/X11/XF86Config and add FontPath "unix/:7100"
Restart X
now your X-Server should use the X Font Server and all Fonts should be available.
You should see an increased look of the unix fonts too, because the font server uses antialiasing for all fonts.

Regards,
Gerald


does this work for Xfree86 3.x or is it just for 4.X?

I got away with adding the FontPath to the ttf files in the XF86Config file in /etc/X11. The fonts you need are already provided with the installation in /usr/share/fonts/truetype I believe


-S

somehow I can get this to work, I did change the "unix/:7100" to "unix/:1" as this was the default but X spits out this message saying it couln't init the fontpath. any suggestions ?
Back to top
mvo
n00b
n00b


Joined: 16 Apr 2002
Posts: 49
Location: Frankfurt/Germany

PostPosted: Tue Apr 16, 2002 9:55 pm    Post subject: Reply with quote

Yes,
change all "-port -1" to "-port 7100" in "/etc/init.d/xfs" and set the path to "unix:/7100" in XF86Config.
Back to top
View user's profile Send private message
chrono
n00b
n00b


Joined: 09 Apr 2002
Posts: 5

PostPosted: Wed Apr 17, 2002 3:52 am    Post subject: Reply with quote

I get an error when i try to start xfs if anyone can help:

Code:

(20:49:32 </home/dan>) 0 $ /etc/init.d/xfs start
 * Starting X Font Server...
/sbin/runscript.sh: -droppriv: command not found                   [ !! ]

(20:49:36 </home/dan>) 0 $



Thanks...
Back to top
View user's profile Send private message
nempo
Guru
Guru


Joined: 16 Apr 2002
Posts: 360
Location: Linkoping, Sweden

PostPosted: Wed Apr 17, 2002 4:27 am    Post subject: Reply with quote

that guest up there thats me, and that "can" after "somehow I", that should be "can't", sorry for the mess-up.
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Fri Apr 19, 2002 5:42 am    Post subject: Reply with quote

Just for the sake of curiosity: Does that 7100 have a special meaning or is it just a random magic number? :)
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Fri Apr 19, 2002 6:05 am    Post subject: Reply with quote

fghellar wrote:
Just for the sake of curiosity: Does that 7100 have a special meaning or is it just a random magic number? :)


From a full /etc/services:
Code:
font-service    7100/tcp   #X Font Service
font-service    7100/udp   #X Font Service
Back to top
View user's profile Send private message
tsuru
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2002
Posts: 99
Location: Nashville, Tennessee, USA

PostPosted: Sat Apr 20, 2002 6:18 pm    Post subject: Reply with quote

quote="gschneider"]add the paths to the TTFs to /etc/X11/fs/config
run /etc/init.d/xfs start
remove all font-paths in /etc/X11/XF86Config and add FontPath "unix/:7100"
Restart X
now your X-Server should use the X Font Server and all Fonts should be available.
You should see an increased look of the unix fonts too, because the font server uses antialiasing for all fonts.

Regards,
Gerald[/quote]


I have tried following all the suggestions made here..but I still can't get my X server to start. :( I know that xfs is started and is on port 7100. The exit message I get is something like "can find fixed font" The fontpaths in /etc/X11/fs/config are all the same as the fontpaths in my previous XF86Config. Anyone else hit this prob? Any pointers would be greatly appreciated

Furthermore, when I tried searching the web to solve my problem... I seemed to get the impression that since XFree86 4 there was no need for xfs to display anti-aliased fonts... am I wrong or am I getting confused between anti-aliased and truetype??..

thanks,
tsuru
Back to top
View user's profile Send private message
DNH
n00b
n00b


Joined: 16 Apr 2002
Posts: 60
Location: Ann Arbor, MI

PostPosted: Sat Apr 20, 2002 11:00 pm    Post subject: Reply with quote

here are the changes I made to get it to work:
1. Remove all of the FontPath enrties from /etc/X11/XF86Config
2. Where those were located, put "FontPath "unix:7100"
3. change "-port -1" to "-port 7100" on lines 14 and 18 of /etc/init.d/xfs
4. exit your X session to a command line.
5. type "/etc/init.d/xfs start"
6. startx

you should have it working now. I was ignoring the hyphen in front of the port numbers in /etc/init.d/xfs and kept getting the same error. hope that helps!
_________________
The answer
Back to top
View user's profile Send private message
AnonNomis
n00b
n00b


Joined: 18 Apr 2002
Posts: 28

PostPosted: Sun Apr 21, 2002 4:04 am    Post subject: Reply with quote

I keep getting this error when trying to start x.

Could not init font path unix/:7100

Fatal server error:
Could not open default font 'fixed'

This only happens when I use "/etc/init.d/xfs start" but if i use "xfs -port 7100" everything starts up fine. I have my /etc/init.d/xfs lines 14 and 18 set to "-port 7100" not "-port -1" and not "-port -7100" Any ideas whats going on?
Back to top
View user's profile Send private message
ketanrp
n00b
n00b


Joined: 19 Apr 2002
Posts: 14

PostPosted: Sun Apr 21, 2002 6:33 pm    Post subject: Same Problem Reply with quote

I have the same problem,:

Could not init font path unix/:7100, removing from font path

Fatal server error:
Could not open default font 'fixed'

I can't even get it to start up if I use 'xfs -port 7100' instead of the script.

As far I can tell this means that the font server is not really started, or X cannot communicate with it, but I don't have a clue as to how to fix it. Any ideas?

*Edited typographical error
Back to top
View user's profile Send private message
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Sun Apr 21, 2002 7:28 pm    Post subject: Reply with quote

AnonNomis wrote:
I keep getting this error when trying to start x.

Could not init font path unix/:7100

Fatal server error:
Could not open default font 'fixed'

This only happens when I use "/etc/init.d/xfs start" but if i use "xfs -port 7100" everything starts up fine. I have my /etc/init.d/xfs lines 14 and 18 set to "-port 7100" not "-port -1" and not "-port -7100" Any ideas whats going on?


i have that error as well....any help would be appreciated...
Back to top
View user's profile Send private message
slik
n00b
n00b


Joined: 18 Apr 2002
Posts: 48
Location: Alberta, Canada

PostPosted: Sun Apr 21, 2002 7:49 pm    Post subject: Reply with quote

Ok, this may be an easier way for you all to get TT fonts going (no font server involved).

Add the following to your /etc/X11/XF86Config file
Code:

Section "Files"
             FontPath      "/usr/X11R6/lib/X11/fonts/truetype"
             <snip other FontPaths and RgbPath>
EndSection

Section "Module"
             Load "freetype"
             <snip other modules to Load>
EndSection


That's it, that's all. HTH
Back to top
View user's profile Send private message
Mindflux
n00b
n00b


Joined: 20 Apr 2002
Posts: 5

PostPosted: Sun Apr 21, 2002 8:10 pm    Post subject: w0ot. Reply with quote

AnonNomis wrote:
I keep getting this error when trying to start x.

Could not init font path unix/:7100

Fatal server error:
Could not open default font 'fixed'

This only happens when I use "/etc/init.d/xfs start" but if i use "xfs -port 7100" everything starts up fine. I have my /etc/init.d/xfs lines 14 and 18 set to "-port 7100" not "-port -1" and not "-port -7100" Any ideas whats going on?

it's "-port 7100" not "-port -7100".
Back to top
View user's profile Send private message
ketanrp
n00b
n00b


Joined: 19 Apr 2002
Posts: 14

PostPosted: Sun Apr 21, 2002 8:21 pm    Post subject: Reply with quote

slik wrote:
Ok, this may be an easier way for you all to get TT fonts going (no font server involved).

Add the following to your /etc/X11/XF86Config file
Code:

Section "Files"
             FontPath      "/usr/X11R6/lib/X11/fonts/truetype"
             <snip other FontPaths and RgbPath>
EndSection

Section "Module"
             Load "freetype"
             <snip other modules to Load>
EndSection


That's it, that's all. HTH


Does this do anti-aliasing?
Back to top
View user's profile Send private message
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Sun Apr 21, 2002 8:33 pm    Post subject: i am confused Reply with quote

can anyone give me an explaination for XFS, FreeType, TTF, and XFT? i am confused...
Back to top
View user's profile Send private message
slik
n00b
n00b


Joined: 18 Apr 2002
Posts: 48
Location: Alberta, Canada

PostPosted: Mon Apr 22, 2002 12:10 am    Post subject: Reply with quote

ketanrp wrote:

Does this do anti-aliasing?


You will have to make sure you have the Xft Render Extentions enabled, check with:
Code:
$ /usr/X11R6/bin/xdpyinfo | grep RENDER

if you don't get a RENDER echoed back, you don't have the render extentions enabled for your X setup.

xterm with antialiased fonts:
Code:
xterm -fa 'Andale Mono' -fs 14
where -fa is font face name and -fs is font size.

for KDE2 and QT2 apps to use antialiasing, you need to set the QT_XFT environment variable to true
for bash shells:
Code:
export QT_XFT=true


Last edited by slik on Sun Apr 28, 2002 9:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
AnonNomis
n00b
n00b


Joined: 18 Apr 2002
Posts: 28

PostPosted: Tue Apr 23, 2002 3:37 am    Post subject: my fault Reply with quote

It works now i should have did this earlier, I only followed the directions at the beginning of the post. When i tried this everything started working.

emerge ttmkfdir
cd /usr/bin/X11R6/lib/X11/fonts/truetype
ttmkfdir > fonts.scale
mkfontdir

Thanks for the all the help.
Back to top
View user's profile Send private message
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Tue Apr 23, 2002 4:11 am    Post subject: Reply with quote

[quote="slik"]Ok, this may be an easier way for you all to get TT fonts going (no font server involved).

Add the following to your /etc/X11/XF86Config file
Code:

Section "Files"
             FontPath      "/usr/X11R6/lib/X11/fonts/truetype"
             <snip other FontPaths and RgbPath>
EndSection

Section "Module"
             Load "freetype"
             <snip other modules to Load>
EndSection



whats the difference between the above method and the one where we load up the XFS server?
Back to top
View user's profile Send private message
dArkMaGE
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 152

PostPosted: Tue Apr 23, 2002 5:05 am    Post subject: Reply with quote

dont you also have to add the freetype module?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum