Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4: Still updatable? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pbarill
n00b
n00b


Joined: 08 Jul 2015
Posts: 10

PostPosted: Sat Aug 13, 2016 11:39 pm    Post subject: KDE4: Still updatable? [SOLVED] Reply with quote

When I try to update, I get a "Error: The above package list contains packages which cannot be installed at the same time on the same system."

Machine is x86 on kde4 profile (desktop/kde). I intend to explore kde5/plasma soon but for the time being would prefer to stick with kde4, or whatever it's become.

What's going on here? Suggestions on how to fix that? Never seen such a mess.
Code:

* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-misc/kcm-touchpad-1.1:4/4::gentoo, installed) pulled in by
    kde-misc/kcm-touchpad required by @selected

  (kde-plasma/libksysguard-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/libksysguard-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/libksysguard-5.6.5:5 required by (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/libksysguard-5.6.5:5 required by (kde-plasma/ksysguard-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/spectacle-15.12.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/spectacle-15.12.3 required by (kde-apps/kdegraphics-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/libkipi-15.08.3:4/15.08::gentoo, installed) pulled in by
    kde-apps/libkipi:4 required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, ebuild scheduled for merge)
    kde-apps/libkipi:4 required by (media-plugins/kipi-plugins-4.4.0:4/4::gentoo, installed)
    >=kde-apps/libkipi-4.14.3:4[aqua=] (>=kde-apps/libkipi-4.14.3:4[-aqua]) required by (kde-apps/ksnapshot-15.08.3-r1:4/15.08::gentoo, installed)

  (kde-apps/libkipi-15.12.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkipi-15.12.3:5 required by (kde-apps/gwenview-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/libkipi-15.12.3 required by (kde-apps/kdegraphics-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/libkipi-15.12.3:5 required by (kde-apps/spectacle-15.12.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/ksysguard-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/ksysguard-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/ksysguard-5.6.5:5 required by (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/kdeplasma-addons-4.14.3-r1:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    kde-base/kdeplasma-addons required by @selected

  (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/powerdevil-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/khotkeys-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/kdeplasma-addons-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-desktop-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdepasswd-15.12.3:4/15.12::gentoo, installed) pulled in by
    >=kde-apps/kdepasswd-4.11.22:4[aqua=] (>=kde-apps/kdepasswd-4.11.22:4[-aqua]) required by (kde-base/kdm-4.11.22:4/4.11::gentoo, installed)

  (kde-apps/ksnapshot-15.08.3-r1:4/15.08::gentoo, installed) pulled in by
    kde-apps/ksnapshot required by @selected

  (kde-plasma/kdeplasma-addons-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kdeplasma-addons-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]


Last edited by pbarill on Fri Aug 19, 2016 2:25 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21354
Location: here

PostPosted: Sun Aug 14, 2016 6:14 am    Post subject: Reply with quote

You followed this guide?

Edit: Sorry my mistake I stop to read on "I intend to explore kde5". genstorm post is correct
_________________
Questions are guaranteed in life; Answers aren't.


Last edited by fedeliallalinea on Sun Aug 14, 2016 12:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Sun Aug 14, 2016 7:29 am    Post subject: Reply with quote

If you want to stay with Plasma-4, this guide: https://wiki.gentoo.org/wiki/KDE#Plasma_4
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pbarill
n00b
n00b


Joined: 08 Jul 2015
Posts: 10

PostPosted: Sun Aug 14, 2016 9:11 pm    Post subject: Reply with quote

Thanks, that helps. Until I reach another set of problems.

First, to install kde-base/kdebase-startkde, I had a bunch of conflicts between qtcore-5.5.1-r1 and its friends (installed) and qtcore-5.6.1. I tried masking, merging separately. Not a chance. So I went on with the very crude (for lack of better) unmerge of qtcore-5.5.1-r1 and its related friends in the conflicts. Ok got kde-base/kdebase-startkde merged.

And now this below appears. On another install, I glanced into upgrading to plasma 5, and I reached the exact same conflict between phonon and qtwebkit.

Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/phonon-gstreamer-4.9.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/phonon-gstreamer-4.9.0[qt4?,qt5?] (>=media-libs/phonon-gstreamer-4.9.0[qt4,qt5]) required by (media-libs/phonon-4.9.0:0/0::gentoo, ebuild scheduled for merge)
    media-libs/phonon-gstreamer:0 required by @preserved-rebuild

  (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/plasma-workspace-4.11.22:4/4.11::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/kruler-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/plasma-runtime-15.12.3:4/15.12::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/ksysguard-4.11.22:4/4.11::gentoo, installed)
    dev-qt/qtwebkit:4 required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
    dev-qt/qtwebkit:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/kamera-15.08.3:4/15.08::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/kdelibs-4.14.20-r2:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/kdeplasma-addons-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/legacy-icons-4.11.22:4/4.11::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/libkipi-15.08.3:4/15.08::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/thumbnailers-15.08.3:4/15.08::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/kwalletmanager-15.04.3:4/15.04::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (media-sound/amarok-2.8.0-r3:4/4::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-plasma/kgamma-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/kdebase-kioslaves-15.12.3:4/15.12::gentoo, installed)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Sun Aug 14, 2016 9:34 pm    Post subject: Reply with quote

Yes, you just need to disable gstreamer use flag for qtwebkit:4
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pbarill
n00b
n00b


Joined: 08 Jul 2015
Posts: 10

PostPosted: Mon Aug 15, 2016 10:51 pm    Post subject: Reply with quote

Thanks again! So I managed to finally perform a bunch of updates, until I reached a new set of obstacles which leave me clueless, again.


Problem no.1: kde-apps/kdebase-meta


So I have kde-apps/kdebase-meta-4.14.3-r2 in world. Yes, I saw what the guide said on this:

Quote:
Please note that previously used meta packages kde-apps/kde-meta and kde-apps/kdebase-meta are unfit as they are pulling in new Plasma 5 already.


Ok. Good. So... What do I do with it? Remove it from world? If I do so, depclean will come up with a list featuring just about everything such as kwrite and dolphin, and a big bunch of dependencies. Do I have to add each and everyone of them to world, or is there some other meta package to use?

If I keep it, I get complaints as the meta package requires kde-apps/kde-wallpapers, and something, somewhere doesn't like it.

Code:
#emerge -avuD @world     

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] kde-apps/kde-wallpapers-15.08.3:4/15.08::gentoo  USE="minimal (-aqua)" 0 KiB
[blocks B      ] <kde-apps/kde-wallpapers-15.08.3-r2 ("<kde-apps/kde-wallpapers-15.08.3-r2" is blocking kde-plasma/plasma-workspace-wallpapers-5.6.5)

Total: 1 package (1 new), Size of downloads: 0 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-wallpapers-15.08.3:4/15.08::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-wallpapers-15.08.3:4[-aqua] required by (kde-apps/kdebase-meta-4.14.3-r2:4/4::gentoo, installed)

  (kde-plasma/plasma-workspace-wallpapers-5.6.5:5/5::gentoo, installed) pulled in by
    kde-plasma/plasma-workspace-wallpapers:5 required by (kde-base/kdebase-startkde-4.11.22-r2:4/4.11::gentoo, installed)



Problem no.2: libkipi

Before I could proceed to updates, I had complaints about gwenview-4.x and digikam-4.x. Since I suppose they will eventually get updated to 15.x, I removed them and could carry on with updates. Now I can't install gwenview.

kde-base/legacy-icons blocking libkipi-15.12? I did not know that a mere package of icons could have such powers.

Code:
#emerge -av gwenview

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-qt/qtimageformats-5.6.1:5/5.6::gentoo  USE="-debug {-test}" 1,865 KiB
[ebuild  N     ] kde-frameworks/kimageformats-5.23.0:5/5.23::gentoo  USE="-debug -eps -openexr {-test}" 200 KiB
[ebuild  NS    ] kde-apps/libkipi-15.12.3:5::gentoo [15.08.3-r1:4/15.08::gentoo] USE="-debug" 97 KiB
[ebuild  N     ] kde-apps/gwenview-15.12.3:5::gentoo  USE="X handbook kipi -debug -raw -semantic-desktop {-test}" 2,785 KiB
[blocks B      ] kde-apps/libkipi:5 ("kde-apps/libkipi:5" is blocking kde-base/legacy-icons-4.11.22-r1)

Total: 4 packages (3 new, 1 in new slot), Size of downloads: 4,945 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/libkipi-15.12.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkipi-15.12.3:5 required by (kde-apps/gwenview-15.12.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/legacy-icons-4.11.22-r1:4/4.11::gentoo, installed) pulled in by
    >=kde-base/legacy-icons-4.11.22:4[aqua=] (>=kde-base/legacy-icons-4.11.22:4[-aqua]) required by (kde-base/systemsettings-4.11.22-r2:4/4.11::gentoo, installed)
    >=kde-base/legacy-icons-4.11.22-r1 required by (kde-apps/kwalletmanager-15.04.3-r1:4/15.04::gentoo, installed)
    >=kde-base/legacy-icons-4.11.22-r1 required by (kde-apps/libkipi-15.08.3-r1:4/15.08::gentoo, installed)

Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Tue Aug 16, 2016 4:40 am    Post subject: Reply with quote

1. Same guide, Applications section.

2. Just look at the other kde4 thread. Basically, it's legacy-icons or upgrade to all the slot 5 versions of packages that are listed here as conflicting. You can keep digikam.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pbarill
n00b
n00b


Joined: 08 Jul 2015
Posts: 10

PostPosted: Tue Aug 16, 2016 8:11 pm    Post subject: Reply with quote

I'm sorry but, what does that mean? Are you saying I can do something about it or not? It appears that legacy-icons is not something optional, because required by kde-base/systemsettings. Those two don't have a slot 5.

Yes, I looked at "the other tread" (if it's that thread), and the magic invoked there (if it's that message) did not work here.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Tue Aug 16, 2016 8:27 pm    Post subject: Reply with quote

Its whole point is being optional; just `emerge --oneshot kde-apps/kwalletmanager:5 kde-apps/libkipi:5` and you will be fine.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pbarill
n00b
n00b


Joined: 08 Jul 2015
Posts: 10

PostPosted: Fri Aug 19, 2016 2:23 am    Post subject: Reply with quote

Ok, now I get it. It was not clear to me that there was choice offered in here. I did that, and it did remove the legacy icon thing. Finally, I can go on with my life. Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum