Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Multilib issue installing xorg-drivers: econf failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
handle2001
n00b
n00b


Joined: 12 Aug 2016
Posts: 10

PostPosted: Fri Aug 12, 2016 11:09 pm    Post subject: [Solved]Multilib issue installing xorg-drivers: econf failed Reply with quote

Hello all!

I am having an issue trying to install Xorg based on this tutorial: https://wiki.gentoo.org/wiki/Xorg/Guide

I have installed the base system with systemd, and everything works fine as far as that goes. I have made the changes to make.conf to list input devices and video cards. The first attempt at running emerge --ask --verbose x11-base/xorg-drivers resulted in a message telling me /etc/portage/package.use needed to be updated with the abi_x86_32 USE flag. So I dutifully merged these changes and ran the emerge command again, only to receive the following error when emerging xproto:

Code:

checking whether we are cross compiling... configure: error: in `/var/tmp/portage/x11-proto/xproto-7.0.28/work/xproto-7.0.28-abi_x86_32.x86':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-proto/xproto-7.0.28/work/xproto-7.0.28-abi_x86_32.x86/config.log
 * ERROR: x11-proto/xproto-7.0.28::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  133:  Called src_configure
 *             environment, line 3679:  Called xorg-2_src_configure
 *             environment, line 4515:  Called autotools-multilib_src_configure
 *             environment, line  708:  Called multilib-minimal_src_configure
 *             environment, line 2866:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *             environment, line 3080:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2796:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2794:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *             environment, line  587:  Called multilib-minimal_abi_src_configure
 *             environment, line 2860:  Called multilib_src_configure
 *             environment, line 3297:  Called autotools-utils_src_configure
 *             environment, line  749:  Called econf '--docdir=/usr/share/doc/xproto-7.0.28' '--disable-specs' '--without-xmlto' '--without-fop'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *


I did some googling and found similar errors were related to the abi_x86_32 flag, so I tried to emerge xproto with the following command:

Code:
USE="-abi_x86_32" emerge --ask x11-proto/xproto


And whadya know, it emerges just fine! So, can I just edit package.use to get rid of that use flag, or is there a good reason for it to be there and I need to track this error down?

Here's the emerge --info in case it helps, but bear in mind this is referring to the xproto I emerged without abi_x86_32 enabled:

Code:
Portage 2.2.28 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-2.2
KiB Mem:     8175956 total,   7431736 free
KiB Swap:   15624188 total,  15624188 free
Timestamp of repository gentoo: Thu, 11 Aug 2016 00:45:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gnutls gpm gstreamer gtk iconv introspection jpeg lcms ldap libnotify libsecret mad mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp openssl pam pango pcre pdf png policykit ppds pulseaudio qt3support readline sdl seccomp session spell sse sse2 ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

x11-proto/xproto-7.0.28::gentoo was built with the following:
USE="-doc" ABI_X86="64 -32 -x32"


Last edited by handle2001 on Sun Aug 14, 2016 6:32 am; edited 1 time in total
Back to top
View user's profile Send private message
handle2001
n00b
n00b


Joined: 12 Aug 2016
Posts: 10

PostPosted: Sat Aug 13, 2016 4:18 am    Post subject: Reply with quote

Here is the relevant section of config.log:

Code:
Target: x86_64-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.9.3/work/gcc-4.9.3/configure --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.9.3 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.9.3 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.9.3/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.9.3/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4 --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.9.3/python --enable-languages=c,c++,fortran --enable-obsolete --enable-secureplt --disable-werror --with-system-zlib --enable-nls --without-included-gettext --enable-checking=release --with-bugurl=https://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.9.3 p1.5, pie-0.6.4' --enable-libstdcxx-time --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-multilib --with-multilib-list=m32,m64 --disable-altivec --disable-fixed-point --enable-targets=all --disable-libgcj --enable-libgomp --disable-libmudflap --disable-libssp --disable-libcilkrts --enable-vtable-verify --enable-libvtv --enable-lto --without-cloog --enable-libsanitizer
Thread model: posix
gcc version 4.9.3 (Gentoo 4.9.3 p1.5, pie-0.6.4)
configure:3352: $? = 0
configure:3341: x86_64-pc-linux-gnu-gcc -m32 -V >&5
x86_64-pc-linux-gnu-gcc: error: unrecognized command line option '-V'
x86_64-pc-linux-gnu-gcc: fatal error: no input files
compilation terminated.
configure:3352: $? = 1
configure:3341: x86_64-pc-linux-gnu-gcc -m32 -qversion >&5
x86_64-pc-linux-gnu-gcc: error: unrecognized command line option '-qversion'
x86_64-pc-linux-gnu-gcc: fatal error: no input files
compilation terminated.
configure:3352: $? = 1
configure:3372: checking whether the C compiler works
configure:3394: x86_64-pc-linux-gnu-gcc -m32 -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed conftest.c  >&5
configure:3398: $? = 0
configure:3446: result: yes
configure:3449: checking for C compiler default output file name
configure:3451: result: a.out
configure:3457: checking for suffix of executables
configure:3464: x86_64-pc-linux-gnu-gcc -m32 -o conftest -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed conftest.c  >&5
configure:3468: $? = 0
configure:3490: result:
configure:3512: checking whether we are cross compiling
configure:3520: x86_64-pc-linux-gnu-gcc -m32 -o conftest -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed conftest.c  >&5
configure:3524: $? = 0
configure:3531: ./conftest
/var/tmp/portage/x11-proto/xproto-7.0.28/work/xproto-7.0.28/configure: line 3533: ./conftest: No such file or directory
configure:3535: $? = 127
configure:3542: error: in `/var/tmp/portage/x11-proto/xproto-7.0.28/work/xproto-7.0.28-abi_x86_32.x86':
configure:3544: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details


I have checked to make sure that 32-bit emulation is enabled in the kernel.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13498

PostPosted: Sat Aug 13, 2016 5:02 pm    Post subject: Reply with quote

Generally, if post length permits, you should edit extra information into your first post instead of replying to it. Some users run a canned search for threads with zero replies as a way of finding posts to answer. When you replied to yourself, you removed your thread from that list, even though you were not replying to announce that the thread was solved. Thus, they would no longer see your thread on the list of unanswered threads.

That error looks to me like you do not have a multilib enabled glibc, which is odd since your profile is multilib. Please post the error message that caused you to try to add abi_x86_32 and the output of emerge --pretend --verbose sys-libs/glibc.
Back to top
View user's profile Send private message
handle2001
n00b
n00b


Joined: 12 Aug 2016
Posts: 10

PostPosted: Sun Aug 14, 2016 6:31 am    Post subject: Reply with quote

I ended up working around this issue by changing the VIDEO_CARDS entry in /etc/portage/make.conf from "nvidia" to "nouveau". This stopped trying to force the abi_x86_32 flag and allowed me to emerge all the packages necessary for Xorg. I am posting this reply from a fully functional Gnome 3 install.

The issue appears to have been caused by my attempt to use the proprietary Nvidia drivers while installing Xorg. I'm not sure why this is so. Once I have the system running to my satisfaction I plan to try and install the proprietary drivers again. In the meantime I'll mark this thread as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum