Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 5 and sound
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
A.S. Pushkin
Apprentice
Apprentice


Joined: 09 Nov 2002
Posts: 298
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Fri Aug 12, 2016 1:47 am    Post subject: KDE 5 and sound Reply with quote

It seems that every time I turn around sound in KDE dies. I re-emerge a number of packages, but this is becoming tiresome.

Does anyone else have this experience? If so have you managed to fix it?

Thanks
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Aug 12, 2016 5:58 am    Post subject: Reply with quote

Can you give *a bit* more precise description?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
A.S. Pushkin
Apprentice
Apprentice


Joined: 09 Nov 2002
Posts: 298
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Sat Aug 13, 2016 6:56 pm    Post subject: KDE 5 and sound - Correction Reply with quote

Thanks genstorm!


I'm currently running stable KDE 4.1x with Plasma 5.x

I may be wrong, but it seems that an update forced the Plasma install.

I'm perplexed on the sound issue, but I just stumbled upon something I had not noted previously.
If I suspend to ram when I reopen the system sound is dead. If I reboot the sound works, i.e. if
I go into system settings -> multimedia -> audio video -> device preference and click on pulseaudio sound server
I then have sound. Similarly, if I choose Audio Hardware Setup and per my setting if I select
Front Left or Front Right I do have a response. Doing the same thing without reboot
there is no sound.

Not enough experiments, but I wonder if the suspend to ram breaks something?

I'll have to check, but my Dell k620 is running CentOS 7 and suspends and restores without breaking sound.

I have Gentoo running on an i7-4770k with Samsung 840PRO and max memory. It took me a long time to
put the hardware together, but my old AMD Athlon was just too slow to keep up with Gentoo building.

I'm wondering now if I should just uninstall Plasma.

Thanks
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
A.S. Pushkin
Apprentice
Apprentice


Joined: 09 Nov 2002
Posts: 298
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Wed Aug 24, 2016 1:45 pm    Post subject: KDE 5 and sound [Solved - Sort of] Reply with quote

Well, I'm not the actual correction, but the problem seems to be connected to suspending to RAM.

I like that I can suspend to RAM as even with an SSD/HDD combination it's even quicker to restart, but when I do this
it kills my sound. If I reboot audio is working again. At least I now have no reason to re-emerge the apps I was doing that for.


If any developers have any idea how to correct this I would appreciate hearing from them. Perhaps I'm the only user
experiencing this problem?
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 526

PostPosted: Wed Aug 24, 2016 4:38 pm    Post subject: Reply with quote

do you have
Code:
CONFIG_SND_PCM_TIMER=y
set in your kernel?

I may be wrong but I think that's a fairly recent change. I had no sound in html5 video and one or two other problems until I enabled that after changing from 3.foo to 4.bar kernels.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum