Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] KDE blockers on plasma update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 8:33 am    Post subject: [solved] KDE blockers on plasma update Reply with quote

Hi,

i tried to update my system as explained here: https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade

So i changed the profile, checked the use flags and --deselected everything blocking.

However, when applying the the new profile i got several blocker:

Code:

localhost ~ # emerge --ask --changed-use --newrepo --deep --pretend world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] media-fonts/noto-20160305-r1  USE="X -cjk"
[ebuild   R    ] sys-firmware/ipxe-1.0.0_p20130925  USE="ipv6%* -efi% -savedconfig%"
[ebuild  N     ] virtual/perl-parent-0.228-r1
[ebuild  N     ] dev-perl/URI-1.710.0  USE="{-test}"
[ebuild  N     ] net-misc/dhcp-4.3.3_p1  USE="client ipv6 ldap server ssl (-libressl) (-selinux) -vim-syntax"
[ebuild  N     ] net-libs/libqmi-1.12.6  USE="-doc -static-libs"
[ebuild   R    ] media-sound/lame-3.99.5-r1  USE="frontend%*"
[ebuild  N     ] net-misc/socat-1.7.3.1  USE="ipv6 readline ssl tcpd"
[ebuild  N     ] dev-qt/qtpaths-5.6.1  USE="-debug {-test}"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild   R    ] sys-devel/gcc-4.9.3  USE="vtv%*"
[ebuild   R    ] app-text/hunspell-1.3.3  L10N="-af% -bg% -ca% -cs% -cy% -da% -de% -de-1901% -el% -en% -eo% -es% -et% -fo% -fr% -ga% -gl% -he% -hr% -hu% -ia% -id% -is% -it% -km% -ku% -lt% -lv% -mk% -ms% -nb% -nl% -nn% -pl% -pt% -pt-BR% -ro% -ru% -sk% -sl% -sq% -sv% -sw% -tn% -uk% -zu%" LINGUAS="(-en%*)"
[ebuild  N     ] dev-python/pygments-2.1.1  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] net-libs/libndp-1.6  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-plasma/kwallet-pam-5.6.5-r1  USE="oldwallet -debug"
[ebuild  N     ] kde-frameworks/breeze-icons-5.23.0  USE="{-test}"
[ebuild  N     ] dev-python/docutils-0.12  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-libs/libgit2-0.23.4  USE="threads -examples -gssapi (-libressl) -ssh {-test} -trace"
[ebuild  N     ] dev-libs/libinput-1.3.0  USE="{-test}" INPUT_DEVICES="-wacom"
[ebuild  N     ] dev-qt/qdbus-5.6.1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kf-env-3
[ebuild  NS    ] dev-qt/qtscript-5.6.1 [4.8.6-r2] USE="jit scripttools -debug {-test}"
[ebuild  N     ] dev-qt/linguist-tools-5.6.1  USE="qml -debug {-test}"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.6.1  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.6.1  USE="widgets -debug {-test}"
[ebuild   R    ] app-text/ghostscript-gpl-9.15-r1  USE="tiff%*" L10N="-de% -ja% -ko% -zh-CN% -zh-TW%"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius"
[ebuild   R    ] app-emulation/qemu-2.5.1  USE="bzip2%*"
[ebuild  N     ] media-gfx/fontforge-20150612-r1  USE="X cairo gif gtk jpeg png python readline svg tiff unicode -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N     ] net-dialup/rp-pppoe-3.11-r3  USE="-tk"
[ebuild  N     ] x11-misc/sddm-0.13.0-r3  USE="consolekit pam -systemd"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] net-misc/modemmanager-1.4.12  USE="introspection (policykit) qmi -mbim -qmi-newest -vala"
[ebuild   R    ] kde-base/kfilemetadata-4.14.3  USE="ffmpeg*"
[ebuild     U  ] kde-apps/phonon-kde-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kioclient-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/knewstuff-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/renamedlg-plugins-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kquitapp-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebugdialog-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kiconfinder-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kimgio-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/ktimezoned-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdontchangethehostname-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kwalletd-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-desktoptheme-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-data-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-menu-icons-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/solid-runtime-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kreadconfig-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kfile-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kpasswdserver-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kstart-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kmimetypefinder-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/keditfiletype-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kurifilter-plugins-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kcmshell-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdesu-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/knotify-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-menu-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/ktraderclient-15.12.3 [15.08.3]
[ebuild  N     ] net-misc/networkmanager-1.0.12-r1  USE="consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -bluetooth -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-plasma/plasma-workspace-wallpapers-5.6.5
[uninstall     ] kde-apps/kde-wallpapers-15.08.3
[blocks b      ] <kde-apps/kde-wallpapers-15.08.3-r2 ("<kde-apps/kde-wallpapers-15.08.3-r2" is blocking kde-plasma/plasma-workspace-wallpapers-5.6.5)
[ebuild  N     ] kde-frameworks/kcoreaddons-5.23.0  USE="nls -debug (-fam) {-test}"
[ebuild  N     ] kde-frameworks/ki18n-5.23.0  USE="-debug {-test}" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kwindowsystem-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kdbusaddons-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kcrash-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kconfig-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/karchive-5.23.0-r1  USE="bzip2 lzma -debug {-test}"
[ebuild  N     ] kde-frameworks/kitemviews-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kcodecs-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kguiaddons-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdoctools-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kservice-5.23.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kcompletion-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/knotifications-5.23.0  USE="X dbus nls -debug (-speech)"
[ebuild  N     ] kde-frameworks/kglobalaccel-5.23.0-r1  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kjobwidgets-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/solid-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kpackage-5.23.0  USE="-debug -man {-test}"
[ebuild  N     ] kde-frameworks/kwayland-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/sonnet-5.23.0  USE="hunspell nls -aspell -debug {-test}"
[ebuild  N     ] kde-frameworks/kidletime-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kpty-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kdecoration-5.6.5  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kitemmodels-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kjs-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kfilemetadata-5.23.0  USE="exif ffmpeg pdf -debug -epub -libav -taglib {-test}"
[ebuild  N     ] kde-plasma/libkscreen-5.6.5  USE="X -debug {-test}"
[ebuild  N     ] kde-frameworks/kunitconversion-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kemoticons-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdesu-5.23.0  USE="X -debug"
[ebuild  N     ] kde-frameworks/attica-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/threadweaver-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdesignerplugin-5.23.0  USE="nls -debug -designer -webkit"
[ebuild  N     ] kde-frameworks/kdnssd-5.23.0  USE="nls -debug {-test} -zeroconf"
[ebuild  N     ] kde-plasma/kwrited-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/kwayland-integration-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/breeze-gtk-5.6.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kpeople-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.23.0  USE="-debug -teamd {-test}"
[ebuild  N     ] kde-frameworks/kjsembed-5.23.0  USE="-debug"
[ebuild     U  ] kde-apps/kde4-l10n-15.12.3-r1 [15.08.3-r2] USE="minimal*" L10N="-ar% -bg% -bs% -ca% -ca-valencia% -cs% -da% -de% -el% -en-GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -ga% -gl% -he% -hi% -hr% -hu% -ia% -id% -is% -it% -ja% -kk% -km% -ko% -lt% -lv% -mr% -nb% -nds% -nl% -nn% -pa% -pl% -pt% -pt-BR% -ro% -ru% -sk% -sl% -sr% -sv% -tr% -ug% -uk% -wa% -zh-CN% -zh-TW%"
[blocks b      ] kde-apps/kde4-l10n[-minimal(+)] ("kde-apps/kde4-l10n[-minimal(+)]" is blocking kde-frameworks/kidletime-5.23.0, kde-plasma/powerdevil-5.6.5, kde-frameworks/karchive-5.23.0-r1, kde-frameworks/kwindowsystem-5.23.0, kde-plasma/kwin-5.6.5-r1, kde-plasma/milou-5.6.5, kde-frameworks/kfilemetadata-5.23.0, kde-frameworks/networkmanager-qt-5.23.0, kde-plasma/kgamma-5.6.5, kde-plasma/ksshaskpass-5.6.5, kde-frameworks/kxmlgui-5.23.0-r1, kde-plasma/breeze-5.6.5-r1, kde-plasma/breeze-gtk-5.6.5, kde-frameworks/kwayland-5.23.0, kde-plasma/kde-gtk-config-5.6.5, kde-frameworks/kbookmarks-5.23.0, kde-plasma/plasma-desktop-5.6.5, kde-frameworks/kpty-5.23.0, kde-frameworks/kdbusaddons-5.23.0, kde-plasma/kde-cli-tools-5.6.5, kde-frameworks/kcrash-5.23.0, kde-frameworks/kded-5.23.0, kde-frameworks/khtml-5.23.0, kde-frameworks/kauth-5.23.0-r1, kde-frameworks/knotifyconfig-5.23.0, kde-frameworks/kunitconversion-5.23.0, kde-plasma/kscreenlocker-5.6.5, kde-frameworks/kcompletion-5.23.0, kde-plasma/kinfocenter-5.6.5, kde-frameworks/kinit-5.23.0, kde-frameworks/kpackage-5.23.0, kde-frameworks/frameworkintegration-5.23.0, kde-plasma/plasma-workspace-5.6.5.1-r2, kde-frameworks/kross-5.23.0, kde-frameworks/kxmlrpcclient-5.23.0, kde-frameworks/kguiaddons-5.23.0, kde-frameworks/kdoctools-5.23.0, kde-plasma/kdecoration-5.6.5, kde-frameworks/kdelibs4support-5.23.0-r1, kde-frameworks/ktextwidgets-5.23.0, kde-frameworks/kcoreaddons-5.23.0, kde-plasma/kwrited-5.6.5, kde-frameworks/kjsembed-5.23.0, kde-plasma/oxygen-5.6.5, kde-frameworks/kitemviews-5.23.0, kde-plasma/systemsettings-5.6.5, kde-plasma/kactivitymanagerd-5.6.5, kde-plasma/sddm-kcm-5.6.5, kde-frameworks/sonnet-5.23.0, kde-frameworks/kpeople-5.23.0, kde-frameworks/kemoticons-5.23.0, kde-frameworks/solid-5.23.0, kde-frameworks/kconfig-5.23.0, kde-frameworks/threadweaver-5.23.0, kde-frameworks/kdesignerplugin-5.23.0, kde-plasma/kmenuedit-5.6.5, kde-frameworks/ki18n-5.23.0, kde-frameworks/knewstuff-5.23.0, kde-frameworks/kdeclarative-5.23.0, kde-frameworks/kdesu-5.23.0, kde-frameworks/kwallet-5.23.0, kde-frameworks/kjs-5.23.0, kde-frameworks/knotifications-5.23.0, kde-frameworks/kitemmodels-5.23.0, kde-frameworks/kcmutils-5.23.0, kde-plasma/kwayland-integration-5.6.5, kde-frameworks/kiconthemes-5.23.0, kde-frameworks/attica-5.23.0, kde-frameworks/kcodecs-5.23.0, kde-frameworks/kwidgetsaddons-5.23.0, kde-frameworks/kconfigwidgets-5.23.0, kde-plasma/libksysguard-5.6.5, kde-plasma/kdeplasma-addons-5.6.5, kde-frameworks/krunner-5.23.0, kde-frameworks/kparts-5.23.0, kde-frameworks/kio-5.23.0, kde-frameworks/kservice-5.23.0, kde-frameworks/kglobalaccel-5.23.0-r1, kde-plasma/ksysguard-5.6.5, kde-plasma/libkscreen-5.6.5, kde-plasma/khotkeys-5.6.5, kde-frameworks/kactivities-5.23.0, kde-plasma/kscreen-5.6.5-r1, kde-frameworks/plasma-5.23.0, kde-frameworks/kdnssd-5.23.0, kde-plasma/user-manager-5.6.5, kde-frameworks/kjobwidgets-5.23.0, kde-plasma/plasma-integration-5.6.5, kde-frameworks/baloo-5.23.0, kde-frameworks/ktexteditor-5.23.0)
[blocks b      ] <kde-apps/kde4-l10n-15.12.3-r1 ("<kde-apps/kde4-l10n-15.12.3-r1" is blocking kde-frameworks/kidletime-5.23.0, kde-plasma/powerdevil-5.6.5, kde-frameworks/karchive-5.23.0-r1, kde-frameworks/kwindowsystem-5.23.0, kde-plasma/kwin-5.6.5-r1, kde-plasma/milou-5.6.5, kde-frameworks/kfilemetadata-5.23.0, kde-frameworks/networkmanager-qt-5.23.0, kde-plasma/kgamma-5.6.5, kde-plasma/ksshaskpass-5.6.5, kde-frameworks/kxmlgui-5.23.0-r1, kde-plasma/breeze-5.6.5-r1, kde-plasma/breeze-gtk-5.6.5, kde-frameworks/kwayland-5.23.0, kde-plasma/kde-gtk-config-5.6.5, kde-frameworks/kbookmarks-5.23.0, kde-plasma/plasma-desktop-5.6.5, kde-frameworks/kpty-5.23.0, kde-frameworks/kdbusaddons-5.23.0, kde-plasma/kde-cli-tools-5.6.5, kde-frameworks/kcrash-5.23.0, kde-frameworks/kded-5.23.0, kde-frameworks/khtml-5.23.0, kde-frameworks/kauth-5.23.0-r1, kde-frameworks/knotifyconfig-5.23.0, kde-frameworks/kunitconversion-5.23.0, kde-plasma/kscreenlocker-5.6.5, kde-frameworks/kcompletion-5.23.0, kde-plasma/kinfocenter-5.6.5, kde-frameworks/kinit-5.23.0, kde-frameworks/kpackage-5.23.0, kde-frameworks/frameworkintegration-5.23.0, kde-plasma/plasma-workspace-5.6.5.1-r2, kde-frameworks/kross-5.23.0, kde-frameworks/kxmlrpcclient-5.23.0, kde-frameworks/kguiaddons-5.23.0, kde-frameworks/kdoctools-5.23.0, kde-plasma/kdecoration-5.6.5, kde-frameworks/kdelibs4support-5.23.0-r1, kde-frameworks/ktextwidgets-5.23.0, kde-frameworks/kcoreaddons-5.23.0, kde-plasma/kwrited-5.6.5, kde-frameworks/kjsembed-5.23.0, kde-plasma/oxygen-5.6.5, kde-frameworks/kitemviews-5.23.0, kde-plasma/systemsettings-5.6.5, kde-plasma/kactivitymanagerd-5.6.5, kde-plasma/sddm-kcm-5.6.5, kde-frameworks/sonnet-5.23.0, kde-frameworks/kpeople-5.23.0, kde-frameworks/kemoticons-5.23.0, kde-frameworks/solid-5.23.0, kde-frameworks/kconfig-5.23.0, kde-frameworks/threadweaver-5.23.0, kde-frameworks/kdesignerplugin-5.23.0, kde-plasma/kmenuedit-5.6.5, kde-frameworks/ki18n-5.23.0, kde-frameworks/knewstuff-5.23.0, kde-frameworks/kdeclarative-5.23.0, kde-frameworks/kdesu-5.23.0, kde-frameworks/kwallet-5.23.0, kde-frameworks/kjs-5.23.0, kde-frameworks/knotifications-5.23.0, kde-frameworks/kitemmodels-5.23.0, kde-frameworks/kcmutils-5.23.0, kde-plasma/kwayland-integration-5.6.5, kde-frameworks/kiconthemes-5.23.0, kde-frameworks/attica-5.23.0, kde-frameworks/kcodecs-5.23.0, kde-frameworks/kwidgetsaddons-5.23.0, kde-frameworks/kconfigwidgets-5.23.0, kde-plasma/libksysguard-5.6.5, kde-plasma/kdeplasma-addons-5.6.5, kde-frameworks/krunner-5.23.0, kde-frameworks/kparts-5.23.0, kde-frameworks/kio-5.23.0, kde-frameworks/kservice-5.23.0, kde-frameworks/kglobalaccel-5.23.0-r1, kde-plasma/ksysguard-5.6.5, kde-plasma/libkscreen-5.6.5, kde-plasma/khotkeys-5.6.5, kde-frameworks/kactivities-5.23.0, kde-plasma/kscreen-5.6.5-r1, kde-frameworks/plasma-5.23.0, kde-frameworks/kdnssd-5.23.0, kde-plasma/user-manager-5.6.5, kde-frameworks/kjobwidgets-5.23.0, kde-plasma/plasma-integration-5.6.5, kde-frameworks/baloo-5.23.0, kde-frameworks/ktexteditor-5.23.0)
[ebuild  N     ] kde-frameworks/kauth-5.23.0-r1  USE="nls (policykit) -debug {-test}"
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.23.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kiconthemes-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/ktextwidgets-5.23.0  USE="-debug (-speech) {-test}"
[ebuild  N     ] kde-frameworks/kxmlgui-5.23.0-r1  USE="-attica -debug {-test}"
[ebuild  N     ] kde-frameworks/kbookmarks-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kwallet-5.23.0  USE="man -debug -gpg {-test}"
[ebuild  N     ] kde-frameworks/frameworkintegration-5.23.0  USE="X -debug {-test}"
[ebuild  NS    ] kde-plasma/ksshaskpass-5.6.5 [0.5.3-r1] USE="-debug"
[ebuild  N     ] kde-frameworks/kio-5.23.0  USE="X acl handbook kwallet -debug -kerberos {-test}"
[ebuild  N     ] kde-frameworks/kinit-5.23.0  USE="caps man -debug"
[ebuild  N     ] kde-frameworks/kded-5.23.0  USE="man -debug"
[ebuild  N     ] kde-frameworks/kparts-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdelibs4support-5.23.0-r1  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-frameworks/kdeclarative-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kcmutils-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kde-cli-tools-5.6.5  USE="X handbook kdesu -debug {-test}"
[ebuild  N     ] kde-frameworks/knewstuff-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/knotifyconfig-5.23.0  USE="phonon -debug"
[ebuild  N     ] kde-frameworks/ktexteditor-5.23.0  USE="-debug -git {-test}"
[ebuild  N     ] kde-frameworks/khtml-5.23.0  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-apps/kio-extras-15.12.3  USE="exif handbook phonon sftp -debug -mtp -openexr -samba -slp {-test}"
[ebuild  N     ] kde-plasma/oxygen-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/plasma-integration-5.6.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/user-manager-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/kgamma-5.6.5  USE="handbook -debug"
[ebuild  N     ] kde-plasma/sddm-kcm-5.6.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kross-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.6.5  USE="-debug"
[uninstall     ] sys-auth/polkit-kde-agent-0.99.1-r1
[blocks b      ] sys-auth/polkit-kde-agent:4[-minimal(-)] ("sys-auth/polkit-kde-agent:4[-minimal(-)]" is blocking kde-plasma/polkit-kde-agent-5.6.5)
[ebuild     U  ] app-emulation/libvirt-1.3.5-r2 [1.3.5-r1]
[ebuild   R    ] kde-base/baloo-4.14.3  USE="minimal*"
[ebuild  N     ] kde-frameworks/baloo-5.23.0  USE="-debug {-test}"
[ebuild  NS    ] kde-apps/baloo-widgets-15.12.3 [4.14.3] USE="-debug {-test}"
[ebuild  NS    ] kde-apps/dolphin-15.12.3-r1 [4.14.3-r1] USE="handbook semantic-desktop -debug {-test} -thumbnail"
[ebuild  NS    ] kde-apps/ark-15.12.3 [4.14.3-r1] USE="bzip2 handbook zlib -debug -lzma {-test}"
[uninstall     ] kde-apps/ark-4.14.3-r1
[blocks b      ] kde-apps/ark:4 ("kde-apps/ark:4" is blocking kde-apps/ark-15.12.3)
[ebuild  NS    ] kde-apps/konsole-15.12.3 [4.14.3-r2] USE="X handbook -debug {-test}"
[uninstall     ] kde-apps/konsole-4.14.3-r2
[blocks b      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.12.3)
[ebuild  NS    ] kde-apps/khelpcenter-5.6.2-r1 [4.14.3] USE="handbook -debug"
[uninstall     ] kde-apps/khelpcenter-4.14.3
[blocks b      ] kde-apps/khelpcenter:4 ("kde-apps/khelpcenter:4" is blocking kde-apps/khelpcenter-5.6.2-r1)
[ebuild  N     ] kde-plasma/kscreen-5.6.5-r1  USE="-debug {-test}"
[uninstall     ] kde-misc/kscreen-1.0.71_p20150824
[blocks b      ] kde-misc/kscreen ("kde-misc/kscreen" is blocking kde-plasma/kscreen-5.6.5-r1)
[ebuild  N     ] kde-plasma/kscreenlocker-5.6.5  USE="pam -debug {-test}"
[uninstall     ] kde-base/kdebase-pam-9
[blocks b      ] kde-base/kdebase-pam:0 ("kde-base/kdebase-pam:0" is blocking kde-plasma/kscreenlocker-5.6.5)
[ebuild  N     ] kde-plasma/kde-gtk-config-5.6.5  USE="gtk3 -debug {-test}"
[uninstall     ] kde-misc/kde-gtk-config-2.2.1
[blocks b      ] kde-misc/kde-gtk-config ("kde-misc/kde-gtk-config" is blocking kde-plasma/kde-gtk-config-5.6.5)
[ebuild  NS    ] kde-plasma/kactivitymanagerd-5.6.5 [4.13.3-r1] USE="-debug"
[ebuild  N     ] kde-frameworks/kactivities-5.23.0  USE="-debug {-test}"
[uninstall     ] kde-plasma/kactivitymanagerd-4.13.3-r1
[blocks b      ] kde-plasma/kactivitymanagerd:4 ("kde-plasma/kactivitymanagerd:4" is blocking kde-plasma/kactivitymanagerd-5.6.5)
[blocks b      ] kde-frameworks/kactivities ("kde-frameworks/kactivities" is blocking kde-plasma/kactivitymanagerd-4.13.3-r1)
[ebuild  N     ] kde-frameworks/plasma-5.23.0  USE="X -debug -egl -gles2 {-test}"
[ebuild     U  ] kde-apps/plasma-runtime-15.12.3 [15.08.3]
[ebuild  N     ] kde-frameworks/krunner-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/breeze-5.6.5-r1  USE="qt4 -debug"
[ebuild  NS    ] kde-apps/kdebase-runtime-meta-15.12.3 [4.14.3] USE="oldwallet pam"
[ebuild  N     ] kde-plasma/kinfocenter-5.6.5  USE="handbook opengl pci -debug -egl -gles -ieee1394 -nfs -samba -wayland"
[ebuild  N     ] kde-plasma/milou-5.6.5  USE="-debug"
[ebuild  NS    ] kde-apps/kwrite-15.12.3 [4.14.3] USE="handbook -debug"
[uninstall     ] kde-apps/kwrite-4.14.3
[blocks b      ] kde-apps/kwrite:4 ("kde-apps/kwrite:4" is blocking kde-apps/kwrite-15.12.3)
[ebuild  N     ] kde-apps/kdecore-meta-15.12.3  USE="handbook -minimal"
[ebuild  NS    ] kde-apps/kate-15.12.3 [4.14.3] USE="addons handbook -debug {-test}"
[uninstall     ] kde-apps/kate-4.14.3
[blocks b      ] kde-apps/kate:4 ("kde-apps/kate:4" is blocking kde-apps/kate-15.12.3)
[ebuild  N     ] kde-plasma/libksysguard-5.6.5  USE="X detailedmemory -debug {-test}"
[ebuild  N     ] kde-plasma/ksysguard-5.6.5  USE="handbook -debug -lm_sensors"
[uninstall     ] kde-base/ksysguard-4.11.22
[blocks b      ] kde-base/ksysguard:4 ("kde-base/ksysguard:4" is blocking kde-plasma/ksysguard-5.6.5, kde-plasma/libksysguard-5.6.5)
[ebuild  N     ] kde-plasma/kwin-5.6.5-r1  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N     ] kde-plasma/systemsettings-5.6.5  USE="gtk handbook -classic -debug"
[uninstall     ] kde-base/kwin-4.11.22
[blocks b      ] kde-base/kwin:4 ("kde-base/kwin:4" is blocking kde-plasma/kwin-5.6.5-r1)
[ebuild  N     ] kde-plasma/plasma-workspace-5.6.5.1-r2  USE="geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[uninstall     ] kde-base/klipper-4.11.22
[blocks b      ] kde-base/klipper:4 ("kde-base/klipper:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/krunner-4.11.22
[blocks b      ] kde-base/krunner:4 ("kde-base/krunner:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/kcminit-4.11.22
[blocks b      ] kde-base/kcminit:4 ("kde-base/kcminit:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/libtaskmanager-4.11.22
[blocks b      ] kde-base/libtaskmanager:4 ("kde-base/libtaskmanager:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/kdebase-startkde-4.11.22
[blocks b      ] kde-base/kdebase-startkde:4 ("kde-base/kdebase-startkde:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/ksmserver-4.11.22
[blocks b      ] kde-base/ksmserver:4 ("kde-base/ksmserver:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.6.5  USE="-debug -share"
[ebuild  N     ] kde-plasma/khotkeys-5.6.5  USE="handbook -debug"
[uninstall     ] kde-base/khotkeys-4.11.22
[blocks b      ] kde-base/khotkeys:4 ("kde-base/khotkeys:4" is blocking kde-plasma/khotkeys-5.6.5)
[ebuild  N     ] kde-plasma/powerdevil-5.6.5  USE="handbook -debug -systemd"
[uninstall     ] kde-base/powerdevil-4.11.22
[blocks b      ] kde-base/powerdevil:4 ("kde-base/powerdevil:4" is blocking kde-plasma/powerdevil-5.6.5)
[ebuild  N     ] kde-plasma/kmenuedit-5.6.5  USE="handbook hotkeys -debug"
[uninstall     ] kde-base/kmenuedit-4.11.22
[blocks b      ] kde-base/kmenuedit:4 ("kde-base/kmenuedit:4" is blocking kde-plasma/kmenuedit-5.6.5)
[ebuild  N     ] kde-plasma/plasma-desktop-5.6.5  USE="fontconfig handbook qt4 -debug -gtk2 -gtk3 -ibus -legacy-systray (-packagekit) -pulseaudio -scim {-test}" INPUT_DEVICES="evdev -synaptics"
[uninstall     ] kde-base/systemsettings-4.11.22-r1
[blocks b      ] kde-base/systemsettings:4 ("kde-base/systemsettings:4" is blocking kde-plasma/kwin-5.6.5-r1, kde-plasma/plasma-desktop-5.6.5, kde-plasma/khotkeys-5.6.5, kde-plasma/systemsettings-5.6.5)
[blocks b      ] kde-base/systemsettings:4[handbook] ("kde-base/systemsettings:4[handbook]" is blocking kde-plasma/powerdevil-5.6.5)
[uninstall     ] kde-base/plasma-workspace-4.11.22
[blocks b      ] kde-base/plasma-workspace:4 ("kde-base/plasma-workspace:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2, kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/kdepasswd-15.08.3
[blocks b      ] kde-apps/kdepasswd ("kde-apps/kdepasswd" is blocking kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/kcontrol-15.08.3
[blocks b      ] kde-apps/kcontrol ("kde-apps/kcontrol" is blocking kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/knetattach-15.08.3
[blocks b      ] kde-apps/knetattach[handbook] ("kde-apps/knetattach[handbook]" is blocking kde-plasma/plasma-desktop-5.6.5)
[ebuild  N     ] kde-plasma/plasma-meta-5.6.5  USE="display-manager gtk handbook pam sddm wallpapers -bluetooth -grub -mediacenter -networkmanager -plymouth -pulseaudio -sdk"
[ebuild  NS    ] kde-apps/kdebase-meta-15.12.3 [4.14.3-r2]
[blocks B      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.12.3)
[blocks B      ] kde-base/kinfocenter:4 ("kde-base/kinfocenter:4" is blocking kde-plasma/kinfocenter-5.6.5)
[blocks B      ] kde-base/solid-actions-kcm:4 ("kde-base/solid-actions-kcm:4" is blocking kde-plasma/plasma-desktop-5.6.5)
[blocks B      ] kde-base/freespacenotifier:4 ("kde-base/freespacenotifier:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[blocks B      ] kde-base/kwrited:4 ("kde-base/kwrited:4" is blocking kde-plasma/kwrited-5.6.5)
[blocks B      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.12.3-r1)
[blocks B      ] kde-plasma/ksshaskpass:4 ("kde-plasma/ksshaskpass:4" is blocking kde-plasma/ksshaskpass-5.6.5)
[blocks B      ] kde-base/kdebase-cursors:4 ("kde-base/kdebase-cursors:4" is blocking kde-plasma/oxygen-5.6.5)
[blocks B      ] kde-base/ksplash:4 ("kde-base/ksplash:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed) pulled in by
    kde-apps/dolphin required by @selected

  (kde-plasma/kinfocenter-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kinfocenter-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/kdebase-cursors-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kdebase-cursors required by @selected

  (kde-base/kwrited-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kwrited required by @selected

  (kde-base/kinfocenter-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kinfocenter required by @selected

  (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/powerdevil-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/khotkeys-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/kdeplasma-addons-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/ksshaskpass-0.5.3-r1:4/4::gentoo, installed) pulled in by
    kde-plasma/ksshaskpass required by @selected

  (kde-base/ksplash-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/ksplash required by @selected

  (kde-base/solid-actions-kcm-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/solid-actions-kcm required by @selected

  (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-desktop-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/dolphin-15.12.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/dolphin-15.12.3 required by (kde-apps/kdecore-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/dolphin required by @selected

  (kde-base/freespacenotifier-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/freespacenotifier required by @selected

  (kde-plasma/oxygen-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/oxygen-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/oxygen-5.6.5:5 required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/ksshaskpass-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-plasma/ksshaskpass required by @selected
    >=kde-plasma/ksshaskpass-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/kwrited-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kwrited-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- kde-apps/ksnapshot-15.08.3-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Johannes Huber <johu@gentoo.org> (14 Jul 2016)
# No longer released upstream. Use kde-apps/spectacle instead.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


make.conf

Code:

localhost ~ # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist ffmpeg mmx sse sse2 -bluetooth -fam -libav"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

MAKEOPTS="-j5"
LINGUAS="en"

GENTOO_MIRRORS="http://de-mirror.org/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.heanet.ie/pub/gentoo/"

#SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"

VIDEO_CARDS="nouveau"
PHP_TARGETS="php5-6 php7-0"
RUBY_TARGETS="ruby20 ruby21"


Is it save to unmerge those packages and emerge the new ones? I am a little bit afraid ending up in a not usable system.

If you need any more information, let me know.

Regards,
Ullrich

Solution:

Removing blocking entries from world file. See answer: https://forums.gentoo.org/viewtopic-p-7952590.html#7952590


Last edited by Ullrich on Mon Aug 08, 2016 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 9:14 am    Post subject: Reply with quote

You've not deselected enough. Why not run the removal command without --pretend as described in the guide?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 1:10 pm    Post subject: Reply with quote

Thanks genstorm for the tip.

I just rerun the deselect command

Code:

localhost ~ # for x in x11-libs/libkscreen kde-misc/kde-gtk-config net-misc/ksshaskpass freespacenotifier kcheckpass kcminit kdebase-cursors kdebase-startkde kdm kephal khotkeys kinfocenter klipper kmenuedit krunner kscreensaver ksmserver ksplash kstartupconfig kstyles ksysguard ksystraycmd kwin kwrited libkgreeter libkworkspace liboxygenstyle libplasmaclock libplasmagenericshell libtaskmanager plasma-workspace powerdevil qguiplatformplugin_kde solid-actions-kcm systemsettings; do equery -q d ${x} | sed -e "s/-[0-9].*//"; done | sed -e "/kdebase-meta/g" -e "/kde-meta/g" | xargs emerge --deselect
>>> No matching atoms found in "world" favorites file...


and still run into the blocking packages:

Code:

* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-plasma/kinfocenter-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kinfocenter-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/oxygen-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/oxygen-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/oxygen-5.6.5:5 required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-desktop-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/ksshaskpass-0.5.3-r1:4/4::gentoo, installed) pulled in by
    kde-plasma/ksshaskpass required by @selected

  (kde-plasma/kwrited-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kwrited-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-plasma/ksshaskpass-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/ksshaskpass-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    kde-plasma/ksshaskpass required by @selected

  (kde-base/kdebase-cursors-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kdebase-cursors required by @selected

  (kde-base/solid-actions-kcm-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/solid-actions-kcm required by @selected

  (kde-base/freespacenotifier-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/freespacenotifier required by @selected

  (kde-base/ksplash-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/ksplash required by @selected

  (kde-base/kinfocenter-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kinfocenter required by @selected

  (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed) pulled in by
    kde-apps/dolphin required by @selected

  (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/kdeplasma-addons-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/powerdevil-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/khotkeys-5.6.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.6.5:5 required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/dolphin-15.12.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/dolphin-15.12.3 required by (kde-apps/kdecore-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/dolphin required by @selected

  (kde-base/kwrited-4.11.22:4/4.11::gentoo, installed) pulled in by
    kde-base/kwrited required by @selected


Should i remove them manually?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 1:27 pm    Post subject: Reply with quote

I think I've found the problem, wiki wasn't updated after net-misc/ksshaskpass pkgmove. Can you please try:

Code:
for x in x11-libs/libkscreen kde-misc/kde-gtk-config ksshaskpass freespacenotifier kcheckpass kcminit kdebase-cursors kdebase-startkde kdm kephal khotkeys kinfocenter klipper kmenuedit krunner kscreensaver ksmserver ksplash kstartupconfig kstyles ksysguard ksystraycmd kwin kwrited libkgreeter libkworkspace liboxygenstyle libplasmaclock libplasmagenericshell libtaskmanager plasma-workspace powerdevil qguiplatformplugin_kde solid-actions-kcm systemsettings; do equery -q d ${x} | sed -e "s/-[0-9].*//"; done | sed -e "/kdebase-meta/g" -e "/kde-meta/g" | xargs emerge --deselect

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 1:40 pm    Post subject: Reply with quote

Sure, but nothing is deselected.

Code:

localhost ~ # for x in x11-libs/libkscreen kde-misc/kde-gtk-config ksshaskpass freespacenotifier kcheckpass kcminit kdebase-cursors kdebase-startkde kdm kephal khotkeys kinfocenter klipper kmenuedit krunner kscreensaver ksmserver ksplash kstartupconfig kstyles ksysguard ksystraycmd kwin kwrited libkgreeter libkworkspace liboxygenstyle libplasmaclock libplasmagenericshell libtaskmanager plasma-workspace powerdevil qguiplatformplugin_kde solid-actions-kcm systemsettings; do equery -q d ${x} | sed -e "s/-[0-9].*//"; done | sed -e "/kdebase-meta/g" -e "/kde-meta/g" | xargs emerge --deselect
>>> No matching atoms found in "world" favorites file...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 1:47 pm    Post subject: Reply with quote

Could you please paste your /var/lib/portage/world file? Do you have any sets in use? It is very strange that dolphin:4 is conflicting while it isn't even in portage tree anymore.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 2:00 pm    Post subject: Reply with quote

Sure:

Code:

localhost ~ # cat /var/lib/portage/world
app-accessibility/at-spi2-atk
app-accessibility/at-spi2-core
app-accessibility/speech-dispatcher
app-admin/eselect
app-admin/perl-cleaner
app-admin/pwgen
app-admin/sudo
app-admin/syslog-ng
app-arch/cpio
app-arch/zip
app-cdr/k3b
app-crypt/gnupg
app-crypt/mit-krb5
app-crypt/pinentry
app-crypt/qca
app-editors/nano
app-editors/vim
app-emulation/libvirt
app-emulation/libvirt-glib
app-emulation/qemu
app-emulation/spice-protocol
app-emulation/virt-manager
app-emulation/virtualbox-bin
app-emulation/virtualbox-guest-additions
app-emulation/virtualbox-modules
app-eselect/eselect-pinentry
app-eselect/eselect-python
app-misc/mc
app-misc/pax-utils
app-misc/strigi
app-office/akonadi-server
app-office/libreoffice-bin
app-office/libreoffice-l10n
app-portage/eix
app-portage/gentoolkit
app-shells/bash
app-text/docbook-xsl-stylesheets
app-text/hunspell
app-text/iso-codes
app-text/poppler
app-text/poppler-data
app-vim/gentoo-syntax
dev-db/libiodbc
dev-db/lmdb
dev-db/mariadb
dev-db/mysql-init-scripts
dev-db/sqlite
dev-db/unixODBC
dev-java/oracle-jdk-bin
dev-java/oracle-jdk-bin:1.8
dev-lang/go
dev-lang/orc
dev-lang/perl
dev-lang/php
dev-lang/php:5.6
dev-lang/php:7.0
dev-lang/python:2.7
dev-lang/ruby
dev-libs/dbus-glib
dev-libs/elfutils
dev-libs/expat
dev-libs/glib
dev-libs/gobject-introspection
dev-libs/icu
dev-libs/libassuan
dev-libs/libdbusmenu-qt
dev-libs/libev
dev-libs/libevent
dev-libs/libgcrypt
dev-libs/libksba
dev-libs/libltdl
dev-libs/libnl
dev-libs/libpcre
dev-libs/libpipeline
dev-libs/librevenge
dev-libs/libtasn1
dev-libs/libusb
dev-libs/libxml2
dev-libs/libxslt
dev-libs/nettle
dev-libs/nspr
dev-libs/nss
dev-libs/openssl
dev-libs/qjson
dev-libs/rasqal
dev-libs/xapian
dev-perl/Authen-SASL
dev-perl/Config-Simple
dev-perl/DBD-mysql
dev-perl/DBI
dev-perl/Data-Dump
dev-perl/Devel-StackTrace
dev-perl/Devel-Symdump
dev-perl/Digest-HMAC
dev-perl/Error
dev-perl/Exception-Class
dev-perl/File-BaseDir
dev-perl/File-DesktopEntry
dev-perl/File-MimeInfo
dev-perl/IO-Socket-SSL
dev-perl/Net-Daemon
dev-perl/Net-SSLeay
dev-perl/Params-Util
dev-perl/PlRPC
dev-perl/Pod-Coverage
dev-perl/Readonly
dev-perl/TermReadKey
dev-perl/Test-Deep
dev-perl/Test-DistManifest
dev-perl/Test-Pod
dev-perl/Test-Pod-Coverage
dev-perl/Text-CSV
dev-perl/Tk
dev-perl/Try-Tiny
dev-perl/X11-Protocol
dev-perl/XML-Parser
dev-perl/XML-SAX
dev-perl/XML-SAX-Base
dev-php/PEAR-Archive_Tar
dev-php/PHP_CodeSniffer
dev-php/pecl-amqp
dev-php/pecl-apcu
dev-php/pecl-memcached
dev-php/pecl-mongo
dev-php/xdebug
dev-php/xdebug-client
dev-python/cryptography
dev-python/ipaddr
dev-python/jinja
dev-python/libvirt-python
dev-python/pygobject
dev-python/python-dateutil
dev-python/setuptools
dev-python/simplejson
dev-python/subunit
dev-python/urllib3
dev-qt/qtcore
dev-qt/qtdbus
dev-qt/qtgui
dev-qt/qtnetwork
dev-qt/qtopengl
dev-qt/qtsql
dev-qt/qtwebkit
dev-qt/qtwebkit:4
dev-qt/qtwidgets
dev-ruby/json
dev-ruby/racc
dev-ruby/rake
dev-ruby/rdoc
dev-ruby/rubygems
dev-util/cmake
dev-util/desktop-file-utils
dev-util/gdbus-codegen
dev-util/gtk-doc-am
dev-util/gtk-update-icon-cache
dev-util/ninja
dev-util/pkgconfig
dev-util/strace
dev-vcs/git
gnome-base/dconf
gnome-base/gsettings-desktop-schemas
gnome-base/librsvg
kde-apps/ark
kde-apps/dolphin
kde-apps/kate
kde-apps/kcalc
kde-apps/kde4-l10n
kde-apps/kdebase-kioslaves
kde-apps/kdebase-meta
kde-apps/kdebase-runtime-meta
kde-apps/knotify
kde-apps/kreadconfig
kde-apps/ksnapshot
kde-apps/kwalletd
kde-apps/libkcddb
kde-apps/okular
kde-base/freespacenotifier
kde-base/kdebase-cursors
kde-base/kdelibs
kde-base/kinfocenter
kde-base/ksplash
kde-base/kstartupconfig
kde-base/ksystraycmd
kde-base/kwrited
kde-base/qguiplatformplugin_kde
kde-base/solid-actions-kcm
kde-misc/kdiff3
kde-plasma/ksshaskpass
mail-mta/nullmailer
media-fonts/corefonts
media-fonts/dejavu
media-gfx/exiv2
media-gfx/graphite2
media-libs/a52dec
media-libs/flac
media-libs/fontconfig
media-libs/freetype
media-libs/gd
media-libs/gst-plugins-base
media-libs/harfbuzz
media-libs/libao
media-libs/libdvbpsi
media-libs/libjpeg-turbo
media-libs/libpng
media-libs/mesa
media-libs/phonon
media-libs/phonon-gstreamer
media-libs/phonon-vlc
media-libs/raptor
media-sound/alsa-utils
media-video/transcode
media-video/vlc
net-analyzer/mtr
net-analyzer/tcpdump
net-analyzer/wireshark
net-dns/bind-tools
net-fs/nfs-utils
net-fs/samba
net-libs/glib-networking
net-libs/gnutls
net-libs/http-parser
net-libs/libpcap
net-libs/libsoup
net-libs/libsoup-gnome
net-libs/libssh
net-libs/libtirpc
net-libs/neon
net-libs/nodejs
net-misc/autossh
net-misc/clusterssh
net-misc/curl
net-misc/dhcpcd
net-misc/memcached
net-misc/ntp
net-misc/openssh
net-misc/rdesktop
net-misc/s3cmd
net-misc/spice-gtk
net-misc/telnet-bsd
net-print/cups
net-print/cups-filters
net-wireless/wireless-regdb
net-wireless/wpa_supplicant
perl-core/Data-Dumper
perl-core/File-Temp
sci-libs/colamd
sci-visualization/gnuplot
sys-apps/dbus
sys-apps/debianutils
sys-apps/dmidecode
sys-apps/gptfdisk
sys-apps/help2man
sys-apps/hwids
sys-apps/kmod
sys-apps/man-db
sys-apps/pciutils
sys-apps/portage
sys-apps/sysvinit
sys-apps/texinfo
sys-apps/usbredir
sys-apps/usbutils
sys-auth/consolekit
sys-auth/polkit
sys-auth/polkit-qt
sys-block/parted
sys-boot/grub
sys-devel/automake
sys-devel/binutils-config
sys-devel/gcc
sys-devel/gettext
sys-devel/libtool
sys-devel/llvm
sys-devel/m4
sys-fs/dosfstools
sys-fs/reiserfsprogs
sys-fs/udev
sys-fs/udev-init-scripts
sys-fs/udisks
sys-kernel/gentoo-sources
sys-kernel/linux-firmware
sys-libs/cracklib
sys-libs/db
sys-libs/e2fsprogs-libs
sys-libs/libcap
sys-libs/libcap-ng
sys-libs/libunwind
sys-libs/timezone-data
sys-libs/zlib
sys-process/cronie
sys-process/iotop
sys-process/parallel
virtual/mysql
virtual/perl-Data-Dumper
virtual/perl-Digest-MD5
virtual/perl-Digest-SHA
virtual/perl-ExtUtils-MakeMaker
virtual/perl-File-Spec
virtual/perl-File-Temp
virtual/perl-Getopt-Long
virtual/perl-Pod-Parser
virtual/perl-Scalar-List-Utils
virtual/perl-Storable
virtual/perl-Sys-Syslog
virtual/perl-Test-Harness
virtual/perl-Test-Simple
virtual/perl-Time-HiRes
virtual/perl-libnet
virtual/rubygems
virtual/ttf-fonts
www-client/chromium
www-client/lynx
www-plugins/chrome-binary-plugins
www-plugins/chrome-binary-plugins:beta
x11-apps/mesa-progs
x11-apps/xbacklight
x11-base/xorg-server
x11-base/xorg-x11
x11-drivers/xf86-video-virtualbox
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gnome-pty-helper
x11-libs/gtk+
x11-libs/gtk+:2
x11-libs/libSM
x11-libs/pango
x11-libs/vte
x11-misc/shared-mime-info
x11-terms/terminator
x11-terms/xterm
x11-themes/adwaita-icon-theme
x11-themes/hicolor-icon-theme
x11-wm/twm


> Do you have any sets in use?

No, none that i am aware of.

Code:

localhost ~ # ls -la /etc/portage/sets/
ls: cannot access /etc/portage/sets/: No such file or directory
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 2:14 pm    Post subject: Reply with quote

Well, the upgrade guide does not account for messed up world files. Remove at least:

Code:
kde-apps/knotify
kde-apps/kreadconfig
kde-apps/ksnapshot
kde-base/freespacenotifier
kde-base/kdebase-cursors
kde-base/kdelibs
kde-base/kinfocenter
kde-base/ksplash
kde-base/kstartupconfig
kde-base/ksystraycmd
kde-base/kwrited
kde-base/qguiplatformplugin_kde
kde-base/solid-actions-kcm


Also bound to break some emerge in your future:
Code:
app-misc/strigi
app-office/akonadi-server


Shouldn't be in a world file:
Code:
sys-auth/consolekit
sys-auth/polkit
sys-auth/polkit-qt


Not necessary at all unless you need it for your own development:
Code:
dev-qt/qtcore
dev-qt/qtdbus
dev-qt/qtgui
dev-qt/qtnetwork
dev-qt/qtopengl
dev-qt/qtsql
dev-qt/qtwebkit
dev-qt/qtwebkit:4
dev-qt/qtwidgets

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Mon Aug 08, 2016 2:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 2:19 pm    Post subject: Reply with quote

> Well, the upgrade guide does not account for messed up world files.

Sorry for that :( - i honestly have no idea why those packages ended up there.

But now theres some progress:

Code:

localhost ~ # emerge --ask --changed-use --newrepo --deep --pretend world
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] media-fonts/noto-20160305-r1  USE="X -cjk"
[ebuild   R    ] sys-firmware/ipxe-1.0.0_p20130925  USE="ipv6%* -efi% -savedconfig%"
[ebuild  N     ] virtual/perl-parent-0.228-r1
[ebuild  N     ] dev-perl/URI-1.710.0  USE="{-test}"
[ebuild  N     ] net-misc/dhcp-4.3.3_p1  USE="client ipv6 ldap server ssl (-libressl) (-selinux) -vim-syntax"
[ebuild  N     ] net-libs/libqmi-1.12.6  USE="-doc -static-libs"
[ebuild   R    ] media-sound/lame-3.99.5-r1  USE="frontend%*"
[ebuild  N     ] net-misc/socat-1.7.3.1  USE="ipv6 readline ssl tcpd"
[ebuild  N     ] dev-qt/qtpaths-5.6.1  USE="-debug {-test}"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild   R    ] sys-devel/gcc-4.9.3  USE="vtv%*"
[ebuild   R    ] app-text/hunspell-1.3.3  L10N="-af% -bg% -ca% -cs% -cy% -da% -de% -de-1901% -el% -en% -eo% -es% -et% -fo% -fr% -ga% -gl% -he% -hr% -hu% -ia% -id% -is% -it% -km% -ku% -lt% -lv% -mk% -ms% -nb% -nl% -nn% -pl% -pt% -pt-BR% -ro% -ru% -sk% -sl% -sq% -sv% -sw% -tn% -uk% -zu%" LINGUAS="(-en%*)"
[ebuild  N     ] dev-python/pygments-2.1.1  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] net-libs/libndp-1.6  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-plasma/kwallet-pam-5.6.5-r1  USE="oldwallet -debug"
[ebuild  N     ] kde-frameworks/breeze-icons-5.23.0  USE="{-test}"
[ebuild  N     ] dev-python/docutils-0.12  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-libs/libgit2-0.23.4  USE="threads -examples -gssapi (-libressl) -ssh {-test} -trace"
[ebuild  N     ] dev-libs/libinput-1.3.0  USE="{-test}" INPUT_DEVICES="-wacom"
[ebuild  N     ] dev-qt/qdbus-5.6.1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kf-env-3
[ebuild  NS    ] dev-qt/qtscript-5.6.1 [4.8.6-r2] USE="jit scripttools -debug {-test}"
[ebuild  N     ] dev-qt/linguist-tools-5.6.1  USE="qml -debug {-test}"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.6.1  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.6.1  USE="widgets -debug {-test}"
[ebuild   R    ] app-text/ghostscript-gpl-9.15-r1  USE="tiff%*" L10N="-de% -ja% -ko% -zh-CN% -zh-TW%"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius"
[ebuild   R    ] app-emulation/qemu-2.5.1  USE="bzip2%*"
[ebuild  N     ] media-gfx/fontforge-20150612-r1  USE="X cairo gif gtk jpeg png python readline svg tiff unicode -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N     ] net-dialup/rp-pppoe-3.11-r3  USE="-tk"
[ebuild  N     ] x11-misc/sddm-0.13.0-r3  USE="consolekit pam -systemd"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] net-misc/modemmanager-1.4.12  USE="introspection (policykit) qmi -mbim -qmi-newest -vala"
[ebuild     U  ] kde-apps/knotify-15.12.3 [15.08.3]
[ebuild   R    ] kde-base/kfilemetadata-4.14.3  USE="ffmpeg*"
[ebuild     U  ] kde-apps/kdebase-menu-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kpasswdserver-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/ktraderclient-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kiconfinder-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kwalletd-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kstart-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kurifilter-plugins-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kioclient-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/solid-runtime-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/renamedlg-plugins-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/keditfiletype-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kimgio-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kreadconfig-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kcmshell-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kquitapp-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebugdialog-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-desktoptheme-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdontchangethehostname-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kmimetypefinder-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kfile-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdesu-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-data-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/kdebase-menu-icons-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/ktimezoned-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/phonon-kde-15.12.3 [15.08.3]
[ebuild     U  ] kde-apps/knewstuff-15.12.3 [15.08.3]
[ebuild  N     ] net-misc/networkmanager-1.0.12-r1  USE="consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -bluetooth -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-plasma/plasma-workspace-wallpapers-5.6.5
[uninstall     ] kde-apps/kde-wallpapers-15.08.3
[blocks b      ] <kde-apps/kde-wallpapers-15.08.3-r2 ("<kde-apps/kde-wallpapers-15.08.3-r2" is blocking kde-plasma/plasma-workspace-wallpapers-5.6.5)
[ebuild  N     ] kde-frameworks/kcoreaddons-5.23.0  USE="nls -debug (-fam) {-test}"
[ebuild  N     ] kde-frameworks/ki18n-5.23.0  USE="-debug {-test}" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kwindowsystem-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kdbusaddons-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kcrash-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kconfig-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/karchive-5.23.0-r1  USE="bzip2 lzma -debug {-test}"
[ebuild  N     ] kde-frameworks/kitemviews-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kcodecs-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kguiaddons-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdoctools-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kservice-5.23.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kcompletion-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/knotifications-5.23.0  USE="X dbus nls -debug (-speech)"
[ebuild  N     ] kde-frameworks/kjobwidgets-5.23.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kglobalaccel-5.23.0-r1  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/solid-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kpackage-5.23.0  USE="-debug -man {-test}"
[ebuild  N     ] kde-frameworks/kwayland-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/sonnet-5.23.0  USE="hunspell nls -aspell -debug {-test}"
[ebuild  N     ] kde-frameworks/kidletime-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kpty-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kdecoration-5.6.5  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kjs-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kitemmodels-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kfilemetadata-5.23.0  USE="exif ffmpeg pdf -debug -epub -libav -taglib {-test}"
[ebuild  N     ] kde-plasma/libkscreen-5.6.5  USE="X -debug {-test}"
[ebuild  N     ] kde-frameworks/kdesu-5.23.0  USE="X -debug"
[ebuild  N     ] kde-frameworks/kunitconversion-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kemoticons-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/attica-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/threadweaver-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdesignerplugin-5.23.0  USE="nls -debug -designer -webkit"
[ebuild  N     ] kde-frameworks/kdnssd-5.23.0  USE="nls -debug {-test} -zeroconf"
[ebuild  N     ] kde-plasma/breeze-gtk-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/kwayland-integration-5.6.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kjsembed-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.23.0  USE="-debug -teamd {-test}"
[ebuild  N     ] kde-frameworks/kpeople-5.23.0  USE="-debug {-test}"
[ebuild     U  ] kde-apps/kde4-l10n-15.12.3-r1 [15.08.3-r2] USE="minimal*" L10N="-ar% -bg% -bs% -ca% -ca-valencia% -cs% -da% -de% -el% -en-GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -ga% -gl% -he% -hi% -hr% -hu% -ia% -id% -is% -it% -ja% -kk% -km% -ko% -lt% -lv% -mr% -nb% -nds% -nl% -nn% -pa% -pl% -pt% -pt-BR% -ro% -ru% -sk% -sl% -sr% -sv% -tr% -ug% -uk% -wa% -zh-CN% -zh-TW%"
[blocks b      ] <kde-apps/kde4-l10n-15.12.3-r1 ("<kde-apps/kde4-l10n-15.12.3-r1" is blocking kde-frameworks/kjs-5.23.0, kde-plasma/breeze-5.6.5-r1, kde-plasma/kdecoration-5.6.5, kde-frameworks/kdeclarative-5.23.0, kde-frameworks/krunner-5.23.0, kde-frameworks/ki18n-5.23.0, kde-frameworks/kglobalaccel-5.23.0-r1, kde-frameworks/kpackage-5.23.0, kde-plasma/kgamma-5.6.5, kde-frameworks/ktexteditor-5.23.0, kde-frameworks/threadweaver-5.23.0, kde-plasma/kde-cli-tools-5.6.5, kde-frameworks/kconfigwidgets-5.23.0, kde-plasma/kwin-5.6.5-r1, kde-frameworks/kwayland-5.23.0, kde-frameworks/kdoctools-5.23.0, kde-plasma/kwayland-integration-5.6.5, kde-plasma/khotkeys-5.6.5, kde-frameworks/kfilemetadata-5.23.0, kde-frameworks/kcompletion-5.23.0, kde-frameworks/frameworkintegration-5.23.0, kde-frameworks/kcmutils-5.23.0, kde-frameworks/kdelibs4support-5.23.0-r1, kde-plasma/kscreenlocker-5.6.5, kde-frameworks/kxmlgui-5.23.0-r1, kde-frameworks/kconfig-5.23.0, kde-frameworks/kwindowsystem-5.23.0, kde-frameworks/kwallet-5.23.0, kde-frameworks/solid-5.23.0, kde-plasma/milou-5.6.5, kde-frameworks/kparts-5.23.0, kde-plasma/plasma-integration-5.6.5, kde-frameworks/ktextwidgets-5.23.0, kde-plasma/kscreen-5.6.5-r1, kde-frameworks/knotifyconfig-5.23.0, kde-frameworks/sonnet-5.23.0, kde-plasma/ksysguard-5.6.5, kde-plasma/systemsettings-5.6.5, kde-plasma/kde-gtk-config-5.6.5, kde-plasma/user-manager-5.6.5, kde-frameworks/kemoticons-5.23.0, kde-frameworks/kio-5.23.0, kde-frameworks/baloo-5.23.0, kde-frameworks/kidletime-5.23.0, kde-frameworks/kwidgetsaddons-5.23.0, kde-frameworks/knewstuff-5.23.0, kde-plasma/kwrited-5.6.5, kde-frameworks/kactivities-5.23.0, kde-frameworks/kdnssd-5.23.0, kde-plasma/oxygen-5.6.5, kde-plasma/plasma-desktop-5.6.5, kde-plasma/kdeplasma-addons-5.6.5, kde-plasma/breeze-gtk-5.6.5, kde-frameworks/kcrash-5.23.0, kde-frameworks/kguiaddons-5.23.0, kde-frameworks/kbookmarks-5.23.0, kde-frameworks/attica-5.23.0, kde-frameworks/kcoreaddons-5.23.0, kde-frameworks/knotifications-5.23.0, kde-frameworks/kcodecs-5.23.0, kde-frameworks/kpty-5.23.0, kde-frameworks/kjobwidgets-5.23.0, kde-frameworks/kservice-5.23.0, kde-frameworks/kded-5.23.0, kde-plasma/kactivitymanagerd-5.6.5, kde-plasma/libksysguard-5.6.5, kde-frameworks/kitemmodels-5.23.0, kde-frameworks/plasma-5.23.0, kde-frameworks/kross-5.23.0, kde-frameworks/kiconthemes-5.23.0, kde-plasma/ksshaskpass-5.6.5, kde-plasma/powerdevil-5.6.5, kde-frameworks/kpeople-5.23.0, kde-plasma/kinfocenter-5.6.5, kde-frameworks/kdbusaddons-5.23.0, kde-frameworks/khtml-5.23.0, kde-frameworks/kitemviews-5.23.0, kde-frameworks/karchive-5.23.0-r1, kde-frameworks/kdesignerplugin-5.23.0, kde-plasma/sddm-kcm-5.6.5, kde-frameworks/networkmanager-qt-5.23.0, kde-frameworks/kjsembed-5.23.0, kde-frameworks/kinit-5.23.0, kde-plasma/kmenuedit-5.6.5, kde-plasma/libkscreen-5.6.5, kde-frameworks/kunitconversion-5.23.0, kde-frameworks/kxmlrpcclient-5.23.0, kde-plasma/plasma-workspace-5.6.5.1-r2, kde-frameworks/kdesu-5.23.0, kde-frameworks/kauth-5.23.0-r1)
[blocks b      ] kde-apps/kde4-l10n[-minimal(+)] ("kde-apps/kde4-l10n[-minimal(+)]" is blocking kde-frameworks/kjs-5.23.0, kde-plasma/breeze-5.6.5-r1, kde-plasma/kdecoration-5.6.5, kde-frameworks/kdeclarative-5.23.0, kde-frameworks/krunner-5.23.0, kde-frameworks/ki18n-5.23.0, kde-frameworks/kglobalaccel-5.23.0-r1, kde-frameworks/kpackage-5.23.0, kde-plasma/kgamma-5.6.5, kde-frameworks/ktexteditor-5.23.0, kde-frameworks/threadweaver-5.23.0, kde-plasma/kde-cli-tools-5.6.5, kde-frameworks/kconfigwidgets-5.23.0, kde-plasma/kwin-5.6.5-r1, kde-frameworks/kwayland-5.23.0, kde-frameworks/kdoctools-5.23.0, kde-plasma/kwayland-integration-5.6.5, kde-plasma/khotkeys-5.6.5, kde-frameworks/kfilemetadata-5.23.0, kde-frameworks/kcompletion-5.23.0, kde-frameworks/frameworkintegration-5.23.0, kde-frameworks/kcmutils-5.23.0, kde-frameworks/kdelibs4support-5.23.0-r1, kde-plasma/kscreenlocker-5.6.5, kde-frameworks/kxmlgui-5.23.0-r1, kde-frameworks/kconfig-5.23.0, kde-frameworks/kwindowsystem-5.23.0, kde-frameworks/kwallet-5.23.0, kde-frameworks/solid-5.23.0, kde-plasma/milou-5.6.5, kde-frameworks/kparts-5.23.0, kde-plasma/plasma-integration-5.6.5, kde-frameworks/ktextwidgets-5.23.0, kde-plasma/kscreen-5.6.5-r1, kde-frameworks/knotifyconfig-5.23.0, kde-frameworks/sonnet-5.23.0, kde-plasma/ksysguard-5.6.5, kde-plasma/systemsettings-5.6.5, kde-plasma/kde-gtk-config-5.6.5, kde-plasma/user-manager-5.6.5, kde-frameworks/kemoticons-5.23.0, kde-frameworks/kio-5.23.0, kde-frameworks/baloo-5.23.0, kde-frameworks/kidletime-5.23.0, kde-frameworks/kwidgetsaddons-5.23.0, kde-frameworks/knewstuff-5.23.0, kde-plasma/kwrited-5.6.5, kde-frameworks/kactivities-5.23.0, kde-frameworks/kdnssd-5.23.0, kde-plasma/oxygen-5.6.5, kde-plasma/plasma-desktop-5.6.5, kde-plasma/kdeplasma-addons-5.6.5, kde-plasma/breeze-gtk-5.6.5, kde-frameworks/kcrash-5.23.0, kde-frameworks/kguiaddons-5.23.0, kde-frameworks/kbookmarks-5.23.0, kde-frameworks/attica-5.23.0, kde-frameworks/kcoreaddons-5.23.0, kde-frameworks/knotifications-5.23.0, kde-frameworks/kcodecs-5.23.0, kde-frameworks/kpty-5.23.0, kde-frameworks/kjobwidgets-5.23.0, kde-frameworks/kservice-5.23.0, kde-frameworks/kded-5.23.0, kde-plasma/kactivitymanagerd-5.6.5, kde-plasma/libksysguard-5.6.5, kde-frameworks/kitemmodels-5.23.0, kde-frameworks/plasma-5.23.0, kde-frameworks/kross-5.23.0, kde-frameworks/kiconthemes-5.23.0, kde-plasma/ksshaskpass-5.6.5, kde-plasma/powerdevil-5.6.5, kde-frameworks/kpeople-5.23.0, kde-plasma/kinfocenter-5.6.5, kde-frameworks/kdbusaddons-5.23.0, kde-frameworks/khtml-5.23.0, kde-frameworks/kitemviews-5.23.0, kde-frameworks/karchive-5.23.0-r1, kde-frameworks/kdesignerplugin-5.23.0, kde-plasma/sddm-kcm-5.6.5, kde-frameworks/networkmanager-qt-5.23.0, kde-frameworks/kjsembed-5.23.0, kde-frameworks/kinit-5.23.0, kde-plasma/kmenuedit-5.6.5, kde-plasma/libkscreen-5.6.5, kde-frameworks/kunitconversion-5.23.0, kde-frameworks/kxmlrpcclient-5.23.0, kde-plasma/plasma-workspace-5.6.5.1-r2, kde-frameworks/kdesu-5.23.0, kde-frameworks/kauth-5.23.0-r1)
[ebuild  N     ] kde-frameworks/kauth-5.23.0-r1  USE="nls (policykit) -debug {-test}"
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.23.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kiconthemes-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/ktextwidgets-5.23.0  USE="-debug (-speech) {-test}"
[ebuild  N     ] kde-frameworks/kxmlgui-5.23.0-r1  USE="-attica -debug {-test}"
[ebuild  N     ] kde-frameworks/kbookmarks-5.23.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kwallet-5.23.0  USE="man -debug -gpg {-test}"
[ebuild  N     ] kde-frameworks/frameworkintegration-5.23.0  USE="X -debug {-test}"
[ebuild  NS    ] kde-plasma/ksshaskpass-5.6.5 [0.5.3-r1] USE="-debug"
[ebuild  N     ] kde-frameworks/kio-5.23.0  USE="X acl handbook kwallet -debug -kerberos {-test}"
[ebuild  N     ] kde-frameworks/kinit-5.23.0  USE="caps man -debug"
[ebuild  N     ] kde-frameworks/kded-5.23.0  USE="man -debug"
[ebuild  N     ] kde-frameworks/kparts-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdelibs4support-5.23.0-r1  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-frameworks/kdeclarative-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kcmutils-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kde-cli-tools-5.6.5  USE="X handbook kdesu -debug {-test}"
[ebuild  N     ] kde-frameworks/knewstuff-5.23.0  USE="-debug"
[ebuild  N     ] kde-frameworks/knotifyconfig-5.23.0  USE="phonon -debug"
[ebuild  N     ] kde-frameworks/ktexteditor-5.23.0  USE="-debug -git {-test}"
[ebuild  N     ] kde-frameworks/khtml-5.23.0  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-apps/kio-extras-15.12.3  USE="exif handbook phonon sftp -debug -mtp -openexr -samba -slp {-test}"
[ebuild  N     ] kde-plasma/plasma-integration-5.6.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/user-manager-5.6.5  USE="-debug"
[ebuild  N     ] kde-plasma/kgamma-5.6.5  USE="handbook -debug"
[ebuild  N     ] kde-plasma/sddm-kcm-5.6.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kross-5.23.0  USE="-debug {-test}"
[ebuild  NS    ] kde-apps/ark-15.12.3 [4.14.3-r1] USE="bzip2 handbook zlib -debug -lzma {-test}"
[uninstall     ] kde-apps/ark-4.14.3-r1
[blocks b      ] kde-apps/ark:4 ("kde-apps/ark:4" is blocking kde-apps/ark-15.12.3)
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.6.5  USE="-debug"
[uninstall     ] sys-auth/polkit-kde-agent-0.99.1-r1
[blocks b      ] sys-auth/polkit-kde-agent:4[-minimal(-)] ("sys-auth/polkit-kde-agent:4[-minimal(-)]" is blocking kde-plasma/polkit-kde-agent-5.6.5)
[ebuild     U  ] app-emulation/libvirt-1.3.5-r2 [1.3.5-r1]
[ebuild   R    ] kde-base/baloo-4.14.3  USE="minimal*"
[ebuild  N     ] kde-frameworks/baloo-5.23.0  USE="-debug {-test}"
[ebuild  NS    ] kde-apps/baloo-widgets-15.12.3 [4.14.3] USE="-debug {-test}"
[ebuild  NS    ] kde-apps/dolphin-15.12.3-r1 [4.14.3-r1] USE="handbook semantic-desktop -debug {-test} -thumbnail"
[ebuild  NS    ] kde-apps/khelpcenter-5.6.2-r1 [4.14.3] USE="handbook -debug"
[uninstall     ] kde-apps/khelpcenter-4.14.3
[blocks b      ] kde-apps/khelpcenter:4 ("kde-apps/khelpcenter:4" is blocking kde-apps/khelpcenter-5.6.2-r1)
[ebuild  NS    ] kde-apps/konsole-15.12.3 [4.14.3-r2] USE="X handbook -debug {-test}"
[uninstall     ] kde-apps/konsole-4.14.3-r2
[blocks b      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.12.3)
[ebuild  N     ] kde-plasma/oxygen-5.6.5  USE="-debug"
[uninstall     ] kde-base/kdebase-cursors-4.11.22
[blocks b      ] kde-base/kdebase-cursors:4 ("kde-base/kdebase-cursors:4" is blocking kde-plasma/oxygen-5.6.5)
[ebuild  N     ] kde-plasma/kscreen-5.6.5-r1  USE="-debug {-test}"
[uninstall     ] kde-misc/kscreen-1.0.71_p20150824
[blocks b      ] kde-misc/kscreen ("kde-misc/kscreen" is blocking kde-plasma/kscreen-5.6.5-r1)
[ebuild  N     ] kde-plasma/kde-gtk-config-5.6.5  USE="gtk3 -debug {-test}"
[uninstall     ] kde-misc/kde-gtk-config-2.2.1
[blocks b      ] kde-misc/kde-gtk-config ("kde-misc/kde-gtk-config" is blocking kde-plasma/kde-gtk-config-5.6.5)
[ebuild  N     ] kde-plasma/kwrited-5.6.5  USE="-debug"
[uninstall     ] kde-base/kwrited-4.11.22
[blocks b      ] kde-base/kwrited:4 ("kde-base/kwrited:4" is blocking kde-plasma/kwrited-5.6.5)
[ebuild  N     ] kde-plasma/kscreenlocker-5.6.5  USE="pam -debug {-test}"
[uninstall     ] kde-base/kdebase-pam-9
[blocks b      ] kde-base/kdebase-pam:0 ("kde-base/kdebase-pam:0" is blocking kde-plasma/kscreenlocker-5.6.5)
[ebuild  NS    ] kde-plasma/kactivitymanagerd-5.6.5 [4.13.3-r1] USE="-debug"
[ebuild  N     ] kde-frameworks/kactivities-5.23.0  USE="-debug {-test}"
[uninstall     ] kde-plasma/kactivitymanagerd-4.13.3-r1
[blocks b      ] kde-frameworks/kactivities ("kde-frameworks/kactivities" is blocking kde-plasma/kactivitymanagerd-4.13.3-r1)
[blocks b      ] kde-plasma/kactivitymanagerd:4 ("kde-plasma/kactivitymanagerd:4" is blocking kde-plasma/kactivitymanagerd-5.6.5)
[ebuild  N     ] kde-frameworks/plasma-5.23.0  USE="X -debug -egl -gles2 {-test}"
[ebuild     U  ] kde-apps/plasma-runtime-15.12.3 [15.08.3]
[ebuild  N     ] kde-frameworks/krunner-5.23.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/breeze-5.6.5-r1  USE="qt4 -debug"
[ebuild  NS    ] kde-apps/kdebase-runtime-meta-15.12.3 [4.14.3] USE="oldwallet pam"
[ebuild  N     ] kde-plasma/milou-5.6.5  USE="-debug"
[ebuild  NS    ] kde-apps/kwrite-15.12.3 [4.14.3] USE="handbook -debug"
[uninstall     ] kde-apps/kwrite-4.14.3
[blocks b      ] kde-apps/kwrite:4 ("kde-apps/kwrite:4" is blocking kde-apps/kwrite-15.12.3)
[ebuild  N     ] kde-apps/kdecore-meta-15.12.3  USE="handbook -minimal"
[ebuild  N     ] kde-plasma/kinfocenter-5.6.5  USE="handbook opengl pci -debug -egl -gles -ieee1394 -nfs -samba -wayland"
[uninstall     ] kde-base/kinfocenter-4.11.22
[blocks b      ] kde-base/kinfocenter:4 ("kde-base/kinfocenter:4" is blocking kde-plasma/kinfocenter-5.6.5)
[ebuild  NS    ] kde-apps/kate-15.12.3 [4.14.3] USE="addons handbook -debug {-test}"
[uninstall     ] kde-apps/kate-4.14.3
[blocks b      ] kde-apps/kate:4 ("kde-apps/kate:4" is blocking kde-apps/kate-15.12.3)
[ebuild  N     ] kde-plasma/libksysguard-5.6.5  USE="X detailedmemory -debug {-test}"
[ebuild  N     ] kde-plasma/ksysguard-5.6.5  USE="handbook -debug -lm_sensors"
[uninstall     ] kde-base/ksysguard-4.11.22
[blocks b      ] kde-base/ksysguard:4 ("kde-base/ksysguard:4" is blocking kde-plasma/libksysguard-5.6.5, kde-plasma/ksysguard-5.6.5)
[ebuild  N     ] kde-plasma/kwin-5.6.5-r1  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N     ] kde-plasma/systemsettings-5.6.5  USE="gtk handbook -classic -debug"
[uninstall     ] kde-base/kwin-4.11.22
[blocks b      ] kde-base/kwin:4 ("kde-base/kwin:4" is blocking kde-plasma/kwin-5.6.5-r1)
[ebuild  N     ] kde-plasma/plasma-workspace-5.6.5.1-r2  USE="geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[uninstall     ] kde-base/freespacenotifier-4.11.22
[blocks b      ] kde-base/freespacenotifier:4 ("kde-base/freespacenotifier:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/ksplash-4.11.22
[blocks b      ] kde-base/ksplash:4 ("kde-base/ksplash:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/kdebase-startkde-4.11.22
[blocks b      ] kde-base/kdebase-startkde:4 ("kde-base/kdebase-startkde:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/kcminit-4.11.22
[blocks b      ] kde-base/kcminit:4 ("kde-base/kcminit:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/ksmserver-4.11.22
[blocks b      ] kde-base/ksmserver:4 ("kde-base/ksmserver:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/klipper-4.11.22
[blocks b      ] kde-base/klipper:4 ("kde-base/klipper:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/libtaskmanager-4.11.22
[blocks b      ] kde-base/libtaskmanager:4 ("kde-base/libtaskmanager:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[uninstall     ] kde-base/krunner-4.11.22
[blocks b      ] kde-base/krunner:4 ("kde-base/krunner:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2)
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.6.5  USE="-debug -share"
[ebuild  N     ] kde-plasma/powerdevil-5.6.5  USE="handbook -debug -systemd"
[uninstall     ] kde-base/powerdevil-4.11.22
[blocks b      ] kde-base/powerdevil:4 ("kde-base/powerdevil:4" is blocking kde-plasma/powerdevil-5.6.5)
[ebuild  N     ] kde-plasma/khotkeys-5.6.5  USE="handbook -debug"
[uninstall     ] kde-base/khotkeys-4.11.22
[blocks b      ] kde-base/khotkeys:4 ("kde-base/khotkeys:4" is blocking kde-plasma/khotkeys-5.6.5)
[ebuild  N     ] kde-plasma/kmenuedit-5.6.5  USE="handbook hotkeys -debug"
[uninstall     ] kde-base/kmenuedit-4.11.22
[blocks b      ] kde-base/kmenuedit:4 ("kde-base/kmenuedit:4" is blocking kde-plasma/kmenuedit-5.6.5)
[ebuild  N     ] kde-plasma/plasma-desktop-5.6.5  USE="fontconfig handbook qt4 -debug -gtk2 -gtk3 -ibus -legacy-systray (-packagekit) -pulseaudio -scim {-test}" INPUT_DEVICES="evdev -synaptics"
[uninstall     ] kde-base/systemsettings-4.11.22-r1
[blocks b      ] kde-base/systemsettings:4[handbook] ("kde-base/systemsettings:4[handbook]" is blocking kde-plasma/powerdevil-5.6.5)
[blocks b      ] kde-base/systemsettings:4 ("kde-base/systemsettings:4" is blocking kde-plasma/plasma-desktop-5.6.5, kde-plasma/kwin-5.6.5-r1, kde-plasma/khotkeys-5.6.5, kde-plasma/systemsettings-5.6.5)
[uninstall     ] kde-base/plasma-workspace-4.11.22
[blocks b      ] kde-base/plasma-workspace:4 ("kde-base/plasma-workspace:4" is blocking kde-plasma/plasma-workspace-5.6.5.1-r2, kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/kdepasswd-15.08.3
[blocks b      ] kde-apps/kdepasswd ("kde-apps/kdepasswd" is blocking kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-base/solid-actions-kcm-4.11.22
[blocks b      ] kde-base/solid-actions-kcm:4 ("kde-base/solid-actions-kcm:4" is blocking kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/kcontrol-15.08.3
[blocks b      ] kde-apps/kcontrol ("kde-apps/kcontrol" is blocking kde-plasma/plasma-desktop-5.6.5)
[uninstall     ] kde-apps/knetattach-15.08.3
[blocks b      ] kde-apps/knetattach[handbook] ("kde-apps/knetattach[handbook]" is blocking kde-plasma/plasma-desktop-5.6.5)
[ebuild  N     ] kde-plasma/plasma-meta-5.6.5  USE="display-manager gtk handbook pam sddm wallpapers -bluetooth -grub -mediacenter -networkmanager -plymouth -pulseaudio -sdk"
[ebuild  NS    ] kde-apps/kdebase-meta-15.12.3 [4.14.3-r2]
[blocks B      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.12.3-r1)
[blocks B      ] kde-plasma/ksshaskpass:4 ("kde-plasma/ksshaskpass:4" is blocking kde-plasma/ksshaskpass-5.6.5)
[blocks B      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.12.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-plasma/ksshaskpass-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-plasma/ksshaskpass required by @selected
    >=kde-plasma/ksshaskpass-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/dolphin-15.12.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/dolphin-15.12.3 required by (kde-apps/kdecore-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/dolphin required by @selected

  (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed) pulled in by
    kde-apps/dolphin required by @selected

  (kde-plasma/ksshaskpass-0.5.3-r1:4/4::gentoo, installed) pulled in by
    kde-plasma/ksshaskpass required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 2:24 pm    Post subject: Reply with quote

Ullrich wrote:
i honestly have no idea why those packages ended up there.

Using emerge for dependencies without adding --oneshot (or -1).

Ullrich wrote:
Code:
  (kde-plasma/ksshaskpass-5.6.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-plasma/ksshaskpass required by @selected
    >=kde-plasma/ksshaskpass-5.6.5:5 required by (kde-plasma/plasma-meta-5.6.5:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/dolphin-15.12.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/dolphin-15.12.3 required by (kde-apps/kdecore-meta-15.12.3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/dolphin required by @selected

  (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed) pulled in by
    kde-apps/dolphin required by @selected

  (kde-plasma/ksshaskpass-0.5.3-r1:4/4::gentoo, installed) pulled in by
    kde-plasma/ksshaskpass required by @selected

As you could see from above world file, you have ksshaskpass:4 and dolphin:4 selected, remove them.

See also the updates to my above post.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 2:36 pm    Post subject: Reply with quote

> Using emerge for dependencies without adding --oneshot (or -1).

You got me. I tend to do this in the past for almost every emerge ...

I removed the packages you mentioned (includsiv dolphin and ksshaskpass) from my world file and now:

Code:


WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-libs/libXau:0

  (x11-libs/libXau-1.0.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                           

Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 08, 2016 3:11 pm    Post subject: Reply with quote

Well, this is not related to Plasma anymore. Did you recently change your ABI_X86 value? If you switched to plasma profile, an emerge with -N is in order anyway, try with `emerge -uvaDN world`.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ullrich
n00b
n00b


Joined: 29 Oct 2005
Posts: 24

PostPosted: Mon Aug 08, 2016 5:04 pm    Post subject: Reply with quote

I solved it with adding

Code:

x11-libs/libXau abi_x86_32


to my package.use file.

Code:

emerge --ask --changed-use --newrepo --deep --pretend world


Is now not complaining anymore.

Thanks, genstorm for your assistance.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum