Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] certbot error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 200
Location: Arlington, VA

PostPosted: Fri Aug 05, 2016 6:18 pm    Post subject: [Solved] certbot error Reply with quote

I install the Letsencrypt certbot. When I try to run it, I get this error

Quote:
certbot --apache certonly
An unexpected error occurred:
VersionConflict: (certbot 0.8.1 (/usr/lib64/python2.7/site-packages), Requirement.parse('certbot==0.9.0.dev0'))
Please see the logfile 'certbot.log' for more details.


I have certbot 0.8.1 installed. I also have certbot-apache 9999 installed.

certbot.log shows this

Quote:
etc # more certbot.log
Traceback (most recent call last):
File "/usr/lib/python-exec/python2.7/certbot", line 9, in <module>
load_entry_point('certbot==0.8.1', 'console_scripts', 'certbot')()
File "/usr/lib64/python2.7/site-packages/certbot/main.py", line 700, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File "/usr/lib64/python2.7/site-packages/certbot/plugins/disco.py", line 174, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File "/usr/lib64/python2.7/site-packages/certbot/plugins/disco.py", line 33, in __init__
self.plugin_cls = entry_point.load()
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2354, in load
self.require(*args, **kwargs)
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2371, in require
items = working_set.resolve(reqs, env, installer)
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 844, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
VersionConflict: (certbot 0.8.1 (/usr/lib64/python2.7/site-packages), Requirement.parse('certbot==0.9.0.dev0'))


Last edited by KayZee on Thu Aug 11, 2016 8:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Wed Aug 10, 2016 2:54 pm    Post subject: Reply with quote

As app-crypt/certbot-apache version 9999 is a "rolling" version (git fetching), I think you also need the 9999 version of app-crypt/certbot.
Back to top
View user's profile Send private message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 200
Location: Arlington, VA

PostPosted: Thu Aug 11, 2016 8:25 pm    Post subject: Reply with quote

Thank you. Switching to app-crypt/certbot-9999 worked.

Since app-crypt/certbot-apache-0.8.1 is not in Portage, app-crypt/certbot-9999 must also be used.

--Karl
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum