Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GenToo GNOME - Emerge error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Razor0068
n00b
n00b


Joined: 26 Jul 2016
Posts: 10

PostPosted: Tue Jul 26, 2016 6:53 pm    Post subject: GenToo GNOME - Emerge error Reply with quote

I am bran new to linux and GenToo. As a beginner, i have been advised to take a crash course with a GenToo install. I have gotten through the base install and, hopefully, most of the way through my GNOME install. However, i have hit a bit of a wall when emerging GNOME.

Before I get to the error, i should note that this is a Virtual Machine using VMware Workstation. If there is any specifics about my build thus far that would help in troubleshooting, please let me know and i will try to provide them as best as I can.

I am following this link for installation: https://wiki.gentoo.org/wiki/GNOME/GNOME_Without_systemd

I am at the point where i run the "emerge --ask --verbose --keep-going gnome-base/gnome" command and have all but 3 packages successfully installed. I have tried to re-emerge multiple times with the same results, as well as emerging packages individually. Reading through, it looks like its mainly to do with the "gnome-builder", as the other 2 packages seem to essentially be dependent on that install first.

Any advice on this matter would be greatly appreciated!! Thanks in advance!


The following is the messages i'm receiving:

Makefile:1858: recipe for target 'libide-1.0.la' failed
make[3]: *** [libide-1.0.la] Aborted
make[3]: Leaving directory '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4/libide'
Makefile:1543: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4/libide'
Makefile:636: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4'
Makefile:568: recipe for target 'all' failed
make: *** [all] Error 2
* ERROR: gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20'`,
* the complete build log and the output of `emerge -pqv '=gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20'`.
* The complete build log is located at '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/environment'.
* Working directory: '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4'
* S: '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4'

>>> Failed to emerge gnome-extra/gnome-builder-3.20.4, Log file:

>>> '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/build.log'
*** Resuming merge...

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB
* emerge --keep-going: gnome-base/gnome-extra-apps-3.20.0 dropped because it
* requires >=gnome-extra/gnome-builder-3.20.0
* emerge --keep-going: gnome-base/gnome-3.20.0 dropped because it requires
* >=gnome-base/gnome-extra-apps-3.20.0

* Messages for package gnome-extra/gnome-builder-3.20.4:

* ERROR: gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20'`,
* the complete build log and the output of `emerge -pqv '=gnome-extra/gnome-builder-3.20.4::dantrell-gnome-3-20'`.
* The complete build log is located at '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/environment'.
* Working directory: '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4'
* S: '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/work/gnome-builder-3.20.4'

* Messages for package gnome-base/gnome-extra-apps-3.20.0:

* emerge --keep-going: gnome-base/gnome-extra-apps-3.20.0 dropped because it
* requires >=gnome-extra/gnome-builder-3.20.0

* Messages for package gnome-base/gnome-3.20.0:

* emerge --keep-going: gnome-base/gnome-3.20.0 dropped because it requires
* >=gnome-base/gnome-extra-apps-3.20.0
*
* The following 3 packages have failed to build, install, or execute
* postinst:
*
* (gnome-extra/gnome-builder-3.20.4:0/0::dantrell-gnome-3-20, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/gnome-extra/gnome-builder-3.20.4/temp/build.log'
* (gnome-base/gnome-extra-apps-3.20.0:3.0/3.0::dantrell-gnome-3-20, ebuild scheduled for merge)
* (gnome-base/gnome-3.20.0:2.0/2.0::dantrell-gnome-3-20, ebuild scheduled for merge)
*
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 528
Location: Earth

PostPosted: Tue Jul 26, 2016 9:32 pm    Post subject: Re: GenToo GNOME - Emerge error Reply with quote

Razor0068 wrote:
I am bran new to linux and GenToo.

Welcome to Gentoo! :)

Razor0068 wrote:
I am following this link for installation: https://wiki.gentoo.org/wiki/GNOME/GNOME_Without_systemd

I am at the point where i run the "emerge --ask --verbose --keep-going gnome-base/gnome" command and have all but 3 packages successfully installed.

Just two things:

1. GNOME Without Systemd is technically Unsupported Software but it is stickied under Documentation, Tips & Tricks. This means it is not supported by Gentoo and therefore all issues should be directed to me through the relevant support thread (which also includes my direct contact information if needed).

2. When sharing build logs, either wrap them in code tags if they are short or link them with an external resource such as bpaste.

That said, your issue has been resolved so sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Razor0068
n00b
n00b


Joined: 26 Jul 2016
Posts: 10

PostPosted: Wed Jul 27, 2016 1:02 pm    Post subject: Reply with quote

My apologies, I was unaware that this install of GNOME fell under you. I will be sure to post any other questions in that thread. And thanks for fixing the issue! I honestly though it was something wrong with my build. This being my very first GenToo and GUI install, it hasn't exactly gone error free!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum