Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot start www-client/chromium-52.0.2743.82 as normal user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Azimoth
n00b
n00b


Joined: 24 Jul 2016
Posts: 34

PostPosted: Sun Jul 24, 2016 8:55 pm    Post subject: Cannot start www-client/chromium-52.0.2743.82 as normal user Reply with quote

Hi everyone,

I'm new to Gentoo and not sure this is really a Portage question, but it felt closest to me, since it occured after a stable update without (actively) changing use flags.

Since I updated to www-client/chromium-52.0.2743.82 (stable) I cannot launch chromium as a normal user.
Running Chromium as root is no problem, but not what I want to do during my everyday usage.

This is not covered by bugreport 589330. The post therein is what I wrote earlier and was told this was NOT the right place to discuss my problem.

Code:
$ chromium
bash: /usr/bin/chromium: permission denied


The first thing I found searching for "chromium" and "permission denied" was this gentoo wiki entry, where ffmpeg was blamed. Of course this error looked different than mine, but I noticed that the "system-ffmpeg" flag was set, and I think that was not the case before the update so I reinstalled Chromium with "-system-ffmpeg".

Unfortunately that did not change anything.

Here's what the error message said and what I tried to solve this problem:

When I checked the permissions I found

Code:
$ ls -las /usr/bin/chromium
lrwxrwxrwx 1 root root 48 23. Jul 05:02 /usr/bin/chromium -> /usr/lib64/chromium-browser/chromium-launcher.sh


looking at this chromium-laucher.sh

Code:
$ ls -las /usr/lib64/chromium-browser/chromium-launcher.sh
4 -rw-r-x--- 1 root root 1201 23. Jul 05:02 /usr/lib64/chromium-browser/chromium-launcher.sh


I tried to fix this with

Code:
$ sudo chmod 655 /usr/lib64/chromium-browser/chromium-launcher.sh


which lead to

Code:
$ chromium
/usr/bin/chromium: Line 7: /etc/chromium/default: permission denied
/usr/bin/chromium: Line 39: /usr/lib64/chromium-browser/chrome: permission denied
/usr/bin/chromium: Line 39: exec: /usr/lib64/chromium-browser/chrome: cannot execute: permission denied


Fixing that with

Code:
$ sudo chmod 655 /etc/chromium/default

and
Code:
sudo chmod 655 /usr/lib64/chromium-browser/chrome


lead to

Code:

$ chromium
[0724/215930:ERROR:icu_util.cc(179)] Invalid file descriptor to ICU data received.
[0724/215930:FATAL:content_main_runner.cc(693)] Check failed: base::i18n::InitializeICU().
#0 0x55ea96cec13e <unknown>
#1 0x55ea96d0183e <unknown>
#2 0x55ea96cbae60 <unknown>
#3 0x55ea96cb937d <unknown>
#4 0x55ea9684ea4a ChromeMain
#5 0x7f8ba8543620 __libc_start_main
#6 0x55ea9684e909 _start

aborted


Does anyone have any idea how to fix this? Downgrading does not seem to be an option, since eix says there's no older version...

PS: The output of "emerge --info chromium"

Code:
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.22-r4, 4.6.4-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.6.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-2620M_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    16336108 total,   9298668 free
KiB Swap:   17825788 total,  17825788 free
Timestamp of repository gentoo: Sun, 24 Jul 2016 10:30:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

c2p-overlay
    location: /var/lib/layman/c2p-overlay
    masters: gentoo
    priority: 50

didactic-duck
    location: /var/lib/layman/didactic-duck
    masters: gentoo
    priority: 50

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://ftp-stud.hs-esslingen.de/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes airplay alsa amd64 avx berkdb bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dlna dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ieee1394 introspection ipv6 jack jpeg lcms ldap libnotify libsecret lirc mad mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit popcnt ppds pulseaudio qt3support qt4 readline sdl seccomp session spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upnp upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes airplay avx bluetooth dlna ieee1394 jack lirc mmx mmxext mp3 popcnt pulseaudio sse sse2 sse3 sse4_1 sse4_2 ssse3 upnp" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" L10N="de en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

www-client/chromium-52.0.2743.82::gentoo was built with the following:
USE="cups gnome gnome-keyring hangouts (pic) proprietary-codecs pulseaudio tcmalloc widevine -custom-cflags (-gn) (-gtk3) -hidpi -hotwording -kerberos (-neon) (-selinux) -system-ffmpeg -test" ABI_X86="64" L10N="de -am -ar -bg -bn -ca -cs -da -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW"
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6781

PostPosted: Tue Jul 26, 2016 2:58 am    Post subject: Reply with quote

Your filesystem permissions sound seriously messed up.

Post the output of this, it should be empty on an average system:
Code:
find /usr/lib64 -type f -! -perm /o=rwx -ls
Back to top
View user's profile Send private message
Azimoth
n00b
n00b


Joined: 24 Jul 2016
Posts: 34

PostPosted: Tue Jul 26, 2016 11:50 am    Post subject: Reply with quote

I... erm... must admit I found the origin of my problem...

when I first installed Firefox on my system I came across this explanation of a simple sandbox.
So I put Firefox and later Chromium in a "sandbox". When I noticed I could not hear any audio from inside the sandbox, I reverted everything, but I forgot about the
files for Chromium and Firefox in /etc/portage/env/www-client/ which contained the following code:

Code:
echo 'post_src_install() {
  chmod -R u-x,g-w,o-o ${D}
  chown -R root:chromium ${D}
}' > /etc/portage/env/www-client/chromium


After removing these two files and re-emerging Chromium and Firefox both run flawlessly again. :oops:

Had Firefox been the first browser, which was updated, I would have had the same problem there (in fact, I had, when I tested my hypothesis regarding these files).

But thanks a lot for your help anyways!


Bonus-Question:

Now the only output of
Code:
find /usr/lib64 -type f -! -perm /o=rwx -ls
is

Code:
40 -rwxr-x---   1  root     dropbox     40184 Jul 14 18:08 /usr/lib64/nautilus/extensions-3.0/libnautilus-dropbox.so


Should I do something about this? If so... what?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum