Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Plasma Clock widget does not show date
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Fri Sep 23, 2016 7:28 pm    Post subject: Reply with quote

Hello thumper,

I changed my /etc/portage/make.conf to this:
Code:
LINGUAS="nl nl_NL"
L10N="nl nl_NL"


After that I did a emerge -avuDN @world and a etc-update.

No changes at all, still same error and no date in the clock.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Fri Sep 23, 2016 9:06 pm    Post subject: Reply with quote

Did you enter the command 'env-update && source /etc/profile' after the commands 'locale-gen' and 'eselect locale set <n> (where <n> is the locale you want to use)? See the Gentoo Wiki - Localization Guide for details.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Mon Sep 26, 2016 7:34 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

No, I did not. So, in order to follow your advise I did following:

Before the command 'env-update && source /etc/profile' >
Code:
eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   nl_NL@euro
  [ ]   (free form)


After the command 'env-update && source /etc/profile'
Code:
eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   nl_NL@euro
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   POSIX
  [ ]   (free form)


So we made some improvement :D

Also emerge is not complaining anymore:
Code:
emerge -avuDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

Nothing to merge; quitting.


But still no date in my digital clock.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Thu Sep 29, 2016 12:15 pm    Post subject: Reply with quote

Well, at least your installation's locale configuration is now fixed.

I can reproduce your problem with the missing date if I reduce the height of the Panel slightly. I know it's a daft question, but I still have to ask it, if only to rule it out: Have you tried increasing the height of the Panel to see if the date reappears?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Sun Oct 02, 2016 6:07 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

I was a little to enthusiastic. The error is back again. Let me explain my procedure:

- I start my computer;
- It boots into the command line (so no kdm, xdm or what ever);
- I login with my normal user account;
- I su to root;
- Then I execute:
Code:
eselect locale list

- Result:
Code:

Available targets for the LANG variable:
  [1]   C
  [2]   nl_NL@euro
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   POSIX
  [ ]   (free form)

- After this I exit back to my normal account;
- Then I start KDE wtih startx;
- After KDE is up and running, I start a xterm window;
- In this xterm window I su to root;
- Then I execute:
Code:
eselect locale list

- Result:
Code:

/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   nl_NL@euro
  [ ]   (free form)

- After running
Code:

env-update && source /etc/profile
>>> Regenerating /etc/ld.so.cache...

- The error is not present anymore until I reboot again.

8O 8O

Quote:
I can reproduce your problem with the missing date if I reduce the height of the Panel slightly. I know it's a daft question, but I still have to ask it, if only to rule it out: Have you tried increasing the height of the Panel to see if the date reappears?


Yes I did, up til a height of prox. 5cm. No improvement.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Sat Oct 08, 2016 5:34 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Are you still available?
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Sat Oct 08, 2016 6:42 pm    Post subject: Reply with quote

GenHeDi wrote:
Hello thumper,

I changed my /etc/portage/make.conf to this:
Code:
LINGUAS="nl nl_NL"
L10N="nl nl_NL"


After that I did a emerge -avuDN @world and a etc-update.

No changes at all, still same error and no date in the clock.

That should be:

Code:
LINGUAS="nl nl_NL"
L10N="nl nl-NL"

Notice the hyphen instead of the underscore in the L10N variable. Here is what mine look like, for example:

Code:
clevow230ss fitzcarraldo # grep "LINGUAS\|L10N" /etc/portage/make.conf
LINGUAS="en en_GB pt_BR es_ES"
L10N="en en-GB pt-BR es-ES"


You'll need to fix that and rebuild again.

2016-06-23-l10n-use_expand wrote:

Title L10N USE_EXPAND variable replacing LINGUAS
Author Mart Raudsepp <leio@gentoo.org>
Author Ulrich Müller <ulm@gentoo.org>
Posted 2016-06-19
Revision 1

The L10N variable is replacing LINGUAS as a USE_EXPAND, to avoid a
conceptual clash with the standard gettext LINGUAS behaviour.

L10N controls which extra localization support will be installed.
This is commonly used for downloads of additional language packs.

If you have set LINGUAS in your make.conf, you most likely want to add
its entries also to L10N. Note that while the common two letter language
codes (like "de" or "fr") are identical, more complex entries have a
different syntax because L10N now uses IETF language tags. (For example,
"pt_BR" becomes "pt-BR" and "sr@latin" becomes "sr-Latn".) You can look
up the available codes in profiles/desc/l10n.desc in the gentoo tree.
A detailed description of language tags (aka BCP 47) can be found at:
https://www.w3.org/International/articles/language-tags/

After a transition time for packages to be converted, the LINGUAS
environment variable will maintain the standard gettext behaviour and
will work as expected with all package managers. It controls which
language translations are built and installed. An unset value means all
available, an empty value means none, and a value can be an unordered
list of gettext language codes, with or without country codes. Usually
two letter language codes suffice, but can be narrowed down by country
codes with a "ll_CC" formatting, where "ll" is the language code and
"CC" is the country code, e.g., "en_GB". Some rare languages also have
three letter language codes. Note that LINGUAS does not only affect
installed gettext catalog files (*.mo), but also lines of translations
in an always shipped file (e.g., *.desktop).

If you want English with a set LINGUAS, it is suggested to list it with
the desired country code, in case the default is not the usual "en_US".
It is also common to list "en" then, in case a package is natively
written in a different language, but does provide an English translation
for whichever country. A list of LINGUAS language codes is available at:
http://www.gnu.org/software/gettext/manual/gettext.html#Language-Codes

If you have per-package customizations of the LINGUAS USE_EXPAND, you
should also rename those. This typically means changing linguas_* to
l10n_*, and possibly updating the syntax as described above.

https://wiki.gentoo.org/wiki/Localization/Guide has also been updated to
reflect this change.


Additionally, check if you have the l10N packages installed. For reference, here is what I have in KDE Plasma 5.7.5:

Code:
clevow230ss fitzcarraldo # eix -I l10n             
[I] app-office/libreoffice-l10n
     Available versions:  5.1.4.2^s ~5.2.1.2^s ~5.2.2.2^s {offlinehelp L10N="af am ar as ast be bg bn bn-IN bo br brx bs ca ca-valencia cs cy da de dgo dz el en en-GB en-ZA eo es et eu fa fi fr ga gd gl gu gug he hi hr hu id is it ja ka kk km kmr-Latn kn ko kok ks lb lo lt lv mai mk ml mn mni mr my nb ne nl nn nr nso oc om or pa pl pt pt-BR ro ru rw sa sat sd si sid sk sl sq sr sr-Latn ss st sv sw-TZ ta te tg th tn tr ts tt ug uk uz ve vi xh zh-CN zh-TW zu"}
     Installed versions:  5.1.4.2^s(02:53:33 29/07/16)(-offlinehelp L10N="en en-GB pt-BR -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -de -dgo -dz -el -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu")
     Homepage:            http://www.libreoffice.org
     Description:         Translations for the Libreoffice suite

[I] kde-apps/kde-l10n
     Available versions:  (5) 16.04.3 ~16.08.1
       {debug +handbook L10N="ar ast bg bs ca ca-valencia cs da de el en-GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt-BR ro ru sk sl sr sr-Latn sr-Latn-ijekavsk sr-ijekavsk sv tr ug uk wa zh-CN zh-TW"}
     Installed versions:  16.04.3(5)(16:48:43 22/08/16)(handbook -debug L10N="en-GB pt-BR -ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE internationalization package

[I] kde-apps/kde4-l10n
     Available versions:  (4) 16.04.3 ~16.08.1
       {aqua debug +handbook +minimal test L10N="ar ast bg bs ca ca-valencia cs da de el en-GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt-BR ro ru sk sl sr sr-Latn sr-Latn-ijekavsk sr-ijekavsk sv tr ug uk wa zh-CN zh-TW"}
     Installed versions:  16.04.3(4)(16:58:37 22/08/16)(handbook minimal -aqua -debug -test L10N="en-GB pt-BR -ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE legacy internationalization package

[I] kde-apps/ktp-l10n
     Available versions:  (5) 16.04.3 ~16.08.1
       {debug L10N="ar ast bg bs ca ca-valencia cs da de el en-GB eo es et fi fr ga gl hu ia it ja kk km ko lt mr nb nds nl pa pl pt pt-BR ro ru sk sl sr sr-Latn sr-Latn-ijekavsk sr-ijekavsk sv tr ug uk wa zh-CN zh-TW"}
     Installed versions:  16.04.3(5)(00:31:27 03/09/16)(-debug L10N="en-GB pt-BR -ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -eo -es -et -fi -fr -ga -gl -hu -ia -it -ja -kk -km -ko -lt -mr -nb -nds -nl -pa -pl -pt -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE Telepathy internationalization package

Found 4 matches

Also double-check your locale settings in System Settings > Regional Settings.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Mon Oct 10, 2016 6:17 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

This weekend I performed following update:

KDE Plasma 5.7.5 KDE-Frameworks 5.26.0 and Qt-version 5.6.1 on a 4.4.6 kernel OS-type 64 bit.

After this update, also my clock time disappeared, only showing a gray space 8O .

Next action was to change /etc/portage/make.conf to:
Code:
LINGUAS="nl nl_NL"
L10N="nl nl-NL"


emerge -avuDN @world did not rebuild anything after this change.
Therefore I took a deep breath and performed following commands:
Code:
env-update && source /etc/profile
emerge -avb glibc binutils gcc libtool
emerge -avbke @system
emerge -avbke @world


After several hours compiling, still no luck.
Then I did some try's in the digital clock settings, at the end I checked the box of my system time zone. To my surprise my time and date appeared.
After unchecking the checkbox, the time and date remained visible. After a reboot still visible.

SUCCES !!!!!!!!!!!!!!!!!


But a little problem is still present. After a fresh boot, following error is still appearing:
Code:
eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   nl_NL@euro
  [ ]   (free form)


Below is a overview of the status of the available l10N packages:
Code:
emerge --search l10n   
setlocale: unsupported locale setting
setlocale: unsupported locale setting
 
[ Results for search key : l10n ]
Searching...

*  app-i18n/kde-l10n-scripts [ Masked ]
      Latest version available: 9999
      Latest version installed: [ Not Installed ]
      Size of files: 0 KiB
      Homepage:      https://github.com/vpelcak/kde-scripts
      Description:   Set of scripts to manage KDE translation files
      License:       LGPL-3

*  app-office/calligra-l10n
      Latest version available: 2.9.11
      Latest version installed: [ Not Installed ]
      Size of files: 1566 KiB
      Homepage:      https://www.kde.org/
      Description:   Calligra localization package
      License:       GPL-2

*  app-office/libreoffice-l10n
      Latest version available: 5.1.4.2
      Latest version installed: [ Not Installed ]
      Size of files: 1257 KiB
      Homepage:      http://www.libreoffice.org
      Description:   Translations for the Libreoffice suite
      License:       || ( LGPL-3 MPL-1.1 )

*  dev-java/cal10n
      Latest version available: 0.8.1
      Latest version installed: [ Not Installed ]
      Size of files: 35 KiB
      Homepage:      http://cal10n.qos.ch/
      Description:   java library for writing localized messages using resource bundle
      License:       MIT

*  kde-apps/kde-l10n
      Latest version available: 16.04.3
      Latest version installed: 16.04.3
      Size of files: 13451 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE internationalization package
      License:       GPL-2

*  kde-apps/kde4-l10n
      Latest version available: 16.04.3
      Latest version installed: 16.04.3
      Size of files: 13451 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE legacy internationalization package
      License:       GPL-2

*  kde-apps/kdepim-l10n
      Latest version available: 16.04.3
      Latest version installed: [ Not Installed ]
      Size of files: 13451 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE PIM internationalization package
      License:       GPL-2

*  kde-apps/ktp-l10n
      Latest version available: 16.04.3
      Latest version installed: [ Not Installed ]
      Size of files: 13451 KiB
      Homepage:      http://l10n.kde.org
      Description:   KDE Telepathy internationalization package
      License:       GPL-2

[ Applications found : 8 ]


I double checked /etc/portage/make.conf
Code:
LINGUAS="nl nl_NL"
L10N="nl nl-NL"

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Mon Oct 10, 2016 7:22 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Some additional information (occurs after a logout / login and a fresh reboot):
Code:
locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nl_NL.US-ASCII
LC_CTYPE="nl_NL.US-ASCII"
LC_NUMERIC="nl_NL.US-ASCII"
LC_TIME="nl_NL.US-ASCII"
LC_COLLATE="nl_NL.US-ASCII"
LC_MONETARY="nl_NL.US-ASCII"
LC_MESSAGES="nl_NL.US-ASCII"
LC_PAPER="nl_NL.US-ASCII"
LC_NAME="nl_NL.US-ASCII"
LC_ADDRESS="nl_NL.US-ASCII"
LC_TELEPHONE="nl_NL.US-ASCII"
LC_MEASUREMENT="nl_NL.US-ASCII"
LC_IDENTIFICATION="nl_NL.US-ASCII"
LC_ALL=


After performing env-update && source /etc/profile

Code:
locale
LANG=nl_NL.iso885915@euro
LC_CTYPE="nl_NL.iso885915@euro"
LC_NUMERIC="nl_NL.iso885915@euro"
LC_TIME="nl_NL.iso885915@euro"
LC_COLLATE="nl_NL.iso885915@euro"
LC_MONETARY="nl_NL.iso885915@euro"
LC_MESSAGES="nl_NL.iso885915@euro"
LC_PAPER="nl_NL.iso885915@euro"
LC_NAME="nl_NL.iso885915@euro"
LC_ADDRESS="nl_NL.iso885915@euro"
LC_TELEPHONE="nl_NL.iso885915@euro"
LC_MEASUREMENT="nl_NL.iso885915@euro"
LC_IDENTIFICATION="nl_NL.iso885915@euro"
LC_ALL=

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Tue Oct 11, 2016 1:03 pm    Post subject: Reply with quote

GenHeDi wrote:
But a little problem is still present. After a fresh boot, following error is still appearing:

Code:
eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.iso885915@euro *
  [4]   nl_NL.utf8
  [5]   nl_NL@euro
  [ ]   (free form)

It's more than a 'little problem'; something is still not right in your installation! Perhaps your problem is due to the fact that you have selected a locale that does not exist in /usr/share/i18n/SUPPORTED:

Code:
# grep -i nl /usr/share/i18n/SUPPORTED
fy_NL UTF-8
li_NL UTF-8
nds_NL UTF-8
nl_AW UTF-8
nl_BE.UTF-8 UTF-8
nl_BE ISO-8859-1
nl_BE@euro ISO-8859-15
nl_NL.UTF-8 UTF-8
nl_NL ISO-8859-1
nl_NL@euro ISO-8859-15


Try selecting a locale that does exist in /usr/share/i18n/SUPPORTED (then re-run the 'env-update && source /etc/profile' command and reboot):

Code:
# eselect locale set nl_NL@euro

Does that get rid of the error messages?

Also try selecting nl_NL.utf8 to see what happens in that case.

I don't know why 'eselect locale list' returns 'nl_NL.utf8' instead of 'nl_NL.UTF-8' in your case if you have specified 'nl_NL.UTF-8 UTF-8' in the file /etc/locale.gen. Here is what I get, for example:

Code:
clevow230ss fitzcarraldo # grep -v ^# /etc/locale.gen


en_GB ISO-8859-1
en_GB.UTF-8 UTF-8
pt_BR ISO-8859-1
pt_BR.UTF-8 UTF-8
es_ES ISO-8859-1
es_ES.UTF-8 UTF-8

clevow230ss fitzcarraldo # eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   en_GB
  [4]   en_GB.iso88591
  [5]   en_GB.utf8
  [6]   es_ES
  [7]   es_ES.iso88591
  [8]   es_ES.utf8
  [9]   pt_BR
  [10]  pt_BR.iso88591
  [11]  pt_BR.utf8
  [12]  spanish
  [13]  en_GB.UTF-8 *
  [ ]   (free form)

Notice that en_GB.UTF-8 exists in /etc/locale.gen (and was used by the command 'locale-gen'). Notice also that en_GB.UTF-8 exists in the output of 'eselect locale list' in my case, not just 'en_GB.utf8'. Notice also that I selected 'en_GB.UTF-8' with the 'eselect locale set' command.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Thu Oct 13, 2016 7:19 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Code:
 # grep -v ^# /etc/locale.gen

nl_NL.UTF-8 UTF-8
nl_NL@euro ISO-8859-15

# eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   nl_NL@euro
  [3]   nl_NL.iso885915@euro
  [4]   nl_NL.utf8 *
  [5]   POSIX
  [ ]   (free form)


I have selected nl_NL.utf8 and will do a reboot now.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Thu Oct 13, 2016 7:33 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Right after reboot before startx
Code:
# locale
LANG=nl_NL.utf8
LC_CTYPE="nl_NL.utf8"
LC_NUMERIC="nl_NL.utf8"
LC_TIME="nl_NL.utf8"
LC_COLLATE="nl_NL.utf8"
LC_MONETARY="nl_NL.utf8"
LC_MESSAGES="nl_NL.utf8"
LC_PAPER="nl_NL.utf8"
LC_NAME="nl_NL.utf8"
LC_ADDRESS="nl_NL.utf8"
LC_TELEPHONE="nl_NL.utf8"
LC_MEASUREMENT="nl_NL.utf8"
LC_IDENTIFICATION="nl_NL.utf8"
LC_ALL=


After startx and KDE is running
Code:
# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nl_NL.US-ASCII
LC_CTYPE="nl_NL.US-ASCII"
LC_NUMERIC="nl_NL.US-ASCII"
LC_TIME="nl_NL.US-ASCII"
LC_COLLATE="nl_NL.US-ASCII"
LC_MONETARY="nl_NL.US-ASCII"
LC_MESSAGES="nl_NL.US-ASCII"
LC_PAPER="nl_NL.US-ASCII"
LC_NAME="nl_NL.US-ASCII"
LC_ADDRESS="nl_NL.US-ASCII"
LC_TELEPHONE="nl_NL.US-ASCII"
LC_MEASUREMENT="nl_NL.US-ASCII"
LC_IDENTIFICATION="nl_NL.US-ASCII"
LC_ALL=


What is causing this change???

More information
Code:
# eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.iso885915@euro
  [4]   nl_NL.utf8 *
  [5]   nl_NL@euro
  [ ]   (free form)


Also
Code:
# grep -i nl /usr/share/i18n/SUPPORTED
fy_NL UTF-8
li_NL UTF-8
nds_NL UTF-8
nl_AW UTF-8
nl_BE.UTF-8 UTF-8
nl_BE ISO-8859-1
nl_BE@euro ISO-8859-15
nl_NL.UTF-8 UTF-8
nl_NL ISO-8859-1
nl_NL@euro ISO-8859-15

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Thu Oct 13, 2016 9:34 pm    Post subject: Reply with quote

What does the file /etc/env.d/02locale contain? Here are the contents of that file on my laptop, for example:

Code:
# Configuration file for eselect
# This file has been automatically generated.
LANG="en_GB.UTF-8"
LC_COLLATE="C"


Also, do you have any language- or locale-related commands or settings in ~/.bashrc, ~/.xinitrc, ~/.xprofile (or any other login files)?

Are you using OpenRC or systemd?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Mon Oct 17, 2016 9:39 am    Post subject: Reply with quote

Hello Fitzcarraldo,

Code:
# cat /etc/env.d/02locale
# Configuration file for eselect
# This file has been automatically generated.
LANG="nl_NL.utf8"


Code:
# cat /home/GenHeDi/.bashrc
# /etc/skel/.bashrc
#
# This file is sourced by all *interactive* bash shells on startup,
# including some apparently interactive shells such as scp and rcp
# that can't tolerate any output.  So make sure this doesn't display
# anything or bad things will happen !


# Test for an interactive shell.  There is no need to set anything
# past this point for scp and rcp, and it's important to refrain from
# outputting anything in those cases.
if [[ $- != *i* ]] ; then
        # Shell is non-interactive.  Be done now!
        return
fi


# Put your fun stuff here.


Code:
# cat /home/GenHeDi/.xinitrc
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startkde


Code:
# cat /home/GenHeDi/.xprofile
cat: /home/GenHeDi/.xprofile: No such file or directory


For the rest I am not aware of any other login files.

I use OpenRC.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Thu Nov 03, 2016 6:16 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Are you still available?
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Fri Nov 04, 2016 10:26 pm    Post subject: Reply with quote

What is the output of the following two commands?:

Code:
# eix -I kde4-l10n

Code:
# eix -I kde-l10n

(You will need to install eix and use the eix-update command to update eix's index file.)

If you reboot, start Plasma 5 and select 'System Settings' > 'Regional Settings':

a) which languages are listed under 'Available Languages' and which languages are listed under 'Preferred Languages' on the 'Translations' page?

b) what is selected for 'Region' on the 'Formats' page?

c) what is selected for 'Default Language' on the 'Spell Check' page?

d) which Time Zone is selected on the 'Date & Time' page?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Thu Nov 10, 2016 5:05 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

Code:
eix -I kde4-l10n
[I] kde-apps/kde4-l10n
     Available versions:  (4) 16.04.3{tbz2} ~16.08.2
       {aqua debug +handbook +minimal test L10N="ar ast bg bs ca ca-valencia cs da de el en-GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt-BR ro ru sk sl sr sr-Latn sr-Latn-ijekavsk sr-ijekavsk sv tr ug uk wa zh-CN zh-TW"}
     Installed versions:  16.04.3(4){tbz2}(03:48:39 10/10/16)(handbook minimal -aqua -debug -test L10N="nl -ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -en-GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nn -pa -pl -pt -pt-BR -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE legacy internationalization package


Code:
eix -I kde-l10n
[I] kde-apps/kde-l10n
     Available versions:  (5) 16.04.3{tbz2} ~16.08.2
       {debug +handbook L10N="ar ast bg bs ca ca-valencia cs da de el en-GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt-BR ro ru sk sl sr sr-Latn sr-Latn-ijekavsk sr-ijekavsk sv tr ug uk wa zh-CN zh-TW"}
     Installed versions:  16.04.3(5){tbz2}(01:16:49 10/10/16)(handbook -debug L10N="nl -ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -en-GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nn -pa -pl -pt -pt-BR -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE internationalization package


a) Available Languages > American English
Preferred Languages > Nederlands (that is Dutch)

b) Region > No change

c) Default Language > Nederlands (Nederland)

d) Time Zone > Area; Amsterdam
Region; Euope/Nederland
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Fri Nov 11, 2016 2:06 am    Post subject: Reply with quote

Well, for 'Region' you should select 'Nederland - Nederlands (nl_NL)' instead of 'No change'.

However, I don't think that will solve the fundamental problem you are seeing, namely:

GenHeDi wrote:
After startx and KDE is running
Code:
# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nl_NL.US-ASCII
LC_CTYPE="nl_NL.US-ASCII"
LC_NUMERIC="nl_NL.US-ASCII"
LC_TIME="nl_NL.US-ASCII"
LC_COLLATE="nl_NL.US-ASCII"
LC_MONETARY="nl_NL.US-ASCII"
LC_MESSAGES="nl_NL.US-ASCII"
LC_PAPER="nl_NL.US-ASCII"
LC_NAME="nl_NL.US-ASCII"
LC_ADDRESS="nl_NL.US-ASCII"
LC_TELEPHONE="nl_NL.US-ASCII"
LC_MEASUREMENT="nl_NL.US-ASCII"
LC_IDENTIFICATION="nl_NL.US-ASCII"
LC_ALL=

I'm not certain why you're seeing the above after you start Plasma 5, but my suspicion is that it has something to do with the fact that 'eselect locale list' lists 'nl_NL.utf8' but not 'nl_NL.UTF-8' before you start Plasma 5 (both 'en_GB.utf8' and 'en_GB.UTF-8' are reported in my case). I suggest you try the following experiment:


1. Edit /etc/locale.gen so that it contains only the line:

Code:
nl_NL.UTF-8 UTF-8

2. Create the locale support files for the nl_NL.UTF-8 locale:

Code:
# localedef -c -i nl_NL -f UTF-8 nl_NL.UTF-8

3. Follow the usual steps in the Gentoo Localisation Guide:

Code:
# locale-gen
# eselect locale list
# eselect locale set nl_NL.UTF-8
# env-update && source /etc/profile
# cat /etc/env.d/02locale


Another possibility is that you are building KDE on a different machine to the machine you are running it on (I notice that the output of the eix commands you posted has '16.04.3{tbz2}' whereas the output of the eix commands in my case is '16.04.3') and one of the machines has a different locale configuration. Are you doing that, by any chance?

A couple of other questions: Are you using '--with-bdeps=y' as well as '--update' '--deep' and '--newuse' when you merge @world? Which version of glibc are you using?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Fri Nov 11, 2016 5:13 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

That is strange because I am only using one computer for Gentoo (including the compiling), not even various distributions on this one.

This is my emerge use during updates:
Code:
emerge -avuDN @world


And my make.conf contains:
Code:
EMERGE_DEFAULT_OPTS="--with-bdeps=y"


glibc version:
Code:
eix -I glibc   
[I] sys-libs/glibc
     Available versions:  (2.2) 2.17^s ~2.18-r1^s 2.19-r1^s 2.20-r2^s 2.21-r2^s 2.22-r4^s{tbz2} ~2.23-r1^s ~2.23-r2^s **9999^s
       {audit caps debug gd hardened multilib nscd profile +rpc selinux suid systemtap vanilla CROSSCOMPILE_OPTS="headers-only"}
     Installed versions:  2.22-r4(2.2)^s{tbz2}(18:26:09 10/09/16)(multilib -debug -gd -hardened -nscd -profile -selinux -suid -systemtap -vanilla CROSSCOMPILE_OPTS="-headers-only")
     Homepage:            https://www.gnu.org/software/libc/libc.html
     Description:         GNU libc6 (also called glibc2) C library


I will perform next Sunday you proposed experiment. Unfortunately, I have a tight schedule lately.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Sun Nov 13, 2016 7:21 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

I performed your proposed experiment:

After a fresh reboot and after a login with my normal user-account in a terminal:
Code:
# locale
LANG=nl_NL.UTF-8
LC_CTYPE="nl_NL.UTF-8"
LC_NUMERIC="nl_NL.UTF-8"
LC_TIME="nl_NL.UTF-8"
LC_COLLATE="nl_NL.UTF-8"
LC_MONETARY="nl_NL.UTF-8"
LC_MESSAGES="nl_NL.UTF-8"
LC_PAPER="nl_NL.UTF-8"
LC_NAME="nl_NL.UTF-8"
LC_ADDRESS="nl_NL.UTF-8"
LC_TELEPHONE="nl_NL.UTF-8"
LC_MEASUREMENT="nl_NL.UTF-8"
LC_IDENTIFICATION="nl_NL.UTF-8"
LC_ALL=


Then startx and KDE starts.
When KDE is running, I open a Konsole.
Code:
# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nl_NL.US-ASCII
LC_CTYPE="nl_NL.US-ASCII"
LC_NUMERIC="nl_NL.US-ASCII"
LC_TIME="nl_NL.US-ASCII"
LC_COLLATE="nl_NL.US-ASCII"
LC_MONETARY="nl_NL.US-ASCII"
LC_MESSAGES="nl_NL.US-ASCII"
LC_PAPER="nl_NL.US-ASCII"
LC_NAME="nl_NL.US-ASCII"
LC_ADDRESS="nl_NL.US-ASCII"
LC_TELEPHONE="nl_NL.US-ASCII"
LC_MEASUREMENT="nl_NL.US-ASCII"
LC_IDENTIFICATION="nl_NL.US-ASCII"
LC_ALL=


So, unfortunately no improvement.

my locale.gen contains at this moment:
Code:
# cat /etc/locale.gen
nl_NL.UTF-8 UTF-8


Also:
Code:
# eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_COLLATE to default locale: No such file or directory
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   nl_NL.utf8
  [4]   nl_NL.UTF-8 *
  [ ]   (free form)

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Sun Nov 13, 2016 11:29 pm    Post subject: Reply with quote

Hmm... KDE is still overriding the standard locale settings. What does the file ~/.config/plasma-locale-settings.sh contain in your case? In mine, it contains the following:

Code:
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=en_GB.UTF-8
export LANGUAGE=en_GB:en_US

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Mon Nov 14, 2016 7:43 pm    Post subject: Reply with quote

Hello Fitzcarraldo,

I think we found the leak.

Code:
#cat ~/.config/plasma-locale-settings.sh
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=nl_NL.US-ASCII
export LANGUAGE=nl


Your assumption seems to be right. I'm not sure what is causing this override.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Tue Nov 15, 2016 12:56 am    Post subject: Reply with quote

Try the following:

Code:
$ mv ~/.config/plasma-locale-settings.sh ~/.config/plasma-locale-settings.sh.bak

Then log out of Plasma 5, log in again and check the locale in Konsole:

Code:
$ locale


I think the problem occurs because the packages kde-apps/kde-l10n and kde-apps/kde4-l10n do not include the locale nl_NL, only nl (which, by default, is Netherlands' Dutch):

https://packages.gentoo.org/packages/kde-apps/kde-l10n

https://packages.gentoo.org/packages/kde-apps/kde4-l10n

You could instead edit ~/.config/plasma-locale-settings.sh so it contains the following:

Code:
export LANG=nl_NL.UTF-8
export LANGUAGE=nl

Then log out of Plasma 5, log in again and check the locale in Konsole.

Try also:

Code:
export LANG=nl_NL.UTF-8
export LANGUAGE=nl_NL


If you use 'System Settings' > 'Regional Settings' to make any changes, that would probably overwrite ~/.config/plasma-locale-settings.sh and your problem would then reoccur if its contents revert to the contents you posted.

Another thing you could try would be to edit /etc/portage/make.conf to contain:

Code:
LINGUAS="nl"
L10N="nl"

then rebuild all the packages that use LINGUAS and L10N, and then repeat the steps in the Gentoo Localisation Guide:

Code:
# locale-gen
# eselect locale list
# eselect locale set <n>
# env-update && source /etc/profile
# cat /etc/env.d/02locale

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Tue Nov 15, 2016 5:23 pm    Post subject: Reply with quote

In order to prevent a total rebuild, how can I select and rebuild only the involved packages?
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 122

PostPosted: Tue Nov 15, 2016 5:45 pm    Post subject: Reply with quote

By the way, I already modified my /etc/portage/make.conf according to your directions a while ago:

Code:
LINGUAS="nl nl_NL"
L10N="nl nl-NL"


After this modification I performed following commands:
Code:
env-update && source /etc/profile
emerge -avb glibc binutils gcc libtool
emerge -avbke @system
emerge -avbke @world


So I doubt if it is necessary to rebuild again. But correct me if I am wrong.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum