Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
networkmanager-1.2.2 and plasma5-nm-5.7.2 wifi EAP no worky
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
rburcham
Apprentice
Apprentice


Joined: 20 Mar 2003
Posts: 223

PostPosted: Fri Jul 22, 2016 4:08 pm    Post subject: networkmanager-1.2.2 and plasma5-nm-5.7.2 wifi EAP no worky Reply with quote

There has been a year long on again off again weirdness between plasma5-nm and networkmanager revisions in which credentials passed from the plasma5 nm widget to networkmanager "don't quit get there," with the net effect of repeated nm popups for credentials and no connection.

Currently it looks like networkmanager-1.2.2 re-introduces this regression. Rolling back networkmanager and its plugins to 1.0.8 seems to resolve the issue for me. I masked the offending versions and re-emerged networkmanager and its plugins.

Code:
# cat /etc/portage/package.mask
=net-misc/networkmanager-1.2.2
=net-misc/networkmanager-openvpn-1.2.2
=net-misc/networkmanager-openconnect-1.2.2
=net-misc/networkmanager-vpnc-1.2.2


Anyone else see this?
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sun Jul 31, 2016 2:13 pm    Post subject: Reply with quote

On my installation it seems like version 1.0.12-r1 of networkmanager is the latest stable version in the portage tree (after emerge --sync)

Code:
*  net-misc/networkmanager
      Latest version available: 1.0.12-r1
      Latest version installed: 1.0.12-r1


I am contemplating an upgrade to KDE Plasma 5. But I hesitate since I see quite many posts with problems after the upgrade. What is your experience in general of KDE Plasma 5?
_________________
/Phil
Back to top
View user's profile Send private message
patter
n00b
n00b


Joined: 01 Aug 2016
Posts: 3

PostPosted: Tue Aug 02, 2016 3:08 pm    Post subject: Re: networkmanager-1.2.2 and plasma5-nm-5.7.2 wifi EAP no wo Reply with quote

rburcham wrote:
There has been a year long on again off again weirdness between plasma5-nm and networkmanager revisions in which credentials passed from the plasma5 nm widget to networkmanager "don't quit get there," with the net effect of repeated nm popups for credentials and no connection.

Currently it looks like networkmanager-1.2.2 re-introduces this regression. Rolling back networkmanager and its plugins to 1.0.8 seems to resolve the issue for me. I masked the offending versions and re-emerged networkmanager and its plugins.

Code:
# cat /etc/portage/package.mask
=net-misc/networkmanager-1.2.2
=net-misc/networkmanager-openvpn-1.2.2
=net-misc/networkmanager-openconnect-1.2.2
=net-misc/networkmanager-vpnc-1.2.2


Anyone else see this?



I've seen it as well. Fortunately using wpa_supplicant & dhcpcd directly works. Good thing I just use the gentoo laptop at home or editing wpa_supplicant.conf would get irritating.

Could be worth trying wicd & one of its X11 interfaces instead of network manager?
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6737
Location: Blighty

PostPosted: Tue Aug 02, 2016 3:50 pm    Post subject: Reply with quote

Or, dare I say, dhcpcd-gtk or dhcpcd-qt :)
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1635
Location: United Kingdom

PostPosted: Tue Aug 02, 2016 4:30 pm    Post subject: Reply with quote

I am using kde-plasma/plasma-nm-5.7.2 with net-misc/networkmanager-1.2.2. Every time I logged in to Plasma 5 I had to click on the plasma-nm applet's icon on the System Tray and manually connect to the Wi-Fi network, even though I had used the applet's Connection Editor and ticked 'Automatically connect to this network when its available'. That used to work fine with kde-misc/plasma-nm:4. Anyway, I manually edited /etc/NetworkManager/system-connections/FitzWiFi and added 'autoconnect=true' in the '[connection]' section, and now NetworkManager does connect automatically. So something is not right with either plasma-nm-5.7.2 or networkmanager-1.2.2. Probably the former.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
rburcham
Apprentice
Apprentice


Joined: 20 Mar 2003
Posts: 223

PostPosted: Wed Aug 03, 2016 8:18 pm    Post subject: Reply with quote

Yes, you are describing an inability to commit changes to a given config via plasma-nm ui. I have seen this too - in my case the OK button often is grayed out.
Back to top
View user's profile Send private message
patter
n00b
n00b


Joined: 01 Aug 2016
Posts: 3

PostPosted: Sat Aug 06, 2016 8:15 am    Post subject: Reply with quote

I've tried several things with nmcli directly & this seems to be an issue with network manager not receiving/applying password options, rather than solely plasma's nm-applet

Code:

nmcli --ask -p c up EE-BrightBox-djmhb2     
Passwords or encryption keys are required to access the wireless network 'EE-BrightBox-djmhb2'.

Repeatadly prompts for the password

Code:
added to /etc/NetworkManager/system-connections/EE-BrightBox-djmhb2
[802-11-wireless-security]
psk=password-removed

fails with

Code:
nmcli c up EE-BrightBox-djmhb2
Passwords or encryption keys are required to access the wireless network 'EE-BrightBox-djmhb2'.
Warning: password for '802-11-wireless-security.psk' not given in 'passwd-file' and nmcli cannot ask without '--ask' option.
Error: Connection activation failed.


& using nmcli to edit the connection
Code:

nmcli edit connections
nmcli connection edit EE-BrightBox-djmhb2
set 802-11-wireless-security.psk
[type key]
save

gives the same password error.

I've disabled network manager & switched back to purely using wpa_supplicant
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Mon Sep 26, 2016 10:57 pm    Post subject: Reply with quote

I have the same issue. What is more, after every suspend / sleep, I have to restart NetworkManager via
Code:
/etc/init.d/NetworkManager restart
. Afterwards, connecting via the plasma-nm applet is not possible anymore. I can, however, open the connection editor via the wrench symbol in the applet and choose and connect to the desired access point from there.

Automatic connection does not work, as well as any tethering via my phone (it connects via wifi or usb, but I can't use the internet, which seems to be a dns issue).

I guess we are forced to use alpha software or stone age terminal-based connections for now.
Back to top
View user's profile Send private message
proxy
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 260
Location: Chantilly, VA

PostPosted: Sun Oct 09, 2016 4:34 am    Post subject: Reply with quote

Fitzcarraldo wrote:
I am using kde-plasma/plasma-nm-5.7.2 with net-misc/networkmanager-1.2.2. Every time I logged in to Plasma 5 I had to click on the plasma-nm applet's icon on the System Tray and manually connect to the Wi-Fi network, even though I had used the applet's Connection Editor and ticked 'Automatically connect to this network when its available'. That used to work fine with kde-misc/plasma-nm:4. Anyway, I manually edited /etc/NetworkManager/system-connections/FitzWiFi and added 'autoconnect=true' in the '[connection]' section, and now NetworkManager does connect automatically. So something is not right with either plasma-nm-5.7.2 or networkmanager-1.2.2. Probably the former.


I've experienced the same thing. It seems that the new version of kde-plasma/plasma-nm simply removes the autoconnect line if the box is checked. But does include an "autoconnect=false" if the box is unchecked.

So either the app is assuming that no autoconnect entry is effectively "on", but the service disagrees, or the app has a bug where it is forgetting to include that line.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1635
Location: United Kingdom

PostPosted: Sun Oct 09, 2016 1:12 pm    Post subject: Reply with quote

proxy wrote:
Fitzcarraldo wrote:
I am using kde-plasma/plasma-nm-5.7.2 with net-misc/networkmanager-1.2.2. Every time I logged in to Plasma 5 I had to click on the plasma-nm applet's icon on the System Tray and manually connect to the Wi-Fi network, even though I had used the applet's Connection Editor and ticked 'Automatically connect to this network when its available'. That used to work fine with kde-misc/plasma-nm:4. Anyway, I manually edited /etc/NetworkManager/system-connections/FitzWiFi and added 'autoconnect=true' in the '[connection]' section, and now NetworkManager does connect automatically. So something is not right with either plasma-nm-5.7.2 or networkmanager-1.2.2. Probably the former.


I've experienced the same thing. It seems that the new version of kde-plasma/plasma-nm simply removes the autoconnect line if the box is checked. But does include an "autoconnect=false" if the box is unchecked.

So either the app is assuming that no autoconnect entry is effectively "on", but the service disagrees, or the app has a bug where it is forgetting to include that line.

Looking at 'man nm-settings', the default for autoconnect is TRUE. As you say, plasma-nm-5.7.5 inserts 'autoconnect=false' in /etc/NetworkManager/system-connections/eth0 if I untick the box, and removes the autoconnect line entirely if I tick the box. So it appears that plasma-nm-5.7.5 is not at fault; it looks like the problem lies with NetworkManager (I'm now using 1.4.0-r1). See Gentoo Bug Report No. 595806 (net-misc/networkmanager-1.4.0-r1: doesn't automatically activate connections marked with "Automatically connect to this network when it's available"). The work-around, which is not ideal, is to also tick 'All users may connect to this network' in plasma-nm, which modifies the contents of the file /etc/NetworkManager/system-connections/eth0 accordingly. At least that connects automatically.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum