Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] plasma 5 - kmail - xapian - slot conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
virtguru
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2010
Posts: 144
Location: Eire

PostPosted: Thu Jul 21, 2016 8:38 pm    Post subject: [Solved] plasma 5 - kmail - xapian - slot conflicts Reply with quote

would really like to try and get kmail merged , unfortunately running into some slot conflicts and --backtrack isn't helping here. On ~amd64 , this is my primary laptop for work so I'm a bit hesitant to move onto an overlay. Whole reason for this , the good idea fairy decided to move the company exchange to (insert rant) office365 now earlybird and lighting is having massive issues. A colleague mentioned on his arch install kmail is working rather well with korganizer and kontact.

Code:
asgard ~ # emerge kmail --backtrack=30

These are the packages that would be merged, in order:

Calculating dependencies    ... done!
[ebuild     UD ] dev-libs/xapian-1.2.23:0/1.2.22::gentoo [1.4.0:0/30::gentoo] USE="brass chert inmemory -doc -static-libs" CPU_FLAGS_X86="sse sse2" 0 KiB
[ebuild  N     ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="minimal (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-apps/kdepim-common-libs-4.14.11_pre20160211:4/4.14::gentoo  USE="(-aqua) -debug -google" 0 KiB
[ebuild  N     ] kde-apps/kontact-4.14.11_pre20160211:4/4.14::gentoo  USE="handbook (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-apps/korganizer-4.14.11_pre20160211:4/4.14::gentoo  USE="handbook kontact (-aqua) -debug" 0 KiB
[ebuild  N     ] kde-apps/kmail-4.14.11_pre20160211:4/4.14::gentoo  USE="handbook kontact (-aqua) -debug {-test}" 0 KiB

Total: 6 packages (1 downgrade, 5 new), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/xapian:0

  (dev-libs/xapian-1.2.23:0/1.2.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/xapian-1.2*[chert] required by (kde-base/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^                ^^^^

  (dev-libs/xapian-1.4.0:0/30::gentoo, installed) pulled in by
    dev-libs/xapian:0/30= required by (kde-apps/khelpcenter-16.04.3:5/5::gentoo, installed)


Ok so , what am I missing here ? cant really downgrade xapian now that Im on 5.7 without dep hell ?

Code:
asgard ~ # equery d xapian
 * These packages depend on xapian:
kde-apps/khelpcenter-16.04.3 (dev-libs/xapian)
asgard ~ # equery d khelpcenter
 * These packages depend on khelpcenter:
kde-base/kdelibs-4.14.22 (handbook ? kde-apps/khelpcenter)


Last edited by virtguru on Thu Jul 21, 2016 9:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Thu Jul 21, 2016 8:48 pm    Post subject: Reply with quote

You can, it's just that khelpcenter will need a rebuild with the older xapian version.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
virtguru
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2010
Posts: 144
Location: Eire

PostPosted: Thu Jul 21, 2016 9:27 pm    Post subject: Reply with quote

genstorm wrote:
You can, it's just that khelpcenter will need a rebuild with the older xapian version.


awesome genstorm thanks, worked like a charm :D yeah , I over-analyzed a bit (facepalm) still a bit confused with the numeric convention on plasma pulling in the 4.x packages , 16 ~ , 5.7 etc. Silly me was looking into slotting xapian XD.

Now more nail in the coffin for gtk and plus I hopefully now dont have to use the silly 365 interface(ruined my day LOL) Cheers !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum