Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Akonadi fails to emerge with out custom patch SOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Skinjob2707
n00b
n00b


Joined: 07 Aug 2013
Posts: 57

PostPosted: Thu Jul 14, 2016 5:19 pm    Post subject: Akonadi fails to emerge with out custom patch SOLVED Reply with quote

Ever since I upgraded to Plasma 5 I've been unable to compile akonadi or libadkonadi before that without a custom patch. I've gone through:
    libakonadi-15.12.1
    libakonadi-15.12.2
    libakonadi-15.12.3
    akonadi-16.03.90
    akonadi-16.04.0
    akonadi-16.04.1
    akonadi-16.04.2
    akonadi-16.04.3


The patch is:
Code:
--- akonadi-16.03.90/src/core/itempayloadinternals_p.h  2016-04-04 09:26:48.000000000 -0400
+++ akonadi-16.03.90/src/core/itempayloadinternals_p-fixed.h    2016-04-09 14:04:05.730394902 -0400
@@ -44,13 +44,14 @@
 
 // Forward-declare boost::shared_ptr so that we don't have to explicitly include
 // it. Caller that tries to use it will aready have it included anyway
+/*
 namespace boost
 {
 template<typename T> class shared_ptr;
 template<typename T, typename U>
 shared_ptr<T> dynamic_pointer_cast(shared_ptr<U> const &ptr) noexcept;
 }
-
+*/
 namespace Akonadi
 {
 namespace Internal


The relevant section from the build.log
Quote:
In file included from /usr/include/boost-1_51/boost/smart_ptr/shared_ptr.hpp:32:0,
from /usr/include/boost-1_51/boost/shared_ptr.hpp:17,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:33,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/include/boost-1_51/boost/smart_ptr/detail/shared_count.hpp:284:33: warning: ‘template<class> class std::auto_ptr’ is deprecated [-Wdeprecated-declarations]
explicit shared_count( std::auto_ptr<Y> & r ): pi_( new sp_counted_impl_p<Y>(
 ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/memory:81:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:31,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/bits/unique_ptr.h:49:28: note: declared here
template<typename> class auto_ptr;
 ^
In file included from /usr/include/boost-1_51/boost/shared_ptr.hpp:17:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:33,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/include/boost-1_51/boost/smart_ptr/shared_ptr.hpp:146:65: warning: ‘template<class> class std::auto_ptr’ is deprecated [-Wdeprecated-declarations]
template< class T, class R > struct sp_enable_if_auto_ptr< std::auto_ptr< T >, R
 ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/memory:81:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:31,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/bits/unique_ptr.h:49:28: note: declared here
template<typename> class auto_ptr;
 ^
In file included from /usr/include/boost-1_51/boost/shared_ptr.hpp:17:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:33,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/include/boost-1_51/boost/smart_ptr/shared_ptr.hpp:285:30: warning: ‘template<class> class std::auto_ptr’ is deprecated [-Wdeprecated-declarations]
explicit shared_ptr(std::auto_ptr<Y> & r): px(r.get()), pn()
 ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/memory:81:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:31,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/bits/unique_ptr.h:49:28: note: declared here
template<typename> class auto_ptr;
 ^
In file included from /usr/include/boost-1_51/boost/shared_ptr.hpp:17:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:33,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/include/boost-1_51/boost/smart_ptr/shared_ptr.hpp:329:34: warning: ‘template<class> class std::auto_ptr’ is deprecated [-Wdeprecated-declarations]
shared_ptr & operator=( std::auto_ptr<Y> & r )
 ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/memory:81:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:31,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/g++-v5/bits/unique_ptr.h:49:28: note: declared here
template<typename> class auto_ptr;
 ^
In file included from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:51:62: error: declaration of ‘template<class T, class U> boost::shared_ptr<X> boost::dynamic_pointer_cast(const boost::shared_ptr<U>&) noexcept’ has a different exception specifier
shared_ptr<T> dynamic_pointer_cast(shared_ptr<U> const &ptr) noexcept;
 ^
In file included from /usr/include/boost-1_51/boost/shared_ptr.hpp:17:0,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/itempayloadinternals_p.h:33,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/item.h:30,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler_p.h:27,
from /var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3/src/core/asyncselectionhandler.cpp:20:
/usr/include/boost-1_51/boost/smart_ptr/shared_ptr.hpp:531:42: error: from previous declaration ‘template<class T, class U> boost::shared_ptr<X> boost::dynamic_pointer_cast(const boost::shared_ptr<U>&)’
template<class T, class U> shared_ptr<T> dynamic_pointer_cast(shared_ptr<U> const
 ^
make[2]: *** [src/core/CMakeFiles/KF5AkonadiCore.dir/build.make:190: src/core/CMakeFiles/KF5AkonadiCore.dir/asyncselectionhandler.cpp.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/kde-apps/akonadi-16.04.3/work/akonadi-16.04.3_build'
make[1]: *** [CMakeFiles/Makefile2:1130: src/core/CMakeFiles/KF5AkonadiCore.dir/all] Error 2


I suspect the issue is related to the changes for GCC 5.3 C++ standards, but I'm confused that no one else seems to have had the problem.

Thanks in advance for your help!


Last edited by Skinjob2707 on Fri Jul 15, 2016 4:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6823
Location: Austria

PostPosted: Thu Jul 14, 2016 5:41 pm    Post subject: Reply with quote

What version of boost is installed?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Thu Jul 14, 2016 5:45 pm    Post subject: Reply with quote

Code:
/usr/include/boost-1_51/
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6823
Location: Austria

PostPosted: Thu Jul 14, 2016 5:46 pm    Post subject: Reply with quote

If that's the case then the system is seriously broken and was probably never rebuilt after the GCC 5.3.0 switch.

Read news items and keep your system up to date.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Skinjob2707
n00b
n00b


Joined: 07 Aug 2013
Posts: 57

PostPosted: Thu Jul 14, 2016 6:28 pm    Post subject: Reply with quote

Are you referring to these directions? https://wiki.gentoo.org/wiki/Upgrading_from_gcc-4.x_to_gcc-5.x

I did follow them at the time. Saying a system that has been running for at least 6 months this was as seriously broken seems odd. Shouldn't I experience other problems? I actually update ever day or two with no other packages having this sort of problem.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6823
Location: Austria

PostPosted: Thu Jul 14, 2016 6:34 pm    Post subject: Reply with quote

Code:
# equery l -p boost
 * Searching for boost ...
[-P-] [  ] dev-libs/boost-1.55.0-r2:0/1.55.0
[-P-] [  ] dev-libs/boost-1.56.0-r1:0/1.56.0
[-P-] [  ] dev-libs/boost-1.58.0-r1:0/1.58.0
[-P-] [  ] dev-libs/boost-1.59.0:0/1.59.0
[-P-] [  ] dev-libs/boost-1.60.0:0/1.60.0
[IP-] [  ] dev-libs/boost-1.61.0:0/1.61.0


Code:
*boost-1.52.0-r2 (11 Nov 2012)

  11 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> +boost-1.52.0-r2.ebuild,
  -boost-1.46.1-r1.ebuild, -boost-1.51.0-r1.ebuild, -boost-1.52.0-r1.ebuild,
  -files/boost-1.37.0-darwin-long-double.patch,
  -files/boost-1.45.0-lambda_bind.patch, -files/boost-1.46.1-python32.patch,
  -files/point_release_naming_fix.patch, -files/random-Jamfile-1.46.1,
  -files/remove-toolset-1.46.1.patch, metadata.xml:
  Remove old and cleanup files. Bump version 1.52 so that only one set of
  libraries between debug and release is used; add a 'nls' USE flag to disable
  the locale library due to bug #436262 (and right now no package in the tree
  uses it anyway).

2012!

Code:
# eselect news list
[...]
  [38]     2015-10-22  GCC 5 Defaults to the New C++11 ABI
  [39]     2015-12-16  Python ABIFLAGS rebuild needed
  [40]     2016-01-08  Some dhcpcd hooks are now examples
  [41]     2016-01-27  Upgrading Apache from 2.2 to 2.4
  [42]     2016-06-19  L10N USE_EXPAND variable replacing LINGUAS


https://www.gentoo.org/support/news-items/2015-10-22-gcc-5-new-c++11-abi.html
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Skinjob2707
n00b
n00b


Joined: 07 Aug 2013
Posts: 57

PostPosted: Thu Jul 14, 2016 6:48 pm    Post subject: Reply with quote

Here is the output from equery l -p boost on my system:

Code:
[-P-] [  ] dev-libs/boost-1.55.0-r2:0/1.55.0
[-P-] [  ] dev-libs/boost-1.56.0-r1:0/1.56.0
[-P-] [  ] dev-libs/boost-1.58.0-r1:0/1.58.0
[-P-] [  ] dev-libs/boost-1.59.0:0/1.59.0
[-P-] [  ] dev-libs/boost-1.60.0:0/1.60.0
[IP-] [  ] dev-libs/boost-1.61.0:0/1.61.0


Thanks![/code]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6823
Location: Austria

PostPosted: Thu Jul 14, 2016 6:49 pm    Post subject: Reply with quote

...and did you read the news? Does it sound familliar, have you done the required steps?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Skinjob2707
n00b
n00b


Joined: 07 Aug 2013
Posts: 57

PostPosted: Thu Jul 14, 2016 6:55 pm    Post subject: Reply with quote

Yes, I did the required steps. I will do so again, but I'm in the middle of a long KDE emerge.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13493

PostPosted: Fri Jul 15, 2016 12:55 am    Post subject: Reply with quote

If your boost is 1.61.0, how do you have a /usr/include/boost-1_51 directory providing outdated include files? Do you have a stale boost installed in addition to the current one? Did you ever try to install a package outside of Portage?
Back to top
View user's profile Send private message
Skinjob2707
n00b
n00b


Joined: 07 Aug 2013
Posts: 57

PostPosted: Fri Jul 15, 2016 4:31 pm    Post subject: Reply with quote

I have not tried to install a boost package outside of portage. When I checked the package owner (equery belongs) for files in /usr/include/boost-1_51 they had no package owner. Akonadi's Cmake was asking for the minimum version. Apparently the file /usr/share/cpame/modules/FindBoost.cmake determined that to be 1.51. Once I moved the directory out of /usr/include I was able to compile Akonadi without any patches.

Thanks for your help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum