Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] - media-plugins/kipi-plugins-5.0.0 fails to build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Tue Jul 12, 2016 9:29 am    Post subject: [SOLVED] - media-plugins/kipi-plugins-5.0.0 fails to build Reply with quote

Hello,
I was trying to install kipi-plugins:5 (unstable, ~amd64) which has just landed on the portage tree, but it fails with the following compile error:
Code:

......
......
.0/work/digikam-5.0.0/extra/kipi-plugins/common/libkipiplugins/dialogs/kpimagedialog.cpp
/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/digikam-5.0.0/extra/kipi-plugins/common/libkipiplugins/widgets/kpimageslist.cpp: In member function ‘bool KIPIPlugins::KPImagesList::isRawFile(const QUrl&) const’:
/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/digikam-5.0.0/extra/kipi-plugins/common/libkipiplugins/widgets/kpimageslist.cpp:826:39: error: ‘class KIPI::Interface’ has no member named ‘rawFiles’
     QString   rawFilesExt = d->iface->rawFiles();
                                       ^
........
........

ake[2]: *** [common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/widgets/kpimageslist.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/digikam-5.0.0/extra/kipi-plugins/common/libkipiplugins/dialogs/kpimagedialog.cpp: In constructor ‘KIPIPlugins::KPImageDialog::KPImageDialog(QWidget*, bool, bool)’:
/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/digikam-5.0.0/extra/kipi-plugins/common/libkipiplugins/dialogs/kpimagedialog.cpp:316:30: error: ‘class KIPI::Interface’ has no member named ‘rawFiles’
         rawFiles = d->iface->rawFiles();
                              ^
common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/build.make:331: recipe for target 'common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/dialogs/kpimagedialog.cpp.o' failed
make[2]: *** [common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/dialogs/kpimagedialog.cpp.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/kipi-plugins-5.0.0_build'
CMakeFiles/Makefile2:227: recipe for target 'common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/all' failed
make[1]: *** [common/libkipiplugins/CMakeFiles/KF5kipiplugins.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-plugins/kipi-plugins-5.0.0/work/kipi-plugins-5.0.0_build'
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: media-plugins/kipi-plugins-5.0.0::gentoo failed (compile phase):
 *   emake failed

I've found a similar issue in this thread, but the solution to rebuild libkipi before emerging kipi-plugins do not work for me.
Has anyone other suggestion before I file a bug?
Thanks.


Last edited by kite14 on Thu Jul 14, 2016 7:31 am; edited 1 time in total
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Thu Jul 14, 2016 7:29 am    Post subject: [SOLVED] media-plugins/kipi-plugins-5.0.0 fails to build Reply with quote

Marked SOLVED: kipi-plugins-5.0.0 build only against the most recent libkipi (i.e. libkipi-16.04.2) which is keyworded at the moment; I have a stable KDE installation which uses only libkipi-15.12.3.
I'm going to stay stable and wait...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum