Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot configure X.. crashes on intel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ayleid96
n00b
n00b


Joined: 25 Apr 2016
Posts: 51
Location: /home/noodles

PostPosted: Wed Jul 06, 2016 4:18 pm    Post subject: Cannot configure X.. crashes on intel Reply with quote

Hi,

i installed gentoo on lenovo m58p.. when i run X -configure i get this:
Code:

[   237.070]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   237.070] X Protocol Version 11, Revision 0
[   237.070] Build Operating System: Linux 4.4.6-gentoo i686 Gentoo
[   237.070] Current Operating System: Linux linuxpc 4.4.6-gentoo #3 SMP Wed Jul 6 17:25:49 Local time zone must be set--see zic m i686
[   237.070] Kernel command line: auto BOOT_IMAGE=gentoo root=804 i915.enable_execlists=0
[   237.070] Build Date: 03 July 2016  07:10:16PM
[   237.070]
[   237.070] Current version of pixman: 0.32.8
[   237.070]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   237.070] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   237.070] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul  6 18:11:56 2016
[   237.070] (II) Loader magic: 0x8299680
[   237.070] (II) Module ABI versions:
[   237.070]    X.Org ANSI C Emulation: 0.4
[   237.070]    X.Org Video Driver: 19.0
[   237.070]    X.Org XInput driver : 21.0
[   237.070]    X.Org Server Extension : 9.0
[   237.070] (II) xfree86: Adding drm device (/dev/dri/card0)
[   237.072] (--) PCI:*(0:0:2:0) 8086:2e12:17aa:3048 rev 3, Mem @ 0xfc000000/4194304, 0xe0000000/268435456, I/O @ 0x00001c70/8
[   237.072] (--) PCI: (0:0:2:1) 8086:2e13:17aa:3048 rev 3, Mem @ 0xfc400000/1048576
[   237.072] List of video drivers:
[   237.072]    intel
[   237.072]    nouveau
[   237.072]    vesa
[   237.072]    fbdev
[   237.072]    modesetting
[   237.072] (II) LoadModule: "intel"
[   237.072] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   237.072] (II) Module intel: vendor="X.Org Foundation"
[   237.072]    compiled for 1.17.4, module version = 2.99.917
[   237.072]    Module class: X.Org Video Driver
[   237.072]    ABI class: X.Org Video Driver, version 19.0
[   237.072] (II) LoadModule: "nouveau"
[   237.072] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   237.073] (II) Module nouveau: vendor="X.Org Foundation"
[   237.073]    compiled for 1.17.4, module version = 1.0.11
[   237.073]    Module class: X.Org Video Driver
[   237.073]    ABI class: X.Org Video Driver, version 19.0
[   237.073] (II) LoadModule: "vesa"
[   237.073] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   237.073] (II) Module vesa: vendor="X.Org Foundation"
[   237.073]    compiled for 1.17.4, module version = 2.3.4
[   237.073]    Module class: X.Org Video Driver
[   237.073]    ABI class: X.Org Video Driver, version 19.0
[   237.073] (II) LoadModule: "fbdev"
[   237.073] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   237.073] (II) Module fbdev: vendor="X.Org Foundation"
[   237.073]    compiled for 1.17.4, module version = 0.4.4
[   237.073]    Module class: X.Org Video Driver
[   237.073]    ABI class: X.Org Video Driver, version 19.0
[   237.073] (II) LoadModule: "modesetting"
[   237.073] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   237.073] (II) Module modesetting: vendor="X.Org Foundation"
[   237.073]    compiled for 1.17.4, module version = 1.17.4
[   237.073]    Module class: X.Org Video Driver
[   237.073]    ABI class: X.Org Video Driver, version 19.0
[   237.073] (EE)
[   237.073] (EE) Backtrace:
[   237.073] (EE) 0: X (xorg_backtrace+0x52) [0x81d6242]
[   237.073] (EE) 1: X (0x8048000+0x192572) [0x81da572]
[   237.073] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb774abb8]
[   237.073] (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7062000+0xb98e) [0xb706d98e]
[   237.073] (EE) 4: X (0x8048000+0x93be8) [0x80dbbe8]
[   237.073] (EE) 5: X (0x8048000+0x93d48) [0x80dbd48]
[   237.073] (EE) 6: X (0x8048000+0x944fd) [0x80dc4fd]
[   237.073] (EE) 7: X (xf86CallDriverProbe+0x26) [0x80aeb36]
[   237.073] (EE) 8: X (DoConfigure+0xd0) [0x80adb40]
[   237.074] (EE) 9: X (0x8048000+0x767a1) [0x80be7a1]
[   237.074] (EE) 9: X (0x8048000+0x767a1) [0x80be7a1]
[   237.074] (EE) 10: X (0x8048000+0x363fa) [0x807e3fa]
[   237.074] (EE) 11: X (0x8048000+0x2048a) [0x806848a]
[   237.074] (EE) 12: /lib/libc.so.6 (__libc_start_main+0xf0) [0xb72a5490]
[   237.074] (EE) 13: X (0x8048000+0x204b8) [0x80684b8]
[   237.074] (EE)
[   237.074] (EE) Segmentation fault at address 0x18
[   237.074] (EE)
Fatal server error:
[   237.074] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   237.074] (EE)
[   237.074] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.             
[   237.074] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   237.074] (EE)


basically crashes with intell.. i had nvidia 8600 gt and worked perfectly... what should do gentoomen? cheers and thanks in advance! :)
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Jul 06, 2016 4:19 pm    Post subject: Reply with quote

I even didn't know X -configure works on KMS ... does it?
Back to top
View user's profile Send private message
ayleid96
n00b
n00b


Joined: 25 Apr 2016
Posts: 51
Location: /home/noodles

PostPosted: Wed Jul 06, 2016 4:24 pm    Post subject: Reply with quote

Buffoon wrote:
I even didn't know X -configure works on KMS ... does it?


ehh i dont know.. i just run command from terminal without any gui..
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Wed Jul 06, 2016 4:47 pm    Post subject: Reply with quote

X -configure does not work with kms. There is no need to use it, X will start without any xorg.conf.
If you need to set a keyboard layout or static multi-monitor layout, create an xorg.conf.d/ snippet for it. See https://wiki.gentoo.org/wiki/Xorg/Guide
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum