Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
4K screen doesn't work with 60Hz on Intel graphics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 8:10 pm    Post subject: 4K screen doesn't work with 60Hz on Intel graphics Reply with quote

Hi there,

I've got a Thinkpad T460p (with Intel Graphics) and a LG 27MU67-B screen, which supports a resolution up to 3840x2160.

My problem is that I only can get the resolution 3840x2160 to work @ 30Hz. As soon as I select 60Hz the screen stays blank. 1920x1080 works @60Hz.

However, xrandr recognizes that the screen supports 60Hz:

Code:

DP3-1 connected 3840x2160+2560+0 (normal left inverted right x axis y axis) 600mm x 340mm
   3840x2160     60.00 +  30.00*
   1920x1080     60.00    59.94 
   1600x900      60.00 
   1280x1024     60.02 
   1280x800      59.81 
   1152x864      59.97 
   1280x720      60.00    59.94 
   1024x768      60.00 
   800x600       60.32 
   720x480       60.00    59.94 
   640x480       60.00    59.94


I tried different cables and ports:

  • miniDisplayPort on the side of the laptop
  • DisplayPort on the UltraDock docking station
  • HDMI port on the laptop
  • HDMI port on the UltraDock


I used cables which came with the screen, so this shouldn't be an issue.

I'm using Gentoo with kernel gentoo-sources-4.6.0 and xf86-video-intel-2.99.917_p20160621-r1

Any ideas or suggestions how I could get 60Hz to work?

Thanks!
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 05, 2016 9:27 pm    Post subject: Reply with quote

Which resolution do you use on the console?

For 3840x2160@60 Hz, the DisplayPort needs to negotiate HBR2 transfer mode. Maybe that failed for some reason. If dmesg doesn't contain any hints, you can use the drm.debug=... kernel parameter to increase debug verbosity.
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 9:50 pm    Post subject: Reply with quote

chithanh wrote:
Which resolution do you use on the console?


Console is at 1280x1024, but that was selected automatically.

chithanh wrote:

For 3840x2160@60 Hz, the DisplayPort needs to negotiate HBR2 transfer mode. Maybe that failed for some reason. If dmesg doesn't contain any hints, you can use the drm.debug=... kernel parameter to increase debug verbosity.


Good hint, I didn't check dmesg so far, but found some errors which might be related to my issue:

Code:
[    2.303018] ------------[ cut here ]------------
[    2.303021] WARNING: CPU: 3 PID: 59 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120
[    2.303022] WARN_ON(!wm_changed)
[    2.303022] Modules linked in:
[    2.303023] CPU: 3 PID: 59 Comm: kworker/3:1 Not tainted 4.6.0-gentoo #1
[    2.303024] Hardware name: LENOVO 20FWCTO1WW/20FWCTO1WW, BIOS R07ET63W (2.03 ) 03/15/2016
[    2.303026] Workqueue: events_long drm_dp_mst_link_probe_work
[    2.303027]  0000000000000000 ffff88042faff8f8 ffffffff81299908 ffff88042faff948
[    2.303028]  0000000000000000 ffff88042faff938 ffffffff81052e0c 00000e0200000001
[    2.303029]  ffff88042fc22000 ffff88042fc23000 ffff88042fb09d6c ffff88042f8baba8
[    2.303029] Call Trace:
[    2.303032]  [<ffffffff81299908>] dump_stack+0x4d/0x65
[    2.303033]  [<ffffffff81052e0c>] __warn+0xcc/0xf0
[    2.303035]  [<ffffffff81052e7a>] warn_slowpath_fmt+0x4a/0x50
[    2.303036]  [<ffffffff813aed04>] skl_update_other_pipe_wm+0x114/0x120
[    2.303037]  [<ffffffff813aee49>] skl_update_wm+0x139/0x5d0
[    2.303039]  [<ffffffff814358de>] ? intel_ddi_enable_transcoder_func+0x16e/0x240
[    2.303040]  [<ffffffff813b0289>] intel_update_watermarks+0x19/0x20
[    2.303041]  [<ffffffff81419d6c>] haswell_crtc_enable+0x31c/0x890
[    2.303043]  [<ffffffff81406019>] ? intel_finish_crtc_commit+0x9/0x10
[    2.303044]  [<ffffffff813747d0>] ? drm_atomic_helper_commit_planes_on_crtc+0x150/0x270
[    2.303045]  [<ffffffff814159d8>] intel_atomic_commit+0x628/0x1570
[    2.303047]  [<ffffffff81397602>] ? drm_atomic_add_affected_connectors+0x22/0xf0
[    2.303048]  [<ffffffff81397122>] drm_atomic_commit+0x32/0x50
[    2.303048]  [<ffffffff813756b2>] restore_fbdev_mode+0x232/0x260
[    2.303049]  [<ffffffff81395ff5>] ? drm_modeset_lock_all_ctx+0x95/0xb0
[    2.303050]  [<ffffffff8137786e>] drm_fb_helper_restore_fbdev_mode_unlocked+0x2e/0x70
[    2.303051]  [<ffffffff813778d8>] drm_fb_helper_set_par+0x28/0x50
[    2.303052]  [<ffffffff813777ed>] drm_fb_helper_hotplug_event+0x9d/0xf0
[    2.303053]  [<ffffffff8142d169>] intel_fbdev_output_poll_changed+0x19/0x20
[    2.303054]  [<ffffffff8136b3f2>] drm_kms_helper_hotplug_event+0x22/0x30
[    2.303055]  [<ffffffff81437300>] intel_dp_mst_hotplug+0x10/0x20
[    2.303056]  [<ffffffff8137100d>] drm_dp_send_link_address+0x18d/0x210
[    2.303057]  [<ffffffff8108608b>] ? pick_next_task_fair+0x12b/0x470
[    2.303058]  [<ffffffff81371138>] drm_dp_check_and_send_link_address+0xa8/0xb0
[    2.303060]  [<ffffffff81371193>] drm_dp_mst_link_probe_work+0x53/0xb0
[    2.303061]  [<ffffffff8106a146>] process_one_work+0x146/0x3f0
[    2.303061]  [<ffffffff8106a8b6>] worker_thread+0x46/0x470
[    2.303062]  [<ffffffff8106a870>] ? max_active_store+0x60/0x60
[    2.303063]  [<ffffffff8106a870>] ? max_active_store+0x60/0x60
[    2.303064]  [<ffffffff8106f434>] kthread+0xc4/0xe0
[    2.303065]  [<ffffffff816c0752>] ret_from_fork+0x22/0x40
[    2.303066]  [<ffffffff8106f370>] ? kthread_park+0x50/0x50
[    2.303067] ---[ end trace d6237fc6e26cda1f ]---

...

[    3.246568] [drm:intel_mst_disable_dp] *ERROR* failed to update payload -22
[    3.263300] ------------[ cut here ]------------
[    3.263306] WARNING: CPU: 1 PID: 60 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120
[    3.263314] WARN_ON(!wm_changed)
[    3.263316] Modules linked in:
[    3.263318] CPU: 1 PID: 60 Comm: kworker/1:1 Tainted: G        W       4.6.0-gentoo #1
[    3.263319] Hardware name: LENOVO 20FWCTO1WW/20FWCTO1WW, BIOS R07ET63W (2.03 ) 03/15/2016
[    3.263322] Workqueue: events drm_dp_destroy_connector_work
[    3.263323]  0000000000000000 ffff88042fabba60 ffffffff81299908 ffff88042fabbab0
[    3.263324]  0000000000000000 ffff88042fabbaa0 ffffffff81052e0c 00000e0200000000
[    3.263325]  ffff88042fc22000 ffff88042fc23000 ffff88042fb09d6c ffff88042f8baba8
[    3.263325] Call Trace:
[    3.263328]  [<ffffffff81299908>] dump_stack+0x4d/0x65
[    3.263330]  [<ffffffff81052e0c>] __warn+0xcc/0xf0
[    3.263331]  [<ffffffff81052e7a>] warn_slowpath_fmt+0x4a/0x50
[    3.263333]  [<ffffffff813aed04>] skl_update_other_pipe_wm+0x114/0x120
[    3.263334]  [<ffffffff813aee49>] skl_update_wm+0x139/0x5d0
[    3.263335]  [<ffffffff813b806b>] ? intel_display_power_put+0xcb/0x130
[    3.263337]  [<ffffffff813b0289>] intel_update_watermarks+0x19/0x20
[    3.263338]  [<ffffffff81415822>] intel_atomic_commit+0x472/0x1570
[    3.263341]  [<ffffffff8139647a>] ? drm_atomic_set_crtc_for_connector+0x2a/0xe0
[    3.263342]  [<ffffffff81397122>] drm_atomic_commit+0x32/0x50
[    3.263343]  [<ffffffff81374fc6>] drm_atomic_helper_set_config+0x76/0xb0
[    3.263345]  [<ffffffff814373a1>] intel_dp_destroy_mst_connector+0x51/0xe0
[    3.263346]  [<ffffffff81370226>] drm_dp_destroy_connector_work+0xa6/0x150
[    3.263348]  [<ffffffff8106a146>] process_one_work+0x146/0x3f0
[    3.263348]  [<ffffffff8106a8b6>] worker_thread+0x46/0x470
[    3.263349]  [<ffffffff8106a870>] ? max_active_store+0x60/0x60
[    3.263350]  [<ffffffff8106f434>] kthread+0xc4/0xe0
[    3.263352]  [<ffffffff816c0752>] ret_from_fork+0x22/0x40
[    3.263353]  [<ffffffff8106f370>] ? kthread_park+0x50/0x50
[    3.263354] ---[ end trace d6237fc6e26cda20 ]---

...

[    3.929558] ------------[ cut here ]------------
[    3.929563] WARNING: CPU: 3 PID: 24 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120
[    3.929564] WARN_ON(!wm_changed)
[    3.929565] Modules linked in:
[    3.929566]  arc4 rtsx_pci_sdmmc mmc_core iwlmvm kvm_intel mac80211 kvm irqbypass input_leds e1000e iwlwifi mei_me mei cfg80211 rtsx_pci mfd_core thinkpad_acpi led_class
[    3.929574] CPU: 3 PID: 24 Comm: kworker/3:0 Tainted: G        W       4.6.0-gentoo #1
[    3.929575] Hardware name: LENOVO 20FWCTO1WW/20FWCTO1WW, BIOS R07ET63W (2.03 ) 03/15/2016
[    3.929578] Workqueue: events_long drm_dp_mst_link_probe_work
[    3.929579]  0000000000000000 ffff8804302ef8f8 ffffffff81299908 ffff8804302ef948
[    3.929580]  0000000000000000 ffff8804302ef938 ffffffff81052e0c 00000e0200000001
[    3.929582]  ffff88042fc22000 ffff88042fc23000 ffff88042fb09d6c ffff88042f8baba8
[    3.929583] Call Trace:
[    3.929586]  [<ffffffff81299908>] dump_stack+0x4d/0x65
[    3.929601]  [<ffffffff81052e0c>] __warn+0xcc/0xf0
[    3.929603]  [<ffffffff81052e7a>] warn_slowpath_fmt+0x4a/0x50
[    3.929604]  [<ffffffff813aed04>] skl_update_other_pipe_wm+0x114/0x120
[    3.929606]  [<ffffffff813aee49>] skl_update_wm+0x139/0x5d0
[    3.929608]  [<ffffffff814358de>] ? intel_ddi_enable_transcoder_func+0x16e/0x240
[    3.929610]  [<ffffffff813b0289>] intel_update_watermarks+0x19/0x20
[    3.929611]  [<ffffffff81419d6c>] haswell_crtc_enable+0x31c/0x890
[    3.929613]  [<ffffffff81406019>] ? intel_finish_crtc_commit+0x9/0x10
[    3.929615]  [<ffffffff813747d0>] ? drm_atomic_helper_commit_planes_on_crtc+0x150/0x270
[    3.929616]  [<ffffffff814159d8>] intel_atomic_commit+0x628/0x1570
[    3.929618]  [<ffffffff81397602>] ? drm_atomic_add_affected_connectors+0x22/0xf0
[    3.929620]  [<ffffffff81397122>] drm_atomic_commit+0x32/0x50
[    3.929621]  [<ffffffff813756b2>] restore_fbdev_mode+0x232/0x260
[    3.929622]  [<ffffffff81395ff5>] ? drm_modeset_lock_all_ctx+0x95/0xb0
[    3.929623]  [<ffffffff8137786e>] drm_fb_helper_restore_fbdev_mode_unlocked+0x2e/0x70
[    3.929624]  [<ffffffff813778d8>] drm_fb_helper_set_par+0x28/0x50
[    3.929625]  [<ffffffff813777ed>] drm_fb_helper_hotplug_event+0x9d/0xf0
[    3.929626]  [<ffffffff8142d169>] intel_fbdev_output_poll_changed+0x19/0x20
[    3.929628]  [<ffffffff8136b3f2>] drm_kms_helper_hotplug_event+0x22/0x30
[    3.929629]  [<ffffffff81437300>] intel_dp_mst_hotplug+0x10/0x20
[    3.929631]  [<ffffffff8137100d>] drm_dp_send_link_address+0x18d/0x210
[    3.929633]  [<ffffffff8108635b>] ? pick_next_task_fair+0x3fb/0x470
[    3.929634]  [<ffffffff81371138>] drm_dp_check_and_send_link_address+0xa8/0xb0
[    3.929636]  [<ffffffff81371193>] drm_dp_mst_link_probe_work+0x53/0xb0
[    3.929638]  [<ffffffff8106a146>] process_one_work+0x146/0x3f0
[    3.929639]  [<ffffffff8106a8b6>] worker_thread+0x46/0x470
[    3.929640]  [<ffffffff8106a870>] ? max_active_store+0x60/0x60
[    3.929641]  [<ffffffff8106f434>] kthread+0xc4/0xe0
[    3.929643]  [<ffffffff816c0752>] ret_from_fork+0x22/0x40
[    3.929644]  [<ffffffff8106f370>] ? kthread_park+0x50/0x50
[    3.929645] ---[ end trace d6237fc6e26cda21 ]---


Any idea how I can fix this?
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 05, 2016 10:07 pm    Post subject: Reply with quote

You do have the Skylake firmware installed and it is loaded properly during boot, yes?

These messages are possibly unrelated to your problem, see https://bugs.freedesktop.org/show_bug.cgi?id=95521

You could try to force the console to higher resolution with the video=3840x2160 kernel parameter, but that might fail too. You could try a newer kernel (4.7-rc6) and if that still doesn't work report a bug at https://bugs.freedesktop.org/
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 10:25 pm    Post subject: Reply with quote

chithanh wrote:
You do have the Skylake firmware installed and it is loaded properly during boot, yes?


I've got sys-kernel/linux-firmware-20160331 installed. However, I found this message in dmesg:

Code:

[    0.360307] i915 0000:00:02.0: enabling device (0006 -> 0007)
[    0.371619] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1.bin failed with error -2
[    0.371623] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/intel-linux-graphics-firmwares], disabling runtime power management.
[    0.387539] [drm] Initialized i915 1.6.0 20160229 for 0000:00:02.0 on minor 0
[    2.303021] WARNING: CPU: 3 PID: 59 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120
[    2.634293] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    3.263306] WARNING: CPU: 1 PID: 60 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120
[    3.929563] WARNING: CPU: 3 PID: 24 at drivers/gpu/drm/i915/intel_pm.c:3586 skl_update_other_pipe_wm+0x114/0x120


Edit: I guess I haven't set the kernel parameters CONFIG_EXTRA_FIRMWARE and CONFIG_EXTRA_FIRMWARE_DIR. I just changed that and will retry with a newly built kernel.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 05, 2016 10:39 pm    Post subject: Reply with quote

If you have the i915 driver built into your kernel, then you need the firmware built-in too.

You can set the following in your kernel config:
Code:
CONFIG_EXTRA_FIRMWARE="i915/skl_dmc_ver1.bin i915/skl_guc_ver1.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"

(if dmesg still complains about missing firmware files, you need to add them too)
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 10:51 pm    Post subject: Reply with quote

Thanks for your help, chithanh!

I recompiled the kernel with the firmware, it now seems to load fine:

Code:

[    0.377983] [drm] Finished loading i915/skl_dmc_ver1.bin (v1.26)
[    0.391256] [drm] Initialized i915 1.6.0 20160229 for 0000:00:02.0 on minor 0


However, I still cannot switch into 60Hz mode. This is the error which appeared when calling xrandr to set 60Hz:

Code:
[  119.231697] ------------[ cut here ]------------
[  119.231712] WARNING: CPU: 0 PID: 1617 at drivers/gpu/drm/i915/intel_display.c:13929 skl_max_scale.part.100+0x6a/0x80
[  119.231716] WARN_ON_ONCE(!crtc_clock || cdclk < crtc_clock)
[  119.231718] Modules linked in:
[  119.231722]  rfcomm acpi_call(O) bnep twofish_x86_64_3way lrw glue_helper twofish_x86_64 twofish_common dm_crypt dm_mod loop fuse btusb btrtl btbcm btintel bluetooth arc4 iwlmvm rtsx_pci_sdmmc mac80211 kvm_intel mmc_core kvm irqbypass iwlwifi input_leds cfg80211 rtsx_pci mfd_core mei_me mei thinkpad_acpi led_class
[  119.231768] CPU: 0 PID: 1617 Comm: X Tainted: G        W  O    4.6.0-gentoo #3
[  119.231771] Hardware name: LENOVO 20FWCTO1WW/20FWCTO1WW, BIOS R07ET63W (2.03 ) 03/15/2016
[  119.231775]  0000000000000000 ffff8800ad6e7a30 ffffffff81299908 ffff8800ad6e7a80
[  119.231781]  0000000000000000 ffff8800ad6e7a70 ffffffff81052e0c 0000366900000870
[  119.231787]  ffff88042bc41900 ffff88042fa83800 ffff880431c36000 ffff88042fa83800
[  119.231792] Call Trace:
[  119.231801]  [<ffffffff81299908>] dump_stack+0x4d/0x65
[  119.231809]  [<ffffffff81052e0c>] __warn+0xcc/0xf0
[  119.231816]  [<ffffffff81052e7a>] warn_slowpath_fmt+0x4a/0x50
[  119.231820]  [<ffffffff8140af7a>] skl_max_scale.part.100+0x6a/0x80
[  119.231824]  [<ffffffff8140b04b>] intel_check_primary_plane+0xbb/0xd0
[  119.231830]  [<ffffffff8143cbe8>] ? intel_dp_source_rates+0x48/0x80
[  119.231834]  [<ffffffff8143cc66>] ? intel_dp_common_rates+0x46/0xd0
[  119.231841]  [<ffffffff813fddd9>] intel_plane_atomic_check+0x129/0x1f0
[  119.231849]  [<ffffffff813737f3>] drm_atomic_helper_check_planes+0x43/0x1d0
[  119.231855]  [<ffffffff81417606>] intel_atomic_check+0x2f6/0x1180
[  119.231861]  [<ffffffff816dbd01>] ? __ww_mutex_lock_slowpath+0x111/0x1b0
[  119.231868]  [<ffffffff81396bee>] drm_atomic_check_only+0x13e/0x640
[  119.231873]  [<ffffffff813964a2>] ? drm_atomic_set_crtc_for_connector+0x52/0xe0
[  119.231878]  [<ffffffff81397102>] drm_atomic_commit+0x12/0x50
[  119.231885]  [<ffffffff81374fc6>] drm_atomic_helper_set_config+0x76/0xb0
[  119.231890]  [<ffffffff81387d1d>] drm_mode_set_config_internal+0x5d/0xf0
[  119.231896]  [<ffffffff8138b553>] drm_mode_setcrtc+0x183/0x4e0
[  119.231901]  [<ffffffff8137d67d>] drm_ioctl+0x13d/0x560
[  119.231907]  [<ffffffff8138b3d0>] ? drm_mode_setplane+0x1b0/0x1b0
[  119.231915]  [<ffffffff81185ba9>] do_vfs_ioctl+0x89/0x580
[  119.231920]  [<ffffffff8105f08d>] ? __set_task_blocked+0x2d/0x70
[  119.231926]  [<ffffffff81175a6c>] ? __sb_end_write+0x1c/0x20
[  119.231931]  [<ffffffff81061621>] ? __set_current_blocked+0x31/0x50
[  119.231937]  [<ffffffff811860dc>] SyS_ioctl+0x3c/0x70
[  119.231941]  [<ffffffff81061881>] ? SyS_rt_sigprocmask+0x81/0xa0
[  119.231947]  [<ffffffff816de09b>] entry_SYSCALL_64_fastpath+0x13/0x8f
[  119.231951] ---[ end trace 5cf240cb25d2429d ]---
[  119.304372] [drm:intel_cpu_fifo_underrun_irq_handler] *ERROR* CPU pipe B FIFO underrun
[  134.530287] [drm:intel_mst_disable_dp] *ERROR* failed to update payload -22
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 05, 2016 10:54 pm    Post subject: Reply with quote

I think this error is related to the dock as per the freedesktop bug above.

Can you try booting the system undocked and see if something changes?
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 11:03 pm    Post subject: Reply with quote

chithanh wrote:
I think this error is related to the dock as per the freedesktop bug above.

Can you try booting the system undocked and see if something changes?


Nope. I rebooted without the dock. I then attached the screen using a MiniDP-Cable, the picture appeared @30Hz. No errors in dmesg until this point. But when I changed to 60Hz I got the exact same error message.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 05, 2016 11:06 pm    Post subject: Reply with quote

Ok, then I am out of ideas. If the latest 4.7-rc kernel does not improve the situation, you can create a bug report at https://bugs.freedesktop.org/ so the Intel upstream can look into it.
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Tue Jul 05, 2016 11:14 pm    Post subject: Reply with quote

OK, I'll try a newer kernel in the next days and let you know if that helped.

Thanks for your help and support, much appreciated!
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Wed Jul 06, 2016 7:09 am    Post subject: Reply with quote

I opened this issue: https://bugs.freedesktop.org/show_bug.cgi?id=96828
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Wed Jul 06, 2016 8:37 am    Post subject: Reply with quote

Good. To give upstream some more information, boot with log_buf_len=1M drm.debug=14 kernel parameters, try to set 4K@60 Hz, and then capture the entire dmesg output and attach to the bug.
Back to top
View user's profile Send private message
*zensiert*
n00b
n00b


Joined: 10 Oct 2004
Posts: 34
Location: Germany

PostPosted: Wed Jul 27, 2016 10:14 pm    Post subject: Reply with quote

I tried again today using the new kernel 4.7.0, but the problem remains.

As you suggested, I added the kernel parameters and attached the log output to the bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum