Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Recommendations for KDE Plasma 5 on nvivia
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 51

PostPosted: Tue Jul 05, 2016 7:50 am    Post subject: Recommendations for KDE Plasma 5 on nvivia Reply with quote

After update Plasma 5 i get black screen. I remove gles2 and now Plasma start (slowly).
Can i remove gles1, gles and egl. I use now classic dri3 egl gallium gbm gles1 llvm nptl opencl udev vdpau wayland xvmc
use flags. emerge -pvuND world show now:

gentookde ~ # emerge -pvuND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

(dev-qt/qtgui-5.5.1-r1:5/5::gentoo, installed) pulled in by
~dev-qt/qtgui-5.5.1[gles2=] required by (dev-qt/qtopengl-5.5.1:5/5::gentoo, installed)
^^^^^^
~dev-qt/qtgui-5.5.1[gles2=] required by (dev-qt/qtprintsupport-5.5.1:5/5::gentoo, installed)
^^^^^^
~dev-qt/qtgui-5.5.1[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, installed)
^^^^^^
>=dev-qt/qtgui-5.5.1:5[gles2=,opengl(+)] required by (kde-plasma/kwin-5.5.5:5/5::gentoo, installed)
^^^^^^
>=dev-qt/qtgui-5.5.1:5[gles2=] required by (kde-frameworks/plasma-5.21.0:5/5.21::gentoo, installed)
^^^^^^
~dev-qt/qtgui-5.5.1[gles2=] required by (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, installed)
^^^^^^

(dev-qt/qtgui-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
>=dev-qt/qtgui-5.5.1:5[gles2] required by (kde-plasma/kinfocenter-5.5.5:5/5::gentoo, installed)
^^^^^

media-libs/mesa:0

(media-libs/mesa-11.0.6:0/0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(media-libs/mesa-11.0.6:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gles2] required by (media-libs/libsdl2-2.0.4:0/0::gentoo, installed)
^^^^^
>=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,egl,gles2,wayland] required by (media-libs/libsdl2-2.0.4:0/0::gentoo, installed)
^^^^^
media-libs/mesa[gles2] required by (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
^^^^^
media-libs/mesa[gles2] required by (media-tv/kodi-14.1:0/0::gentoo, ebuild scheduled for merge)
^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kinfocenter-5.5.5::gentoo[gles]
# required by kde-plasma/plasma-meta-5.5.5::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtgui-5.5.1-r1 gles2
# required by media-libs/libsdl2-2.0.4::gentoo[gles]
# required by media-tv/kodi-14.1::gentoo[sdl]
# required by @selected
# required by @world (argument)
>=media-libs/mesa-11.0.6 gles2

emerge: there are no ebuilds built with USE flags to satisfy "~dev-qt/qtgui-5.5.1[-egl]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-5.5.1-r1::gentoo (Change USE: -egl, this change violates use flag constraints defined by dev-qt/qtgui-5.5.1-r1: 'any-of ( eglfs xcb ) accessibility? ( dbus xcb ) eglfs? ( egl ) ibus? ( dbus ) libinput? ( udev ) xcb? ( gles2? ( egl ) )')
(dependency required by "dev-qt/qtmultimedia-5.5.1-r2::gentoo[-gles2,qml]" [installed])
(dependency required by "dev-qt/qtwebkit-5.5.1-r1::gentoo[multimedia]" [installed])
(dependency required by "kde-plasma/libksysguard-5.5.5::gentoo[detailedmemory]" [installed])
(dependency required by "kde-plasma/plasma-workspace-5.5.5-r2::gentoo" [installed])
(dependency required by "kde-plasma/kdeplasma-addons-5.5.5::gentoo" [installed])
(dependency required by "kde-plasma/plasma-meta-5.5.5::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I'm tired to compile the qt libraries again. I would like to know good use flags settings.
KDE 4 work very well. Plasma start slow.
_________________
---
Sakarias
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum