Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
su in KDE5 takes 20 seconds [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Sat Jul 02, 2016 8:00 pm    Post subject: su in KDE5 takes 20 seconds [SOLVED] Reply with quote

I recently upgraded from KDE4 to KDE5 as per news "KDE Plasma 5 Upgrade". There is a strange thing after the upgrade, when doing su in terminal in KDE5 it takes 20 seconds, although before the upgrade or in the console it is immediate. Anyone has an idea, what could be wrong?

strace su somehow does not show anything useful, it ends with failure after 5 seconds, i.e. not switching to root

new su as a root is immediate in KDE5


Last edited by trubicoid on Fri Aug 12, 2016 8:55 am; edited 1 time in total
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Wed Jul 13, 2016 3:39 pm    Post subject: Reply with quote

No one? Can at least someone with KDE5 try su and tell, if it is fast as usual or if he experiences a delay as me?
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Wed Jul 13, 2016 4:15 pm    Post subject: Reply with quote

Using "su" is immediate on my KDE5 installation.
I have no clue as to your issue but I don't upgrade....only do new installations.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Jul 13, 2016 4:43 pm    Post subject: Reply with quote

It doesn't sound like anything related to Plasma or konsole... can you try with a different terminal emulator from within your Plasma session or with konsole in a different window manager, a new user?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Wed Jul 13, 2016 8:30 pm    Post subject: Reply with quote

I think the problem is related to something Plasma runs, not directly to Plasma nor konsole, e.g. polkit?

In TWM there is no delay in xterm nor konsole.

New user in plasma has the same delay (if he is in wheel group, otherwise it is a bit shorter).

In Plasma the console emulator does not matter, the same delay in konsole and xterm.

There are some sddm complains during the logging in about pam_systemd.so (I don't use systemd) and pam_kwallet, however I'm logged in fine, no delay. Nothing in the logs during the su delay.

Code:
Jul 13 22:12:31 [sddm-helper] PAM unable to dlopen(/lib64/security/pam_systemd.so): /lib64/security/pam_systemd.so: cannot open shared object file: No such file or directory
Jul 13 22:12:31 [sddm-helper] PAM adding faulty module: /lib64/security/pam_systemd.so
Jul 13 22:12:31 [sddm-helper] pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
Jul 13 22:12:39 [sddm-helper] pam_kwallet(sddm:auth): (null): pam_sm_authenticate_
Jul 13 22:12:39 [sddm-helper] pam_kwallet5(sddm:auth): (null): pam_sm_authenticate_
Jul 13 22:12:40 [sddm-helper] pam_kwallet(sddm:setcred): pam_kwallet: pam_sm_setcred
Jul 13 22:12:40 [sddm-helper] pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
Jul 13 22:12:40 [sddm-helper] pam_unix(sddm:session): session opened for user fik by (uid=0)
Jul 13 22:12:40 [sddm-helper] pam_ck_connector(sddm:session): nox11 mode, ignoring PAM_TTY :0
Jul 13 22:12:40 [sddm-helper] pam_kwallet(sddm:session): pam_kwallet: pam_sm_open_session_
Jul 13 22:12:40 [sddm-helper] pam_kwallet(sddm:session): pam_kwallet: final socket path: /tmp/kwallet_fik.socket
Jul 13 22:12:40 [sddm-helper] pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session_
Jul 13 22:12:40 [sddm-helper] pam_kwallet5(sddm:session): pam_kwallet5: final socket path: /tmp/kwallet5_fik.socket
Jul 13 22:12:41 [polkitd] Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session7 (system bus name :1.41 [/usr/lib64/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Jul 13 22:14:12 [su] Successful su for root by fik
Jul 13 22:14:12 [su] + /dev/pts/1 fik:root
Jul 13 22:14:12 [su] pam_unix(su:session): session opened for user root by fik(uid=1000)
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3647
Location: Hamburg

PostPosted: Wed Jul 13, 2016 10:11 pm    Post subject: Reply with quote

I had experiences annoying delays during log out from the desktop. It vanished when I switched to kf 5.23 + plasma 5.6.5.
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Thu Jul 14, 2016 7:45 am    Post subject: Reply with quote

interesting, by kf 5.23 you mean kde-frameworks/kfilemetadata?

I have found an error message in ~/.xsession-errors

Code:
QXcbConnection: XCB error: 2 (BadValue), sequence: 56705, resource id: 23068702, major code: 141 (Unknown), minor code: 3


And there is probably related bug in kde, where they observe 20s delay but during logging in https://bugs.kde.org/show_bug.cgi?id=353203
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Jul 14, 2016 8:02 am    Post subject: Reply with quote

Yeah that QXcbConnection thing is a well-known error but won't cause any su delay.

On plasma workspace startup so many things are going on that issues with delays sometimes are caused by race conditions (I've seen dbus timeouts, splash screen timeout in a much earlier version) but again nothing that would cause any trouble for su.

Someone with more knowledge about what is going on when you 'su' would be helpful...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Sat Jul 16, 2016 4:20 pm    Post subject: Reply with quote

Upgrading to unstable plasma 5.7.1 didn't solve the problem
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Sun Jul 17, 2016 5:49 pm    Post subject: Reply with quote

are you using sddm?
What happens if you disable sddm, log in as your normal user in the text console, and then start KDE5 manually? In my case the "su" succeeds immediately.
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Tue Aug 09, 2016 4:00 pm    Post subject: Reply with quote

yes, it is with sddm

strange thing, I just upgraded a second laptop to KDE5 and there is no 20s delay after su, I'll have to find the difference...
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 54

PostPosted: Fri Aug 12, 2016 8:56 am    Post subject: Reply with quote

the problem was in wrong primary group for the user, after setting the correct group and restart, the problem is gone

interestingly, the wrong group caused no problems in KDE4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum