Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server conflicts.
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ICannotStandXorg
n00b
n00b


Joined: 02 Jun 2016
Posts: 9

PostPosted: Fri Jul 01, 2016 12:37 am    Post subject: xorg-server conflicts. Reply with quote

Hello everyone.

I am attempting to change from amdgpu to fglrx to compare their performances. I am currently using the unstable branch on portage. When changing the VIDEO_CARDS variable to fglrx then attempting to remerge with
Code:
emerge -av --changed-use --deep --verbose-conflicts @world
I get the following output:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.3:0/1.18.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.17.49[-minimal] required by (x11-drivers/ati-drivers-15.12-r1:1/1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                 


I saw this in another thread and made it's suggested changes to /etc/portage/package.mask/xorg-server:

Code:

>=x11-drivers/xf86-input-evdev-2.10.1
>=x11-base/xorg-server-1.18.0
>=x11-base/xorg-drivers-1.18-r1


and then attempting to remerge using the previous command I get this new output:

In the package installed list I see:

Code:

<x11-drivers/xf86-input-evdev-2.10.0 ("<x11-drivers/xf86-input-evdev-2.10.0" is blocking x11-base/xorg-drivers-1.18-r1)


and after it I see:

Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-base/xorg-drivers-1.18-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.17 required by (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, ebuild scheduled for merge)


When I look at the list of things being emerged I see:

Code:

x11-base/xorg-drivers-1.18-r1::gentoo


Why is it ignoring the fact that I'm masking out that version of xorg-drivers? What am I doing wrong? Changing from unstable branch to stable would probably fix this, but I'd really rather not and I want to see if there is another solution.

EDIT: Just tried masking out ati-drivers to the stable version, same error.

Thanks for your time.
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 542
Location: Cracow, Poland

PostPosted: Sat Sep 17, 2016 4:54 pm    Post subject: Reply with quote

I have same issue :( szhoul I mask new xorg-server and/or xf86-input-evdev, or what???
Code:
[ebuild     U ~] app-portage/find_cruft-3.0.10::mv [3.0.9::mv] 11 KiB
[ebuild     U ~] app-portage/useflags-4.1.0::mv [4.0.0::mv] 7 KiB
[ebuild     U  ] dev-perl/Text-Unidecode-1.270.0::gentoo [0.40.0-r1::gentoo] 132 KiB
[ebuild     U  ] x11-proto/xproto-7.0.29::gentoo [7.0.28::gentoo] USE="-doc" ABI_X86="32 (64) (-x32)" 302 KiB
[ebuild     U  ] x11-proto/inputproto-2.3.2::gentoo [2.3.1::gentoo] ABI_X86="32 (64) (-x32)" 197 KiB
[ebuild     U  ] x11-libs/pixman-0.34.0::gentoo [0.32.8::gentoo] USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmxext sse2 ssse3" 723 KiB
[ebuild     U  ] x11-libs/libdrm-2.4.70::gentoo [2.4.65::gentoo] USE="-libkms -static-libs -valgrind" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon -amdgpu (-exynos) (-freedreno) -intel -nouveau (-omap) (-tegra) (-vc4) -vmware" 677 KiB
[ebuild     U  ] x11-proto/videoproto-2.3.3::gentoo [2.3.2::gentoo] ABI_X86="32 (64) (-x32)" 119 KiB
[ebuild     U  ] x11-misc/xorg-cf-files-1.0.6::gentoo [1.0.5::gentoo] 330 KiB
[ebuild     U  ] media-libs/babl-0.1.18::gentoo [0.1.12::gentoo] USE="(-altivec)" CPU_FLAGS_X86="mmx sse sse2 -f16c% -sse4_1%" 718 KiB
[ebuild     U  ] x11-libs/libXdmcp-1.1.2-r1::gentoo [1.1.2::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] x11-base/xorg-drivers-1.18-r1::gentoo [1.17::gentoo] INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard (-libinput) -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="radeon -amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB
[ebuild     U  ] x11-libs/libXfixes-5.0.2::gentoo [5.0.1::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 298 KiB
[ebuild     U  ] x11-libs/libXi-1.7.6::gentoo [1.7.5::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 474 KiB
[ebuild     U  ] x11-apps/xkbcomp-1.3.1::gentoo [1.3.0::gentoo] 242 KiB
[ebuild     U  ] x11-misc/xkeyboard-config-2.17::gentoo [2.16::gentoo] 951 KiB
[ebuild     U  ] x11-apps/xrandr-1.5.0::gentoo [1.4.3::gentoo] 179 KiB
[ebuild     U  ] x11-terms/xterm-325::gentoo [320::gentoo] USE="openpty truetype unicode xinerama%* -Xaw3d -toolbar" 1,209 KiB
[ebuild     U  ] dev-libs/libevdev-1.5.2::gentoo [1.4.4::gentoo] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 389 KiB
[ebuild     U  ] x11-proto/xcb-proto-1.12-r2::gentoo [1.11::gentoo] ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_3) (-python3_5)" 151 KiB
[ebuild  r  U  ] x11-libs/libxcb-1.12:0/1.12::gentoo [1.11.1:0/1.11.1::gentoo] USE="xkb -doc (-selinux) -static-libs {-test}" ABI_X86="32 (64) (-x32)" 600 KiB
[ebuild  rR    ] x11-libs/xcb-util-renderutil-0.3.9-r1::gentoo  USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] x11-libs/xcb-util-keysyms-0.4.0::gentoo  USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] x11-libs/xcb-util-wm-0.4.1-r1::gentoo  USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libxkbcommon-0.6.0::gentoo [0.5.0::gentoo] USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 595 KiB
[ebuild  rR    ] x11-libs/xcb-util-0.4.0::gentoo  USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] x11-libs/xcb-util-image-0.4.0::gentoo  USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] x11-libs/xcb-util-cursor-0.1.3-r1::gentoo [0.1.2::gentoo] USE="-doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 289 KiB
[ebuild  rR    ] dev-qt/qtgui-5.6.1:5/5.6::gentoo  USE="dbus gif jpeg png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -gtkstyle -ibus -libinput {-test} -tslib -tuio" 0 KiB
[ebuild     U  ] sys-devel/llvm-3.7.1-r3:0/3.7.1::gentoo [3.5.0:0/3.5::gentoo] USE="clang libffi ncurses static-analyzer xml -debug -doc -gold -libedit -lldb% -multitarget -ocaml -python {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 (-pypy%)" VIDEO_CARDS="radeon" 24,610 KiB
[ebuild     U  ] sys-devel/clang-3.7.1-r100:0/3.7::gentoo [3.5.0-r100:0/3.5::gentoo] USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" 0 KiB
[blocks b      ] <=sys-devel/clang-3.7.1-r99 ("<=sys-devel/clang-3.7.1-r99" is blocking sys-devel/llvm-3.7.1-r3)
[ebuild     U  ] media-libs/mesa-12.0.1::gentoo [11.0.6::gentoo] USE="bindist classic dri3 egl gallium gbm gles2 llvm nptl udev -d3d9 -debug -gles1 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind% -vdpau -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi (-vc4) -vmware" 8,371 KiB
[ebuild     U  ] x11-base/xorg-server-1.18.4:0/1.18.4::gentoo [1.17.4:0/1.17.4::gentoo] USE="glamor ipv6 suid udev xorg xvfb -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest (-nptl%*)" 5,869 KiB
[ebuild     U  ] x11-apps/mesa-progs-8.3.0::gentoo [8.2.0::gentoo] USE="-egl -gles2" 9,810 KiB
[ebuild     U  ] x11-drivers/xf86-input-evdev-2.10.3::gentoo [2.9.2::gentoo] 395 KiB
[blocks b      ] <x11-drivers/xf86-input-evdev-2.10.0 ("<x11-drivers/xf86-input-evdev-2.10.0" is blocking x11-base/xorg-drivers-1.18-r1)
[ebuild     U  ] x11-drivers/xf86-video-ati-7.7.0::gentoo [7.5.0::gentoo] USE="glamor udev" 818 KiB
[blocks b      ] <x11-drivers/xf86-video-ati-7.6.1 ("<x11-drivers/xf86-video-ati-7.6.1" is blocking x11-base/xorg-drivers-1.18-r1)
[ebuild     U  ] x11-drivers/xf86-input-synaptics-1.8.3::gentoo [1.8.2::gentoo] 473 KiB
[ebuild     U  ] x11-drivers/ati-drivers-15.12-r1:1::gentoo [15.9-r1:1::gentoo] USE="modules qt4 -debug -gdm-hack -pax_kernel -static-libs" ABI_X86="32 (64)" 181,047 KiB


Code:
x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    <=x11-base/xorg-server-1.17.49[-minimal] required by (x11-drivers/ati-drivers-15.12-r1:1/1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                       
    >=x11-base/xorg-server-1.7:0/1.17.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.20-r1:0/0::gentoo, installed)
                              ^^^^^^^^^^                                                                                                                               


Code:
The following packages are causing rebuilds:

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-0.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 193
Location: Bavaria

PostPosted: Sat Sep 17, 2016 6:06 pm    Post subject: Reply with quote

Try the option "--backtrack=30" for the emerge command.
This resolved the issue here.
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 542
Location: Cracow, Poland

PostPosted: Sat Sep 17, 2016 6:10 pm    Post subject: Reply with quote

tomtom69 wrote:
Try the option "--backtrack=30" for the emerge command.
This resolved the issue here.

What I posted ealier was result with optioyn '--backtrack=300' !!
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 193
Location: Bavaria

PostPosted: Sat Sep 17, 2016 7:04 pm    Post subject: Reply with quote

Maybe a newer ebuild/patch for ati-drivers is needed?
I needed an update from nvidia-drivers-304.131 to nvidia-drivers-304.131-r4 to be able to update xorg-server. However this update was only possible with --backtrack=30, otherwise it showed similar blockers.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Sep 17, 2016 7:37 pm    Post subject: Reply with quote

Forget about fglrx, it is dead. It will never be updated to modern X server or kernels.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 407

PostPosted: Mon Sep 19, 2016 9:29 am    Post subject: Reply with quote

asturm wrote:
Forget about fglrx, it is dead. It will never be updated to modern X server or kernels.


Exactly this, + if you want to compare them anyway, try to use the same Xorg version otherwise it is not much of a comparison.
So instead of updating all of your xorg, try the fglrx on the new xorg (if possible)
But yeah, you probably want to look at the new AMDPRO drivers instead of old fglrx.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Sep 19, 2016 9:54 am    Post subject: Reply with quote

fglrx development is afaik dead. Since august ? what i read somewhere else
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Tue Sep 20, 2016 5:53 am    Post subject: Reply with quote

I am having this exact same problem but other than some brief references to getting rid of fglrx I don't understand the solution being suggested. Can someone clarify? What are we suppose to be doing? I tried masking package versions as well and it did nothing. Thanks.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Sep 20, 2016 6:18 am    Post subject: Reply with quote

It means if you want to use fglrx you need to mask recent xorg-server and kernel versions, or migrate to radeon or amdgpu.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Tue Sep 20, 2016 6:32 am    Post subject: Reply with quote

asturm wrote:
It means if you want to use fglrx you need to mask recent xorg-server and kernel versions, or migrate to radeon or amdgpu.


OK. Let me back up. So this exact same error message came when I did my world update and although I do have fglrx and Intel in my make.conf file this isn't occurring because of a change that I have made on my box.

So I removed fglrx from make left intel and added amdpro but that didn't do anything.

I did mask most recent xorg srever too. I assume the requested upgrade of xorg is what kicked this whole shebang off in my case but too many oter things are also asking for the new version as well.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Sep 20, 2016 6:42 am    Post subject: Reply with quote

Budoka wrote:
So I removed fglrx from make left intel and added amdpro but that didn't do anything.

Because a manual rebuild in the past without using --oneshot might have put it in your world file? Or did you forget to rebuild xorg-drivers?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Thu Sep 22, 2016 2:23 am    Post subject: Reply with quote

asturm wrote:
Budoka wrote:
So I removed fglrx from make left intel and added amdpro but that didn't do anything.

Because a manual rebuild in the past without using --oneshot might have put it in your world file? Or did you forget to rebuild xorg-drivers?


I'm sorry but I am confused. Can you clarify a bit. I am pretty sure that xorg is in my world file and should be. Is that incorrect? Orare you talking about fglrx, which isn't in it?

Basically, any emerge I do at this point, including trying to rebuild xorg-drivers, bombs out with the same error as the original poster. Masking doesn't work because other packages are asking for the new version of xorg-server.

I am not trying to hijack this thread but since this is the exact same issue seems better not to duplicate it in a new thread.

Quote:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

(x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
>=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
^^ ^^^^

(x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
<=x11-base/xorg-server-1.17.49[-minimal] required by (x11-drivers/ati-drivers-15.12-r1:1/1::gentoo, installed)
^^ ^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Sep 22, 2016 2:43 am    Post subject: Reply with quote

Basically my post and your portage output tells you everything you need to know. Just editing make.conf and removing a use flag from there achieves nothing unless affected packages (in this case xorg-drivers) are rebuilt with -N. If emerge is not able to remove the ati-drivers blocker by itself after/while doing that, then the package is part of your world file (in case you emerged it manually in the past without --oneshot or -1). So you unmerge it manually. Also, the new driver is correctly called 'amdgpu' and only supports relatively new chips, so you need to check if that is the right thing to do for your card rather than selecting the established AMD opensource drivers.

Taking the other route (keeping fglrx), well, if other packages are requiring the xorg-server upgrade then these other packages' versions would need to be added to the mask as well, again you can see from portage output which one that is.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Thu Sep 22, 2016 4:00 am    Post subject: Reply with quote

asturm wrote:
Basically my post and your portage output tells you everything you need to know. Just editing make.conf and removing a use flag from there achieves nothing unless affected packages (in this case xorg-drivers) are rebuilt with -N.


I understand that but am having the same problem as the original poster in that portage won't rebuild it when using -N. It kicks out the package block error.

Quote:
If emerge is not able to remove the ati-drivers blocker by itself after/while doing that, then the package is part of your world file (in case you emerged it manually in the past without --oneshot or -1). So you unmerge it manually. Also, the new driver is correctly called 'amdgpu' and only supports relatively new chips, so you need to check if that is the right thing to do for your card rather than selecting the established AMD opensource drivers.


So are you indicating that ati-drivers should not be in the world file and if it is I should remove it? It is impossible to manually unmerge ati-drivers or xorg-drivers because xorg-server has them as a dependency. I suspect manually unmerging and re-emerging xorg-server isn't the answer.

Quote:
Taking the other route (keeping fglrx), well, if other packages are requiring the xorg-server upgrade then these other packages' versions would need to be added to the mask as well, again you can see from portage output which one that is.
I am not partial to either. That is jsut the way my system was originally setup. This thread is the first that I heard fglrx is essentially dead. As I indicated I wasn't making changes to my system, as the original poster did, that caused this. It was just a regular world update.

I apologize if I am missing something that seems obvious to the more seasoned Gentoo'ers

ICannotStandXorg were you able to resolve this on your box?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Sep 22, 2016 7:31 am    Post subject: Reply with quote

Budoka wrote:
So are you indicating that ati-drivers should not be in the world file and if it is I should remove it? It is impossible to manually unmerge ati-drivers or xorg-drivers because xorg-server has them as a dependency. I suspect manually unmerging and re-emerging xorg-server isn't the answer.

No, it's not impossible if you do, as I said, _rebuild_ xorg-drivers after the use flag change. Nowhere did I talk about xorg-server or removing xorg-drivers.

Of course, at that point it should be clear what driver you are migrating to, if you want to be greeted with an X server on next restart.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Thu Sep 22, 2016 3:39 pm    Post subject: Reply with quote

asturm wrote:
Budoka wrote:
So are you indicating that ati-drivers should not be in the world file and if it is I should remove it? It is impossible to manually unmerge ati-drivers or xorg-drivers because xorg-server has them as a dependency. I suspect manually unmerging and re-emerging xorg-server isn't the answer.

No, it's not impossible if you do, as I said, _rebuild_ xorg-drivers after the use flag change. Nowhere did I talk about xorg-server or removing xorg-drivers.

Of course, at that point it should be clear what driver you are migrating to, if you want to be greeted with an X server on next restart.


Thanks asturm. I appreciate your patience and help.

I guess I didn't make it clear but I can't rebuild the xorg-drivers. When I do the package block message is kicked back.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Sep 22, 2016 4:10 pm    Post subject: Reply with quote

Then be creative, just remove ati-drivers before rebuilding xorg-drivers ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Fri Sep 23, 2016 2:34 am    Post subject: Reply with quote

asturm wrote:
Then be creative, just remove ati-drivers before rebuilding xorg-drivers ;)


I'm not communicating well. I can't do that because ati-drivers is being pulled in by xorg-drivers...and xorg-drivers is being pulled in by xorg-server. So "no" I am unable to do that. Any other ideas?
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Fri Sep 23, 2016 3:01 am    Post subject: Reply with quote

How about finding out the packages that is depending on ati-drivers. If you remove/disable that part, you can easily remove ati-drivers; and since nothing else should would depend on it, it shouldn't be pulled in.

You can use this to find any packages that is depending on this package.
Code:
equery d ati-drivers


After this package is removed, you can easily add this temporarily to your package.mask to prevent it from being pulled in. The nice part of this is that portage will tell you what packages are pulling that in too.
Code:
x11-drivers/ati-drivers


Once this is resolved, you should be able to remove that line if you like.
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 667
Location: Tokyo, Japan

PostPosted: Fri Sep 23, 2016 4:08 am    Post subject: Reply with quote

ct85711 wrote:
How about finding out the packages that is depending on ati-drivers. If you remove/disable that part, you can easily remove ati-drivers; and since nothing else should would depend on it, it shouldn't be pulled in.

You can use this to find any packages that is depending on this package.
Code:
equery d ati-drivers


After this package is removed, you can easily add this temporarily to your package.mask to prevent it from being pulled in. The nice part of this is that portage will tell you what packages are pulling that in too.
Code:
x11-drivers/ati-drivers


Once this is resolved, you should be able to remove that line if you like.


Thanks for the info! But...I relly feel like I am missing something in the conversation. As I said it is xorg-drivers/xorg-server that is asking for this.

Code:
# equery d ati-drivers
 * These packages depend on ati-drivers:
x11-base/xorg-drivers-1.17 (video_cards_fglrx ? x11-drivers/ati-drivers)
# equery d xorg-drivers
 * These packages depend on xorg-drivers:
x11-base/xorg-server-1.17.4 (xorg ? >=x11-base/xorg-drivers-1.17)


And not sure if relevant but as I indicated if I rety to rebuild at--drivers without fglrx it throws the block error.

Thanks everyone.
Back to top
View user's profile Send private message
mhodak
Veteran
Veteran


Joined: 15 Nov 2003
Posts: 1213

PostPosted: Fri Sep 23, 2016 7:40 am    Post subject: Reply with quote

It appears that the root cause is the following
Code:

(x11-base/xorg-server-1.18.3:0/1.18.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.17.49[-minimal] required by (x11-drivers/ati-drivers-15.12-r1:1/1::gentoo, ebuild scheduled for merge)


The first line says that xorg-server-1.18.3 is available for update (nothing special there), but the second line says that that ati-drivers-15.12-r1 can only be used with xorg-server version lower than 1.17.49. So this indeed is a conflict.

Looking in the ebuild file, /usr/portage/x11-drivers/ati-drivers/ati-drivers-15.12.ebuild you can see that it is true:
Code:
DEPEND="
    <=x11-base/xorg-server-1.17.49[-minimal]


Basically, what is happening is that xorg 1.18 became stable, but the available ati-drivers cannot use this version. This should be reported as a bug (maybe it already has been reported, not sure). Or perhaps ati-drivers package is deprecated now? I am not sure, I am not using this package myself.

In the meantime to get around this, the best thing is to actually mask anything forcing the update, the 3 packages mentioned above and probably more. However, please use this only as a temporary measure and remove these from package.mask as soon as the issue is resolved, otherwise you will hit other problems later.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Sep 23, 2016 8:19 am    Post subject: Reply with quote

Budoka wrote:
asturm wrote:
Then be creative, just remove ati-drivers before rebuilding xorg-drivers ;)

I can't do that because ati-drivers is being pulled in by xorg-drivers...and xorg-drivers is being pulled in by xorg-server. So "no" I am unable to do that. Any other ideas?

Yes you can.

mhodak wrote:
This should be reported as a bug (maybe it already has been reported, not sure). Or perhaps ati-drivers package is deprecated now? I am not sure, I am not using this package myself.

As I said, it is dead. It's not a bug because the dependencies are correct.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mhodak
Veteran
Veteran


Joined: 15 Nov 2003
Posts: 1213

PostPosted: Fri Sep 23, 2016 9:07 am    Post subject: Reply with quote

Budoka,

asturm already told you everything you need to know. ati-drivers is a deprecated package will not work with the latest xorg version. Therefore you need to do the following:

1. unmerge ati-drivers
2. Replace the drivers with either xf86-video-amdgpu (better, but only supports relatively new chips) or AMD opensource drivers (not sure what the exact name is).

This should resolve your blockers.


asturm, correct me if I am wrong.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Sat Sep 24, 2016 12:43 am    Post subject: Reply with quote

x11-base/xorg-drivers will only request x11-drivers/ati-drivers if told to do so by USE=video_cards_fglrx. Budoka: please confirm that you have set VIDEO_CARDS in /etc/portage/make.conf to a value that does not include fglrx. Then, run emerge --oneshot --verbose x11-base/xorg-drivers && emerge --ask --depclean --verbose x11-drivers/ati-drivers. If either of those fail, post the output.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum