Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rsnapshot: error executing any local command
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Mon Jun 27, 2016 10:08 pm    Post subject: rsnapshot: error executing any local command Reply with quote

I'm experiencing an issue where rsnapshot appears to be unable to execute local commands (whether run from crontab or locally). If I run the exact same commands manually, they succeed.

/mnt/store4/ is a local hard disk (not an nfs or other network mount). It has plenty of disk space and inodes.

rsnapshot runs as root, so permissions should not be an issue. I do not run selinux / hardened. I am not using systemd.

Perl is 5.20.2. I've tried rsnapshot 1.3.1, 1.4.1 and 1.4.2 (bumped ebuild - the commit logs on github specifically mention some issues with rsync return values)

Note how even the logger command fails (I'm using metalog, but again, running the same command manually succeeds)

Does anyone know what might be wrong or can give me more ideas on things to check?

Code:
require Lchown
Lchown module loaded successfully
Setting locale to POSIX "C"
echo 13528 > /var/run/rsnapshot.pid
/bin/cp -al /mnt/store4/backup/snapshots/hourly.0 \
    /mnt/store4/backup/snapshots/hourly.1
----------------------------------------------------------------------------
rsnapshot encountered an error! The program was invoked with these options:
/usr/bin/rsnapshot hourly
----------------------------------------------------------------------------
ERROR: /bin/cp -al /mnt/store4/backup/snapshots/hourly.0 /mnt/store4/backup/snapshots/hourly.1 failed (result -1, exit status 72057594037927935).
ERROR: Perhaps your cp does not support -al options?
ERROR: Error! cp_al("/mnt/store4/backup/snapshots/hourly.0/", "/mnt/store4/backup/snapshots/hourly.1/")
/usr/bin/logger -p user.err -t rsnapshot[13528] /usr/bin/rsnapshot hourly: \
    ERROR: Error! cp_al("/mnt/store4/backup/snapshots/hourly.0/", \
    "/mnt/store4/backup/snapshots/hourly.1/")
WARNING: Could not log to syslog:
WARNING: /usr/bin/logger -p user.err -t rsnapshot[13528] /usr/bin/rsnapshot hourly: ERROR: Error! cp_al("/mnt/store4/backup/snapshots/hourly.0/", "/mnt/store4/backup/snapshots/hourly.1/")
rm -f /var/run/rsnapshot.pid

_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Tue Jun 28, 2016 1:12 pm    Post subject: Reply with quote

Further investigation revealed that perl was unable to run any commands - tested with:
Code:
perl -e 'print system('whoami');'


(You should see a result of 0 and your current username displayed)

Recompiling perl has fixed the issue.
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum