Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X Crashes (Radeon HD 4250 Card)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rsnfunky
n00b
n00b


Joined: 30 Dec 2007
Posts: 48

PostPosted: Sat Jun 25, 2016 4:19 am    Post subject: X Crashes (Radeon HD 4250 Card) Reply with quote

Hi All,

I am unable to start X on my system. It is installed with systemd, Plasma 5 and on a radeon HD4250 card

I am using the open source drivers. Have followed the Gentoo radeon wiki to the 't' and even added the drivers to the kernel. The issues I face are:

1) If I compile the Frame Buffer drivers in the kernel I get a completely black screen after boot (ie after dmsg and starting of few services)
2) If I donot compile these drivers in the kernel, I can boot normally (without framebuffer), but cannot start X as /dev/dri/card0 is not found

Please help on howto solve the issue
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Sat Jun 25, 2016 6:34 am    Post subject: Reply with quote

The Radeon support need firmware files that must be include in the kernel images itself when the Radeon support is in the kernel. If you compile the Radeon support in module and want an early load of it, you need and initramfs who contain the radeon module and the firmware files.

Otherwise, you have to wait when Linux mount the root partition for it to access the radeon module and the firmwares files. You first need to install the package who give firmware files to the Radeon support. There is an option in the kernel configuration to include firmware files in the image. Else you can use Dracut to create an initramfs with every things needed.

When the Radeon support probe the video card it need the firmware files immediately to write the microcode (firmware files) in the flash memory. It cannot wait otherwise it fail with a black screen. You don't need all Radeon firmware files in the kernel image or the initramfs but all the ones for your card.

Note that you can wait Linux to mount the real root partition to load the radeon module. It delay radeondrmfb to replace the precedent Linux video support, but easy the task. A good idea in that case is to force the radeon module to be autoload by the boot process. You should have everything work with KMS at the console login prompt and X should start using the radeon driver.
_________________
Paul
Back to top
View user's profile Send private message
rsnfunky
n00b
n00b


Joined: 30 Dec 2007
Posts: 48

PostPosted: Sat Jun 25, 2016 7:24 am    Post subject: Reply with quote

Thanks, I do have initramfs during boot as am using systemd. The radeon driver have not been built as a module but into the kernel.

Have also added in kernel firmware blobs as mentioned in the manual choosing the correct firmware.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Sat Jun 25, 2016 11:36 am    Post subject: Reply with quote

You may miss some firmware files anyway and it is hard to know because after getting the black screen you cannot check the radeon and the kernel messages with dmesg. Those messages are probably not be written in /var/log/ because the root partition is not yet mounted. After boot with nomodeset check if you can see previous boot messages without nomodeset in /var/log and with journalctl. Only one missing firmware file can make a freeze.

I see two possibility to have information from the kernel, remove any quiet parameter and add loglevel=7 to the kernel parameters for debugging purpose. Maybe you will see helpful output before the black screen.

After boot with nomodeset have you try to rmmod the radeon module and insmod it again? You will receive error messages if there is a problem. To do so, do not boot in X but without it.

Uou may want to see this thread too Radeon is Broken.
_________________
Paul
Back to top
View user's profile Send private message
rsnfunky
n00b
n00b


Joined: 30 Dec 2007
Posts: 48

PostPosted: Sun Jun 26, 2016 5:45 am    Post subject: Reply with quote

I could not boot with nomodset also. Used the Live CD to chroot to the PC and recompiled the Kernel. Now I am able to boot in text mode but cannot startx and get a message /dev/dri/card0 not found.

My dmesg (abridged) is given below. Will post the other outputs in separate posts.
Code:


[    0.000000] MTRR default type: uncachable
[    0.000000] MTRR fixed ranges enabled:
[    0.000000]   00000-9FFFF write-back
[    0.000000]   A0000-BFFFF uncachable
[    0.000000]   C0000-C7FFF write-protect
[    0.000000]   C8000-FFFFF uncachable
[    0.000000] MTRR variable ranges enabled:
[    0.000000]   0 base 000000000000 mask FFFF80000000 write-back
[    0.000000]   1 base 000080000000 mask FFFFC0000000 write-back
[    0.000000]   2 base 0000C0000000 mask FFFFF0000000 write-back
[    0.000000]   3 base 0000CFE00000 mask FFFFFFE00000 uncachable
[    0.000000]   4 disabled
[    0.000000]   5 disabled
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000] AGP: Checking aperture...
[    0.000000] AGP: No AGP bridge found
[    0.000000] AGP: Node 0: aperture [bus addr 0xc4000000-0xc5ffffff] (32MB)
[    0.000000] Aperture pointing to e820 RAM. Ignoring.
[    0.000000] AGP: Your BIOS doesn't leave an aperture memory hole
[    0.000000] AGP: Please enable the IOMMU option in the BIOS setup
[    0.000000] AGP: This costs you 64MB of RAM
[    0.000000] AGP: Mapping aperture over RAM [mem 0xc4000000-0xc7ffffff] (65536KB)
[    0.000000] PM: Registered nosave memory: [mem 0xc4000000-0xc7ffffff]
[    0.000000] Memory: 7595244K/7861816K available (5225K kernel code, 376K rwdata, 1904K rodata, 832K init, 668K bss, 266572K reserved, 0K cma-reserved)
[    0.000000] Hierarchical RCU implementation.
[    0.000000]    Build-time adjustment of leaf fanout to 64.
[    0.000000]    RCU restricting CPUs from NR_CPUS=32 to nr_cpu_ids=8.
[    0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=64, nr_cpu_ids=8
[    0.000000] NR_IRQS:4352 nr_irqs:488 16
[    0.000000] Console: colour VGA+ 80x25
[    0.000000] console [tty0] enabled
[    0.000000] clocksource: hpet: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 133484873504 ns

[    0.878053] Linux agpgart interface v0.103
[    0.878151] vga16fb: initializing
[    0.878152] vga16fb: mapped to 0xffff8800000a0000
[    0.878249] fb0: VGA16 VGA frame buffer device
[    0.878313] [drm] Initialized drm 1.1.0 20060810
[    0.880413] brd: module loaded

[    1.168544] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:05.1/sound/card1/input2
[    1.174580] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC889: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    1.174664] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    1.174717] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    1.174768] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    1.175588] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e
[    1.175639] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    1.175690] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    1.175742] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    1.175793] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[    1.192694] input: HDA ATI SB Front Mic as /devices/pci0000:00/0000:00:14.2/sound/card0/input3
[    1.192874] input: HDA ATI SB Rear Mic as /devices/pci0000:00/0000:00:14.2/sound/card0/input4
[    1.193016] input: HDA ATI SB Line as /devices/pci0000:00/0000:00:14.2/sound/card0/input5
[    1.193131] input: HDA ATI SB Line Out Front as /devices/pci0000:00/0000:00:14.2/sound/card0/input6
[    1.193284] input: HDA ATI SB Line Out Surround as /devices/pci0000:00/0000:00:14.2/sound/card0/input7
[    1.193430] input: HDA ATI SB Line Out CLFE as /devices/pci0000:00/0000:00:14.2/sound/card0/input8
[    1.193582] input: HDA ATI SB Line Out Side as /devices/pci0000:00/0000:00:14.2/sound/card0/input9
[    1.193731] input: HDA ATI SB Front Headphone as /devices/pci0000:00/0000:00:14.2/sound/card0/input10
[    1.273280] random: systemd-udevd urandom read with 29 bits of entropy available

[    6.520214] systemd[1]: display-manager.service: Cannot add dependency job, ignoring: Unit display-manager.service failed to load: No such file or directory.

[    6.542227] systemd[1]: Starting Setup Virtual Console...
[    6.542701] systemd[1]: Starting File System Check on Root Device...
[    6.818779] systemd[1]: tmp.mount: Directory /tmp to mount over is not empty, mounting anyway.
[    6.828925] systemd[1]: Mounting Temporary Directory...
Back to top
View user's profile Send private message
rsnfunky
n00b
n00b


Joined: 30 Dec 2007
Posts: 48

PostPosted: Sun Jun 26, 2016 5:53 am    Post subject: Reply with quote

The output of error (abridged) for X Log is:

Code:

X.Org X Server 1.17.4
Release Date: 2015-10-28
[    59.306] X Protocol Version 11, Revision 0
[    59.306] Build Operating System: Linux 4.4.6-gentoo x86_64 Gentoo
[
[    59.529] (--) PCI:*(0:1:5:0) 1002:9715:1458:d000 rev 0, Mem @ 0xd0000000/268435456, 0xfdee0000/65536, 0xfdd00000/1048576, I/O @ 0x0000ee00/256
[    59.529] (II) LoadModule: "glx"
[    59.539] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    59.754] (II) Module glx: vendor="X.Org Foundation"
[    59.754]    compiled for 1.17.4, module version = 1.0.0
[    59.754]    ABI class: X.Org Server Extension, version 9.0
[    59.754] (==) AIGLX enabled
[    59.754] (==) Matched ati as autoconfigured driver 0
[    59.754] (==) Matched modesetting as autoconfigured driver 1
[    59.754] (==) Matched fbdev as autoconfigured driver 2
[    59.754] (==) Matched vesa as autoconfigured driver 3
[    59.754] (==) Assigned the driver to the xf86ConfigLayout
[    59.754] (II) LoadModule: "ati"
[    59.821] (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
[    59.824] (II) Module ati: vendor="X.Org Foundation"
[    59.824]    compiled for 1.17.4, module version = 7.5.0
[    59.824]    Module class: X.Org Video Driver
[    59.824]    ABI class: X.Org Video Driver, version 19.0
[    59.824] (II) LoadModule: "radeon"
[    59.824] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[    59.860] (II) Module radeon: vendor="X.Org Foundation"
[    59.860]    compiled for 1.17.4, module version = 7.5.0
[    59.860]    Module class: X.Org Video Driver
[    59.860]    ABI class: X.Org Video Driver, version 19.0
[    59.860] (II) LoadModule: "modesetting"
[    59.860] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    59.878] (II) Module modesetting: vendor="X.Org Foundation"
[    59.879]    compiled for 1.17.4, module version = 1.17.4
[    59.879]    Module class: X.Org Video Driver
[    59.879]    ABI class: X.Org Video Driver, version 19.0
[    59.879] (II) LoadModule: "fbdev"
[    59.879] (WW) Warning, couldn't open module fbdev
[    59.879] (II) UnloadModule: "fbdev"
[    59.879] (II) Unloading fbdev
[    59.879] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    59.879] (II) LoadModule: "vesa"
[    59.879] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    59.891] (II) Module vesa: vendor="X.Org Foundation"
[    59.891]    compiled for 1.17.4, module version = 2.3.4
[    59.891]    Module class: X.Org Video Driver
[    59.891]    ABI class: X.Org Video Driver, version 19.0
[    59.891] (II) RADEON: Driver for ATI Radeon chipsets:
   ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
   
[    59.893] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    59.893] (II) VESA: driver for VESA chipsets: vesa
[    59.893] (++) using VT number 1

[    59.893] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    59.894] (II) [KMS] drm report modesetting isn't supported.
[    59.894] (EE) open /dev/dri/card0: No such file or directory
[    59.894] (WW) Falling back to old probe method for modesetting
[    59.894] (EE) open /dev/dri/card0: No such file or directory
[    59.894] (EE) Screen 0 deleted because of no matching config section.
[    59.894] (II) UnloadModule: "radeon"
[    59.894] (EE) Screen 0 deleted because of no matching config section.
[    59.894] (II) UnloadModule: "modesetting"
[    59.894] (II) Loading sub module "vbe"
[    59.894] (II) LoadModule: "vbe"
[    59.894] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    59.899] (II) Module vbe: vendor="X.Org Foundation"
[    59.899]    compiled for 1.17.4, module version = 1.1.0
[    59.899]    ABI class: X.Org Video Driver, version 19.0
[    59.899] (II) Loading sub module "int10"
[    59.899] (II) LoadModule: "int10"
[    59.900] (II) Loading /usr/lib64/xorg/modules/libint10.so
[    59.920] (II) Module int10: vendor="X.Org Foundation"
[    59.920]    compiled for 1.17.4, module version = 1.0.0
[    59.920]    ABI class: X.Org Video Driver, version 19.0
[    59.920] (II) VESA(0): initializing int10
[    59.922] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    59.922] (II) VESA(0): VESA BIOS detected
[    59.922] (II) VESA(0): VESA VBE Version 3.0
[    59.922] (II) VESA(0): VESA VBE Total Mem: 16384 kB
[    59.922] (II) VESA(0): VESA VBE OEM: ATI ATOMBIOS
[    59.922] (II) VESA(0): VESA VBE OEM Software Rev: 10.94
[    59.922] (II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
[    59.922] (II) VESA(0): VESA VBE OEM Product: RS880
[    59.922] (II) VESA(0): VESA VBE OEM Product Rev: 01.00
[    59.938] (II) VESA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    59.938] (==) VESA(0): Depth 24, (--) framebuffer bpp 32
[    59.938] (==) VESA(0): RGB weight 888
[    59.938] (==) VESA(0): Default visual is TrueColor
[    59.938] (==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
[    59.938] (II) Loading sub module "ddc"
[    59.938] (II) LoadModule: "ddc"
[    59.938] (II) Module "ddc" already built-in

[    62.140] (II) systemd-logind: releasing fd for 13:78
[    62.543] (II) Server terminated successfully (0). Closing log file.


The output of Emerge --info is as under:

Code:

Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-AMD_Phenom-tm-_II_X4_975_Processor-with-gentoo-2.2
KiB Mem:     7666384 total,   7219544 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 26 Jun 2016 03:00:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=amdfam10 -mcx16 -mpopcnt -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=amdfam10 -mcx16 -mpopcnt -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.neolabs.kz/gentoo http://mirror.neolabs.kz/gentoo/pub rsync://gentoo.bloodhost.ru/gentoo-distfiles ftp://gentoo.bloodhost.ru/ ftp://mirror2.corbina.ru/gentoo-distfiles/ http://ftp.daum.net/gentoo/ ftp://ftp.kaist.ac.kr/gentoo/ ftp://ftp.twaren.net/Linux/Gentoo/ http://ftp.twaren.net/Linux/Gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 bash-completition bcmath berkdb bittorrent bluetooth branding bzip2 cairo cdda cdr clamav clamdtop cli cracklib crypt css cue cxx dbus declarative dga djvu dri dts dv dvd dvdr emboss encode exif exit fam firefox flac fortran gdbm geoipgif gif gimp glamor gphoto2 gpm gstreamer gtk hddtemp iconv ieee1394 ipv6 java6 javascript joystick jpeg kde kipi lcms ldap libnotify lm_sensors lzma mad minizip mmx mmxext mng modules mp3 mp4 mpeg mplayer multilib ncurses networkmanager nls nptl offlinehelp ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session smp sound spell sse sse2 sse3 ssl ssse3 startup-notification svg syslog systemd tcpd threads tiff truetype udev udisks unicode upnp-av upower usb vcd vorbis wallpapers widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xmp xmpp xscreensaver xv xvid xvmc ydbus zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Sun Jun 26, 2016 10:13 am    Post subject: Reply with quote

The Xorg radeon/ati module cannot be use because of this
Code:
[    59.894] (II) [KMS] drm report modesetting isn't supported.
[    59.894] (EE) open /dev/dri/card0: No such file or directory
[    59.894] (WW) Falling back to old probe method for modesetting

Your Linux kernel Radeon support do not provide KMS as it must do. I always compile only one video support in hard in the kernel, so here, I would disable all other frambuffer/vga supports and keep only Radeon for the video card and display. What about the output of
Code:
dmesg | grep -i -e drm -e firmware -e microcode -e radeon

In the link I gave you before, there was a problem using efifb as first framebuffer. It can prevent an other framebuffer to replace it. From what I see, you do not boot in EFI mode and not use efifb.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum